[Résolu] Accès impossible à Page Rank de Google

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: #1.9.4.3
#~ Url du site : http://www.jardin-l-enchanteur.fr
#~ Hébergeur / Soft : One &one
#~ Informations Système :
#~ Version du CMS
#~ 1.9.4.2
#~ Modules installés
#~ CMSMailer
#~ 2.0.1
#~ FileManager
#~ 1.1.0
#~ MenuManager
#~ 1.7.6
#~ ModuleManager
#~ 1.4.2
#~ News
#~ 2.11.3
#~ nuSOAP
#~ 1.0.2
#~ Printing
#~ 1.1.2
#~ Search
#~ 1.6.10
#~ ThemeManager
#~ 1.1.4
#~ TinyMCE
#~ 2.8.4
#~ CGExtensions
#~ 1.26.6
#~ FormBuilder
#~ 0.7
#~ jQuery
#~ 1.1.3
#~ JQueryTools
#~ 1.0.10
#~ Showtime
#~ 2.0.4
#~ FormBrowser
#~ 0.4
#~ CGSimpleSmarty
#~ 1.4.8
#~ CGGoogleMaps
#~ 2.1.4
#~ Informations de configuration
#~ php_memory_limit:
#~ process_whole_template:
#~ false
#~ output_compression:
#~ false
#~ max_upload_size:
#~ 40000000
#~ default_upload_permission:
#~ 664
#~ url_rewriting:
#~ none
#~ page_extension:
#~ query_var:
#~ page
#~ image_manipulation_prog:
#~ GD
#~ auto_alias_content:
#~ true
#~ locale:
#~ default_encoding:
#~ utf-8
#~ admin_encoding:
#~ utf-8
#~ set_names:
#~ true
#~ debug:
#~ false
#~ root_url:
#~ http://jardin-l-enchanteur.fr
#~ ssl_url:
#~ https://jardin-l-enchanteur.fr
#~ root_path:
#~ /homepages/38/d372955801/htdocs/1_J-L (0755)
#~ previews_path:
#~ /homepages/38/d372955801/htdocs/1_J-L/tmp/cache (0755)
#~ uploads_path:
#~ /homepages/38/d372955801/htdocs/1_J-L/uploads (0755)
#~ uploads_url:
#~ http://jardin-l-enchanteur.fr/uploads
#~ image_uploads_path:
#~ /homepages/38/d372955801/htdocs/1_J-L/uploads/images (0755)
#~ image_uploads_url:
#~ http://jardin-l-enchanteur.fr/uploads/images
#~ ssl_uploads_url:
#~ /uploads
#~ use_smarty_php_tags:
#~ false
#~ Informations PHP :
#~ Version PHP actuelle (phpversion):
#~ 5.2.17
#~ Fonction md5 (md5_function):
#~ On (Vrai)
#~ Version GD (gd_version):
#~ 2
#~ Fonction PHP tempnam (tempnam_function):
#~ On (Vrai)
#~ Test magic_quotes_runtime (magic_quotes_runtime):
#~ Off (Faux)
#~ E_STRICT est désactivé dans error_reporting (E_STRICT):
#~ Mémoire Limite PHP effective (memory_limit):
#~ 90M
#~ Temps Maximum d'éxecution (max_execution_time):
#~ 50000
#~ Fonction PHP output_buffering (output_buffering):
#~ 0
#~ Safe Mode PHP (safe_mode):
#~ Off (Faux)
#~ Upload de fichier (file_uploads):
#~ On (Vrai)
#~ Taille maximum par méthode POST (post_max_size):
#~ 8M
#~ Taille maximum pour l'Upload (upload_max_filesize):
#~ 40M
#~ Chemin du dossier Session (session_save_path):
#~ /tmp (1777)
#~ Autorisation pour l'utilisation des cookies de session (session_use_cookies):
#~ On (Vrai)
#~ Support de Basic XML (expat) (xml_function):
#~ On (Vrai)
#~ Vérification si le processus httpd peut créer un fichier dans un nouveau dossier. (create_dir_and_file):
#~ Fonction PHP register_globals (register_globals):
#~ Off (Faux)
#~ Directive PHP disable_functions (disable_functions):
#~ PHP open_basedir (open_basedir):
#~ Test l'URL distant (test_remote_url):
#~ fsockopen: Connexion ok !
#~ fopen: Lorsque la fonction allow_url_fopen est désactivée, vous ne serez pas en mesure d'accéder à des objets comme une URL ou des fichiers en protocole ftp ou http.
#~ Test ini_set (check_ini_set):
#~ On (Vrai)
#~ Informations serveur :
#~ API serveur (server_api):
#~ cgi
#~ Serveur de base de données (server_db_type):
#~ MySQL (mysql)
#~ Version du serveur de base de données (server_db_version):
#~ 5.0.91
#~ Version software du serveur (server_software):
#~ Apache
#~ Système d'exploitation serveur (server_os):
#~ Linux Linux infong 2.4 #1 SMP Thu Nov 25 01:59:22 UTC 2010 i686 GNU/Linux On Linux infong 2.4 #1 SMP Thu Nov 25 01:59:22 UTC 2010 i686 GNU/Linux
#~ Informations sur les Permissions
#~ tmp:
#~ /homepages/38/d372955801/htdocs/1_J-L/tmp (0755)
#~ templates_c:
#~ /homepages/38/d372955801/htdocs/1_J-L/tmp/templates_c (0755)
#~ modules:
#~ /homepages/38/d372955801/htdocs/1_J-L/modules (0755)
#~ Masque de création de fichier (umask) :
#~ /homepages/38/d372955801/htdocs/1_J-L/tmp/cache (0755)
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~

Smile Impossible d'accéder aux pages rank de mon site. J'y parviens bien avec la page accueil mais avec les autres :impossible.
url de la page rank dont j ai besoin :
http://jardin-l-enchanteur.fr/index.php?page=commander
système utilisé pour connaître page rank :
http://www.pagerank.fr/afficher-pagerank.fr.html
Merci d'avance pour le tuyau.
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: #1.9.4.3
#~ Url du site : http://www.jardin-l-enchanteur.fr
#~ Hébergeur / Soft : One &one
#~ Informations Système :
#~ Version du CMS
#~ 1.9.4.2
#~ Modules installés
#~ CMSMailer
#~ 2.0.1
#~ FileManager
#~ 1.1.0
#~ MenuManager
#~ 1.7.6
#~ ModuleManager
#~ 1.4.2
#~ News
#~ 2.11.3
#~ nuSOAP
#~ 1.0.2
#~ Printing
#~ 1.1.2
#~ Search
#~ 1.6.10
#~ ThemeManager
#~ 1.1.4
#~ TinyMCE
#~ 2.8.4
#~ CGExtensions
#~ 1.26.6
#~ FormBuilder
#~ 0.7
#~ jQuery
#~ 1.1.3
#~ JQueryTools
#~ 1.0.10
#~ Showtime
#~ 2.0.4
#~ FormBrowser
#~ 0.4
#~ CGSimpleSmarty
#~ 1.4.8
#~ CGGoogleMaps
#~ 2.1.4
#~ Informations de configuration
#~ php_memory_limit:
#~ process_whole_template:
#~ false
#~ output_compression:
#~ false
#~ max_upload_size:
#~ 40000000
#~ default_upload_permission:
#~ 664
#~ url_rewriting:
#~ none
#~ page_extension:
#~ query_var:
#~ page
#~ image_manipulation_prog:
#~ GD
#~ auto_alias_content:
#~ true
#~ locale:
#~ default_encoding:
#~ utf-8
#~ admin_encoding:
#~ utf-8
#~ set_names:
#~ true
#~ debug:
#~ false
#~ root_url:
#~ http://jardin-l-enchanteur.fr
#~ ssl_url:
#~ https://jardin-l-enchanteur.fr
#~ root_path:
#~ /homepages/38/d372955801/htdocs/1_J-L (0755)
#~ previews_path:
#~ /homepages/38/d372955801/htdocs/1_J-L/tmp/cache (0755)
#~ uploads_path:
#~ /homepages/38/d372955801/htdocs/1_J-L/uploads (0755)
#~ uploads_url:
#~ http://jardin-l-enchanteur.fr/uploads
#~ image_uploads_path:
#~ /homepages/38/d372955801/htdocs/1_J-L/uploads/images (0755)
#~ image_uploads_url:
#~ http://jardin-l-enchanteur.fr/uploads/images
#~ ssl_uploads_url:
#~ /uploads
#~ use_smarty_php_tags:
#~ false
#~ Informations PHP :
#~ Version PHP actuelle (phpversion):
#~ 5.2.17
#~ Fonction md5 (md5_function):
#~ On (Vrai)
#~ Version GD (gd_version):
#~ 2
#~ Fonction PHP tempnam (tempnam_function):
#~ On (Vrai)
#~ Test magic_quotes_runtime (magic_quotes_runtime):
#~ Off (Faux)
#~ E_STRICT est désactivé dans error_reporting (E_STRICT):
#~ Mémoire Limite PHP effective (memory_limit):
#~ 90M
#~ Temps Maximum d'éxecution (max_execution_time):
#~ 50000
#~ Fonction PHP output_buffering (output_buffering):
#~ 0
#~ Safe Mode PHP (safe_mode):
#~ Off (Faux)
#~ Upload de fichier (file_uploads):
#~ On (Vrai)
#~ Taille maximum par méthode POST (post_max_size):
#~ 8M
#~ Taille maximum pour l'Upload (upload_max_filesize):
#~ 40M
#~ Chemin du dossier Session (session_save_path):
#~ /tmp (1777)
#~ Autorisation pour l'utilisation des cookies de session (session_use_cookies):
#~ On (Vrai)
#~ Support de Basic XML (expat) (xml_function):
#~ On (Vrai)
#~ Vérification si le processus httpd peut créer un fichier dans un nouveau dossier. (create_dir_and_file):
#~ Fonction PHP register_globals (register_globals):
#~ Off (Faux)
#~ Directive PHP disable_functions (disable_functions):
#~ PHP open_basedir (open_basedir):
#~ Test l'URL distant (test_remote_url):
#~ fsockopen: Connexion ok !
#~ fopen: Lorsque la fonction allow_url_fopen est désactivée, vous ne serez pas en mesure d'accéder à des objets comme une URL ou des fichiers en protocole ftp ou http.
#~ Test ini_set (check_ini_set):
#~ On (Vrai)
#~ Informations serveur :
#~ API serveur (server_api):
#~ cgi
#~ Serveur de base de données (server_db_type):
#~ MySQL (mysql)
#~ Version du serveur de base de données (server_db_version):
#~ 5.0.91
#~ Version software du serveur (server_software):
#~ Apache
#~ Système d'exploitation serveur (server_os):
#~ Linux Linux infong 2.4 #1 SMP Thu Nov 25 01:59:22 UTC 2010 i686 GNU/Linux On Linux infong 2.4 #1 SMP Thu Nov 25 01:59:22 UTC 2010 i686 GNU/Linux
#~ Informations sur les Permissions
#~ tmp:
#~ /homepages/38/d372955801/htdocs/1_J-L/tmp (0755)
#~ templates_c:
#~ /homepages/38/d372955801/htdocs/1_J-L/tmp/templates_c (0755)
#~ modules:
#~ /homepages/38/d372955801/htdocs/1_J-L/modules (0755)
#~ Masque de création de fichier (umask) :
#~ /homepages/38/d372955801/htdocs/1_J-L/tmp/cache (0755)
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~

Smile Impossible d'accéder aux pages rank de mon site. J'y parviens bien avec la page accueil mais avec les autres :impossible.
url de la page rank dont j ai besoin :
http://jardin-l-enchanteur.fr/index.php?page=commander
système utilisé pour connaître page rank :
http://www.pagerank.fr/afficher-pagerank.fr.html
Merci d'avance pour le tuyau.
#2
Et donc, il te faut passer en mod_rewrite :|
#2
Et donc, il te faut passer en mod_rewrite :|
#3
Bonsoir SmileOui mais j ai manipulé les choix pour les url dans les paramètres et je n ai pas réussi . J ai fait des recherches et rien trouvé. Que faut-il faire pour passer en mode_rewrite?
Merci
#3
Bonsoir SmileOui mais j ai manipulé les choix pour les url dans les paramètres et je n ai pas réussi . J ai fait des recherches et rien trouvé. Que faut-il faire pour passer en mode_rewrite?
Merci
#5
Merci . Je n avais pas trouvé malgré dans la doc ma recherche.
Ceci dit, le problème n'est pas résolu.

Je modifie bien config php et place un .htacces à la racine de mon site avec le code suivant:
RewriteEngine On
# RewriteBase /
# Rewrites urls
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php?page=$1 [QSA

Les url sont bien modifiées. mais deviennent inaccessibles.
Merci de ton aide
#5
Merci . Je n avais pas trouvé malgré dans la doc ma recherche.
Ceci dit, le problème n'est pas résolu.

Je modifie bien config php et place un .htacces à la racine de mon site avec le code suivant:
RewriteEngine On
# RewriteBase /
# Rewrites urls
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php?page=$1 [QSA

Les url sont bien modifiées. mais deviennent inaccessibles.
Merci de ton aide
#6
Code :
RewriteRule ^(.+)$ index.php?page=$1 [QSA

t'es sur ? il manque pas un "]" à la fin ?

me donner seulement ce code ne m'aidera pas

donne nous également la portion du code contenu dans config.php propre aux pretty-url

je t'explique :

Code :
RewriteRule ^(.+)$ index.php?page=$1 [QSA]

peut également être

Code :
RewriteRule ^(.+).html$ index.php?page=$1 [QSA]

dans certains cas
#6
Code :
RewriteRule ^(.+)$ index.php?page=$1 [QSA

t'es sur ? il manque pas un "]" à la fin ?

me donner seulement ce code ne m'aidera pas

donne nous également la portion du code contenu dans config.php propre aux pretty-url

je t'explique :

Code :
RewriteRule ^(.+)$ index.php?page=$1 [QSA]

peut également être

Code :
RewriteRule ^(.+).html$ index.php?page=$1 [QSA]

dans certains cas
#7
Voici le code dans config.php :

#http://wiki.cmsmadesimple.org/index.php/FAQ/Installation/Pretty_URLs#Pretty_URL.27s
$config['url_rewriting'] = 'mod_rewrite';

#Extension to use if you're using mod_rewrite for pretty URLs.
$config['page_extension'] = '.html';

#If using none of the above options, what should we be using for the query string
#variable? (ex. http://www.mysite.com/index.php?page=somecontent)
$config['query_var'] = 'page';

#--------------
j ai corrigé le code .htaccess et essayé la solution alternative que tu as donné.
Rien à faire: les url changent mais elles ne sont plus accessibles
#7
Voici le code dans config.php :

#http://wiki.cmsmadesimple.org/index.php/FAQ/Installation/Pretty_URLs#Pretty_URL.27s
$config['url_rewriting'] = 'mod_rewrite';

#Extension to use if you're using mod_rewrite for pretty URLs.
$config['page_extension'] = '.html';

#If using none of the above options, what should we be using for the query string
#variable? (ex. http://www.mysite.com/index.php?page=somecontent)
$config['query_var'] = 'page';

#--------------
j ai corrigé le code .htaccess et essayé la solution alternative que tu as donné.
Rien à faire: les url changent mais elles ne sont plus accessibles
#8
ça ne peut pas...

Code :
# RewriteBase /

change le en

Code :
RewriteBase /

pour information chez moi j'ai

Code :
Options +FollowSymLinks
  RewriteEngine on
  RewriteBase /

  # Rewrites urls in the form of /parent/child/
  # but only rewrites if the requested URL is not a file or directory
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.+).html$ index.php?page=$1 [QSA]

+

Code :
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';
$config['query_var'] = 'page';
#8
ça ne peut pas...

Code :
# RewriteBase /

change le en

Code :
RewriteBase /

pour information chez moi j'ai

Code :
Options +FollowSymLinks
  RewriteEngine on
  RewriteBase /

  # Rewrites urls in the form of /parent/child/
  # but only rewrites if the requested URL is not a file or directory
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.+).html$ index.php?page=$1 [QSA]

+

Code :
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';
$config['query_var'] = 'page';
#9
SmileSmileSmile Le roblème est résolu. J'ai repris textuellement ce qui est dans ta citation


bess a écrit :Options +FollowSymLinks
RewriteEngine on
RewriteBase /

# Rewrites urls in the form of /parent/child/
# but only rewrites if the requested URL is not a file or directory
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+).html$ index.php?page=$1 [QSA]
+
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';
$config['query_var'] = 'page';
Merci beaucoup
#9
SmileSmileSmile Le roblème est résolu. J'ai repris textuellement ce qui est dans ta citation


bess a écrit :Options +FollowSymLinks
RewriteEngine on
RewriteBase /

# Rewrites urls in the form of /parent/child/
# but only rewrites if the requested URL is not a file or directory
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+).html$ index.php?page=$1 [QSA]
+
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';
$config['query_var'] = 'page';
Merci beaucoup


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)