Bienvenue, Visiteur
Vous devez vous enregistrer avant de pouvoir poster.

Nom d’utilisateur
  

Mot de passe
  





Rechercher dans les forums

(Recherche avancée)

Statistiques du Forum
» Membres : 625
» Dernier membre : sahrenity
» Sujets du forum : 4,239
» Messages du forum : 28,490

Statistiques complètes

Utilisateurs en ligne
Il y a actuellement 80 utilisateurs connectés.
» 0 Membre(s) | 79 Visiteur(s)
Yandex

Derniers sujets
Créer une colone / conten...
Forum : Général
Dernier message : Ouik
Il y a 8 heures
» Réponses : 2
» Affichages : 52
Lien vers page de contenu...
Forum : Général
Dernier message : Ouik
Il y a 8 heures
» Réponses : 4
» Affichages : 70
complétement perdu
Forum : Général
Dernier message : Ouik
03/06/2020, 21:36:49
» Réponses : 1
» Affichages : 20
Récupération variable
Forum : Modules, Tags
Dernier message : pierrepercee
03/06/2020, 17:42:42
» Réponses : 1
» Affichages : 34
Un petit site pour découv...
Forum : Vous, vos sites ...
Dernier message : sahrenity
03/06/2020, 14:19:14
» Réponses : 4
» Affichages : 3,244
Bloc contenu activable et...
Forum : Développement et Astuces
Dernier message : pierrepercee
31/05/2020, 19:46:42
» Réponses : 8
» Affichages : 359
Problème accès forum et s...
Forum : Général
Dernier message : Jean le Chauve
21/05/2020, 01:02:38
» Réponses : 17
» Affichages : 1,187
Réponse à Pierrepercee
Forum : Général
Dernier message : Jean le Chauve
20/05/2020, 19:35:17
» Réponses : 2
» Affichages : 57
Tuto pour créer une galer...
Forum : Modules, Tags
Dernier message : Ouik
20/05/2020, 14:33:03
» Réponses : 14
» Affichages : 812
Ecran blanc - mise à jour...
Forum : Installation
Dernier message : Dio
18/05/2020, 13:29:25
» Réponses : 2
» Affichages : 107

  DesignManager > Aide sur Gabarit de Page ?
Posté par : pixetmots - 01/04/2020, 17:58:41 - Forum : Modules, Tags - Réponses (3)

Bonjour à tous,

Existe-t-il une doc reprenant les différents balises , variables utilisable dans un gabarit de page ?

Comme par exemple dans les gabarits de navigator lorsque l'on clique sur aide du gabarit , pour les gabarits de page on affiche "à faire "  Smile .

Ce "à faire" est-il la traduction d'une version anglaise ou rien n'existe ?  

Pour ce cas particulier, je cherche à savoir si on peut accéder dans le gabarit de page au nom de la page parent si elle existe ( sans passer par navigator , ou avec ... )

Merci...

Imprimer cet élément

  Nouvelle version 2.2.14 T'Sou-ke
Posté par : jce76350 - 30/03/2020, 18:45:46 - Forum : Annonces - Pas de réponse

Annonce du Site En : CMS Made Simple Core 2.2.14 - T'Sou-ke

Documentation En Introducing CMSMS 2.0

Lire attentivement les informations du changelog

Core - General
- Correction de la V 2.2.13
 Corrections PHP 7.4
- Search v1.51.8
- News v2.51.9
- FileManager v1.6.11
- DesignManager v1.1.8
- CMSContentManager v1.1.9
- AdminSearch v1.0.5


Nota cette version 2.2.14 comprend la mise à jour depuis une version 1.12 mini directement
avant de mettre à jour une ancienne version inférieure à 1.12 d'abord faire une mise à jour en 1.12

À compter de maintenant l'équipe de développement de CMSMS supportera uniquement les questions pour CMSMS 2.2.14 et 2.2.13.

Voir la documentation en anglais.

Discussion fermée
Pour les questions ou soucis, poster sur le forum en ouvrant une nouvelle discussion :
  • dans le forum "Installation" pour les problèmes d'installation
  • dans le forum "Modules, Tags" pour les problèmes sur les modules et tags

Imprimer cet élément

  [Résolu] FormBuilder > Erreur sur édition de champ
Posté par : pixetmots - 27/03/2020, 17:46:18 - Forum : Modules, Tags - Pas de réponse

Bonjour à tous ,

Soucis lorsque je veux éditer un champ dans FormBuilder (quel que soit le formulaire ).
Je tombe sur une page blanche .

Le log Serveur ( error PHP ) me donne ceci:

Citation :[27-Mar-2020 16:39:38 Europe/Paris] PHP Fatal error:  Uncaught CmsError404Exception: Module action not found in /Applications/MAMP/www/tphv/lib/classes/class.CMSModule.php:1395
Stack trace:
#0 /Applications/MAMP/www/tphv/modules/FormBuilder/FormBuilder.module.php(193): CMSModule->DoAction('admin_add_edit_...', 'm1_', Array, '')
#1 /Applications/MAMP/www/tphv/lib/classes/class.CMSModule.php(1479): FormBuilder->DoAction('admin_add_edit_...', 'm1_', Array, '')
#2 /Applications/MAMP/www/tphv/admin/moduleinterface.php(74): CMSModule->DoActionBase('admin_add_edit_...', 'm1_', Array, '', Object(Smarty_CMS))
#3 {main}
  thrown in /Applications/MAMP/www/tphv/lib/classes/class.CMSModule.php on line 1395

Je suis sur nouvelle install du CMS avec la dernière version.

Une petite idée du problème ?

Citation :----------------------------------------------
[b]Cms Version[/b]: 2.2.13
[b]Installed Modules[/b]:
  • AdminSearch: 1.0.4

  • CGContentUtils: 2.5.4

  • CGExtensions: 1.65.2

  • CGSimpleSmarty: 2.2.1

  • CMSContentManager: 1.1.8

  • Captcha: 1.0

  • CmsJobManager: 0.1.3

  • DesignManager: 1.1.7

  • ECB2: 1.5.3

  • FileManager: 1.6.10

  • FilePicker: 1.0.4.1

  • FormBuilder: 1.0.2

  • Gallery: 2.4.2

  • JQueryTools: 1.4.2

  • LISE: 1.3.1

  • LISEResultats: 1.3.1

  • LISEinfo: 1.3.1

  • MicroTiny: 2.2.4

  • ModuleManager: 2.1.7

  • Navigator: 1.0.9

  • News: 2.51.8

  • Search: 1.51.7

  • SiteMapMadeSimple: 2.0.3

  • TinyMCE: 3.3.1
[b]Config Information[/b]:
  • php_memory_limit:

  • max_upload_size: 32000000

  • url_rewriting: mod_rewrite

  • page_extension: .html

  • query_var: page

  • auto_alias_content: true

  • locale:

  • set_names: true

  • timezone: Europe/Paris

  • permissive_smarty: false
[b]Php Information[/b]:
  • phpversion: 7.3.7

  • md5_function: On  (Vrai)

  • json_function: On  (Vrai)

  • gd_version: 2

  • tempnam_function: On  (Vrai)

  • magic_quotes_runtime: Off  (Faux)

  • E_ALL: 32767

  • E_STRICT: 2048

  • E_DEPRECATED: 8192

  • test_file_timedifference: Aucune différence de date du système trouvée

  • test_db_timedifference: Aucune différence de date du système trouvée

  • create_dir_and_file: 1

  • memory_limit: 128M

  • max_execution_time: 30

  • register_globals: Off  (Faux)

  • output_buffering: 4096

  • disable_functions:

  • open_basedir:

  • test_remote_url: Valable

  • file_uploads: On  (Vrai)

  • post_max_size: 8M

  • upload_max_filesize: 32M

  • session_save_path: /Applications/MAMP/tmp/php (0777)

  • session_use_cookies: On  (Vrai)

  • xml_function: On  (Vrai)

  • xmlreader_class: On  (Vrai)

  • check_ini_set: On  (Vrai)

  • curl: On 
[b]Performance Information:[/b]
  • allow_browser_cache: On  (Vrai)

  • browser_cache_expiry: 60

  • php_opcache: Off  (Faux)

  • smarty_cache: Off  (Faux)

  • smarty_compilecheck: Off  (Faux)

  • auto_clear_cache_age: On  (Vrai)
[b]Server Information[/b]:
  • Server Software: Apache

  • Server Api: apache2handler

  • Server Os: Darwin 18.7.0 On  x86_64

  • Server Db Type: MySQL (mysqli)

  • Server Db Version: 5.7.26

  • Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
[b]Permission Information[/b]:
  • tmp: /Applications/MAMP/www/tphv/tmp (0755)

  • tmp_cache: /Applications/MAMP/www/tphv/tmp/cache (0755)

  • templates_c: /Applications/MAMP/www/tphv/tmp/templates_c (0755)

  • modules: /Applications/MAMP/www/tphv/modules (0755)

  • uploads: /Applications/MAMP/www/tphv/uploads (0755)

  • Masque de création de fichier (umask) : /Applications/MAMP/www/tphv/tmp/cache (0755)

  • config_file: 0444
----------------------------------------------

Bon, la solution était sur la forge  :

http://dev.cmsmadesimple.org/bug/view/12189

Le fichier
Citation :action.admin_add_edit_field.php
n'était effectivement pas installé ...

Je laisse quand même le post si ça peut aider quelqu'un ...

Imprimer cet élément

  log pour les modules
Posté par : sechanbask - 21/03/2020, 01:47:01 - Forum : Modules, Tags - Pas de réponse

Bonjour à tous,

J'ai dû utilisé en catastrophe un vieux site avec CMSMS 1.11.13 avec NMS 2.9.5

lorsqu'on envoi des mailling list avec NMS, on reçoit un rapport comme ça :

Code :
NMS Mail Job Complete
Job Name     Job created at: 21/03/2020 00:10:55- bidon
Mail Subject     COVID-19 - ATEGIE OPERATIONNEL
Lists     moi
Start Time:     mars 21, 2020
End Time:     mars 21, 2020
Errors (invalid addresses)     

    [email protected] ([email protected])

et un autre comme ça :

Code :
A CGJobMgr Job has terminated

You are receiving this notification to inform you of a job that has terminated with an important status.
Job Name:     NMS - Job created at: 21/03/2020 00:10:55- bidon
Job Id:     186
Job Owner:     1
Job Status:     finished
Job Started At:     21/03/2020 00:11:22
Job Finished At:     21/03/2020 00:12:29

You are advised to login to the admin interface on your site to review the error log.


le problème c'est que le système était mal configuré, je n'ai pas reçu ces mails avant que je recadre tout.

Est-ce qu'on peut récupérer avoir les logs pour savoir si y'a des mails en erreur ?

Imprimer cet élément

  Annonce officielle sur la suite du développement de CMS Made Simple
Posté par : Ouik - 19/03/2020, 20:06:30 - Forum : Général - Réponses (1)

À lire sur le site .org : https://www.cmsmadesimple.org/2020/03/A-...ona-Virus/

Imprimer cet élément

  en route vers la version 2.2.14
Posté par : jce76350 - 18/03/2020, 14:54:56 - Forum : Général - Réponses (6)

alors rolf reprend la barre pour les corrections sur la future version Wink
http://viewsvn.cmsmadesimple.org/revisio...&rev=12467

Imprimer cet élément

  Web-3D
Posté par : archeo - 29/02/2020, 19:35:00 - Forum : Général - Réponses (2)

Bonjour,

J'ouvre ce sujet car je travaille sur la question depuis quelques temps.
Il s'agit de visualiser des objets en 3D dans une page web.
J'utilise depuis pas mal de temps le site sketchfab pour publier les modèles que je crée puis intégrer  les dans mes pages Web. Mais depuis quelques temps ce site a décidé de limiter le nombre de modèles dans la version gratuite. J'avais déjà testé des scripts permettant la visualisation en 3D mais sans grand succès.
three.js utilise WebGL supporté nativement par la plupart des navigateurs actuels. J'ai pas trop accroché au début jusqu'à ce que je découvre model-viewer qui est plus facile à mettre en oeuvre puisqu'il suffit de 3 lignes de code dans une page pour afficher un objet

Code :
<script type="module" src="https://unpkg.com/@google/model-viewer/dist/model-viewer.js"></script>
<script nomodule src="https://unpkg.com/@google/model-viewer/dist/model-viewer-legacy.js"></script>

<model-viewer style="width: 100%; height: 600px;" src="{root_url}/uploads/images/histoire/sortie/images/psilophyton.glb" alt="" auto-rotate camera-controls  height='750'></model-viewer>
Les deux premières lignes chargent le script (il est préférable de les mettre en fin de page)

La troisième affiche l'objet. Attention il faut donner l'adresse absolue du fichier
Pour contrôler les dimensions de l'objet il faut mettre width à 100% et choisir la taille de l'objet en agissant sur height.

modele-viewer affiche les objets 3D au format glb et glTF. La plupart des logiciels de modélisation exportent dans ce format sinon vous devrez passer par l'éditeur de three.js pour convertir un fichier d'un autre format.

Imprimer cet élément

  Configuration xampp sur Linux Mint Mate
Posté par : Eric - 14/02/2020, 10:41:40 - Forum : Installation - Réponses (5)

Bonjour,

J'ai installé xampp sur mon ordinateur. Ca marche.

En revanche, quand je vais dans localhost dans mon navigateur et que je clique sur le fichier d'installation de CMSMS

J'ai

Fatal Error
Invalid config value for dest - not a directory, or not writable


J'ai essayé de mettre tous les droits de lecture et d'écriture sur le dossier (et les fichiers qu'il contient) dans lequel j'ai mis le fichir d'installation de CMSMS mais, ça ne change rien...

J'aimerais bien pouvoir  installer CMSMS sur mon ordinateur plutôt que le mettre sur un compte mais voilà, pour l'instant, je n'y arrive pas !!!

Os Court !!!!
Smile

Imprimer cet élément

  Tuto pour créer une galerie d'image
Posté par : FikoU - 31/01/2020, 09:02:14 - Forum : Modules, Tags - Réponses (14)

Bonjour,
J'ai repris l'administration d'un site développé avec CMS-MadeSimple
J'aimerai installer une galerie de photos. Je ne trouve rien sur ce forum ou alors des discussion datant de 2011
Si voua avez un tuto, Un truc pas trop compliqué cela serai sympa.
Merci d'avance
FikoU

Imprimer cet élément

  Linux...etc...
Posté par : pierrepercee - 04/12/2019, 19:34:10 - Forum : Général - Réponses (10)

Petit retour sur Linux pour les débutants....

Installation d'un Ubuntu 18.04 en dual-boot. Puis de LAMP, Phpmyadmin. Pour qui l'a déjà fait pas de souci, pour les autres, préparez votre accès internet....
Abandonner la parfaite compatibilité Windows, c'est juste condamner CMSMS.

J'entends d'ici les linuxiens...Coooomment pas Debian !!!! Non
Lamp c'est 3 lignes dans le terminal... non plus
Le passage à Linux demande un vrai investissement, peu de webmasters, developpeurs, maquettistes ont la possibilité de s'offrir un mois de formation... Ce n'est pas inintéressant, ce n'est pas non plus redoutablement complexe, mais faut un peu de temps.

Je me répète, mais c'est toujours mieux que d'accepter servilement de suivre le cercueil, en faisant semblant d'opiner du chef.

Bon les Linuxiens je les laisse à leurs illusions et à leur terminal, je sens que cela leur manque déjà.

Le reste, du verbiage... pour convaincre les convaincus.

Imprimer cet élément