Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 25/05/2018 11:04:55

locodinodi
Membre
Inscription : 13/01/2015
Messages : 25

Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

----------------------------------------------

Cms Version: 2.2.7

Installed Modules:

    AdminSearch: 1.0.4
    CGExtensions: 1.60.4
    CGGoogleMaps2: 1.1.1
    CGSimpleSmarty: 2.1.8
    CMSContentManager: 1.1.6
    CmsJobManager: 0.1.2
    DesignManager: 1.1.4
    FileManager: 1.6.6
    FilePicker: 1.0.2
    MenuManager: 1.50.3
    MicroTiny: 2.2.2
    ModuleManager: 2.1.3
    Navigator: 1.0.8
    News: 2.51.3
    Search: 1.51.4
    Showtime2: 3.5.4
    SiteMapMadeSimple: 1.2.8


Config Information:

    php_memory_limit:
    max_upload_size: 128000000
    url_rewriting: mod_rewrite
    page_extension: .html
    query_var: page
    auto_alias_content: true
    locale:
    set_names: true
    timezone: Europe/Paris
    permissive_smarty: false


Php Information:

    phpversion: 7.0.27
    md5_function: On  (Vrai)
    json_function: On  (Vrai)
    gd_version: 2
    tempnam_function: On  (Vrai)
    magic_quotes_runtime: Off  (Faux)
    E_ALL: 32759
    E_STRICT: 2048
    E_DEPRECATED: 8192
    test_file_timedifference: Aucune différence de date du système trouvée
    test_db_timedifference: Aucune différence de date du système trouvée
    create_dir_and_file: 1
    memory_limit: 512M
    max_execution_time: 300
    register_globals: Off  (Faux)
    output_buffering: 4096
    disable_functions: _dyuweyrj4, _dyuweyrj4r, dl
    open_basedir:
    test_remote_url: Valable
    file_uploads: On  (Vrai)
    post_max_size: 130M
    upload_max_filesize: 128M
    session_save_path: /tmp (0700)
    session_use_cookies: On  (Vrai)
    xml_function: On  (Vrai)
    xmlreader_class: On  (Vrai)
    check_ini_set: On  (Vrai)
    curl: On 


Performance Information:

    allow_browser_cache: On  (Vrai)
    browser_cache_expiry: 60
    php_opcache: On  (Vrai)
    smarty_cache: Off  (Faux)
    smarty_compilecheck: Off  (Faux)
    auto_clear_cache_age: On  (Vrai)

Server Information:

    Server Software: Apache
    Server Api: fpm-fcgi
    Server Os: Linux 4.14.19-ovh-vps-grsec-zfs-classid On  x86_64
    Server Db Type: MySQL (mysqli)
    Server Db Version: 5.5.55
    Server Db Grants: Impossible de trouver un privilège "GRANT ALL". Cela ne conduit pas nécessairement à des problèmes... Mais si vous avez des problèmes pour installer/retirer des modules ou ajouter/supprimer des éléments de contenu ou pages cela pourrait en être la cause.


Permission Information:

    tmp: /home/technopl/www/tmp (0705)
    tmp_cache: /home/technopl/www/tmp/cache (0705)
    templates_c: /home/technopl/www/tmp/templates_c (0705)
    modules: /home/technopl/www/modules (0705)
    uploads: /home/technopl/www/uploads (0705)
    Masque de création de fichier (umask) : /home/technopl/www/tmp/cache (0705)
    config_file: 0444

----------------------------------------------

Je rencontre les mêmes difficultés que sur cette conversation [résolue] mais avec un questionnement persistant ...
Accueil» Installation» [Résolu] Mise à jour des modules demandés mais impossible avec 2.2.3.1

A savoir :

Certains modules (CGExtensions, CGSimpleSmarty, FileManager, Search) apparaissent avec une mise à jour disponible. Lorsque j'essaie de faire cette mise à jour, le message suivant apparait "Le noyau CMSMS™ doit être mis à jour avant que cette opération ne réussisse" et bloque toute mise à jour.
Cependant, dans le "à propos", je vois que la version du module est bien la dernière. J'ai donc modifié à la main le contenu de la table `cms_modules`avec les bonnes références.
Tout est rentré dans l'ordre.

Qu'est-ce qui peut être à l'origine de ce problème ?
Merci de votre aide.

Dernière modification par locodinodi (05/06/2018 10:21:22)

Hors ligne

#2 25/05/2018 12:38:56

airelibre
Administrateur
Lieu : Alsace
Inscription : 01/12/2009
Messages : 1 182
Site Web

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

Bonjour,

de toute évidence quelque chose s'est mal passé lors de la mise à jour. Les logs serveur te permettent d'en savoir plus ?

Hors ligne

#3 25/05/2018 14:02:10

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

Peut être vérifier dans la base de sonnées la table xxx_version, le champ version doit avoir 202
et bien vider les caches navigateur et cms


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#4 28/05/2018 13:16:49

locodinodi
Membre
Inscription : 13/01/2015
Messages : 25

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

Merci Jce,
En effet, le champ version est à 201 et pas à 202 comme tu l'indiques. J'ai vidé les caches navigateur et cms très régulièrement. Dois-je remplacer le champ version dans la base de données ?
Merci de ton aide

Hors ligne

#5 28/05/2018 19:48:01

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

>Dois-je remplacer le champ version dans la base de données ?

Oui bien sur c'est ce que j'ai indiqué (le champ version doit avoir 202), cela est le bug courant qui m'est arrivé plusieurs fois  cool


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#6 29/05/2018 17:56:59

locodinodi
Membre
Inscription : 13/01/2015
Messages : 25

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

Je viens de modifier. J'attends les prochaines mises à jour pour tester ...
Merci pour ton aide Jce

Hors ligne

#7 29/05/2018 18:24:36

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

tu as réussi tes mise à jour de tes modules ?


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#8 30/05/2018 09:47:14

locodinodi
Membre
Inscription : 13/01/2015
Messages : 25

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

C'est ce que je te disais ... aucune mise à jour à faire (je les avais déjà toutes faites) donc j'attends pour tester ...
A quoi correspond ce 202 ?

Hors ligne

#9 30/05/2018 16:15:12

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

je ne comprends alors tu disais

Certains modules (CGExtensions, CGSimpleSmarty, FileManager, Search) apparaissent avec une mise à jour disponible. Lorsque j'essaie de faire cette mise à jour, le message suivant apparait "Le noyau CMSMS™ doit être mis à jour avant que cette opération ne réussisse" et bloque toute mise à jour.

et c'est pour cela que je t'ai dis de mettre le champ version doit avoir 202

A quoi correspond ce 202 ?

au numéro de version dans la base de données pour le CMSMS ET depuis la version 2.2.0 OU lors de l'upgrade


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#10 01/06/2018 10:18:49

locodinodi
Membre
Inscription : 13/01/2015
Messages : 25

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

Merci Jce.
J'ai bien mis 202 dans le champ version de la BDD
Depuis le début de cette discussion, j'ai pu faire toutes les mises à jour, le bug était lié à l'affichage :
Cependant, dans le "à propos", je vois que la version du module est bien la dernière. J'ai donc modifié à la main le contenu de la table `cms_modules`avec les bonnes références.
J'attends les prochaines mises à jour pour valider que le changement de la version dans la BDD automatise l'affichage des bonnes versions de modules.

Hors ligne

#11 01/06/2018 14:30:23

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

Bonjour locodinodi,
La recherche dans ce forum a été améliorée par Bess il y a quelques années pour que les informations du cms ne soient pas prises en compte SI ET SEULEMENT SI elles sont placées dans une balise [ code] ou écrites dans le champs spécifique lors de la création du premier post.
Ici, toutes tes infos cms vont renvoyer un résultat positif pour la recherche, par exemple si je tape "CGGoogleMaps2" qui est dans tes infos, ton post apparaît, alors qu'il n'a aucun rapport avec ce module.
Pourrais-tu modifier ton premier message et placer tes infos entre [ code] et [ /code] sans les espaces ?
Merci d'avance.

Hors ligne

#12 05/06/2018 10:45:00

locodinodi
Membre
Inscription : 13/01/2015
Messages : 25

Re : Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules

Bonjour,
C'est fait [ code].
Je ne peux toujours pas valider le bon fonctionnement de la modification.
Merci pour ton aide.

Hors ligne

Pied de page des forums