Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 17/04/2018 20:11:44

pixetmots
Membre
Inscription : 23/09/2015
Messages : 42

[Résolu] Module News - Les liens de pagination ne fonctionnent pas

----------------------------------------------
Cms Version: 2.2.3.1
Installed Modules:
AdminSearch: 1.0.4
CGExtensions: 1.57.1
CGSimpleSmarty: 2.1.7
CMSContentManager: 1.1.6
CMSMailer: 6.2.14
Captcha: 0.5.5
CmsJobManager: 0.1.1
DesignManager: 1.1.3
FEupload: 0.3.1
FileManager: 1.6.4
FilePicker: 1.0.1
FormBuilder: 0.8.1.6
Gallery: 2.3.2
JQueryTools: 1.4.0.3
MicroTiny: 2.2.1
MleCMS: 2.0-beta1
ModuleManager: 2.1.2
Navigator: 1.0.8
News: 2.51.3
Search: 1.51.2
SiteMapMadeSimple: 1.2.8

Config Information:
php_memory_limit:
max_upload_size: 64000000
url_rewriting: mod_rewrite
page_extension: .html
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: Europe/Paris
permissive_smarty: false

Php Information:
phpversion: 7.0.28
md5_function: On  (Vrai)
json_function: On  (Vrai)
gd_version: 2
tempnam_function: On  (Vrai)
magic_quotes_runtime: Off  (Faux)
E_ALL: 22517
E_STRICT: 0
E_DEPRECATED: 0
test_file_timedifference: Aucune différence de date du système trouvée
test_db_timedifference: Aucune différence de date du système trouvée
create_dir_and_file: 1
memory_limit: 256M
max_execution_time: 50000
register_globals: Off  (Faux)
output_buffering: 0
disable_functions:
open_basedir:
test_remote_url: Valable
file_uploads: On  (Vrai)
post_max_size: 64M
upload_max_filesize: 64M
session_save_path: /tmp (1777)
session_use_cookies: On  (Vrai)
xml_function: On  (Vrai)
xmlreader_class: On  (Vrai)
check_ini_set: On  (Vrai)
curl: On

Performance Information:
allow_browser_cache: Off  (Faux)
browser_cache_expiry: 60
php_opcache: Off  (Faux)
smarty_cache: On  (Vrai)
smarty_compilecheck: Off  (Faux)
auto_clear_cache_age: On  (Vrai)
Server Information:
Server Software: Apache
Server Api: cgi-fcgi
Server Os: Linux Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux On  Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux
Server Db Type: MySQL (mysqli)
Server Db Version: 5.5.59
Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté

Permission Information:
tmp: /homepages/34/d389106031/htdocs/sonnenberg/tmp (0705)
tmp_cache: /homepages/34/d389106031/htdocs/sonnenberg/tmp/cache (0705)
templates_c: /homepages/34/d389106031/htdocs/sonnenberg/tmp/templates_c (0705)
modules: /homepages/34/d389106031/htdocs/sonnenberg/modules (0705)
uploads: /homepages/34/d389106031/htdocs/sonnenberg/uploads (0705)
Masque de création de fichier (umask) : /homepages/34/d389106031/htdocs/sonnenberg/tmp/cache (0705)
config_file: 0604
----------------------------------------------

Bonjour,

J'ai un soucis avec les liens de pagination de ma page d'affichage des news.
Tout fonctionne correctement sur safari avec OS X
Sur tous les autres navigateurs et OS, les liens rechargent la page actuelle. (y compris sur iOS et les iBidules)

Les liens générés dans le code sources sont exactement les mêmes :

Voici le lien généré :

<a href="http://www.pixetmots.com/sonnenberg/index.php?mact=News,m60317,default,1&amp;m60317summarytemplate=Sonnenberg-NewsNews&amp;m60317category=general&amp;m60317number=4&amp;m60317pagenumber=2&amp;m60317returnid=45&amp;page=45">&gt;</a>

et dans le template :

{if $pagecount > 1}
<div class="clear"></div>
<div class="NewsPagination">
  <p>
    {if $pagenumber > 1}
      {$firstpage}&nbsp;{$prevpage}&nbsp;
    {/if}
    Page&nbsp;{$pagenumber}&nbsp;{$oftext}&nbsp;{$pagecount}
    {if $pagenumber < $pagecount}
      &nbsp;{$nextpage}&nbsp;{$lastpage}
    {/if}
  </p>
</div>
{/if}

Et le lien vers le site (en développement / test ) :

Si quelqu'un à a une petite explication...
Merci.

Dernière modification par pixetmots (18/04/2018 09:10:56)

Hors ligne

#2 18/04/2018 08:44:53

airelibre
Administrateur
Lieu : Alsace
Inscription : 01/12/2009
Messages : 1 212
Site Web

Re : [Résolu] Module News - Les liens de pagination ne fonctionnent pas

Bonjour,

étrange, mais Safari est-il ton navigateur de développement où tu es connecté à l'admin ? Il y a peut être une histoire de cache derrière cela. Dans ce cas :
- Vérifies que la page est non cachable
- Ou si tu assigne la valeur de {content} à une variable, vérifies que "nocache" est bien utilisé :

{$content nocache}

Cela peut être autre chose, mais je commencerai par là ... bon courage !

Hors ligne

#3 18/04/2018 09:12:15

pixetmots
Membre
Inscription : 23/09/2015
Messages : 42

Re : [Résolu] Module News - Les liens de pagination ne fonctionnent pas

En effet, en rendant la page de News non-cachable, et après vidage du cache dans l'admin, ça fonctionne sur tous les navigateurs.

Merciiiii.

Hors ligne

Pied de page des forums