Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 05/01/2018 18:12:53

AG1111
Membre
Lieu : Kerlouan
Inscription : 23/11/2009
Messages : 254
Site Web

[RESOLU] FEU: suite à MàJ 1.12 en 2.2.5 connexion user impossible

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.2.4
#~ Url du site : randokerlouan.fr
#~ Hébergeur / Soft : ovh
#~ Informations Système :
#~      ----------------------------------------------
#~      Cms Version: 2.2.5
#~      Installed Modules:
#~          AdminSearch: 1.0.4
#~          CGExtensions: 1.57.1
#~          CGGoogleMaps2: 1.1.1
#~          CGSimpleSmarty: 2.1.7
#~          CMSContentManager: 1.1.6
#~          CMSMailer: 6.2.14
#~          Captcha: 0.5.5
#~          CmsJobManager: 0.1.2
#~          CustomContent: 1.10
#~          DesignManager: 1.1.4
#~          DownCnt: 2.5.0
#~          FileManager: 1.6.5
#~          FilePicker: 1.0.2
#~          FormBuilder: 0.8.1.6
#~          FrontEndUsers: 2.7.1
#~          Gallery: 2.3.2
#~          Gbook: 2.2.6
#~          JQueryTools: 1.4.0.3
#~          MenuManager: 1.50.3
#~          MicroTiny: 2.2.2
#~          ModuleManager: 2.1.3
#~          Navigator: 1.0.8
#~          News: 2.51.3
#~          Printing: 1.1.2
#~          Search: 1.51.2
#~          SiteMapMadeSimple: 1.2.8
#~          ThemeManager: 1.1.8
#~      Config Information:
#~          php_memory_limit:
#~          max_upload_size: 128000000
#~          url_rewriting: mod_rewrite
#~          page_extension: .html
#~          query_var: page
#~          auto_alias_content: true
#~          locale:
#~          set_names: true
#~          timezone: Europe/Paris
#~          permissive_smarty: false
#~      Php Information:
#~          phpversion: 5.6.30
#~          md5_function: On  (Vrai)
#~          json_function: On  (Vrai)
#~          gd_version: 2
#~          tempnam_function: On  (Vrai)
#~          magic_quotes_runtime: Off  (Faux)
#~          E_ALL: 32759
#~          E_STRICT: 2048
#~          E_DEPRECATED: 8192
#~          test_file_timedifference: Aucune différence de date du système trouvée
#~          test_db_timedifference: Aucune différence de date du système trouvée
#~          create_dir_and_file: 1
#~          memory_limit: 512M
#~          max_execution_time: 300
#~          register_globals: Off  (Faux)
#~          output_buffering: 4096
#~          disable_functions: _dyuweyrj4, _dyuweyrj4r, dl
#~          open_basedir:
#~          test_remote_url: Echec
#~          file_uploads: On  (Vrai)
#~          post_max_size: 130M
#~          upload_max_filesize: 128M
#~          session_save_path: /tmp (0700)
#~          session_use_cookies: On  (Vrai)
#~          xml_function: On  (Vrai)
#~          xmlreader_class: On  (Vrai)
#~          check_ini_set: On  (Vrai)
#~          curl: On
#~      Performance Information:
#~          allow_browser_cache: Off  (Faux)
#~          browser_cache_expiry: 60
#~          php_opcache: On  (Vrai)
#~          smarty_cache: Off  (Faux)
#~          smarty_compilecheck: Off  (Faux)
#~          auto_clear_cache_age: Off  (Faux)
#~      Server Information:
#~          Server Software: Apache
#~          Server Api: fpm-fcgi
#~          Server Os: Linux 4.4.67-ovh-vps-grsec-zfs-classid On  x86_64
#~          Server Db Type: MySQL (mysqli)
#~          Server Db Version: 5.5.55
#~          Server Db Grants: Impossible de trouver un privilège "GRANT ALL". Cela ne conduit pas nécessairement à des problèmes... Mais si vous avez des problèmes pour installer/retirer des modules ou ajouter/supprimer des éléments de contenu ou pages cela pourrait en être la cause.
#~      Permission Information:
#~          tmp: /home/randoker/www/test/tmp (0705)
#~          tmp_cache: /home/randoker/www/test/tmp/cache (0705)
#~          templates_c: /home/randoker/www/test/tmp/templates_c (0705)
#~          modules: /home/randoker/www/test/modules (0705)
#~          uploads: /home/randoker/www/test/uploads (0705)
#~          Masque de création de fichier (umask) : /home/randoker/www/test/tmp/cache (0705)
#~          config_file: 0444
#~      ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~

Bonjour à toutes et à tous avec mes meilleurs vœux pour 2018.


Sur un environnement de test en ligne, j'ai mis à jour ce site de la version 1.12 à la version 2.2.5., j'ai également mis à jour tous les modules additionnels à leur dernière version. Tout fonctionne sauf que les utilisateurs ne peuvent se connecter sur le site parce que le champ de saisie de l'image captcha n'apparaît pas. Je sais un truck connu et la solution est de mettre à jour CGExtension, mais il est à la dernière version ??

Connexion sur randokerlouan.fr

J'ai essayé de trouver le gabarit 'loggin' du module mais il n'est pas accessible à partir de l'admin ni dans les "utilisateurs du site" ni dans les "parametres FEU".

Où se cachent les gabarits de FEU ?

Avez-vous une idée ?


Merci d'avance pour vous réponses

Cordialement

Alain

Dernière modification par AG1111 (08/01/2018 19:07:24)

Hors ligne

#2 06/01/2018 17:47:19

Ouik
Modérateur
Lieu : Bourgogne
Inscription : 08/01/2008
Messages : 1 062
Site Web

Re : [RESOLU] FEU: suite à MàJ 1.12 en 2.2.5 connexion user impossible

Les gabarits FEU se trouvent désormais dans disposition > gestion du design.

Hors ligne

#3 07/01/2018 11:46:51

AG1111
Membre
Lieu : Kerlouan
Inscription : 23/11/2009
Messages : 254
Site Web

Re : [RESOLU] FEU: suite à MàJ 1.12 en 2.2.5 connexion user impossible

Merci Ouik, j'ai fini par les trouver.

Par contre, ça ne m'avance pas beaucoup car le code qui affiche la partie captcha du template de loggin est le même que celui qui existe en cmsms v 1.12. SI je passe ce code de la v 2.2.5 en 1.12 il fonctionne et à l'inverse le code de la v1.12 ne fonctionne pas non plus en v2.2.5. Ce qui peut être rassurant. Autre précision ce comportement est le même avec IE et Chorme donc ce ne doit pas être un pb de config de navigateur.

J'ai lu dans un texte de JCE "CMS Made Simple Version 2.0" qui date de 2015, dans les problèmes de mise à jour, que la portée des variables Smarty à changée et qu'il faut les copier explicitement dans un autre champs d'application. Là je coince car mes compétences en Smarty sont quasi nulles et je sais pas comment m'en sortir.

Voici le code :

[== Indéfini ==]
  {if isset($captcha)}
  <div class="row">
    <p class="col-md-4 text-right"><label for="feu_captcha">{$captcha_title}:</label></p>
    <div class="col-md-8">{$captcha}
       <div class="row">{$input_captcha}</div>
  </div>
  {/if}

Dans le code de la page j’obtiens :

[== Indéfini ==]
<div class="row">
    <p class="col-md-4 text-right"><label for="feu_captcha">Veuillez entrer le texte de l'image:</label></p>
    <div class="col-md-8"><input type="hidden" name="hncaptcha" value="31122132231111123221331113221122"/>
<input type="hidden" name="hncaptcha_public_key" value="4b4de"/>
<img class="captchapict" src="/tmp/cache/hn_captcha_4b4de.jpg" width="198" height="72" alt="This is a captcha-picture. It is used to prevent mass-access by robots. (see: www.captcha.net)" title="No Bots allowed" />


       <div class="row"></div>
  </div>

Donc, à priori, c'est la variable $input_captcha qui ne fonctionne pas. Mais dans ce cas pourquoi les autres variables Smarty de ce gabarit fonctionnent et pas celle là ?

Que faire ?

Merci d'avance

Hors ligne

#4 08/01/2018 19:06:42

AG1111
Membre
Lieu : Kerlouan
Inscription : 23/11/2009
Messages : 254
Site Web

Re : [RESOLU] FEU: suite à MàJ 1.12 en 2.2.5 connexion user impossible

Bon, je n'ai pas trouvé pourquoi ça ne fonctionne pas mais j'ai trouvé un contournement : je passe par reCaptcha et là pas de pb.

Donc sans être résolu je modifie mon premier poste mais si vous avez une idée du pourquoi ceci se produit je suis preneur.

Dans la foulée je passe le site en prod en version 2.2.5. donc à bientôt pour d'autres surprises.

Amicalement

Alain

Hors ligne

Pied de page des forums