Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 27/06/2013 14:05:45

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 6 094
Site Web

MicroTiny ne s'affiche pas dans les pages

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: !1.11.6
#~ Url du site : www.furie.be
#~ Hébergeur / Soft : firstheberg
#~ Informations Système :
#~      ----------------------------------------------
#~      Cms Version: 1.11.6
#~      Installed Modules:
#~          CMSMailer: 5.2.1
#~          FileManager: 1.4.3
#~          MenuManager: 1.8.5
#~          MicroTiny: 1.2.5
#~          ModuleManager: 1.5.5
#~          News: 2.12.10
#~          Search: 1.7.7
#~          CGExtensions: 1.35
#~          CGSmartImage: 1.10.10
#~          SiteMapMadeSimple: 1.2.7
#~          Captcha: 0.4.6
#~          CGFeedMaker: 1.0.17
#~          Shootbox: 1.4.0
#~          JQueryFU: 1.0.5
#~          DownCnt: 2.3.0
#~          Disqus: 2.0
#~          SEOTools2: 1.2.1
#~      Config Information:
#~          php_memory_limit:
#~          process_whole_template:
#~          output_compression:
#~          max_upload_size: 2000000
#~          url_rewriting: mod_rewrite
#~          page_extension: .html
#~          query_var: page
#~          image_manipulation_prog: GD
#~          auto_alias_content: true
#~          locale:
#~          default_encoding: utf-8
#~          admin_encoding: utf-8
#~          set_names: true
#~      Php Information:
#~          phpversion: 5.3.3-7+squeeze15
#~          md5_function: On (Vrai)
#~          gd_version: 2
#~          tempnam_function: On (Vrai)
#~          magic_quotes_runtime: Off (Faux)
#~          E_STRICT: 0
#~          E_DEPRECATED: 0
#~          memory_limit: 128M
#~          max_execution_time: 30
#~          output_buffering: 4096
#~          safe_mode: Off (Faux)
#~          file_uploads: On (Vrai)
#~          post_max_size: 8M
#~          upload_max_filesize: 2M
#~          session_save_path: /var/lib/php5 (1733)
#~          session_use_cookies: On (Vrai)
#~          xml_function: On (Vrai)
#~          xmlreader_class: On (Vrai)
#~      Server Information:
#~          Server Api: cgi-fcgi
#~          Server Db Type: MySQL (mysql)
#~          Server Db Version: 5.1.66
#~          Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
#~      ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Salut la compagnie

J'ai un soucis récurent sur mon serveur qui est sous Cherokee (et le soucis est peut être lié)

MicroTiny ne s'affiche pas dans les pages de contenu, il s'affiche néanmoins dans deux conditions :

* dans l'édition des news
* si je décoche les options "Autoriser les images" & "Afficher la barre d'état", j'ai l'exemple de microtiny qui remarche, les contenu par contre ne fonctionnent toujours pas...

Ce qui est frustrant big_smile

L'erreur est lié à JS comme le montre la console d'erreur de FF :

Horodatage : 27/06/2013 12:55:09
Erreur : SyntaxError: syntax error
Fichier Source : http://www.furie.be/tmp/cache/mt_98416e … 1372330438
[...]

et pour cause, à la ligne donnée (285) du fichier on se rend compte que celui ci est tronqué ! C'est donc la mise en cache du fichier qui est à l'origine des pannes.

J'ai vérifié : le serveur est à la bonne heure UTC+2
J'ai vérifié : config.php contient $config['timezone'] = 'Europe/Paris';

J'ai ensuite zieuté le fichier mt_98416e8rv8vane9sqlbn5vngu2.js de plus prêt : sous unix il est parfait, aucun symbole ou caractère bizarre et pourtant firefox continue de me dire qu'il est tronqué... J'ouvre avec IE : pareil il est tronqué !

http://www.furie.be/tmp/cache/mt_98416e … n5vngu2.js?

function CMSMSFilePicker (field_name, url, type, win) {
     
  var cmsURL = "http://www.furie.be/admin/moduleinterface.php?mact=MicroTiny,,filepicker,0&_sx_=32fecd50&type="+type+"&showtemplate=false";
 
  tinyMCE.activeEditor.windowManager.open({
 
    file : cmsURL,
    title : 'Fichiers CMSMadeSimple',
    width : '800',
    height : '500',
    resizable : "yes",
    scrollbars : "yes",
    inline : "yes", 
    close_pr

avec un analyseur de trame réseau on voit bel et bien qu'un caractère spécial est envoyé au client depuis le serveur

J'ai réussit à m'en sortir en éditant avec nano directement le fichier (suppression des derniers caractères blanc potentiellement des caractères spéciaux) et ça remarche... mais pour combien de temps et surtout comment cela est il possible ???

Si l'un d'entre vous a déjà rencontré le soucis je suis preneur smile

Hors ligne

 

Pied de page des forums

  Flux Rss Twitter FaceBook