Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#51 29/11/2012 12:57:01

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 051
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

Il faut poster sur le Bug pour enfoncer le clou

je modifie le titre   [Résolu-mais bug #8684]


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

 

#52 29/11/2012 13:08:29

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

J'ai posté sur le bug.
@pierrepercee : peux-tu modifier le bug en ajoutant Assigned To: Calguy

Hors ligne

#53 29/11/2012 13:27:58

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

@Jce, comprend-tu cette table routes ?

Hors ligne

#54 29/11/2012 13:56:17

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 051
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

>comprend-tu cette table routes ?

ben je n'ai pas trop chercher à comprendre ...
sur l'install standard ça ne concerne que les news

je viens de regarder sur une version de base ancienne 1.9.5 mise à jour 1.1.14 sans news la table est vide
je mets à jour en admin et c'est toujours vide


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#55 29/11/2012 14:03:46

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

je mets à jour en admin et c'est toujours vide

Oui, bizarre. Et pourtant ça a un rapport direct avec le temps nécessaire pour afficher la page login.

Dernière modification par Jean le Chauve (29/11/2012 14:05:09)

Hors ligne

#56 29/11/2012 17:29:32

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

Ok, j'ai pigé : il y a un bug pour la création des routes (ce qui donne d'ailleurs le problème des pages 404 pour le détail des news en url rewriting).
Voici le cas : SI vous êtes en url_rewriting ET SI la table _routes est vide ET que vous videz le cache, les pages de détail des news et les pages de contenu avec url de page renseignée (voir options de la page) envoient sur un 404.
SI vous cliquez ensuite sur mise à jour de la table routes, la table se remplit avec 4 lignes key1 News et les lignes key1 _CONTENT_ pour les pages avec url renseignées.
L'erreur 404 n'apparaît plus.
Videz à nouveau le cache, remettez à jour la table route : la table _routes se vide.
L'erreur 404 n'apparaît pas.
Videz le cache, erreur 404.

De plus, après quelques essais, il n'y a plus rien dans tmp/cache et tmp/template_c et vous ne pouvez plus accéder à votre admin ni au frontend.

Hors ligne

#57 29/11/2012 18:33:49

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

Ok, exactement la même chose ne local avec la svn 8514 (qui corrige le type de table).
Quelqu'un peut confirmer ?

Hors ligne

#58 29/11/2012 19:22:54

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 051
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

en local WAMP 1.11.4 8513Fr

cela veut dire l'install ou mise à jour c'est mal passée et dans ce cas il y une alter te sur la mise à jour

donc le test
- url_rewriting
-la table _routes est vidée
le cache vidé

les pages de détail des news  -> erreur 404
pour les pages normales tout est Ok


>et les pages de contenu avec url de page renseignée (voir options de la page) envoient sur un 404.
La je ne vois pas ce que tu veux dire

-  mise à jour de la table routes, la table se remplit   pas d'erreur 404


>Videz à nouveau le cache, remettez à jour la table route : la table _routes se vide.
OK
>L'erreur 404 n'apparaît pas.
OK

>Videz le cache, erreur 404.
OK uniquement pages de détail des  news

EDIT a l'instant
Révision 8514 -- modify CreateTableSQL to be smarter about table options  - ...
Mais cela ne change "le bidule" que l'ors d'une installa ou MAJ


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#59 29/11/2012 19:41:47

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

Les pages de contenu avec url renseignée se comportent exactement comme les news pour l'erreur 404.
Administration du site, paramètres globaux, paramètres de la liste des pages, Afficher la colonne "URL" : oui
Contenu, pages, options,
URL de page :
Spécifie une URL alternative (relative à la racine du site Web) qui peut être utilisée pour uniquement identifier la page. Exemple : chemin/vers/mapage. Les URLs des pages sont utilisables si "URL de page" est actif.

Hors ligne

#60 29/11/2012 19:45:48

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

Une meilleure traduction serait : ...qui peut être utilisée pour identifier de manière unique cette page

Hors ligne

#61 29/11/2012 19:53:45

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 051
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

>et les pages de contenu avec url de page renseignée
OK Vu apres ton explication et test
bien sur l'URL est dans table route  neutral

Alors tu n'a plus qu'a refaire un nouveau bug ! pour la table route (en déroute)


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#62 29/11/2012 19:58:19

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 051
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

NOTA le bug #8684 est normalement corrigé sur le SVN Révision 8514 -- modify CreateTableSQL to be smarter about table options  - ...
Fixed in SVN.  Needs significant testing for new installs and
uninstall/re-install of modules when using mysqli driver particularly.

A tester et valider si OK

Pour moi install complète WAMP PHP 5.4.9 + MySql 5.5.20  avec mysqli ou mysql driver
pas bon les tables  _seq ne sont pas  MyISAM mais InnoDB ->A confirmer !


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#63 29/11/2012 20:04:23

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

Je laisse tomber pour ce soir, je déposerai le bug demain et testerai les créations de table sous 8514.
Bonne soirée à tous et un grand merci, surtout à toi Jce.

Hors ligne

#64 29/11/2012 20:13:58

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 051
Site Web

Re : [Résolu-mais bug #8684]Erreur maintenance du système

>Je laisse tomber pour ce soir

Ok je vais fermé cette discussion et ouvrir une nouvelle uniquement sur le #8684 pour suivi avec référence a ce topic
Suite sur http://www.cmsmadesimple.fr/forum/viewtopic.php?id=4755


@Jean -a ce moment si tu veux ouvrir une autre discussion sur le bug que tu va déposé avec référence a ce topic


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

Pied de page des forums

  Flux Rss Twitter FaceBook