Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de Cms Made Simple. Nous ne faisons de support que sur LA dernière version de CmsMadeSimple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 31/01/2012 08:22:39

matbio
Membre
Inscription : 31/01/2012
Messages : 6

[resolu] Ancienne version comment migrer

Bonjour a tous,

J'ai un vieux site en version 1.41


Je dois le faire evoluer et par la meme occasion le mettre a jour, en suivant les etapes de base avec la version 1.10 ça ne fonctionne  ....


methode utilisé : transfert et remplacement des fichiers de la 1.10 sur ancienne version --- vidange du dossier temporaire --- upgrade.php

je me retrouve avec pas mal d'erreur ...


y'a t'il une methode pour que je puisse tout upgrader de cette ancienne version vers la plus recente ??


merci de vos conseils...

Dernière modification par matbio (31/01/2012 23:43:03)

Hors ligne

 

#2 31/01/2012 09:58:19

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 5 935
Site Web

Re : [resolu] Ancienne version comment migrer

tu as choisit la bonne méthode. Reste à suivre les recommandations de la 1.10, notamment les modules qui posent problèmes.

Quels messages d'erreurs as tu ?
Vas tu jusqu'au bout du processus de mise à jour ?
où sont les informations qu'on demande lors de la création du topic ? (version php?)

Hors ligne

#3 31/01/2012 22:53:59

matbio
Membre
Inscription : 31/01/2012
Messages : 6

Re : [resolu] Ancienne version comment migrer

merci pour ta reponse ,

premiere chose je suis sous ovh,

enduite j'ai modifié le htaccess pour etre en php 5

j'ai eu des erreurs basiques avant de l'integrer a la racine bien sur
actuellement le processus ne decolle pas

j'ai une erreur php :

Call to undefined method ContentOperations::get_instance() sur le fichier /lib/autoloader.php

voila ou j'en suis

le processus n'a pas avancé d'un poil

Hors ligne

#4 31/01/2012 23:08:07

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 5 935
Site Web

Hors ligne

#5 31/01/2012 23:09:49

matbio
Membre
Inscription : 31/01/2012
Messages : 6

Re : [resolu] Ancienne version comment migrer

j'ai mis

SetEnv PHP_VER 5

Dernière modification par matbio (31/01/2012 23:10:01)

Hors ligne

#6 31/01/2012 23:42:21

matbio
Membre
Inscription : 31/01/2012
Messages : 6

Re : [resolu] Ancienne version comment migrer

J ai trouvé un topic en anglais disant de supprimer l'ensemble des fichiers, j'ai donc recréé un dossier ou j'ai mis l'ancien config ça a la maj a fonctionné , maintenant j'ai des soucis de rewriting , ça fais longtemps que je me suis plus penché dessus ... en tout cas la solution est la ...

uploader l'ensemble de la nouvelle version, et modifier le config.php uniquement, ensuite lancer l'upgrade ...

Hors ligne

#7 31/01/2012 23:42:45

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 5 935
Site Web

Re : [resolu] Ancienne version comment migrer

http://guide.ovh.com/Php5ChezOvh

tente plutôt SetEnv PHP_VER 5_3

Si tu as la même erreur décrit nous cette partie

j'ai eu des erreurs basiques avant de l'integrer a la racine bien sur
actuellement le processus ne decolle pas

Hors ligne

#8 31/01/2012 23:47:22

matbio
Membre
Inscription : 31/01/2012
Messages : 6

Re : [resolu] Ancienne version comment migrer

Merci pour ta reponse , elle se sont croisées
j'ai tout de meme tenter ta modif,

voici les erreurs

Deprecated: Assigning the return value of new by reference is deprecated in /****/lib/classes/class.contentoperations.inc.php on line 61

Deprecated: Assigning the return value of new by reference is deprecated in /*****/lib/classes/class.contentoperations.inc.php on line 547

Fatal error: Call to undefined method ContentOperations::get_instance() in /****/lib/autoloader.php on line 82


eventuellement je peux continuer les tests sur la version qui veut pas se mettre a jour voir si il est possible de trouver une solution qui pourrait etre utile.... je reste a disposition sur ce post

Hors ligne

#9 31/01/2012 23:52:17

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 5 935
Site Web

Re : [resolu] Ancienne version comment migrer

les deprecated... fallait s'y attendre. Reviens sur ta version d'origine pour le .htaccess, de toute façon ça ne corrige rien visiblement...

Je suis tombé sur le même topic que toi. Si la solution t'as convenu : tant mieux, mais je t'avoue que je comprend pas ce qui peut se passer... enfin bon, un bon reset d'une installation aussi vielle pose certes quelques soucis de reparamétrage, mais tu gagne énormément en stabilité de l'appli (à l'inverse de claquer des fichiers avec une telle différence de version)

Hors ligne

#10 01/02/2012 08:05:21

matbio
Membre
Inscription : 31/01/2012
Messages : 6

Re : [resolu] Ancienne version comment migrer

J'ai surtout gagner le droit de me replonger la dedans a plein tube !!!! il va falloir mettre les mains dans le cambouis !!!

en tout cas merci  ...



bonne journée

Hors ligne

Pied de page des forums

  Flux Rss Twitter FaceBook
fermer

Maintenance cette fin de WE

Bess opère une série d'opération sur les serveurs ce dimanche qui va certainement s'étendre sur le début de la semaine prochaine. [lire la suite]