Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 21/11/2017 13:47:53

bobjo
Membre
Inscription : 24/02/2012
Messages : 184

Plus de wysiwyg dans l'administration

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.2.3.1
#~ Url du site :
#~ Hébergeur / Soft :
#~ Informations Système :
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bonjour,

Je viens de mettre à jour notre site (2.1.3 vers 2.2.3.1).
Nous n'avons plus de wysiwyg dans l'admin...
Tous les modules ont été mis à jour.

Auriez vous une solution ?

Cordialement

bobjo

Hors ligne

#2 21/11/2017 16:00:59

bobjo
Membre
Inscription : 24/02/2012
Messages : 184

Re : Plus de wysiwyg dans l'administration

Bon apparemment c'est dans le module TinyMCE que je trouve un problème.
La méthode WYSIWYGGenerateHeader (ligne 89) doit retourner les balises script avec les chemin vers les différents fichiers .js.
Le retour ce fait par la variable $header.
Après plusieurs débug j'ai remarqué que la variable ne se concatène pas alors qu'il n'y a pas de condition qui l'en empêche.

Si vous avez une idée...

Cordialement

bobjo

Hors ligne

#3 21/11/2017 16:15:22

bobjo
Membre
Inscription : 24/02/2012
Messages : 184

Re : Plus de wysiwyg dans l'administration

Bon en mettant echo $header; avant le return de la fonction, le wysiwyg est chargé...

Si quelqu'un peut m'expliqué.......

Cordialement

bobjo

Hors ligne

#4 21/11/2017 16:29:19

bobjo
Membre
Inscription : 24/02/2012
Messages : 184

Re : Plus de wysiwyg dans l'administration

Alors le fait de mettre echo $header affiche les balises script dans la balise head au tous début. C'est pour cela que le wysiwyg fonctionne.
Donc le problème ne viens pas du module wysiwyg mais de la fonction qui intègre les balise dans la balise head. Dans le fichier footer.php : $themeObject->add_headtext($obj->WYSIWYGGenerateHeader());

Cordialement

bobjo

Hors ligne

Pied de page des forums