Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 16/11/2017 13:43:01

pierrepercee
Membre
Inscription : 11/06/2009
Messages : 429
Site Web

[résolu] TinyMCE 3.2 thumbnails prévisualisation images invisibles

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.2.3.1
#~ Url du site :
#~ Hébergeur / Soft : ovh 2014 pro
#~ Informations Système :
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bon cela devient compliqué . Sur des sites mis à jour de 2.1.4 en 2.2.3.1 je ne réussis pas à avoir la prévisualisation des images dans le responsive file manager. Les thumbs correspondantes aux images sont pourtant bien présentes dans le répertoire tmp/thumbs etc... J'ai tout essayé, vider le cache(y compris manuellement en ftp) changer les chmod (de 644 en 755...), activer/desactiver aviary, mais rien n'y fait. (y compris desinstallation et reinstallation complète du module).
J'ai fouiné un peu et voilà le résultat de l'enquête.
Le code HTML retourné pour une image donnée est celui-ci :

[== HTML ==]
<div class="img-container">
<img class=" lazy-loaded" data-original="../../../../tmp/thumbs/images/ballons/foot-2015.jpg" src="data:image/png;base64,iVBORw0....">
</div>

Visiblement tout se passe comme si l'image était incorporé dans le HTML (embed) or sur une installation neuve directement en 2.2.3.1 tout fonctionne normalement et le code obtenu est celui-ci.

[== Indéfini ==]
<img class=" lazy-loaded" data-original="../../../../tmp/thumbs/images/ballons/foot-2015.jpg" src="../../../../tmp/thumbs/images/ballons/foot-2015.jpg" style="display: inline;">

Un paramètre ancien a du rester dans la base de données et être récupéré par tinyMCE.

Si cela parle à quelqu'un... Pour info voici la liste des modules "exogènes" installés sur les sites mises à jour (certains n'ont ni cgsimplesmarty ni cgcalendar et présentent la même pathologie)

CGCalendar: 2.5
CGExtensions: 1.57.1
CGSimpleSmarty: 2.1.7
Captcha: 0.5.5
FormBuilder: 0.8.1.6
Gallery: 2.3.2
TinyMCE: 3.2-beta3

chez OVH du mutu en php 7.0.23, en principe ça fonctionne plutôt correctement.(Server Api: fpm-fcgi )

Bon allez je vais regarder du côté de la bd....

AireLibre si t'es dans le coin smile

Dernière modification par pierrepercee (16/11/2017 16:55:44)


Win 7 pro 64 - CMSMS 1.6.4 à 2.1.2

Hors ligne

#2 16/11/2017 14:22:13

airelibre
Administrateur
Lieu : Alsace
Inscription : 01/12/2009
Messages : 1 183
Site Web

Re : [résolu] TinyMCE 3.2 thumbnails prévisualisation images invisibles

Il faut que je mette en place le dernier Responsive File Manager - il y a en effet un problème d'affichage des miniatures - au rechargement de page c'est OK

A suivre... !

Hors ligne

#3 16/11/2017 14:34:51

pierrepercee
Membre
Inscription : 11/06/2009
Messages : 429
Site Web

Re : [résolu] TinyMCE 3.2 thumbnails prévisualisation images invisibles

Effectivement sur une installation "fraiche" il y a ce petit souci de "rafraichissement" mais bon lorsqu'on le sait ce n'est pas trop pénalisant.
Par contre sur une installation mise à jour (2.1.4 c'est pas non plus la préhistoire) là c'est beaucoup plus gênant.

Je n'arrive pas à savoir ce qui perturbe le fonctionnement du module et fait qu'il "incorpore" les images dans le html ...


Win 7 pro 64 - CMSMS 1.6.4 à 2.1.2

Hors ligne

#4 16/11/2017 16:54:11

pierrepercee
Membre
Inscription : 11/06/2009
Messages : 429
Site Web

Re : [résolu] TinyMCE 3.2 thumbnails prévisualisation images invisibles

Bon j'ai tout essayé sauf de changer les droits sur le répertoire Thumbs qui était en 0766.... Et comme ce répertoire n'avait pas été supprimé lors de la mise à jour.... En 0755 ça passe bien mieux hein AireLibre (j'ai trouvé le bug et la réponse sur le forum En)


Win 7 pro 64 - CMSMS 1.6.4 à 2.1.2

Hors ligne

#5 16/11/2017 16:55:02

airelibre
Administrateur
Lieu : Alsace
Inscription : 01/12/2009
Messages : 1 183
Site Web

Re : [résolu] TinyMCE 3.2 thumbnails prévisualisation images invisibles

Bien vu wink

Hors ligne

Pied de page des forums