Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 14/03/2017 17:53:11

bobjo
Membre
Inscription : 24/02/2012
Messages : 172

[RESOLU] CMSMS et HTTPS

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: ?
#~ Url du site :
#~ Hébergeur / Soft :
#~ Informations Système :
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bonjour,

Je dois passer plusieurs sites en https.

J'ai modifié le fichier .htaccess comme ceci pour avoir une redirection :

[== Indéfini ==]
 RewriteCond %{SERVER_PORT} 80
 RewriteRule ^(.*) https://www.monsite.tld/$1 [QSA,L,R=301]

Sur le front cela fonctionne mais j'ai un problème avec l'administration.
Sur le forum j'ai vu qu'il fallait ajouter :

[== Indéfini ==]
$config['admin_url'] = 'https://www.monsite.tld/admin';

Cela me met bien https sur la page de connexion, mais dans l'administration en soit.

Auriez vous une solution ou une idée pour résoudre ce problème ?

Cordialement

bobjo

Dernière modification par bobjo (15/03/2017 12:33:03)

Hors ligne

 

#2 14/03/2017 19:19:04

airelibre
Administrateur
Lieu : Alsace
Inscription : 01/12/2009
Messages : 1 124
Site Web

Re : [RESOLU] CMSMS et HTTPS

Bonjour,

essaye en ajoutant $config['root_url'] = 'https://www.monsite.tld';

Avec ca, plus besoin de admin_url normalement

Tiens-nous au jus,

Hors ligne

#3 15/03/2017 12:32:42

bobjo
Membre
Inscription : 24/02/2012
Messages : 172

Re : [RESOLU] CMSMS et HTTPS

C'est parfait.

Cela fonctionne nickel !!!

Merci.

Cordialement

bobjo

Hors ligne

#4 15/03/2017 12:39:21

airelibre
Administrateur
Lieu : Alsace
Inscription : 01/12/2009
Messages : 1 124
Site Web

Re : [RESOLU] CMSMS et HTTPS

Génial wink

En général pour un passage en HTTPS, il faut adapter le config.php avec le bon $config['root_url'], puis veillez à ce que le .htaccess n'ait pas une redirections quelconque vers un "http:".

Enfin, une vidange du cache pour être sûr wink

Hors ligne

Pied de page des forums

  Flux Rss Twitter FaceBook