Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 04/12/2012 23:27:48

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Tests sur 1.11.4 ImageManager sous Windows

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 1.11.4 TEST
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~

Recherche testeurs avec version future 1.11.4 (sotie possible fin de semaine) pour tester à fond ImageManager sous WAMP (Windows)
il semble avoir des soucis pour la suppression d'images
les logs de suppression ne semblent pas pris en compte

donner les informations ici
merci

Edit le bug  http://dev.cmsmadesimple.org/bug/view/8673


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#2 05/12/2012 08:50:49

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Cms Version: 1.11.4 Fernandina_8539Fr

Installed Modules:

    CMSMailer: 5.2.1
    CMSPrinting: 1.0.3
    FileManager: 1.4.3
    MenuManager: 1.8.4
    MicroTiny: 1.2.5
    ModuleManager: 1.5.5
    News: 2.12.10
    Search: 1.7.7
    ThemeManager: 1.1.7

Config Information:

    php_memory_limit:
    process_whole_template:
    output_compression:
    max_upload_size: 20000000
    url_rewriting: mod_rewrite
    page_extension:
    query_var: page
    image_manipulation_prog: GD
    auto_alias_content: true
    locale:
    default_encoding: utf-8
    admin_encoding: utf-8
    set_names: true

Php Information:

    phpversion: 5.3.13
    md5_function: On (Vrai)
    gd_version: 2
    tempnam_function: On (Vrai)
    magic_quotes_runtime: Off (Faux)
    E_STRICT: 0
    E_DEPRECATED: 8192
    memory_limit: 124M
    max_execution_time: 80
    output_buffering: 1
    safe_mode: Off (Faux)
    file_uploads: On (Vrai)
    post_max_size: 28M
    upload_max_filesize: 20M
    session_save_path: T:/Applications7/Wamp/tmp (0777)
    session_use_cookies: On (Vrai)
    xml_function: On (Vrai)
    xmlreader_class: On (Vrai)

Server Information:

    Server Api: apache2handler
    Server Db Type: MySQL (mysqli)
    Server Db Version: 5.5.24
    Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté

@Jce : il manque 1 fichier dans ton archive cms1113_fr.tar.bz2 : /lib/jquery/js/jquery.ui.nestedSortable-1.3.4.js

Installation neuve avec Wamp 2.2, Windows7 64bits, mod_rewrite activé, debug activé, testé sur Firefox 17.0.1, IE9

L'archive diff. svn a été prise sur le site de Jce.
Upload d'1 jpg dans uploads/images : test.jpg -> OK (+log admin)
delete de test.jpg -> NO
script appelé : images.php?dir=/&delf=%2Ftest.jpg

Création d'un sous-dossier : uploads/images/design -> OK (+log admin)
Upload d'1 jpg dans uploads/image/design : test.jpg ->OK (+log admin)
delete de /images/test.jpg -> OK (pas de log admin)
script appelé : images.php?dir=/design/&delf=%2Fdesign%2Ftest.jpg

Les images situées dans des sous-dossiers peuvent être supprimées, pas celles de /images
Pas de création de ligne dans le journal de l'administration lors de la suppression réussie d'une image.

Les tests ont été également réalisés avec jquery-1.8.3.min.js (résultats semblables).

Dernière modification par Jean le Chauve (05/12/2012 08:59:16)

Hors ligne

#3 05/12/2012 09:55:30

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Sur wamp : 1.11.4 “Fernandina_8522Fr”
Les images ne peuvent pas être supprimées dans le dossier images, mais peuvent être supprimées dans les sous-dossiers
Sur wamp : 1.11.2.1 “Isabela”
Les images ne peuvent pas être supprimées dans le dossier images ni dans les sous-dossiers
Sur OVH : 1.11.4 “Fernandina_8526Fr”
Les images peuvent être supprimées dans le dossier images et les sous-dossiers.

Hors ligne

#4 05/12/2012 10:19:16

heriquet
Administrateur
Lieu : Stavelot
Inscription : 20/01/2009
Messages : 1 018
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Elle a quoi de neuf la 1.11.4 ? Je trouve pas de roadmap...


www.web-ep.be - Développeur Web Freelance - Développeur/Intégrateur CMS Made Simple (création de sites, développement de modules/plugins/templates sur mesure), spécialisé dans les sites pour l'immobilier.

Hors ligne

#5 05/12/2012 10:42:14

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

>@Jce : il manque 1 fichier dans ton archive cms1113_fr.tar.bz2 : /lib/jquery/js/jquery.ui.nestedSortable-1.3.4.js
Zut loupé un fichier alors je corrige - merci

Sur OVH : 1.11.4 “Fernandina_8526Fr”

tu es sur Windows ??

Les images situées dans des sous-dossiers peuvent être supprimées, pas celles de /images
Pas de création de ligne dans le journal de l'administration lors de la suppression réussie d'une image.

OUI c'est idem pour moi
Reste à trouver l'erreur de Non suppression parce Robert il a du mal à trouver vu que il "hait" windows

Elle a quoi de neuf la 1.11.4 ? Je trouve pas de roadmap...

ha!! ça existe la roadmap  yikes
Donc ce n'est que les correction de la 1.11.3 en gros
- Correction type des table à MyIsam bug 8684
- Filemanager  V 1.4.3  bug 8679
- Microtiny V 1.2.5
- mise à jour de doc/CMSMS_config_reference.pdf
sinon lire le changelog pour les info complètes


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#6 05/12/2012 11:05:33

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Sur OVH : 1.11.4 “Fernandina_8526Fr” : non, c'est du linux (c'était pour allonger le post wink)

Hors ligne

#7 05/12/2012 11:22:37

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Pour le fonctionnement sous Linux c'est OK la suppression ça doit venir d'un p'tite erreur de lien sous Windoze


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#8 05/12/2012 11:34:53

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Pour moi, le problème vient de ceci :
Dans un sous-dossier (design), Firebug m'annonce :
HTMLDocument Scope    Document images.php?_sx_=989e9acd&dir=/design/
Par contre, dans images/ :
HTMLDocument Scope    Document images.php?dir=%2F  devrait être /

Dernière modification par Jean le Chauve (05/12/2012 11:35:24)

Hors ligne

#9 05/12/2012 11:48:30

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Oui il y a un problème sur le /


je pense que
dans ImageManager.php  function _delFile($relative)

$r2 = Files::fixPath(dirname($relative));
           // si dans images/ $r2 = \/  // si dans images/test   $r2 = /test/
et la fonction

if( !$this->validRelativePath($r2) ) return false;  //renvoi false


Il y a tellement de modif avec les URLs en HTTPS que ....

Bref en 1.10.3.0Fr  "Hyacinthe-7675 c'était bon


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#10 05/12/2012 11:59:39

pierrepercee
Membre
Inscription : 11/06/2009
Messages : 429
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Marrant, je viens de faire le test avec 1.11.4 “Fernandina_8526Fr”, cela ne fonctionne évidemment pas pour l'image à la racine mais par contre, contrairement à Jean le / prend bien un coup d'URLencode dans les deux cas ...(vérifié avec Firebug)


[== Indéfini ==]

http://127.0.0.1/1124/lib/filemanager/ImageManager/images.php?dir=/&delf=%2Ffeu-280.jpg
http://127.0.0.1/1124/lib/filemanager/ImageManager/images.php?dir=/abc/&delf=%2Fabc%2Fzagreb280.jpg

Dernière modification par pierrepercee (05/12/2012 12:01:06)


Win 7 pro 64 - CMSMS 1.6.4 à 2.1.2

Hors ligne

#11 05/12/2012 13:19:22

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

On n'est pas au même endroit :
Place-toi sur l'onglet "script" et clique sur "point d'arrêt la prochaine fois (en-dessous de l'insecte) et regarde à droite (espions)
Il va s'arrêter à chaque procédure, tu cliques alors sur "step into" ou F11
Tu verras alors le scope.

Autre problème : crée un dossier "essai" et suis la procédure indiquée ci-dessus.
Tout se passe bien, il supprime le dossier.
Maintenant, essaye à nouveau de supprimer une image dans /images
HTMLDocument Scope    Document images.php?dir=/&deld=%2Fessai%2F
Le scope est différent !

Hors ligne

#12 05/12/2012 13:30:38

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#13 05/12/2012 13:31:39

pierrepercee
Membre
Inscription : 11/06/2009
Messages : 429
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Salut Jean, je vais vérifier. Je viens de mettre le doigt sur un autre bug.... Si tu mets des majuscules dans le nom d'un sous répertoire, il ne parvient pas à créer la thumbs et donc à l'afficher
abc/fr-gh1/dk-UP3/edbw420.jpg --> marche pas
abc/fr-gh1/dk-up3/edbw420.jpg --> fonctionne

Pour les utilisateurs avertis, y a pas de risque, ils mettront pas de maj sur le nom d'un dossier, pour les autres. Il faut absolument blinder ces histoires de chemin au moins dans le Core ! En terme de qualité perçue c'est hmm
Dans un module tierce c'est déjà pas top mais là !
J'ai tendance à être un peu conservateur... je préfère moins de fonctionnalités nouvelles et des fonctions de base plus solides !
Quant au développement sous Win, j'ai la faiblesse de croire qu'il reste majoritaire sauf les quelques "hard codeur" qui développent vraiment de nouveaux modules. A un moment ou un autre...


Win 7 pro 64 - CMSMS 1.6.4 à 2.1.2

Hors ligne

#14 05/12/2012 13:44:34

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Merci du retour smile

Quant au développement sous Win, j'ai la faiblesse de croire qu'il reste majoritaire sauf les quelques "hard codeur" qui développent vraiment de nouveaux modules. A un moment ou un autre...

Sauf que les serveurs web sont en majorité des linux wink
Le problème, ici, ne semble concerner que wamp.

Hors ligne

#15 05/12/2012 13:49:34

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Sur ovh (linux), la casse du nom de dossier ne cause pas de problème, le thumb est créé.
Et le thumb se crée également sous wamp svn 1.11.4 “Fernandina_8539Fr” dossier images/Test/dk-UP3

Dernière modification par Jean le Chauve (05/12/2012 13:49:49)

Hors ligne

#16 05/12/2012 13:50:53

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

@jean as tu tester
http://www.cmsmadesimple.fr/forum/viewtopic.php?id=4775

Le problème, ici, ne semble concerner que wamp.

Oui en fait, sauf les inconditionnels le Bil ont des serveurs sous windoze  cool


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#17 05/12/2012 14:33:15

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Oui, j'ai essayé et j'ai répondu que ça ne peut pas fonctionner.

Alors, j'ai placé un echo dans imageManager.php (577):

[== Indéfini ==]
function _delFile($relative) 
	{ 
          $r2 = Files::fixPath(dirname($relative));
	  if( !$this->validRelativePath($r2) ){
	  echo 'r2';
	  return false;
	  }

ET r2 apparaît, donc la fonction retourne false

Hors ligne

#18 05/12/2012 14:36:13

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Un peu idiot, j'ai remplacé 'r2' par echo $r2 et voici le problème : $r2 = \/
Il y a donc un échappement qui se promène quelque part où il ne devrait pas être.

Hors ligne

#19 05/12/2012 14:40:34

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

>ET r2 apparaît, donc la fonction retourne false

ha oui c'est que j'ai déjà trouve
http://www.cmsmadesimple.fr/forum/viewt … 758#p32758

ça vient de la function _dirs($base, $path)
$base = Files::fixPath($base);
// base =F:\Sites\Test\xxx1\uploads\images/

d'ailleurs si sous dossier
base =F:\Sites\Test\xxx\uploads\images/test/
il y a des / et \ qui se croisent

en fait si son supprime  les urls sont
    // If images/  _delFile = F:\Sites\Test\xxx1\uploads\images/chrome_flash.png
    // If images/test _delFile = F:\Sites\Test\xxx\uploads\images/test/chrome_flash.png
il y a aussi des / et \ qui se croisent


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#20 05/12/2012 14:53:53

pierrepercee
Membre
Inscription : 11/06/2009
Messages : 429
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Que Wamp

cela doit signifier au moins 30 % des installations sous Win. En ligne 90% des sites sont sous Apache c'est clair ne serait-ce que pour des questions de coût. Mais une majorité d'entre eux sont d'abords développés localement sous WinMachin dont une bonne partie avec Wamp.
Ma config locale: xpsp3 Wampserver 2.2 CMSMS svn 1.11.4 “Fernandina_8540Fr”
Pour moi la sensibilité à la casse dans les noms de dossier pause toujours problème... mais petite nouveauté :
Jean, peux tu essayer d'uploader une image jpg nommée "edbw420.jpg" avec l'arbo :
abc/fr-gh1/dk-UP3/edbw420.jpg

Maintenant tu peux essayer avec :
abc/fr-gh1/dk-UP3/edbw430.jpg

J'ai évidemment vidé le cache, supprimé via ftp, fait plusieurs essais avec différents fichiers renommés. Dès que l'image se nomme "edbw420.jpg" la thumbs n'est pas faite. Je dois être fatigué. C'est incohérent cette histoire !


Win 7 pro 64 - CMSMS 1.6.4 à 2.1.2

Hors ligne

#21 05/12/2012 15:02:17

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

il y a aussi des / et \ qui se croisent

Il me semble qu'on s'était déjà penché sur ce problème il y a plusieurs mois si pas 1 an.

ha oui c'est que j'ai déjà trouve

Et oui, je ne t'avais pas bien lu  big_smile (mais, des fois, c'est un peu difficile de te suivre wink)
@Pierrepercee, je vais tester

Hors ligne

#22 05/12/2012 15:06:13

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 693
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

@pierrepercee : le thumb se crée  lol

Hors ligne

#23 05/12/2012 15:08:51

pierrepercee
Membre
Inscription : 11/06/2009
Messages : 429
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Je file chercher un exorciste ! wink


Win 7 pro 64 - CMSMS 1.6.4 à 2.1.2

Hors ligne

#24 05/12/2012 15:10:50

pierrepercee
Membre
Inscription : 11/06/2009
Messages : 429
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

Sinon y a déjà un petit moment que ces histoires de / et \ polluent le bon fonctionnement, je me souviens de thread déjà anciens...


Win 7 pro 64 - CMSMS 1.6.4 à 2.1.2

Hors ligne

#25 05/12/2012 17:51:38

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 098
Site Web

Re : Tests sur 1.11.4 ImageManager sous Windows

j'ai envoyé le résultat à Robert


ImageManager.php 
function _delFile($relative)
    {
//    echo "_delFile =  ". Files::makeFile($this->getBaseDir(),$relative);
    // If images/  _delFile = F:\Sites\Test\xxx\uploads\images/chrome_flash.png
    // If images/test _delFile = F:\Sites\Test\xxx\uploads\images/test/chrome_flash.png
          $r2 = Files::fixPath(dirname($relative));
          echo 'r2 = '. $r2; // If images/ $r2 = \/  // If images/test   $r2 = /test/

      if( !$this->validRelativePath($r2) ) return false;
// SO  return false -> If images/  and no file deleted
      
      $fullpath = Files::makeFile($this->getBaseDir(),$relative);
      echo 'fullpath= '.$fullpath; 
      // If images/test
      // fullpath= F:\Sites\Test\xxx\uploads\images/test/chrome_flash.png
// OK file deleted

See  / and \  into the links

Check also

    function _dirs($base, $path)
    {
        $base = Files::fixPath($base);
        echo ' base ='.$base;
        // base =F:\Sites\Test\xxx\uploads\images/
        // base =F:\Sites\Test\xxx\uploads\images/test/

you can see /  after images


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

Pied de page des forums