Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 15/08/2012 19:37:30

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 6 094
Site Web

Futur cmsms 2.0, les hébergeurs compatibles

Par JCE
[Ancien titre de la discussion : Futur cmsms 2.0, l'abandon de php 5.2, les hébergeurs compatibles]
[Passé en Futur cmsms 2.0,  les hébergeurs compatibles ]

CmsMadeSimple 1.11.1 vient de sortir de son oeuf il y a quelques heures que déjà une nouvelle orientation est annoncée pour la version majeure suivante : l'abandon du support de PHP 5.2 au profit de php 5.3 uniquement

Alors il faut savoir deux choses :

Techniquement parlant CmsMadeSimple 1.11.x support déjà entièrement php 5.3 sans aucun soucis. La version 1.11.1 corrige d'ailleurs un problème liée à php 5.2...

Tous les hébergeurs ne supportent pas php 5.3

Je vous propose ici de lister les hébergeurs compatibles 5.3.x, et éventuellement de poster les astuces pour profiter de cette version

OVH : il faut un fichier .htacess à la racine de votre hébergement contenant la ligne suivante (sources)

SetEnv PHP_VER 5_3

Free.fr : prévision de passer en 5.3 depuis plusieurs années... en vain... on oublie pour l'instant

FirstHeberg mutualisé: pas de php 5.3 (site)

Gandi AI + Simple Hosting : prise en charge de php 5.3 (source)

Planet Work : prise en charge de php 5.3 (merci Kraygoon)

Easy-hebergement : prise en charge de php 5.3 (merci Jean Le Chauve)

Phpnet : : prise en charge de php 5.3 (merci Ouick)

Avez vous des informations pour votre propre hébergeur ?

Hors ligne

#2 16/08/2012 09:00:43

kraygoon
Membre
Lieu : Pau, France
Inscription : 02/11/2007
Messages : 495
Site Web

Re : Futur cmsms 2.0, les hébergeurs compatibles

Planet Work sur toutes leurs formules support le PHP 5.3.

Hors ligne

#3 16/08/2012 09:32:00

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 6 094
Site Web

Hors ligne

#4 16/08/2012 12:20:26

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Hors ligne

#5 20/08/2012 17:24:56

Ouik
Modérateur
Lieu : Bourgogne
Inscription : 08/01/2008
Messages : 1 062
Site Web

Re : Futur cmsms 2.0, les hébergeurs compatibles

sur Phpnet, php5.3 depuis un moment déjà, actuellement 5.3.16.

Hors ligne

#6 08/10/2012 14:11:05

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : Futur cmsms 2.0, les hébergeurs compatibles

1&1 (version standard Version 5.2.17) est compatible 5.4.7 
moyennant une astuce
un fichier .htaccess dans le répertoire souhaité (ou ajoutez-le à un fichier .htaccess déjà existant) avec le contenu suivant :

# essai PHP 6.x = PHP5.4.x
AddType x-mapp-php6 .php
AddHandler x-mapp-php6 .php

http://faq.1and1.fr/upgrade/upgradephp/5.html


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#7 09/10/2012 09:34:57

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 6 094
Site Web

Re : Futur cmsms 2.0, les hébergeurs compatibles

firstheberg annonce sur leur forum qu'ils vont revoir l'infra mutualisé et prendre en compte dans la foulée les dernières versions de php

Aucune date n'est annoncée pour l'instant.

Hors ligne

#8 09/10/2012 15:04:41

rtlinfo
Membre
Inscription : 11/03/2010
Messages : 53

Re : Futur cmsms 2.0, les hébergeurs compatibles

ouvaton : PHP Version 5.3.3

PS : à celles et ceux qui utilisent gandi avec l'offre single hosting, pourraient me contacter en MP ? j'ai quelques soucis avec ce mode d'hébergement dont j'aimerais débattre

Hors ligne

#9 09/10/2012 18:31:29

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : Futur cmsms 2.0, les hébergeurs compatibles

Pour info les dernières versions :  PHP 5.3.17 et  5.4.7 au 19/09/2012


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#10 22/01/2013 19:42:29

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : Futur cmsms 2.0, les hébergeurs compatibles

Si cous êtes Client chez l'hébergeur 1and1, vous avez probablement reçu un email vous prévenant du passage obligatoire des serveurs à PHP 5.4 le 1er avril 2013. Ce n'est pas une blague mais bel et bien l'initiative de 1and1 de mettre à jour ses serveurs sur la dernière version de PHP.
Jusqu'au 31.03.2013 il vous sera possible d'utiliser différentes versions PHP. Passé cette date, nous ne proposerons plus que PHP 5.4.

[attention les erreurs cool ]

@ bess j'ai modifié le titre de 1.12 à 2.0


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#11 22/01/2013 20:06:56

bess
Administrateur
Lieu : Rennes
Inscription : 16/12/2008
Messages : 6 094
Site Web

Hors ligne

#12 16/01/2014 16:18:50

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : Futur cmsms 2.0, les hébergeurs compatibles

POUR LA V2 se sera PHP  5.4.x Mini et 5.5.x recommandé

Pour information chez l'hébergeur 1and1 vous pouvez avoir du PHP 5..5.x (ce jour 5.5.8) soit directement dans votre Espace client (Version globale PHP)

soit pour un dossier particulier
un fichier .htaccess dans le répertoire souhaité (ou ajoutez-le à un fichier .htaccess déjà existant) avec le contenu suivant :

AddHandler x-mapp-php5.5 .php3 .php4 .php .phtml

Par JCE
[Ancien titre de la discussion : Futur cmsms 2.0, l'abandon de php 5.2, les hébergeurs compatibles]
[Passé en Futur cmsms 2.0,  les hébergeurs compatibles ]


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#13 17/01/2014 11:59:10

Ouik
Modérateur
Lieu : Bourgogne
Inscription : 08/01/2008
Messages : 1 062
Site Web

Re : Futur cmsms 2.0, les hébergeurs compatibles

Phpnet propose PHP5.5 (et toujours 5.4 et 5.3 et... 5.2) depuis quelques semaines maintenant, paramétrage comme d'habitude : dans hébergement > les domaines hébergés > modifier les paramètres.

Hors ligne

Pied de page des forums