Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 11/08/2012 11:45:41

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

[Résolu]FileManager et 1.11

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: #1.11.0
#~ Url du site : http://www.tutos-pour-cmsmadesimple.be
#~ Hébergeur / Soft : ovh mutu
#~ Informations Système :
#~      ----------------------------------------------
#~      Cms Version: 1.11 Galapagos-8212-Fr
#~      Installed Modules:
#~      CMSMailer: 5.2.1
#~      CMSPrinting: 1.0.2
#~      FileManager: 1.4.0
#~      MenuManager: 1.8.2
#~      MicroTiny: 1.2.3
#~      ModuleManager: 1.5.5
#~      News: 2.12.7
#~      Search: 1.7.6
#~      ThemeManager: 1.1.7
#~      CGExtensions: 1.30
#~      CGSmartImage: 1.9.3
#~      CGSimpleSmarty: 1.5.2
#~      FormBuilder: 0.7.3
#~      Config Information:
#~      php_memory_limit:
#~      process_whole_template:
#~      output_compression:
#~      max_upload_size: 64000000
#~      url_rewriting: mod_rewrite
#~      page_extension:
#~      query_var: page
#~      image_manipulation_prog: GD
#~      auto_alias_content: true
#~      locale: fr_FR.utf8
#~      default_encoding: utf-8
#~      admin_encoding: utf-8
#~      set_names: true
#~      Php Information:
#~      phpversion: 5.3.14
#~      md5_function: On (True)
#~      gd_version: 2
#~      tempnam_function: On (True)
#~      magic_quotes_runtime: Off (False)
#~      E_STRICT: 0
#~      E_DEPRECATED: 8192
#~      memory_limit: 128M
#~      max_execution_time: 120
#~      output_buffering: 4096
#~      safe_mode: Off (False)
#~      file_uploads: On (True)
#~      post_max_size: 64M
#~      upload_max_filesize: 64M
#~      session_save_path: /tmp (1777)
#~      session_use_cookies: On (True)
#~      xml_function: On (True)
#~      xmlreader_class: On (True)
#~      Server Information:
#~      Server Api: cgi-fcgi
#~      Server Db Type: MySQL (mysql)
#~      Server Db Version: 5.1.49
#~      Server Db Grants: Could not find a suitable "GRANT ALL" permission. This may mean you could have problems installing or removing modules. Or even adding and deleting items, including pages
#~      ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Est-ce que quelqu'un a déjà testé l'upload de fichiers par drag and drop et le "sélectionner fichiers" traditionnel ?
Cela a l'air de fonctionner uniquement avec des images.
Pas moyen d'uploader des pdf, zip... On voit la barre de progression, mais le fichier ne se retrouve pas dans le ftp.
De plus, si vous passez en mode avancé, les fonctions créer thumbnail, déplacer ne fonctionnent pas.

Dernière modification par Jean le Chauve (03/09/2012 16:23:00)

Hors ligne

#2 11/08/2012 12:46:08

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : [Résolu]FileManager et 1.11

je viens de faire un test  par drag and drop et en mode normal sur un ficher Zip et un PDF c'est OK pour moi


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#3 11/08/2012 13:07:03

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

Et dans le mode avancé ?

Hors ligne

#4 11/08/2012 13:47:28

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : [Résolu]FileManager et 1.11

>Et dans le mode avancé ?
Oui c'est bon depuis une page Gabarits actuels par exemple fichiers de l'ordre de 100  Ko


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#5 11/08/2012 13:52:15

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

Je parle depuis filemanager même(en mode abancé), uploader un .pdf, créer un thumbnail ou déplacer un fichier.

Hors ligne

#6 11/08/2012 14:01:59

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

Si tu te mets en debug et que tu changes les paramètres dans gestionnaire de fichiers, obtiens-tu cette notice : Notice: Undefined index: path in /***/modules/FileManager/action.savesettings.php on line 44 ?

Dernière modification par Jean le Chauve (11/08/2012 14:02:13)

Hors ligne

#7 11/08/2012 16:28:03

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : [Résolu]FileManager et 1.11

Le retour wink

j'ai essayé de puis FileManager dans les 2 cas
- par drag and drop et le "sélectionner fichiers" traditionnel
et aussi depuis la page Gabarits actuels en drag and drop
Sur 2 sites pas de soucis

je fais un essai mode debug true dans Gestionnaire de fichiers Chemin actuel : uploads/File
- Ficher PDF  700 KO -> OK aucune erreur
- Fichier ZIP  300 KO -> OK aucune erreur
Version PHP actuelle (phpversion)     Valable      5.3.3-7+squeeze13


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#8 12/08/2012 16:55:31

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

Je viens de réinstaller un tout nouveau site 1.11.1 (avec tes fichiers Jce) sur wamp avec et sans mod_rewrite activé.



----------------------------------------------

Cms Version: 1.11.1 Baltra-8234-Fr

Installed Modules:

    CMSMailer: 5.2.1
    CMSPrinting: 1.0.3
    FileManager: 1.4.0
    MenuManager: 1.8.3
    MicroTiny: 1.2.3
    ModuleManager: 1.5.5
    News: 2.12.8
    Search: 1.7.6
    ThemeManager: 1.1.7


Config Information:

    php_memory_limit:
    process_whole_template:
    output_compression:
    max_upload_size: 20000000
    url_rewriting: none
    page_extension:
    query_var: page
    image_manipulation_prog: GD
    auto_alias_content: true
    locale:
    default_encoding: utf-8
    admin_encoding: utf-8
    set_names: true


Php Information:

    phpversion: 5.3.13
    md5_function: On (Vrai)
    gd_version: 2
    tempnam_function: On (Vrai)
    magic_quotes_runtime: Off (Faux)
    E_STRICT: 0
    E_DEPRECATED: 8192
    memory_limit: 124M
    max_execution_time: 80
    output_buffering: 1
    safe_mode: Off (Faux)
    file_uploads: On (Vrai)
    post_max_size: 28M
    upload_max_filesize: 20M
    session_save_path: T:/Applications7/Wamp/tmp (0777)
    session_use_cookies: On (Vrai)
    xml_function: On (Vrai)
    xmlreader_class: On (Vrai)


Server Information:

    Server Api: apache2handler
    Server Db Type: MySQL (mysqli)
    Server Db Version: 5.5.24
    Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté


----------------------------------------------

<?php
# CMS Made Simple - Fichier de configuration 
# Documentation : /doc/CMSMS_config_reference.pdf
#
$config['dbms'] = 'mysqli';
$config['db_hostname'] = 'localhost';
$config['db_username'] = 'root';
$config['db_password'] = '';
$config['db_name'] = 'site1111';
$config['db_prefix'] = 'cms_';
$config['timezone'] = 'UTC';
#$config['url_rewriting'] = 'mod_rewrite';
$config['debug'] = true;
?>

Si je coche filemanager->paramètres->

Activer le mode avancé ? (si autorisé) :

Donner accès à TOUT le système de fichiers de l'installation CMSMS, pas uniquement à /uploads/ (si autorisé)
Vlan, je me prends la notice qui amène les problèmes annoncés plus haut.
En images : http://www.tutos-pour-cmsmadesimple.be/ … /avant.png
http://www.tutos-pour-cmsmadesimple.be/ … /apres.png

Dernière modification par Jean le Chauve (12/08/2012 17:23:18)

Hors ligne

#9 13/08/2012 10:12:11

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : [Résolu]FileManager et 1.11

Alors je ne suis mis dans ds conditions proche de toi (c'est mon install de test du SVN)
CMS Made Simple™ 1.11.1 “Baltra-8235-Fr”
Windauble XP SP 32 bits WAMP WampServer2.2a avec Mysql 5.5.20
- PHP 5.3.1 puis 5.3.15 (php.ini error_reporting  = E_ALL & ~E_DEPRECATED & ~E_STRICT)
puis php 5.4.5 (php.inierror_reporting  = E_ALL )
le config

$config['timezone'] = 'Europe/Paris';
$config['default_encoding'] = 'utf-8';
$config['locale'] = 'fr_FR';
$config['root_url'] = 'http://localhost/Test/cmsmadesimple111';
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';
$config['debug'] = true;

dans filemanager Activer le mode avancé ? OUI
Essai de téléchargement de 9 fichiers PDF et ZIP dans  cmsmadesimple111/uploads/File
- soit par Télécharger les fichiers (parcurir) ou glisser déposer du filemanager
- soit par le glisser déposer en haut

aucun problème

nota essai de décompatage d'un fichier Zip (RestorWIN.zip) OK par contre suppression du dossier dézippé Non Ok (Le dossier RestorWIN n'est pas vide wink )


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#10 13/08/2012 12:51:33

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

Merci de tes retours.
Est-ce que quelqu'un d'autre voudrait tester la création de thumbnail et vérifier s'il reçoit un message de notice ?
Airelibre a les mêmes problèmes que moi.

Hors ligne

#11 15/08/2012 14:59:35

Philipppe
Membre
Lieu : Arradon
Inscription : 19/11/2007
Messages : 472

Re : [Résolu]FileManager et 1.11

@Jean,

Je viens de tester en mode debug = true; sur wamp en local avec un site que je suis en train de passer en 1.11 ...
J'ai fait la maj diff de jce (merci au passage de chacune de tes versions de maj partielles) vers
----------------------------------------------
Cms Version: 1.11.1 Baltra-8250-Fr

Installed Modules:

    CMSMailer: 5.2.1
    CMSPrinting: 1.0.3
    FileManager: 1.4.0
    MenuManager: 1.8.3
    MicroTiny: 1.2.3
    ModuleManager: 1.5.5
    News: 2.12.8
    Search: 1.7.7
    ThemeManager: 1.1.7
    CGExtensions: 1.29.1
    LightBox: 1.0.1
    CGSimpleSmarty: 1.5.1
    CGGoogleMaps: 2.3.1


Config Information:

    php_memory_limit:
    process_whole_template:
    output_compression:
    max_upload_size: 10000000
    url_rewriting: none
    page_extension:
    query_var: page
    image_manipulation_prog: GD
    auto_alias_content: true
    locale:
    default_encoding: utf-8
    admin_encoding: utf-8
    set_names: true


Php Information:

    phpversion: 5.3.8
    md5_function: On (Vrai)
    gd_version: 2
    tempnam_function: On (Vrai)
    magic_quotes_runtime: Off (Faux)
    E_STRICT: 0
    E_DEPRECATED: 8192
    memory_limit: 128M
    max_execution_time: 180
    output_buffering: 1
    safe_mode: Off (Faux)
    file_uploads: On (Vrai)
    post_max_size: 10M
    upload_max_filesize: 10M
    session_save_path: c:/wamp/tmp (0777)
    session_use_cookies: On (Vrai)
    xml_function: On (Vrai)
    xmlreader_class: On (Vrai)


Server Information:

    Server Api: apache2handler
    Server Db Type: MySQL (mysqli)
    Server Db Version: 5.5.16
    Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
----------------------------------------------

Quand j'active le mode avancé du FileManager, j'ai le message de notification d'erreur identique au tiens Jean !
Mais cela ne semble pas affecter le fonctionnement du gestionnaire de fichiers.
Veux-tu que je fasse un test plus précis ?


Philippe
CmsMs V1.6.11 Fr (merci jce) et V1.11.x Fr
Hébergeur  Free.fr, Gandi.net (GandiAI et SimpleHosting)

Hors ligne

#12 15/08/2012 15:13:42

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : [Résolu]FileManager et 1.11

Bizarre comme truc .... ce message


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#13 15/08/2012 17:24:42

Philipppe
Membre
Lieu : Arradon
Inscription : 19/11/2007
Messages : 472

Re : [Résolu]FileManager et 1.11

jce76350 a écrit :

Bizarre comme truc .... ce message

Est-ce que le détails du fichier d'erreurs peut te donner indication ?

[Wed Aug 15 13:15:57 2012] [error] [client 127.0.0.1] PHP Notice:  Undefined index: path in C:\\wamp\\www\\arbrelueur\\modules\\FileManager\\action.savesettings.php on line 44, referer: http://localhost/arbrelueur/admin/moduleinterface.php?mact=FileManager,m1_,defaultadmin,0&_sx_=013c3a7e&m1_path=&m1_fmmessage=settingssaved&m1_tab=settings
[Wed Aug 15 13:15:57 2012] [error] [client 127.0.0.1] PHP Stack trace:, referer: http://localhost/arbrelueur/admin/moduleinterface.php?mact=FileManager,m1_,defaultadmin,0&_sx_=013c3a7e&m1_path=&m1_fmmessage=settingssaved&m1_tab=settings
[Wed Aug 15 13:15:57 2012] [error] [client 127.0.0.1] PHP   1. {main}() C:\\wamp\\www\\arbrelueur\\admin\\moduleinterface.php:0, referer: http://localhost/arbrelueur/admin/moduleinterface.php?mact=FileManager,m1_,defaultadmin,0&_sx_=013c3a7e&m1_path=&m1_fmmessage=settingssaved&m1_tab=settings
[Wed Aug 15 13:15:57 2012] [error] [client 127.0.0.1] PHP   2. CMSModule->DoActionBase() C:\\wamp\\www\\arbrelueur\\admin\\moduleinterface.php:131, referer: http://localhost/arbrelueur/admin/moduleinterface.php?mact=FileManager,m1_,defaultadmin,0&_sx_=013c3a7e&m1_path=&m1_fmmessage=settingssaved&m1_tab=settings
[Wed Aug 15 13:15:57 2012] [error] [client 127.0.0.1] PHP   3. CMSModule->DoAction() C:\\wamp\\www\\arbrelueur\\lib\\classes\\class.CMSModule.php:1801, referer: http://localhost/arbrelueur/admin/moduleinterface.php?mact=FileManager,m1_,defaultadmin,0&_sx_=013c3a7e&m1_path=&m1_fmmessage=settingssaved&m1_tab=settings
[Wed Aug 15 13:15:57 2012] [error] [client 127.0.0.1] PHP   4. include() C:\\wamp\\www\\arbrelueur\\lib\\classes\\class.CMSModule.php:1732, referer: http://localhost/arbrelueur/admin/moduleinterface.php?mact=FileManager,m1_,defaultadmin,0&_sx_=013c3a7e&m1_path=&m1_fmmessage=settingssaved&m1_tab=settings

Les 6 lignes me semblent "liées" (au moins par l'heure!), mais je ne sais qu'en déduire!


Philippe
CmsMs V1.6.11 Fr (merci jce) et V1.11.x Fr
Hébergeur  Free.fr, Gandi.net (GandiAI et SimpleHosting)

Hors ligne

#14 15/08/2012 19:15:03

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : [Résolu]FileManager et 1.11

dans le fichier config est que les chemins sont avec double anti slash (\\wamp\\www\\arbrelueur)


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#15 15/08/2012 20:24:49

Philipppe
Membre
Lieu : Arradon
Inscription : 19/11/2007
Messages : 472

Re : [Résolu]FileManager et 1.11

jce76350 a écrit :

dans le fichier config est que les chemins sont avec double anti slash (\\wamp\\www\\arbrelueur)

Pas que je sache !
Mais je ne peux vérifier que demain matin !
A suivre.


Philippe
CmsMs V1.6.11 Fr (merci jce) et V1.11.x Fr
Hébergeur  Free.fr, Gandi.net (GandiAI et SimpleHosting)

Hors ligne

#16 16/08/2012 11:05:48

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

Merci Philippe.
Pourrais-tu essayer, en mode avancé, de créer un thumbnail et déplacer un fichier ?
Et également, tester sur une installation neuve ?

Hors ligne

#17 16/08/2012 11:22:31

Philipppe
Membre
Lieu : Arradon
Inscription : 19/11/2007
Messages : 472

Re : [Résolu]FileManager et 1.11

@jce, mon fichier config a été créé avec le script d'installation de la V1.11, et donc ne contiens pas en clair le "root_path" ...
J'ai regardé ce matin dans la doc pour trouver comment et où est créé la variable ... mais je n'ai pas su trouver !

Une lumière please ?

@Jean, si tu regardes ton log error, tu as aussi les chemins avec des doubles anti-slash ?
L'installation sur laquelle j'ai testé est une installation neuve, montée avec les fichiers d'installation de la version française de jce.

Dernière modification par Philipppe (16/08/2012 11:26:18)


Philippe
CmsMs V1.6.11 Fr (merci jce) et V1.11.x Fr
Hébergeur  Free.fr, Gandi.net (GandiAI et SimpleHosting)

Hors ligne

#18 16/08/2012 12:04:14

Philipppe
Membre
Lieu : Arradon
Inscription : 19/11/2007
Messages : 472

Re : [Résolu]FileManager et 1.11

Jean le Chauve a écrit :

Merci Philippe.
Pourrais-tu essayer, en mode avancé, de créer un thumbnail et déplacer un fichier ?
Et également, tester sur une installation neuve ?

Donc, en mode avancé, je coche à "OUI" la création automatique de vignettes ... et je télécharge deux fichiers images :
   - En utilisant le mode "Parcourir"
      Les fichiers proprements dits ne sont pas téléchargés
      Les vignettes SONT CREES

   - En utilisant le mode "Copier/coller", et en déposant les fichiers dans la zone de dépôt du FileManager
      Les vignettes sont créées aussi, mais seulement si je fais attention à bien positionner le mot "Déplacement" du Copier/Coller en face de la zone de dépôt.
      Mais les fichiers eux-même ne sont pas téléchargés.

Donc :
   - avec la création de vignette positionné à "Non", les fichiers sont téléchargés.
   - avec la création de vignette positionné à "Oui", les vignettes sont créées mais les fichiers ne sont pas téléchargés.

Pas bon ça !

Dernière modification par Philipppe (16/08/2012 12:11:23)


Philippe
CmsMs V1.6.11 Fr (merci jce) et V1.11.x Fr
Hébergeur  Free.fr, Gandi.net (GandiAI et SimpleHosting)

Hors ligne

#19 16/08/2012 12:17:07

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

Bonjour Philippe,
Oui, j'ai aussi des doubles anti slashes, mais cela n'a rien à voir avec cmsms (je pense que c'est l'échappement dû au ModSecurity d'Apache : http://books.google.be/books?id=HnQl5OV … q&f=false)
As-tu pu créer des thumbnails et déplacer des fichiers en mode avancé ?

Hors ligne

#20 16/08/2012 12:38:55

Philipppe
Membre
Lieu : Arradon
Inscription : 19/11/2007
Messages : 472

Re : [Résolu]FileManager et 1.11

Jean le Chauve a écrit :

Bonjour Philippe,
......
As-tu pu créer des thumbnails et déplacer des fichiers en mode avancé ?

Je vais déjeuner, et regarde le déplacement cet après-midi.


Philippe
CmsMs V1.6.11 Fr (merci jce) et V1.11.x Fr
Hébergeur  Free.fr, Gandi.net (GandiAI et SimpleHosting)

Hors ligne

#21 16/08/2012 15:20:43

Philipppe
Membre
Lieu : Arradon
Inscription : 19/11/2007
Messages : 472

Re : [Résolu]FileManager et 1.11

@Jean,
J'ai testé déplacement :
  - En mode non avancé,
   Le déplacement est fonctionnel, dans les sous-dossiers de uploads
   La création de vignette est ok, dans le dossier du fichier original.
  - En mode avancé,
   Déplacement impossible
       message d'erreur = "Le dossier de destination n'est pas valide"
   Création de vignette impossible
       message d'erreur = "Fichier non trouvé"

Au passage, j'ai vu que les chemins des dossiers sont normalement codés avec un seul "\" !


Philippe
CmsMs V1.6.11 Fr (merci jce) et V1.11.x Fr
Hébergeur  Free.fr, Gandi.net (GandiAI et SimpleHosting)

Hors ligne

#22 17/08/2012 05:27:16

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

Merci Philippe de m'avoir confirmé ce bug.

Hors ligne

#23 17/08/2012 10:00:58

Philipppe
Membre
Lieu : Arradon
Inscription : 19/11/2007
Messages : 472

Re : [Résolu]FileManager et 1.11

Jean le Chauve a écrit :

Merci Philippe de m'avoir confirmé ce bug.

Un plaisir ... Ta Seigneurie !
Ca va probablement m'enhardir à proposer mes services pour les tests de la prochaine version ...., déjà annoncée !
Tu t'occupes du rapport ad-hoc je suppose ...

Pour ma gouverne, tu sais où se trouve le code défectueux ?


Philippe
CmsMs V1.6.11 Fr (merci jce) et V1.11.x Fr
Hébergeur  Free.fr, Gandi.net (GandiAI et SimpleHosting)

Hors ligne

#24 17/08/2012 11:35:29

jce76350
Administrateur
Lieu : Rouen
Inscription : 23/09/2007
Messages : 6 086
Site Web

Re : [Résolu]FileManager et 1.11

si je comprends bien ce "défaut" ne semble se faire que sous WAMP (donc sous windows) et encore pas chez tous
- quelle version de WAMP ? quel windows
jean est en windows 64 bits

donner des détail des versions  WAMP + windows

perso je suis sous XP SP 32 bits WAMP WampServer2.2a avec Mysql 5.5.20 Apache 2.2.21
- PHP 5.3.1 puis 5.3.15 (php.ini error_reporting  = E_ALL & ~E_DEPRECATED & ~E_STRICT)
- PHP 5.4.5 (php.inierror_reporting  = E_ALL )
+ CMS Made Simple™ 1.11.1 “Baltra-8235-Fr” et aussi dernier essai avec  1.11.2 “BaltraPlus-8251-Fr”
et pas d'erreur en PHp et sur les logs apache

est-ce Afficher les fichiers cachés  est coché ?
en cochant ou décochant j'ai
Notice: Undefined index: path in ...\modules\FileManager\action.savesettings.php on line 44
seul erreur


J-C Etiemble Tutoriels v 2.2.x

Hors ligne

#25 17/08/2012 13:37:27

Jean le Chauve
Sa Seigneurie le Chauve, Comte du domaine .be
Lieu : Bruxelles
Inscription : 13/12/2007
Messages : 4 687
Site Web

Re : [Résolu]FileManager et 1.11

si je comprends bien ce "défaut" ne semble se faire que sous WAMP (donc sous windows)

Non, je l'ai aussi en ligne avec serveur linux.
Cocher ou pas fichiers cachés n'a pas d'importance.
Si tu as la notice, tu as aussi le bug.
Crée un répertoire uploads/images/test
En cochant mode avancé et afficher les vignettes, uploade une image -> pas de problème.
Crée un thumbnail -> ça ne marchera pas (Warning: rawurlencode() expects parameter 1 to be string, array given)
Déplace cette image -> ça ne marchera pas (le dossier de destination spécifié n'est pas valide).
Décoche mode avancé
Retourne dans le répertoire uploads/images/test car il a perdu le chemin.
Crée ta vignette -> ça marche
Coche mode avancé, la vignette a disparu.

Dernière modification par Jean le Chauve (17/08/2012 13:42:48)

Hors ligne

Pied de page des forums