[RÉSOLU] Problème format date dans News après màj de 1.2 à 1.9.2

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Citation :#~~~~~ NE PAS SUPPRIMER CE BLOC ~~~~~
#~ Version du CMS: 1.9.3
#~ Nom de l'hébergeur : infomaniak
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 1.9.2
#~ Installed Modules:
#~ * CMSMailer: 2.0
#~ * FileManager: 1.0.3
#~ * MenuManager: 1.7.4
#~ * ModuleManager: 1.4
#~ * News: 2.11
#~ * nuSOAP: 1.0.2
#~ * Printing: 1.1.1
#~ * Search: 1.6.8
#~ * ThemeManager: 1.1.3
#~ * TinyMCE: 2.8.2
#~ * ABFlashGallery: 0.2
#~ * Album: 0.9.2
#~ * Archiver: 0.2
#~ * FrontEndUsers: 1.3.3
#~ * TinyMCEAdv: 2.2.2
#~ * Captcha: 0.3.1
#~ * Forum: 0.9.1
#~ * Banners: 2.2.1
#~ * CGExtensions: 1.6
#~ * SelfRegistration: 1.1.5
#~ Config Information:
#~ * php_memory_limit:
#~ * process_whole_template: false
#~ * output_compression: false
#~ * max_upload_size: 48000000
#~ * default_upload_permission: 664
#~ * url_rewriting: none
#~ * page_extension:
#~ * query_var: page
#~ * image_manipulation_prog: GD
#~ * auto_alias_content: true
#~ * locale:
#~ * default_encoding: fr_FR.utf8
#~ * admin_encoding: utf-8
#~ * set_names: false
#~ Php Information:
#~ * phpversion: 5.2.17
#~ * md5_function: On (Vrai)
#~ * gd_version: 2
#~ * tempnam_function: On (Vrai)
#~ * magic_quotes_runtime: Off (Faux)
#~ * E_STRICT: 0
#~ * memory_limit: 96M
#~ * max_execution_time: 10
#~ * output_buffering: 20480
#~ * safe_mode: Off (Faux)
#~ * file_uploads: On (Vrai)
#~ * post_max_size: 300M
#~ * upload_max_filesize: 300M
#~ * session_save_path: Aucune vérification à cause de la restriction spécifiée par PHP open_basedir
#~ * session_use_cookies: On (Vrai)
#~ * xml_function: On (Vrai)
#~ Server Information:
#~ * Server Api: apache2handler
#~ * Server Db Type: MySQL (mysql)
#~ * Server Db Version: 5.0.67
#~ ----------------------------------------------
#~~~~~ NE PAS SUPPRIMER CE BLOC ~~~~~



Bonjour,

Après une mise à jour de mon CMS de la 1.2 (eh oui!) à la 1.9.2 j'ai des problèmes de format de date dans mon module news. Sur le côté visiteurs du site j'ai une date au format 2011-02-05 21:00:00 et sur le backend c'est encore plus curieux, le format est du style suivant: Saturday, le 5 Feb 2011 (j'ai dans les paramètres d'administration global du site le format de date %A, le %e %b %Y).
J'ai modifié mes gabarits :{$entry->postdate|cms_date_format}
J'ai bien essayé les modifications proposées dans les différents posts
-modification config.php: ajouté fr_FR.utf8 au paramètre $config['locale']
-modification include.php: $frontendlang = ...
Je ne sais plus vraiment dans quelle direction chercher, alors, merci d'avance pour votre aide Smile
#1
Citation :#~~~~~ NE PAS SUPPRIMER CE BLOC ~~~~~
#~ Version du CMS: 1.9.3
#~ Nom de l'hébergeur : infomaniak
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 1.9.2
#~ Installed Modules:
#~ * CMSMailer: 2.0
#~ * FileManager: 1.0.3
#~ * MenuManager: 1.7.4
#~ * ModuleManager: 1.4
#~ * News: 2.11
#~ * nuSOAP: 1.0.2
#~ * Printing: 1.1.1
#~ * Search: 1.6.8
#~ * ThemeManager: 1.1.3
#~ * TinyMCE: 2.8.2
#~ * ABFlashGallery: 0.2
#~ * Album: 0.9.2
#~ * Archiver: 0.2
#~ * FrontEndUsers: 1.3.3
#~ * TinyMCEAdv: 2.2.2
#~ * Captcha: 0.3.1
#~ * Forum: 0.9.1
#~ * Banners: 2.2.1
#~ * CGExtensions: 1.6
#~ * SelfRegistration: 1.1.5
#~ Config Information:
#~ * php_memory_limit:
#~ * process_whole_template: false
#~ * output_compression: false
#~ * max_upload_size: 48000000
#~ * default_upload_permission: 664
#~ * url_rewriting: none
#~ * page_extension:
#~ * query_var: page
#~ * image_manipulation_prog: GD
#~ * auto_alias_content: true
#~ * locale:
#~ * default_encoding: fr_FR.utf8
#~ * admin_encoding: utf-8
#~ * set_names: false
#~ Php Information:
#~ * phpversion: 5.2.17
#~ * md5_function: On (Vrai)
#~ * gd_version: 2
#~ * tempnam_function: On (Vrai)
#~ * magic_quotes_runtime: Off (Faux)
#~ * E_STRICT: 0
#~ * memory_limit: 96M
#~ * max_execution_time: 10
#~ * output_buffering: 20480
#~ * safe_mode: Off (Faux)
#~ * file_uploads: On (Vrai)
#~ * post_max_size: 300M
#~ * upload_max_filesize: 300M
#~ * session_save_path: Aucune vérification à cause de la restriction spécifiée par PHP open_basedir
#~ * session_use_cookies: On (Vrai)
#~ * xml_function: On (Vrai)
#~ Server Information:
#~ * Server Api: apache2handler
#~ * Server Db Type: MySQL (mysql)
#~ * Server Db Version: 5.0.67
#~ ----------------------------------------------
#~~~~~ NE PAS SUPPRIMER CE BLOC ~~~~~



Bonjour,

Après une mise à jour de mon CMS de la 1.2 (eh oui!) à la 1.9.2 j'ai des problèmes de format de date dans mon module news. Sur le côté visiteurs du site j'ai une date au format 2011-02-05 21:00:00 et sur le backend c'est encore plus curieux, le format est du style suivant: Saturday, le 5 Feb 2011 (j'ai dans les paramètres d'administration global du site le format de date %A, le %e %b %Y).
J'ai modifié mes gabarits :{$entry->postdate|cms_date_format}
J'ai bien essayé les modifications proposées dans les différents posts
-modification config.php: ajouté fr_FR.utf8 au paramètre $config['locale']
-modification include.php: $frontendlang = ...
Je ne sais plus vraiment dans quelle direction chercher, alors, merci d'avance pour votre aide Smile
#2
sur cmsmadesimple on a :

format de date : "%e %B %Y"
Langue par défaut de la partie publique du site : Français
dans le gabarit : {$entry->postdate|cms_date_format|utf8_encode} (pour éviter les problèmes d'accents)

Donc à priori on devrait être bon tous les deux.As tu pensé à vider le cache après mise à jour totale ?

Je crains que tu n'ai d'autre choix que de débugger à la mimine : genre écrire dans ton gabarit différents tests :

{$entry->postdate}
{$entry->postdate|cms_date_format}
{$entry->postdate|cms_date_format|utf8_encode}
#2
sur cmsmadesimple on a :

format de date : "%e %B %Y"
Langue par défaut de la partie publique du site : Français
dans le gabarit : {$entry->postdate|cms_date_format|utf8_encode} (pour éviter les problèmes d'accents)

Donc à priori on devrait être bon tous les deux.As tu pensé à vider le cache après mise à jour totale ?

Je crains que tu n'ai d'autre choix que de débugger à la mimine : genre écrire dans ton gabarit différents tests :

{$entry->postdate}
{$entry->postdate|cms_date_format}
{$entry->postdate|cms_date_format|utf8_encode}
#3
#~ Version du CMS: 1.9.3
#~ Cms Version: 1.9.2
heu .... y a comme un truc mettre à jour Wink

>Je ne sais plus vraiment dans quelle direction chercher
faire recherche avec date news

et regarder ici 'pour le backend news'
http://www.cmsmadesimple.fr/forum/viewto...398#p11398
J-C Etiemble Tutoriels v 2.2.x
#3
#~ Version du CMS: 1.9.3
#~ Cms Version: 1.9.2
heu .... y a comme un truc mettre à jour Wink

>Je ne sais plus vraiment dans quelle direction chercher
faire recherche avec date news

et regarder ici 'pour le backend news'
http://www.cmsmadesimple.fr/forum/viewto...398#p11398
J-C Etiemble Tutoriels v 2.2.x
#4
Bonjour et merci d'avoir répondu si rapidement. Quel bonheur de voir cette réactivité dans le monde du logiciel libre, on n'a pas cette qualité de service dans le monde du logiciel payant. MERCI SmileSmileSmile

@Bess:
Voici les résultats des tests dans le gabarit:
{$entry->postdate} -->2010-09-24 08:15:20
{$entry->postdate|cms_date_format} -->Friday, le 24 Sep 2010 ? Problème d'interprétation de langue de la balise ?
{$entry->postdate|cms_date_format|utf8_encode} -->2010-09-24 08:15:20
J'ai vidé le cache après chaque modification (config.php, gabarits...) avant de tester.
Est-ce un problème avec la balise cms_date_format ??? Si c'est le cas, comment y remédier? Est-il possible de recréer une balise avec le même code que la balise cms_date_format et la remplacer dans le gabarit? Si oui, quel est le code de la balise?

@jce : Je ne vois pas comment a pu venir cette indication de ver 1.9.3 :/ ?
J'ai tout d'abord essayé de faire une mise à jour avec les fichiers français uniquement (http://jc.etiemble.free.fr/abc/uploads/F...fr.tar.bz2) Wink, mais l'installation a échoué, de nombreux fichiers php contenant des commandes de chargement de modules dédoublés, ce qui générait des 'Fatal error, could not reload module xxx in .... xxx.php'. J'ai corrigé les 3 premiers fichiers puis ai jeté l'éponge (cela continuait chaque fois avec un autre fichier .php) et finalement fait ma mise à jour avec la ver 1.9.2 full (cmsmadesimple-1.9.2-full.tar.gz), téléchargée le 29 janvier, soit avant la sortie de la ver 1.9.3, alors je ne vois vraiment pas d'où vient cette mention 1.9.3 ? Mystère...

Pour en revenir à mon problème Wink
Je constate que avec {$entry->postdate|cms_date_format}, j'obtiens le même affichage en partie publique qu'en backend, le utf8_encode ne change rien. Ma base de donnée chez Infomaniak indique dans ses propriétés "Jeu de caractères pour MySQL: UTF-8 Unicode (utf8)"
Et puis j'ai les heures minutes secondes qui sont aussi affichées dans les deux autres cas...?
J'ai cherché dans les 4 pages de posts avec date + news, histoire de ne pas avoir de remontrance de la part de Sa Seigneurie Le Chauve Wink, mais rien à faire.


Merci encore une fois de votre précieuse aide
#4
Bonjour et merci d'avoir répondu si rapidement. Quel bonheur de voir cette réactivité dans le monde du logiciel libre, on n'a pas cette qualité de service dans le monde du logiciel payant. MERCI SmileSmileSmile

@Bess:
Voici les résultats des tests dans le gabarit:
{$entry->postdate} -->2010-09-24 08:15:20
{$entry->postdate|cms_date_format} -->Friday, le 24 Sep 2010 ? Problème d'interprétation de langue de la balise ?
{$entry->postdate|cms_date_format|utf8_encode} -->2010-09-24 08:15:20
J'ai vidé le cache après chaque modification (config.php, gabarits...) avant de tester.
Est-ce un problème avec la balise cms_date_format ??? Si c'est le cas, comment y remédier? Est-il possible de recréer une balise avec le même code que la balise cms_date_format et la remplacer dans le gabarit? Si oui, quel est le code de la balise?

@jce : Je ne vois pas comment a pu venir cette indication de ver 1.9.3 :/ ?
J'ai tout d'abord essayé de faire une mise à jour avec les fichiers français uniquement (http://jc.etiemble.free.fr/abc/uploads/F...fr.tar.bz2) Wink, mais l'installation a échoué, de nombreux fichiers php contenant des commandes de chargement de modules dédoublés, ce qui générait des 'Fatal error, could not reload module xxx in .... xxx.php'. J'ai corrigé les 3 premiers fichiers puis ai jeté l'éponge (cela continuait chaque fois avec un autre fichier .php) et finalement fait ma mise à jour avec la ver 1.9.2 full (cmsmadesimple-1.9.2-full.tar.gz), téléchargée le 29 janvier, soit avant la sortie de la ver 1.9.3, alors je ne vois vraiment pas d'où vient cette mention 1.9.3 ? Mystère...

Pour en revenir à mon problème Wink
Je constate que avec {$entry->postdate|cms_date_format}, j'obtiens le même affichage en partie publique qu'en backend, le utf8_encode ne change rien. Ma base de donnée chez Infomaniak indique dans ses propriétés "Jeu de caractères pour MySQL: UTF-8 Unicode (utf8)"
Et puis j'ai les heures minutes secondes qui sont aussi affichées dans les deux autres cas...?
J'ai cherché dans les 4 pages de posts avec date + news, histoire de ne pas avoir de remontrance de la part de Sa Seigneurie Le Chauve Wink, mais rien à faire.


Merci encore une fois de votre précieuse aide
#5
>Je ne vois pas comment a pu venir cette indication de ver 1.9.3
C'est toi qui a renseignée la fiche ou ta main mais bref c'est écrit
>J'ai tout d'abord essayé de faire une mise à jour avec les fichiers français uniquement
Y pas de ... avec les fichiers français uniquement, cms191_fr.tar.bz2 c'est une version complète francisée
je comprends pas la solution de faire une mise à jour de 1.9.2 vers 1.9.1 !!!!!!
mais si tu vais pris soin de lire le forum ou la doc sur la mise à jour Wink

as tu regardé le lien "et regarder ici 'pour le backend news'" ??

et dans Administration du site » Paramètres globaux Format de la date : voir http://fr2.php.net/strftime
J-C Etiemble Tutoriels v 2.2.x
#5
>Je ne vois pas comment a pu venir cette indication de ver 1.9.3
C'est toi qui a renseignée la fiche ou ta main mais bref c'est écrit
>J'ai tout d'abord essayé de faire une mise à jour avec les fichiers français uniquement
Y pas de ... avec les fichiers français uniquement, cms191_fr.tar.bz2 c'est une version complète francisée
je comprends pas la solution de faire une mise à jour de 1.9.2 vers 1.9.1 !!!!!!
mais si tu vais pris soin de lire le forum ou la doc sur la mise à jour Wink

as tu regardé le lien "et regarder ici 'pour le backend news'" ??

et dans Administration du site » Paramètres globaux Format de la date : voir http://fr2.php.net/strftime
J-C Etiemble Tutoriels v 2.2.x
#6
Ah, j'ai les oreilles qui bourdonnent :lol:
Essaye un peu avec le modificateur {$entry->postdate|date_format:"%A %e %B %Y"} au lieu de |cms_date_format
#6
Ah, j'ai les oreilles qui bourdonnent :lol:
Essaye un peu avec le modificateur {$entry->postdate|date_format:"%A %e %B %Y"} au lieu de |cms_date_format
#7
J'aime quand ça bourdonne Smile)
Suite du message précédent... je creuse !
Quand je change la langue de la partie publique du site, tout se met dans la langue définie, sauf... la date, dont les noms de jour et de mois restent en anglais :/, que ce soit dans la partie publique ou le backend.
Est-ce un fichier contenant les traductions des dates en français qui est corrompu, mal mis en place, mal défini, incomplet... ?

@Sa Seigneurie le Chauve
le résultat avec le modificateur donne --> Friday 24 September 2010

@jce
Je me suis peut-être mal exprimé: ma première tentative a été de faire la màj de la 1.2 à la 1.9.1 citée, puis vu l'échec, j'ai fait la màj de la 1.2 à la 1.9.2 full.
Pour l'histoire de version, je ne sais pas où mes doigts ont fouchés, la fatigue? Smile Mea culpa
J'ai tenté les modifications proposées pour modifier le fichier \lib\smarty\plugins function.html_select_date.php, cela change bien l'affichage du backend lors de l'édition ou la création de news (des chiffres à la place des mots, plus de problème de langue...Smile), mais même dans la liste de mes article dans le backend, mes dates de début ou de fin sont toujours en anglais Sad
Et désolé si j'ai estropié le nom de la "version complète francisée", chuis qu'un pauvre p'tit suisse qu'a un brevet en viticulture et oenologie, pô un informaticien de votre niveau Wink
#7
J'aime quand ça bourdonne Smile)
Suite du message précédent... je creuse !
Quand je change la langue de la partie publique du site, tout se met dans la langue définie, sauf... la date, dont les noms de jour et de mois restent en anglais :/, que ce soit dans la partie publique ou le backend.
Est-ce un fichier contenant les traductions des dates en français qui est corrompu, mal mis en place, mal défini, incomplet... ?

@Sa Seigneurie le Chauve
le résultat avec le modificateur donne --> Friday 24 September 2010

@jce
Je me suis peut-être mal exprimé: ma première tentative a été de faire la màj de la 1.2 à la 1.9.1 citée, puis vu l'échec, j'ai fait la màj de la 1.2 à la 1.9.2 full.
Pour l'histoire de version, je ne sais pas où mes doigts ont fouchés, la fatigue? Smile Mea culpa
J'ai tenté les modifications proposées pour modifier le fichier \lib\smarty\plugins function.html_select_date.php, cela change bien l'affichage du backend lors de l'édition ou la création de news (des chiffres à la place des mots, plus de problème de langue...Smile), mais même dans la liste de mes article dans le backend, mes dates de début ou de fin sont toujours en anglais Sad
Et désolé si j'ai estropié le nom de la "version complète francisée", chuis qu'un pauvre p'tit suisse qu'a un brevet en viticulture et oenologie, pô un informaticien de votre niveau Wink
#8
Citation :brevet en viticulture et oenologie

je songe à faire payer l'accès au forum moi... disons une bonne bouteille de vin !

à envoyer à l'adresse de l'asso à Lorient stp Big Grin
#8
Citation :brevet en viticulture et oenologie

je songe à faire payer l'accès au forum moi... disons une bonne bouteille de vin !

à envoyer à l'adresse de l'asso à Lorient stp Big Grin
#9
Comme tu viens d'une ancienne version, ton config.php n'est peut-être pas complet.
vérifie que tu as bien ceci :
Code :
# Timezone setting
# PHP 5.3 requires that timezones be set at the server level.
# This variable can be used to set your sites timezone.
# Valid values for this variable can be found at:
# http://www.php.net/manual/en/timezones.php
# If this field is empty, no timezone will be set
$config['timezone'] = 'Europe/Europe/Zurich';
Maintenant, si ton site n'est pas trop important, tu devrais peut-être repartir sur une install fraîche, je suis d'ailleurs étonné que tu n'aies pas eu de pépin lors des upgrades.
#9
Comme tu viens d'une ancienne version, ton config.php n'est peut-être pas complet.
vérifie que tu as bien ceci :
Code :
# Timezone setting
# PHP 5.3 requires that timezones be set at the server level.
# This variable can be used to set your sites timezone.
# Valid values for this variable can be found at:
# http://www.php.net/manual/en/timezones.php
# If this field is empty, no timezone will be set
$config['timezone'] = 'Europe/Europe/Zurich';
Maintenant, si ton site n'est pas trop important, tu devrais peut-être repartir sur une install fraîche, je suis d'ailleurs étonné que tu n'aies pas eu de pépin lors des upgrades.
#10
Alors là les gars, MORT DE RIRE =D =D =D
J'ai reçu hier soir un mail de mon hébergeur m'informant que mon site avait été déplacé dans la journée sur un autre serveur et que j'étais prié de tester si toutes les fonctionnalités étaient OK, et là, miracle, les noms de jour et de mois s'affichent en français. Dire qu'on s'est creusé les méninges pendant des heures pour rien...
Encore un grand MERCI à vous tous. Wink
#10
Alors là les gars, MORT DE RIRE =D =D =D
J'ai reçu hier soir un mail de mon hébergeur m'informant que mon site avait été déplacé dans la journée sur un autre serveur et que j'étais prié de tester si toutes les fonctionnalités étaient OK, et là, miracle, les noms de jour et de mois s'affichent en français. Dire qu'on s'est creusé les méninges pendant des heures pour rien...
Encore un grand MERCI à vous tous. Wink


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)