Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Migration depuis une très ancienne version (1.2.4)
#1
Bonjour
Je vais m'engager dans une opération d'installation d'une nouvelle version de cmsms pour free. Et je pense qu'il n'est pas évidemment pas possible de faire un "upgrade" et qu'il faut faire une réinstallation complète. Mais avant de me lancer , j'aurais voulu savoir comment procéder pour pouvoir faire coexister l'ancien système et le nouveau pendant le temps de l'installation et de la reprise de tout l'historique (gabarits, données, etc.) , ce qui peut durer plusieurs jours ...
J'ai bien compris que ce forum s'adressait plutôt aux problèmes rencontrés avec les nouvelles versions, mais je n'ai pas trouvé d'infos ni de forum concernant ma queston.

Merci d'avance pour votre attention
LM
Répondre
#2
Bonjour,
0- vider le cache.
1- sauvegarder dossiers et bdd.
2- tout rapatrier en local
3- tout installer en local (modif config.php)
4- ne rien toucher en ligne ou bien répercuter à chaque fois en local.
5- installer la dernière version en local.
6- migrer "à la main" copier/coller ou export/import les contenus, gabarit, css... et faire les ajustements
7- quand tout est fini, supprimer la version en ligne et mettre en ligne la version locale.
Alternative:
créer un sous-dossier en ligne, une seconde bdd (ou si pas possible prefixer les tables différemment), modif config.php et travailler sur ce sous-dossier comme en local.

Tu pars de quelle version?
{SEO}
Inscrivez-vous à notre Newsletter sur le site (colonne de droite, en bas).
Vous appréciez CMSMS et l'aide qui vous est fournie ici, aidez-nous en participant au projet.
Formation CMS Made Simple | Création de site CMS Made Simple.

C'est en se plantant qu'on devient cultivé.
J'ai un string dans l'Array (Paris Hilton)
Répondre
#3
Merci pour la réponse.

Je pars de la version 1.2.4 ...
Pour tout installer en local, il faut l'environnement adéquat (serveur, bdd, .. ). Que me conseilles-tu ?

LM
PS : je suis un peu néophyte !!
Répondre
#4
sous windows: wampserver (http://www.wampserver.com ) ou easyphp ( http://www.easyphp.org/download.php ).
C'est simple à installer et tout y est Wink
Yapluka bosser Smile
{SEO}
Inscrivez-vous à notre Newsletter sur le site (colonne de droite, en bas).
Vous appréciez CMSMS et l'aide qui vous est fournie ici, aidez-nous en participant au projet.
Formation CMS Made Simple | Création de site CMS Made Simple.

C'est en se plantant qu'on devient cultivé.
J'ai un string dans l'Array (Paris Hilton)
Répondre
#5
Yapluka :/
Merci beaucoup pour toutes les infos, je vais récupérer tous les morceaux et m'y mettre ce week end !
Répondre
#6
Je me permet de rappeler un point : pour faire des migrations sur de si anciennes version il y a deux écoles.

la première est utile pour des petits sites et c'est celle fournie par jissey : la recopie de page en page.

l'intéret et de faire vite tout en ayant la possibilité de profiter des nouveautés si on copie/colle pas bêtement. Je pense par exemple aux tags dans le gabarit

Code :
{cms_stylesheet}

ou

Code :
{if isset($canonical)}<link rel="canonical" href="{$canonical}" />{elseif isset($content_obj)}<link rel="canonical" href="{$content_obj->GetURL()}" />{/if}

qui sont présent depuis peu de temps (1.6.x il me semble pour le canonical)

L'autre solution est a utiliser pour un max de sécurité et éviter un "oublie" de copie/colle. Très intéressant également si le site est énorme : c'est l'upload du core+fichier de traduction en version 1.9.2 par exemple tout d'un bloc et passer par la méthode d'upgrade dans /install/upgrade.php

c'est sécure au moins !


Dans tous les cas : BACKUP !
Répondre
#7
La seconde école étant la meilleure effectivement.
Je ne pensais pas qu'on pouvait upgrader depuis si loin...vers l'infini et haut-delà!
{SEO}
Inscrivez-vous à notre Newsletter sur le site (colonne de droite, en bas).
Vous appréciez CMSMS et l'aide qui vous est fournie ici, aidez-nous en participant au projet.
Formation CMS Made Simple | Création de site CMS Made Simple.

C'est en se plantant qu'on devient cultivé.
J'ai un string dans l'Array (Paris Hilton)
Répondre
#8
pour info : dernièrement passage de 1.2.2 à 1.9.2 direct en envoyant sur le serveur la 1.9.2 + upgrade avec les précautions d'usage
J-C Etiemble Tutoriels v 2.2.x
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)