Problème chemin image V2.2.16

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Thumbs Up 
Bonjour,

Sur la nouvelle Version 2.2.16,
le chemin de l'image n'est pas le bon !
Il y à les \ dans le mauvais sens (voir pièce jointe) = les images ne s'affiche pas !

Comment modifier pour avoir le chemin suivant: /images/xxx.jpg ?

Merci à vous.


Pièces jointes Miniature(s)
   
Répondre
#1
Thumbs Up 
Bonjour,

Sur la nouvelle Version 2.2.16,
le chemin de l'image n'est pas le bon !
Il y à les \ dans le mauvais sens (voir pièce jointe) = les images ne s'affiche pas !

Comment modifier pour avoir le chemin suivant: /images/xxx.jpg ?

Merci à vous.


Pièces jointes Miniature(s)
   
Répondre
#2
donnes des précisons
- version de PHP sur un serveur local ou sur hébergement
- parce que cet onglet "image" n'est pas par défaut dans le gestionnaire de contenu
- quel module ou autre fonction est utilisé dans ce cas pour cet onglet "image"
J-C Etiemble Tutoriels v 2.2.x
Répondre
#2
donnes des précisons
- version de PHP sur un serveur local ou sur hébergement
- parce que cet onglet "image" n'est pas par défaut dans le gestionnaire de contenu
- quel module ou autre fonction est utilisé dans ce cas pour cet onglet "image"
J-C Etiemble Tutoriels v 2.2.x
Répondre
#3
La version de PHP v 7.4.16 sur un serveur local.
L'onglet "image" est dans le template (gabarit) suivant :

{strip}
{$background_image="{content_image block='background_image' tab='Images' urlonly=1 label='Background Image (dimensions will vary based upon amount of conent), leave blank for none.'}"}
{/strip}

<div class="column row text-center expanded has-background" {if $background_image} style="background-image: url({$background_image});"{/if}>
<div class="row">

<h2>{title}</h2>

<div class="column menu-home">
{content label='full-width content'}
</div>
</div>
</div>
Répondre
#3
La version de PHP v 7.4.16 sur un serveur local.
L'onglet "image" est dans le template (gabarit) suivant :

{strip}
{$background_image="{content_image block='background_image' tab='Images' urlonly=1 label='Background Image (dimensions will vary based upon amount of conent), leave blank for none.'}"}
{/strip}

<div class="column row text-center expanded has-background" {if $background_image} style="background-image: url({$background_image});"{/if}>
<div class="row">

<h2>{title}</h2>

<div class="column menu-home">
{content label='full-width content'}
</div>
</div>
</div>
Répondre
#4
>L'onglet "image" est dans le template (gabarit) suivant :
Oui mais ce gabarit il vient d’où ? parce que la je ne suis pas devin Wink
-  faut donner des informations pour pouvoir reproduire "ton soucis" et  répondre


> La version de PHP v 7.4.16 sur un serveur local.
PS c'est un serveur sous Windows ?? si oui c'est pour cela que " Il y à les \ dans le mauvais sens"
J-C Etiemble Tutoriels v 2.2.x
Répondre
#4
>L'onglet "image" est dans le template (gabarit) suivant :
Oui mais ce gabarit il vient d’où ? parce que la je ne suis pas devin Wink
-  faut donner des informations pour pouvoir reproduire "ton soucis" et  répondre


> La version de PHP v 7.4.16 sur un serveur local.
PS c'est un serveur sous Windows ?? si oui c'est pour cela que " Il y à les \ dans le mauvais sens"
J-C Etiemble Tutoriels v 2.2.x
Répondre
#5
Merci pour ta réponse rapide !

C'est un thème de CMS Made Simple :
https://themes.cmsmadesimple.org/ (thème eat free)

Après des heures de recherche, je panse que cela peux venir de la :

la l'image s'affiche:
<img src="http://127.0.0.1/uploads/\images\votre-site-internet.png">

et la avec le code qui pose problème (sa ne s'affiche pas) :

<div class="column row text-center expanded has-background" style="background-image: url(http://127.0.0.1/uploads/\images\themes.png);">

et quand je modifie les slaches sa marche :
http://127.0.0.1/uploads/images/themes.png

la je suis perdu !
Merci encore pour ton aide, vraiment sympa !!!
Répondre
#5
Merci pour ta réponse rapide !

C'est un thème de CMS Made Simple :
https://themes.cmsmadesimple.org/ (thème eat free)

Après des heures de recherche, je panse que cela peux venir de la :

la l'image s'affiche:
<img src="http://127.0.0.1/uploads/\images\votre-site-internet.png">

et la avec le code qui pose problème (sa ne s'affiche pas) :

<div class="column row text-center expanded has-background" style="background-image: url(http://127.0.0.1/uploads/\images\themes.png);">

et quand je modifie les slaches sa marche :
http://127.0.0.1/uploads/images/themes.png

la je suis perdu !
Merci encore pour ton aide, vraiment sympa !!!
Répondre
#6
hé ... Oui c'est du Windows Wink
Si c'est résolu ...

A la fin de la discussion, éditez votre premier message et ajoutez dans le début du titre le terme [Résolu] entre crochet. Cette information permettra aux futurs visiteurs de trouver plus rapidement une réponse à leur question
J-C Etiemble Tutoriels v 2.2.x
Répondre
#6
hé ... Oui c'est du Windows Wink
Si c'est résolu ...

A la fin de la discussion, éditez votre premier message et ajoutez dans le début du titre le terme [Résolu] entre crochet. Cette information permettra aux futurs visiteurs de trouver plus rapidement une réponse à leur question
J-C Etiemble Tutoriels v 2.2.x
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)