Mise à jour 2.2.16 HTTP ERROR 500 [RESOLU]

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Cms Version: 2.2.15
Installed Modules:
  • AceEditor: 1.0
  • AdminSearch: 1.0.5
  • AjaxMadeSimple: 0.4.0
  • CGExtensions: 1.65.2
  • CGFeedFactory: 1.0
  • CGFeedMaker: 1.0.20
  • CGSimpleSmarty: 2.0
  • CGSmartImage: 1.22.7
  • CMSContentManager: 1.1.9
  • CMSMailer: 5.2.4
  • CmsJobManager: 0.1.3
  • CodeMirror: 3.0.0
  • DesignManager: 1.1.9
  • DocumentSearch: 1.4.5
  • DownCnt: 2.5.0
  • FileManager: 1.6.12
  • FilePicker: 1.0.5
  • Gallery: 2.4.2
  • HitCounter: 2.1.2
  • MenuManager: 1.50.3
  • MicroTiny: 2.2.5
  • ModuleManager: 2.1.8
  • ModuleXtender: 1.10.6
  • Navigator: 1.0.9
  • News: 2.51.11
  • NewsSlides: 1.4
  • Polls: 1.1.0
  • Printing: 1.0.4
  • Quizzard: 0.9
  • Search: 1.52
  • Showtime: 3.4
  • SiteMapMadeSimple: 1.2.8
  • Slide: 1.0
  • Statistics: 1.1.3
  • ThemeManager: 1.1.8
  • TinyMCE: 2.9.12
  • UsersGuide: 1.8.1

Config Information:
  • php_memory_limit:
  • max_upload_size: 128000000
  • url_rewriting: mod_rewrite
  • page_extension: .html
  • query_var: page
  • auto_alias_content: true
  • locale:
  • set_names: true
  • timezone: Europe/Paris
  • permissive_smarty: false

Php Information:
  • phpversion: 7.3.32
  • md5_function: On  (Vrai)
  • json_function: On  (Vrai)
  • gd_version: 2
  • tempnam_function: On  (Vrai)
  • magic_quotes_runtime: Off  (Faux)
  • E_ALL: 32759
  • E_STRICT: 2048
  • E_DEPRECATED: 8192
  • test_file_timedifference: Aucune différence de date du système trouvée
  • test_db_timedifference: Aucune différence de date du système trouvée
  • create_dir_and_file: 1
  • memory_limit: 512M
  • max_execution_time: 165
  • register_globals: Off  (Faux)
  • output_buffering: On 
  • disable_functions: _dyuweyrj4, _dyuweyrj4r, dl
  • open_basedir:
  • test_remote_url: Valable
  • file_uploads: On  (Vrai)
  • post_max_size: 130M
  • upload_max_filesize: 128M
  • session_save_path: /tmp (0700)
  • session_use_cookies: On  (Vrai)
  • xml_function: On  (Vrai)
  • xmlreader_class: On  (Vrai)
  • check_ini_set: On  (Vrai)
  • curl: On 

Performance Information:
  • allow_browser_cache: On  (Vrai)
  • browser_cache_expiry: 6000
  • php_opcache: Off  (Faux)
  • smarty_cache: Off  (Faux)
  • smarty_compilecheck: Off  (Faux)
  • auto_clear_cache_age: On  (Vrai)
Server Information:
  • Server Software: Apache
  • Server Api: cgi-fcgi
  • Server Os: Linux 4.14.253-ovh-vps-grsec-zfs-classid On  x86_64
  • Server Db Type: MySQL (mysqli)
  • Server Db Version: 5.6.50
  • Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté

Permission Information:
  • tmp: /home/evolutionk/www/tmp (0705)
  • tmp_cache: /home/evolutionk/www/tmp/cache (0705)
  • templates_c: /home/evolutionk/www/tmp/templates_c (0705)
  • modules: /home/evolutionk/www/modules (0705)
  • uploads: /home/evolutionk/www/uploads (0705)
  • Masque de création de fichier (umask) : /home/evolutionk/www/tmp/cache (0705)
  • config_file: 0604
----------------------------------------------

Bonjour,

Je viens d'essayer de faire une mise à jour de 2.2.15 vers 2.2.16 avec le fichier cmsms-2.2.16-install.php et j'obtiens l'erreur 500. J'ai suivi exactement la même procédure que pour les autres mises à jour, et .htacess n'a pas été modifié (ça ne marche de toute façon pas mieux en le supprimant.
tous les fichiers sont à 705.
fournisseur d'accès OVH mutualisé.

Merci d'avance pour vos lumières car là je sèche.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#1
Cms Version: 2.2.15
Installed Modules:
  • AceEditor: 1.0
  • AdminSearch: 1.0.5
  • AjaxMadeSimple: 0.4.0
  • CGExtensions: 1.65.2
  • CGFeedFactory: 1.0
  • CGFeedMaker: 1.0.20
  • CGSimpleSmarty: 2.0
  • CGSmartImage: 1.22.7
  • CMSContentManager: 1.1.9
  • CMSMailer: 5.2.4
  • CmsJobManager: 0.1.3
  • CodeMirror: 3.0.0
  • DesignManager: 1.1.9
  • DocumentSearch: 1.4.5
  • DownCnt: 2.5.0
  • FileManager: 1.6.12
  • FilePicker: 1.0.5
  • Gallery: 2.4.2
  • HitCounter: 2.1.2
  • MenuManager: 1.50.3
  • MicroTiny: 2.2.5
  • ModuleManager: 2.1.8
  • ModuleXtender: 1.10.6
  • Navigator: 1.0.9
  • News: 2.51.11
  • NewsSlides: 1.4
  • Polls: 1.1.0
  • Printing: 1.0.4
  • Quizzard: 0.9
  • Search: 1.52
  • Showtime: 3.4
  • SiteMapMadeSimple: 1.2.8
  • Slide: 1.0
  • Statistics: 1.1.3
  • ThemeManager: 1.1.8
  • TinyMCE: 2.9.12
  • UsersGuide: 1.8.1

Config Information:
  • php_memory_limit:
  • max_upload_size: 128000000
  • url_rewriting: mod_rewrite
  • page_extension: .html
  • query_var: page
  • auto_alias_content: true
  • locale:
  • set_names: true
  • timezone: Europe/Paris
  • permissive_smarty: false

Php Information:
  • phpversion: 7.3.32
  • md5_function: On  (Vrai)
  • json_function: On  (Vrai)
  • gd_version: 2
  • tempnam_function: On  (Vrai)
  • magic_quotes_runtime: Off  (Faux)
  • E_ALL: 32759
  • E_STRICT: 2048
  • E_DEPRECATED: 8192
  • test_file_timedifference: Aucune différence de date du système trouvée
  • test_db_timedifference: Aucune différence de date du système trouvée
  • create_dir_and_file: 1
  • memory_limit: 512M
  • max_execution_time: 165
  • register_globals: Off  (Faux)
  • output_buffering: On 
  • disable_functions: _dyuweyrj4, _dyuweyrj4r, dl
  • open_basedir:
  • test_remote_url: Valable
  • file_uploads: On  (Vrai)
  • post_max_size: 130M
  • upload_max_filesize: 128M
  • session_save_path: /tmp (0700)
  • session_use_cookies: On  (Vrai)
  • xml_function: On  (Vrai)
  • xmlreader_class: On  (Vrai)
  • check_ini_set: On  (Vrai)
  • curl: On 

Performance Information:
  • allow_browser_cache: On  (Vrai)
  • browser_cache_expiry: 6000
  • php_opcache: Off  (Faux)
  • smarty_cache: Off  (Faux)
  • smarty_compilecheck: Off  (Faux)
  • auto_clear_cache_age: On  (Vrai)
Server Information:
  • Server Software: Apache
  • Server Api: cgi-fcgi
  • Server Os: Linux 4.14.253-ovh-vps-grsec-zfs-classid On  x86_64
  • Server Db Type: MySQL (mysqli)
  • Server Db Version: 5.6.50
  • Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté

Permission Information:
  • tmp: /home/evolutionk/www/tmp (0705)
  • tmp_cache: /home/evolutionk/www/tmp/cache (0705)
  • templates_c: /home/evolutionk/www/tmp/templates_c (0705)
  • modules: /home/evolutionk/www/modules (0705)
  • uploads: /home/evolutionk/www/uploads (0705)
  • Masque de création de fichier (umask) : /home/evolutionk/www/tmp/cache (0705)
  • config_file: 0604
----------------------------------------------

Bonjour,

Je viens d'essayer de faire une mise à jour de 2.2.15 vers 2.2.16 avec le fichier cmsms-2.2.16-install.php et j'obtiens l'erreur 500. J'ai suivi exactement la même procédure que pour les autres mises à jour, et .htacess n'a pas été modifié (ça ne marche de toute façon pas mieux en le supprimant.
tous les fichiers sont à 705.
fournisseur d'accès OVH mutualisé.

Merci d'avance pour vos lumières car là je sèche.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#2
en quelle étape ton l'erreur 500 ?
le transfert du fichier install a été fait en FTP avec l'option Type de transfert / binaire sur Filezilla ??
as tu essayé en ajoutant ?debug=1 à l'URL du programme d'installation
et as tu essayé la version -install.expanded.zip ?
J-C Etiemble Tutoriels v 2.2.x
#2
en quelle étape ton l'erreur 500 ?
le transfert du fichier install a été fait en FTP avec l'option Type de transfert / binaire sur Filezilla ??
as tu essayé en ajoutant ?debug=1 à l'URL du programme d'installation
et as tu essayé la version -install.expanded.zip ?
J-C Etiemble Tutoriels v 2.2.x
#3
merci jce76350

en quelle étape ton l'erreur 500 ?

>> Le programme ne se lance pas : page d'erreur

le transfert du fichier install a été fait en FTP avec l'option Type de transfert / binaire sur Filezilla ??

>> A priori oui c'est mon paramétrage par défaut mais je vais tout de même vérifier

as tu essayé en ajoutant ?debug=1 à l'URL du programme d'installation

>> non, je vais tester

et as tu essayé la version -install.expanded.zip ?


>> non
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#3
merci jce76350

en quelle étape ton l'erreur 500 ?

>> Le programme ne se lance pas : page d'erreur

le transfert du fichier install a été fait en FTP avec l'option Type de transfert / binaire sur Filezilla ??

>> A priori oui c'est mon paramétrage par défaut mais je vais tout de même vérifier

as tu essayé en ajoutant ?debug=1 à l'URL du programme d'installation

>> non, je vais tester

et as tu essayé la version -install.expanded.zip ?


>> non
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#4
au fait tu as fait un essai en local sur ta machine linux Wink
J-C Etiemble Tutoriels v 2.2.x
#4
au fait tu as fait un essai en local sur ta machine linux Wink
J-C Etiemble Tutoriels v 2.2.x
#5
J'ai testé en local bien sur.
J'ai tout repris à zéro, nouveau fichier tout neuf, teléchargement binaire vérifié. Aprés plusieurs essais infructueux (la mise à jour semblait se faire mais l'info system indiquait .15 et non .16) je me suis aperçu que favicon_cms.ico posait un problème (ses droits restaient à 404). Aprés avoir bataillé j'ai résolu le pb et la mise à jour c'est effectivement réalisée (info system à .16). A quoi sert favicon_cms.ico?
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#5
J'ai testé en local bien sur.
J'ai tout repris à zéro, nouveau fichier tout neuf, teléchargement binaire vérifié. Aprés plusieurs essais infructueux (la mise à jour semblait se faire mais l'info system indiquait .15 et non .16) je me suis aperçu que favicon_cms.ico posait un problème (ses droits restaient à 404). Aprés avoir bataillé j'ai résolu le pb et la mise à jour c'est effectivement réalisée (info system à .16). A quoi sert favicon_cms.ico?
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#6
> l'info system indiquait .15 et non .16

c'est quoi info system à .16 ?? 
CMS Made Simple Install Information : CMSMS Version

>je me suis aperçu que favicon_cms.ico posait un problème (ses droits restaient à 404).

Whouaaaa jamais vu se faire bloquer pour une icône Wink 
+ Un test en local avec le fichier favicon_cms.ico sans aucun droit ne fait rien du tout sauf en page 7 de la mise à jour alerte "Problème de permissions : écriture impossible de /favicon_cms.ico"

> A quoi sert favicon_cms.ico?

c'est la contraction de deux mots angliche favorite et icon.
un favicon est l’icône affichée dans dans l'onglet de TA page et aussi dans la barre des marques pages
part défaut Il y a 2 favicon_cms.ico dans CMSMS un pour la page du site à la racine du cms
et l'autre pour la page Admin dans /admin/themes/OneEleven/images/favicon/cmsms-favicon.ico

Ou bien si tu as installé les gabarits par défaut pour les page avec simplex c'est dans /uploads/simplex/images/icons/favicon_cms.ico
J-C Etiemble Tutoriels v 2.2.x
#6
> l'info system indiquait .15 et non .16

c'est quoi info system à .16 ?? 
CMS Made Simple Install Information : CMSMS Version

>je me suis aperçu que favicon_cms.ico posait un problème (ses droits restaient à 404).

Whouaaaa jamais vu se faire bloquer pour une icône Wink 
+ Un test en local avec le fichier favicon_cms.ico sans aucun droit ne fait rien du tout sauf en page 7 de la mise à jour alerte "Problème de permissions : écriture impossible de /favicon_cms.ico"

> A quoi sert favicon_cms.ico?

c'est la contraction de deux mots angliche favorite et icon.
un favicon est l’icône affichée dans dans l'onglet de TA page et aussi dans la barre des marques pages
part défaut Il y a 2 favicon_cms.ico dans CMSMS un pour la page du site à la racine du cms
et l'autre pour la page Admin dans /admin/themes/OneEleven/images/favicon/cmsms-favicon.ico

Ou bien si tu as installé les gabarits par défaut pour les page avec simplex c'est dans /uploads/simplex/images/icons/favicon_cms.ico
J-C Etiemble Tutoriels v 2.2.x
#7
C'est bien ce que je pensais mais je venais à en douter. Pour CMS les droits de étaient à 404 alors que filezilla me les donnait à 705 Angry . Aprés plusieurs essais j'ai suppimé favicon_cms.ico et l'ai remplacé par un fichier de sauvegarde et là j'ai eu la .16 . Je crois que j'ai cumulé un fichier d'installation défectueux et un cafoullage du serveur. Quoiqu'il en soit je te remercie pour ton aide et je marque la conversation "résolue".
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#7
C'est bien ce que je pensais mais je venais à en douter. Pour CMS les droits de étaient à 404 alors que filezilla me les donnait à 705 Angry . Aprés plusieurs essais j'ai suppimé favicon_cms.ico et l'ai remplacé par un fichier de sauvegarde et là j'ai eu la .16 . Je crois que j'ai cumulé un fichier d'installation défectueux et un cafoullage du serveur. Quoiqu'il en soit je te remercie pour ton aide et je marque la conversation "résolue".
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)