Mise à jour du noyau

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Bonjour ,

Je souhaite mettre à jour ma version de cmsms ( passage en 2.2.15 ) , mais j'ai un soucis .
J'ai eu beaucoup de difficulté à mettre à jour ma version mais apparemment j'y suis arrivé. Mais lorsque je veux mettre mes modules à jour, un message apparait en me disant de mettre le noyau à jour...
Pouvez vous m'aider?
Voici des captures d'écrans ainsi que mes infos des différentes versions de module.

Aussi en front-end j'ai ces erreurs :
[font="Helvetica Neue", Helvetica, Arial, sans-serif][b]Warning[/font][/b][font="Helvetica Neue", Helvetica, Arial, sans-serif]: count(): Parameter must be an array or an object that implements Countable in [/font][font="Helvetica Neue", Helvetica, Arial, sans-serif][b]/homepages/24/d610266730/htdocs/SITE/SITE2/lib/classes/class.contentoperations.inc.php on line xxx[/font][/b]




[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif]----------------------------------------------[/font]
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Cms Version[/b]: 2.2.15[/font]
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Installed Modules[/b]:[/font]
  • AdminSearch: 1.0.2

  • CGBlog: 1.14.4

  • CGExtensions: 1.57

  • CGSimpleSmarty: 2.1.7

  • CGSmartImage: 1.21.9

  • CMSContentManager: 1.1.4

  • CMSMailer: 6.2.14

  • CmsJobManager: 0.1.3

  • CustomContent: 1.10

  • DesignManager: 1.1.1

  • ECB: 1.6

  • FileManager: 1.5.2

  • FilePicker: 1.0.5

  • FormBuilder: 0.8.1.6

  • FrontEndUsers: 1.31.3

  • GBFilePicker: 1.3.3

  • Gallery: 2.3.1

  • JQueryTools: 1.4.0.3

  • LISE: 1.3.1

  • LISEGuide: 1.3.1

  • LessCSS: 2.7

  • Matomo: 0.0.1

  • MenuManager: 1.50.2

  • MicroTiny: 2.0.3

  • ModuleManager: 2.0.5

  • Navigator: 1.0.3

  • News: 2.50.6

  • SEOTools2: 1.2.1

  • Search: 1.50.2

  • SiteMapMadeSimple: 1.2.8

  • ThemeManager: 1.1.8
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Config Information[/b]:[/font]
  • php_memory_limit:

  • max_upload_size: 64000000

  • url_rewriting: mod_rewrite

  • page_extension:

  • query_var: page

  • auto_alias_content: true

  • locale:

  • set_names: true

  • timezone: Europe/Paris

  • permissive_smarty: false
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Php Information[/b]:[/font]
  • phpversion: 7.4.13

  • md5_function: On  (Vrai)

  • json_function: On  (Vrai)

  • gd_version: 2

  • tempnam_function: On  (Vrai)

  • magic_quotes_runtime: Off  (Faux)

  • E_ALL: 22517

  • E_STRICT: 0

  • E_DEPRECATED: 0

  • test_file_timedifference: Aucune différence de date du système trouvée

  • test_db_timedifference: Aucune différence de date du système trouvée

  • create_dir_and_file: 1

  • memory_limit: -1

  • max_execution_time: 50000

  • register_globals: Off  (Faux)

  • output_buffering: 0

  • disable_functions:

  • open_basedir:

  • test_remote_url: Valable

  • file_uploads: On  (Vrai)

  • post_max_size: 64M

  • upload_max_filesize: 64M

  • session_save_path: /tmp/.priv (1733)

  • session_use_cookies: On  (Vrai)

  • xml_function: On  (Vrai)

  • xmlreader_class: On  (Vrai)

  • check_ini_set: On  (Vrai)

  • curl: On 
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Performance Information:[/b][/font]
  • allow_browser_cache: On  (Vrai)

  • browser_cache_expiry: 60

  • php_opcache: Off  (Faux)

  • smarty_cache: Off  (Faux)

  • smarty_compilecheck: On  (Vrai)

  • auto_clear_cache_age: Off  (Faux)
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Server Information[/b]:[/font]
  • Server Software: Apache

  • Server Api: cgi-fcgi

  • Server Os: Linux 4.4.236-icpu-055 On  x86_64

  • Server Db Type: MySQL (mysqli)

  • Server Db Version: 5.7.32

  • Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Permission Information[/b]:[/font]
  • tmp: /homepages/24/d610266730/htdocs/SITE/SITE2/tmp (0705)

  • tmp_cache: /homepages/24/d610266730/htdocs/SITE/SITE2/tmp/cache (0705)

  • templates_c: /homepages/24/d610266730/htdocs/SITE/SITE2/tmp/templates_c (0705)

  • modules: /homepages/24/d610266730/htdocs/SITE/SITE2/modules (0705)

  • uploads: /homepages/24/d610266730/htdocs/SITE/SITE2/uploads (0705)

  • Masque de création de fichier (umask) : /homepages/24/d610266730/htdocs/SITE/SITE2/tmp/cache (0705)

  • config_file: 0444
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif]----------------------------------------------[/font]


Pièces jointes Miniature(s)
       
Répondre
#1
Bonjour ,

Je souhaite mettre à jour ma version de cmsms ( passage en 2.2.15 ) , mais j'ai un soucis .
J'ai eu beaucoup de difficulté à mettre à jour ma version mais apparemment j'y suis arrivé. Mais lorsque je veux mettre mes modules à jour, un message apparait en me disant de mettre le noyau à jour...
Pouvez vous m'aider?
Voici des captures d'écrans ainsi que mes infos des différentes versions de module.

Aussi en front-end j'ai ces erreurs :
[font="Helvetica Neue", Helvetica, Arial, sans-serif][b]Warning[/font][/b][font="Helvetica Neue", Helvetica, Arial, sans-serif]: count(): Parameter must be an array or an object that implements Countable in [/font][font="Helvetica Neue", Helvetica, Arial, sans-serif][b]/homepages/24/d610266730/htdocs/SITE/SITE2/lib/classes/class.contentoperations.inc.php on line xxx[/font][/b]




[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif]----------------------------------------------[/font]
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Cms Version[/b]: 2.2.15[/font]
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Installed Modules[/b]:[/font]
  • AdminSearch: 1.0.2

  • CGBlog: 1.14.4

  • CGExtensions: 1.57

  • CGSimpleSmarty: 2.1.7

  • CGSmartImage: 1.21.9

  • CMSContentManager: 1.1.4

  • CMSMailer: 6.2.14

  • CmsJobManager: 0.1.3

  • CustomContent: 1.10

  • DesignManager: 1.1.1

  • ECB: 1.6

  • FileManager: 1.5.2

  • FilePicker: 1.0.5

  • FormBuilder: 0.8.1.6

  • FrontEndUsers: 1.31.3

  • GBFilePicker: 1.3.3

  • Gallery: 2.3.1

  • JQueryTools: 1.4.0.3

  • LISE: 1.3.1

  • LISEGuide: 1.3.1

  • LessCSS: 2.7

  • Matomo: 0.0.1

  • MenuManager: 1.50.2

  • MicroTiny: 2.0.3

  • ModuleManager: 2.0.5

  • Navigator: 1.0.3

  • News: 2.50.6

  • SEOTools2: 1.2.1

  • Search: 1.50.2

  • SiteMapMadeSimple: 1.2.8

  • ThemeManager: 1.1.8
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Config Information[/b]:[/font]
  • php_memory_limit:

  • max_upload_size: 64000000

  • url_rewriting: mod_rewrite

  • page_extension:

  • query_var: page

  • auto_alias_content: true

  • locale:

  • set_names: true

  • timezone: Europe/Paris

  • permissive_smarty: false
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Php Information[/b]:[/font]
  • phpversion: 7.4.13

  • md5_function: On  (Vrai)

  • json_function: On  (Vrai)

  • gd_version: 2

  • tempnam_function: On  (Vrai)

  • magic_quotes_runtime: Off  (Faux)

  • E_ALL: 22517

  • E_STRICT: 0

  • E_DEPRECATED: 0

  • test_file_timedifference: Aucune différence de date du système trouvée

  • test_db_timedifference: Aucune différence de date du système trouvée

  • create_dir_and_file: 1

  • memory_limit: -1

  • max_execution_time: 50000

  • register_globals: Off  (Faux)

  • output_buffering: 0

  • disable_functions:

  • open_basedir:

  • test_remote_url: Valable

  • file_uploads: On  (Vrai)

  • post_max_size: 64M

  • upload_max_filesize: 64M

  • session_save_path: /tmp/.priv (1733)

  • session_use_cookies: On  (Vrai)

  • xml_function: On  (Vrai)

  • xmlreader_class: On  (Vrai)

  • check_ini_set: On  (Vrai)

  • curl: On 
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Performance Information:[/b][/font]
  • allow_browser_cache: On  (Vrai)

  • browser_cache_expiry: 60

  • php_opcache: Off  (Faux)

  • smarty_cache: Off  (Faux)

  • smarty_compilecheck: On  (Vrai)

  • auto_clear_cache_age: Off  (Faux)
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Server Information[/b]:[/font]
  • Server Software: Apache

  • Server Api: cgi-fcgi

  • Server Os: Linux 4.4.236-icpu-055 On  x86_64

  • Server Db Type: MySQL (mysqli)

  • Server Db Version: 5.7.32

  • Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif][b]Permission Information[/b]:[/font]
  • tmp: /homepages/24/d610266730/htdocs/SITE/SITE2/tmp (0705)

  • tmp_cache: /homepages/24/d610266730/htdocs/SITE/SITE2/tmp/cache (0705)

  • templates_c: /homepages/24/d610266730/htdocs/SITE/SITE2/tmp/templates_c (0705)

  • modules: /homepages/24/d610266730/htdocs/SITE/SITE2/modules (0705)

  • uploads: /homepages/24/d610266730/htdocs/SITE/SITE2/uploads (0705)

  • Masque de création de fichier (umask) : /homepages/24/d610266730/htdocs/SITE/SITE2/tmp/cache (0705)

  • config_file: 0444
[font="Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif]----------------------------------------------[/font]


Pièces jointes Miniature(s)
       
Répondre
#2
Bonjour,

Peux-tu nous dire comment tu as fait la mise à jour, et depuis quelle version ?
Comment s'est déroulée la mise à jour ?
Quel est l'hébergeur ?
Merci.
Ouik - communication . outils numériques . design graphique
Répondre
#2
Bonjour,

Peux-tu nous dire comment tu as fait la mise à jour, et depuis quelle version ?
Comment s'est déroulée la mise à jour ?
Quel est l'hébergeur ?
Merci.
Ouik - communication . outils numériques . design graphique
Répondre
#3
Bonjour Ouik,
merci pour ta réponse rapide,

Mon hébergeur est ionos ( 1and1 ).
Je suis passé de la 2.1.6 à la 2.2.15
Sur ionos, j'ai dû utiliser la version .expanded
J'ai fait une copie de mes fichiers vers un autre dossier (pour faire la migration )J'ai testé pour voir si tt fonctionnait ce qui était le cas. ( j'ai modifié du coup le config.php ) et j'ai eu quelques difficulté car il ne me détectait pas qu'une installation existait.
Mais j'y suis arrivé quand même
J'ai vidé mon cache ( pc + site internet ) .ca ne change rien.
J'ai vérifié dans le répertoire lib s'il manquait un fichier mais tt avait l'air ok.
Est ce qu'il fallait passer par une version intermédiaire?
Merci pr tes prochaines réponses

Bonne journée



Citation :Bonjour,

Peux-tu nous dire comment tu as fait la mise à jour, et depuis quelle version ?
Comment s'est déroulée la mise à jour ?
Quel est l'hébergeur ?
Merci.
Répondre
#3
Bonjour Ouik,
merci pour ta réponse rapide,

Mon hébergeur est ionos ( 1and1 ).
Je suis passé de la 2.1.6 à la 2.2.15
Sur ionos, j'ai dû utiliser la version .expanded
J'ai fait une copie de mes fichiers vers un autre dossier (pour faire la migration )J'ai testé pour voir si tt fonctionnait ce qui était le cas. ( j'ai modifié du coup le config.php ) et j'ai eu quelques difficulté car il ne me détectait pas qu'une installation existait.
Mais j'y suis arrivé quand même
J'ai vidé mon cache ( pc + site internet ) .ca ne change rien.
J'ai vérifié dans le répertoire lib s'il manquait un fichier mais tt avait l'air ok.
Est ce qu'il fallait passer par une version intermédiaire?
Merci pr tes prochaines réponses

Bonne journée



Citation :Bonjour,

Peux-tu nous dire comment tu as fait la mise à jour, et depuis quelle version ?
Comment s'est déroulée la mise à jour ?
Quel est l'hébergeur ?
Merci.
Répondre
#4
Normalement, ça devrait passer sans problème depuis une version 2.1.x.
Ionos, effectivement, expanded obligatoire (c'est un peu pénible). As-tu bien suivi la procédure particulière de mise à jour expanded ? Il n'est pas normal que l'installation ne soit pas détectée.
Peut-être faudrait-il tenter un rafraichissement de l'installation en suivant la procédure ?
Ouik - communication . outils numériques . design graphique
Répondre
#4
Normalement, ça devrait passer sans problème depuis une version 2.1.x.
Ionos, effectivement, expanded obligatoire (c'est un peu pénible). As-tu bien suivi la procédure particulière de mise à jour expanded ? Il n'est pas normal que l'installation ne soit pas détectée.
Peut-être faudrait-il tenter un rafraichissement de l'installation en suivant la procédure ?
Ouik - communication . outils numériques . design graphique
Répondre
#5
Par raffraichissement tu entends, faire une install neuve puis apres recharger le contenu en prenant dans la bdd que les tables correspondantes?La procédure est la meme que pr une install neuve...sauf qu'il doit détecter si installation il y a sur le serveur c'est ca?

(08/01/2021, 14:47:51)Ouik a écrit : Normalement, ça devrait passer sans problème depuis une version 2.1.x.
Ionos, effectivement, expanded obligatoire (c'est un peu pénible). As-tu bien suivi la procédure particulière de mise à jour expanded ? Il n'est pas normal que l'installation ne soit pas détectée.
Peut-être faudrait-il tenter un rafraichissement de l'installation en suivant la procédure ?
Répondre
#5
Par raffraichissement tu entends, faire une install neuve puis apres recharger le contenu en prenant dans la bdd que les tables correspondantes?La procédure est la meme que pr une install neuve...sauf qu'il doit détecter si installation il y a sur le serveur c'est ca?

(08/01/2021, 14:47:51)Ouik a écrit : Normalement, ça devrait passer sans problème depuis une version 2.1.x.
Ionos, effectivement, expanded obligatoire (c'est un peu pénible). As-tu bien suivi la procédure particulière de mise à jour expanded ? Il n'est pas normal que l'installation ne soit pas détectée.
Peut-être faudrait-il tenter un rafraichissement de l'installation en suivant la procédure ?
Répondre
#6
Non, le rafraichissement consiste en relancer la procédure de mise à jour en suivant scrupuleusement les indications de mises à jour (elles sont dans le dossier expanded, fichier readme.txt). Il n'y a pas à tripatouiller la base de données pour ce faire.

NB : Ça fait 2 fois que je corrige la mise en forme de tes posts. Tu n'es pas obligé de citer le post précédent si tu n'es pas à l'aise avec la façon de le faire.
Ouik - communication . outils numériques . design graphique
Répondre
#6
Non, le rafraichissement consiste en relancer la procédure de mise à jour en suivant scrupuleusement les indications de mises à jour (elles sont dans le dossier expanded, fichier readme.txt). Il n'y a pas à tripatouiller la base de données pour ce faire.

NB : Ça fait 2 fois que je corrige la mise en forme de tes posts. Tu n'es pas obligé de citer le post précédent si tu n'es pas à l'aise avec la façon de le faire.
Ouik - communication . outils numériques . design graphique
Répondre
#7
Du coup j'ai fait un petit rafraichissement qui s'est passé sans problème.
Le site m'indique plein d'erreur.
[font="Helvetica Neue", Helvetica, Arial, sans-serif][b][b][font="Helvetica Neue", Helvetica, Arial, sans-serif][b]Warning[/font][/b][font="Helvetica Neue", Helvetica, Arial, sans-serif]: count(): Parameter must be an array or an object that implements Countable in [/font][font="Helvetica Neue", Helvetica, Arial, sans-serif][b]/homepages/24/d610266730/htdocs/SITE/SITE2/lib/classes/class.contentoperations.inc.php[/font][/b][font="Helvetica Neue", Helvetica, Arial, sans-serif] [/font][/b][/font][/b]
[font="Helvetica Neue", Helvetica, Arial, sans-serif][font="Helvetica Neue", Helvetica, Arial, sans-serif]Je vais mettre à jour les modules, je vais voir si ça corrige tout ça.
Merci[/font]
[/font]
Répondre
#7
Du coup j'ai fait un petit rafraichissement qui s'est passé sans problème.
Le site m'indique plein d'erreur.
[font="Helvetica Neue", Helvetica, Arial, sans-serif][b][b][font="Helvetica Neue", Helvetica, Arial, sans-serif][b]Warning[/font][/b][font="Helvetica Neue", Helvetica, Arial, sans-serif]: count(): Parameter must be an array or an object that implements Countable in [/font][font="Helvetica Neue", Helvetica, Arial, sans-serif][b]/homepages/24/d610266730/htdocs/SITE/SITE2/lib/classes/class.contentoperations.inc.php[/font][/b][font="Helvetica Neue", Helvetica, Arial, sans-serif] [/font][/b][/font][/b]
[font="Helvetica Neue", Helvetica, Arial, sans-serif][font="Helvetica Neue", Helvetica, Arial, sans-serif]Je vais mettre à jour les modules, je vais voir si ça corrige tout ça.
Merci[/font]
[/font]
Répondre
#8
En fait il n'indique qu'une erreur… et ça pourrait venir de LISE dont ta version installée n'est pas compatible avec PHP 7.4. Si tu mets à jour les modules, ça devrait disparaître.
Ouik - communication . outils numériques . design graphique
Répondre
#8
En fait il n'indique qu'une erreur… et ça pourrait venir de LISE dont ta version installée n'est pas compatible avec PHP 7.4. Si tu mets à jour les modules, ça devrait disparaître.
Ouik - communication . outils numériques . design graphique
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)