Tuto pour créer une galerie d'image

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Bonjour,
J'ai repris l'administration d'un site développé avec CMS-MadeSimple
J'aimerai installer une galerie de photos. Je ne trouve rien sur ce forum ou alors des discussion datant de 2011
Si voua avez un tuto, Un truc pas trop compliqué cela serai sympa.
Merci d'avance
FikoU
Répondre
#1
Bonjour,
J'ai repris l'administration d'un site développé avec CMS-MadeSimple
J'aimerai installer une galerie de photos. Je ne trouve rien sur ce forum ou alors des discussion datant de 2011
Si voua avez un tuto, Un truc pas trop compliqué cela serai sympa.
Merci d'avance
FikoU
Répondre
#2
Bonjour,

généralement les galeries photos s'appuient sur le module Gallery qui permet de créer des dossiers, sous-dossiers (etc.), et d'y placer des images auxquelles tu peux attribuer un titre, un commentaire, etc.. et les réordonner dans leur dossier.
Côté rendu visuel pour l'utilisateur, le module embarque quelques exemples de galeries ou diaporamas défilants, mais tu peux également intégrer le gabarit / plugin de ton choix en créant un nouveau gabarit.

Concernant les tutos, finalement le module n'a que peu bougé depuis le départ car son but est avant tout de bien stocker des photos, et côté rendu il laisse libre l'intégrateur qui peut choisir un script récent / ancien / maison, ... Wink

Tu peux également te passer bien sûr de module et intégrer ta galerie à la main dans un gabarit de page ou un gabarit générique. Tout dépend si tu as besoin d'une administration pour tes images ?

Tiens-nous informé,
Répondre
#2
Bonjour,

généralement les galeries photos s'appuient sur le module Gallery qui permet de créer des dossiers, sous-dossiers (etc.), et d'y placer des images auxquelles tu peux attribuer un titre, un commentaire, etc.. et les réordonner dans leur dossier.
Côté rendu visuel pour l'utilisateur, le module embarque quelques exemples de galeries ou diaporamas défilants, mais tu peux également intégrer le gabarit / plugin de ton choix en créant un nouveau gabarit.

Concernant les tutos, finalement le module n'a que peu bougé depuis le départ car son but est avant tout de bien stocker des photos, et côté rendu il laisse libre l'intégrateur qui peut choisir un script récent / ancien / maison, ... Wink

Tu peux également te passer bien sûr de module et intégrer ta galerie à la main dans un gabarit de page ou un gabarit générique. Tout dépend si tu as besoin d'une administration pour tes images ?

Tiens-nous informé,
Répondre
#3
Bonjour,
Merci pour cette réponse rapide.
Je vais regarder, mais je ne connais pas ce ce CMS. J'ai juste fait des mises à jour au mois de mai 2019 et j'ai aussi du me faire aider par un membre de ce forum....
Donc ou une marche à suivre me serai d'un grand secours
@+FikoU

Bon ben là c'est galère, je n'arrive pas dans cette page http://crplausanne.ch/index.php?page=Inauguration
à créer une section ou un module ?
Je voulais créer un nouveau module pour insérer la galerie et après supprimer les modules qui contiennent les photos.

@+FikoU
Répondre
#3
Bonjour,
Merci pour cette réponse rapide.
Je vais regarder, mais je ne connais pas ce ce CMS. J'ai juste fait des mises à jour au mois de mai 2019 et j'ai aussi du me faire aider par un membre de ce forum....
Donc ou une marche à suivre me serai d'un grand secours
@+FikoU

Bon ben là c'est galère, je n'arrive pas dans cette page http://crplausanne.ch/index.php?page=Inauguration
à créer une section ou un module ?
Je voulais créer un nouveau module pour insérer la galerie et après supprimer les modules qui contiennent les photos.

@+FikoU
Répondre
#4
Il faut que tu installes le module Gallery http://dev.cmsmadesimple.org/projects/gallery comme te l'a dis airelibre sur le forum
(perso ne n’utilise pas ce module donc pas possible de t’aider)
J-C Etiemble Tutoriels v 2.2.x
Répondre
#4
Il faut que tu installes le module Gallery http://dev.cmsmadesimple.org/projects/gallery comme te l'a dis airelibre sur le forum
(perso ne n’utilise pas ce module donc pas possible de t’aider)
J-C Etiemble Tutoriels v 2.2.x
Répondre
#5
En effet commence par l'installer via Extensions / Gestionnaire de modules > Modules disponibles > onglet "G" > "Installer" en face de Gallery.

Tu aura alors accès au module via Contenu / Galeries d'images

Chaque galerie te donne un "tag" sous la forme : {Gallery dir='mon/dossier'} - Cette balise est à placer sur la ou les pages (ou articles, ou autre..) où tu veux faire apparaître la galerie.

Bonne découverte, et tiens-nous au courant
Répondre
#5
En effet commence par l'installer via Extensions / Gestionnaire de modules > Modules disponibles > onglet "G" > "Installer" en face de Gallery.

Tu aura alors accès au module via Contenu / Galeries d'images

Chaque galerie te donne un "tag" sous la forme : {Gallery dir='mon/dossier'} - Cette balise est à placer sur la ou les pages (ou articles, ou autre..) où tu veux faire apparaître la galerie.

Bonne découverte, et tiens-nous au courant
Répondre
#6
Bonjour,
Je reviens vers vous, j'avais abandonner l'idée d'une galerie d'images. Mais sur demande de mes collègues je dois installer cette "galerie".
Je n'arrive pas à installer le module "gallery" je n'ai pas le "gestionnaire de modules" dans dans le menu extensions (recherche, recherche dans l'administration, sélecteur de fichiers, Éditeur WYSIWYG MicroTiny, Balises).
Comme déjà dit je ne connait pas cmsmadesimple. Ce n'est pas moi qui ai créer le site, je fais que des mises à jours.
Merci d'avance.
Fikou


Pièces jointes Miniature(s)
   
Répondre
#6
Bonjour,
Je reviens vers vous, j'avais abandonner l'idée d'une galerie d'images. Mais sur demande de mes collègues je dois installer cette "galerie".
Je n'arrive pas à installer le module "gallery" je n'ai pas le "gestionnaire de modules" dans dans le menu extensions (recherche, recherche dans l'administration, sélecteur de fichiers, Éditeur WYSIWYG MicroTiny, Balises).
Comme déjà dit je ne connait pas cmsmadesimple. Ce n'est pas moi qui ai créer le site, je fais que des mises à jours.
Merci d'avance.
Fikou


Pièces jointes Miniature(s)
   
Répondre
#7
(18/05/2020, 11:47:10)FikoU a écrit : Bonjour,
Je reviens vers vous, j'avais abandonner l'idée d'une galerie d'images. Mais sur demande de mes collègues je dois installer cette "galerie".
Je n'arrive pas à installer le module "gallery" je n'ai pas le "gestionnaire de modules" dans dans le menu extensions (recherche, recherche dans l'administration, sélecteur de fichiers, Éditeur WYSIWYG MicroTiny, Balises).
Comme déjà dit je ne connait pas cmsmadesimple. Ce n'est pas moi qui ai créer le site, je fais que des mises à jours.
Merci d'avance.
Fikou
Il faut aller dans administration du site, le menu juste en-dessous, puis gestionnaire de modules, rechercher Gallery et l'installer.
Ensuite, reviens par ici si tu as des problèmes pour la mise en place de galeries. Mais avant, tu peux aller regarder l'aide sur la page gestionnaire de modules, à droite de chaque module.
Ouik - communication | outils numériques | design graphique
Répondre
#7
(18/05/2020, 11:47:10)FikoU a écrit : Bonjour,
Je reviens vers vous, j'avais abandonner l'idée d'une galerie d'images. Mais sur demande de mes collègues je dois installer cette "galerie".
Je n'arrive pas à installer le module "gallery" je n'ai pas le "gestionnaire de modules" dans dans le menu extensions (recherche, recherche dans l'administration, sélecteur de fichiers, Éditeur WYSIWYG MicroTiny, Balises).
Comme déjà dit je ne connait pas cmsmadesimple. Ce n'est pas moi qui ai créer le site, je fais que des mises à jours.
Merci d'avance.
Fikou
Il faut aller dans administration du site, le menu juste en-dessous, puis gestionnaire de modules, rechercher Gallery et l'installer.
Ensuite, reviens par ici si tu as des problèmes pour la mise en place de galeries. Mais avant, tu peux aller regarder l'aide sur la page gestionnaire de modules, à droite de chaque module.
Ouik - communication | outils numériques | design graphique
Répondre
#8
Merci pour cette réponse rapide,
Mon cerveau doit toujours être en mode confinement....
Sous "gestionnaire de modules" je ne trouve pas la recherche.
Dans l'aide il est dit : Pour utiliser ce module, vous devez avoir la permission "Modify Modules".
Pas trouvé dans "préferences utilisateur"
Dans "informations système" j'ai ModuleManager 2.1.2 ???
Merci d'avance.
Fikou
Répondre
#8
Merci pour cette réponse rapide,
Mon cerveau doit toujours être en mode confinement....
Sous "gestionnaire de modules" je ne trouve pas la recherche.
Dans l'aide il est dit : Pour utiliser ce module, vous devez avoir la permission "Modify Modules".
Pas trouvé dans "préferences utilisateur"
Dans "informations système" j'ai ModuleManager 2.1.2 ???
Merci d'avance.
Fikou
Répondre
#9
Es-tu connecté en tant qu'administrateur du site ?

Si oui, dans le gestionnaire de modules, tu dois avoir quelque chose comme ce qu'affiche la pièce jointe ci-dessous.

   

Sinon, il faut que tu aies un accès administrateur pour ce faire.
Ouik - communication | outils numériques | design graphique
Répondre
#9
Es-tu connecté en tant qu'administrateur du site ?

Si oui, dans le gestionnaire de modules, tu dois avoir quelque chose comme ce qu'affiche la pièce jointe ci-dessous.

   

Sinon, il faut que tu aies un accès administrateur pour ce faire.
Ouik - communication | outils numériques | design graphique
Répondre
#10
Sous gestionnaire de module je n'ai rien qui correspond à ta capture c'est comme la capture que je t'ai envoyé.
Ce n'est pas moi qui ai créé ce site. Je vais me logger avec d'autres identifiants pour voir.
J'ai déjà modifier pas mal de truc sur ce site...

Bon effectivement je n'ai pas tout les pouvoirs.
Voila je suis en "administrateur" avec un autre compte grrrr.
J'avais en son temps créé un compte que je croyais admin car je pouvais faire des modifs.
Pfff je crois avoir pigé je modifie les comptes et je teste
Merci beaucoup
Fikou
PS : si jamais je reviens...

Bon ben j'ai pas fais long, tout est ok côté utilisateurs.
Dans contenu j'ai bien "galerie d'images"
Mais j'aimerai l’insérer dans un contenu/colonne d'une page existante. Sais tu si il y a une doc en français ?
Répondre
#10
Sous gestionnaire de module je n'ai rien qui correspond à ta capture c'est comme la capture que je t'ai envoyé.
Ce n'est pas moi qui ai créé ce site. Je vais me logger avec d'autres identifiants pour voir.
J'ai déjà modifier pas mal de truc sur ce site...

Bon effectivement je n'ai pas tout les pouvoirs.
Voila je suis en "administrateur" avec un autre compte grrrr.
J'avais en son temps créé un compte que je croyais admin car je pouvais faire des modifs.
Pfff je crois avoir pigé je modifie les comptes et je teste
Merci beaucoup
Fikou
PS : si jamais je reviens...

Bon ben j'ai pas fais long, tout est ok côté utilisateurs.
Dans contenu j'ai bien "galerie d'images"
Mais j'aimerai l’insérer dans un contenu/colonne d'une page existante. Sais tu si il y a une doc en français ?
Répondre
#11
Alors, c'est assez simple :
1 - il faut créer une sous-galerie
2 - uploader des images dans cette sous-galerie
3 - récupérer le code de cette sous-galerie, ex : {Gallery dir="cheminversmon/repertoire"}
4 - le coller là où tu veux afficher la galerie = tu vas dans le champ d'édition de la page, et tu colles ce code.

Après tu peux personnaliser le gabarit d'affichage dans l'onglet Gabarits du module.
Ouik - communication | outils numériques | design graphique
Répondre
#11
Alors, c'est assez simple :
1 - il faut créer une sous-galerie
2 - uploader des images dans cette sous-galerie
3 - récupérer le code de cette sous-galerie, ex : {Gallery dir="cheminversmon/repertoire"}
4 - le coller là où tu veux afficher la galerie = tu vas dans le champ d'édition de la page, et tu colles ce code.

Après tu peux personnaliser le gabarit d'affichage dans l'onglet Gabarits du module.
Ouik - communication | outils numériques | design graphique
Répondre
#12
Bonjour,
C'est toujours moi...
J'ai réussi à créer une galerie mais avec de toutes petites vignettes.
Donc j'ai fais divers essais et pour finir plus rien ne fonctionne. J'ai tout supprimé et je ne sais plus quoi faire.
Mes questions :
Pourquoi chaque fois que j'enregistre je dois vider l'historique de mon navigateur pour voir les modifications ?
Au bout d'un certain temps lorsque je veux sauvegarder il me jette et je dois me reconnecter ?
Bon je reviens bientôt je teste un dernier truc avant de vous embêtez plus...
FikoU
Répondre
#12
Bonjour,
C'est toujours moi...
J'ai réussi à créer une galerie mais avec de toutes petites vignettes.
Donc j'ai fais divers essais et pour finir plus rien ne fonctionne. J'ai tout supprimé et je ne sais plus quoi faire.
Mes questions :
Pourquoi chaque fois que j'enregistre je dois vider l'historique de mon navigateur pour voir les modifications ?
Au bout d'un certain temps lorsque je veux sauvegarder il me jette et je dois me reconnecter ?
Bon je reviens bientôt je teste un dernier truc avant de vous embêtez plus...
FikoU
Répondre
#13
Pour les vignettes, il faut aller dans gabarits et définir la taille des images vignettes que tu souhaites.
Qu'as-tu essayé qui a fait que "plus rien ne fonctionne" ?
Pour l'historique, peux-tu vérifier dans Administration du site > Paramètres globaux > paramètres Smarty si le cache Smarty est activé ? Si oui, le désactiver. Sinon, peux-tu nous dire quel est ton hébergeur, s'il y a un cache sur l'hébergement ?

Pour la reconnexion, tu parles bien de CMSMS ? Si oui, utilises-tu TinyMCE ?

Ah, et autre question, tu es sur quelle version du CMS ?
Ouik - communication | outils numériques | design graphique
Répondre
#13
Pour les vignettes, il faut aller dans gabarits et définir la taille des images vignettes que tu souhaites.
Qu'as-tu essayé qui a fait que "plus rien ne fonctionne" ?
Pour l'historique, peux-tu vérifier dans Administration du site > Paramètres globaux > paramètres Smarty si le cache Smarty est activé ? Si oui, le désactiver. Sinon, peux-tu nous dire quel est ton hébergeur, s'il y a un cache sur l'hébergement ?

Pour la reconnexion, tu parles bien de CMSMS ? Si oui, utilises-tu TinyMCE ?

Ah, et autre question, tu es sur quelle version du CMS ?
Ouik - communication | outils numériques | design graphique
Répondre
#14
Bonjour Ouik,
Merci,
J'ai désactivé le cache Smarty.
Version : 2.2.3.1 (je n'ose pas mettre à jour, cela l'air compliqué et comme j'ai un comité lundi prochain je veux leur dire que le site fonctionne.
Je n'ai pas trouvé de TinyMCE mais microTiny...
Pour la galerie j'ai utilisé prettyPhotos. J'aurai préféré avoir directement le slide sans les vignettes, mais bon ça fonctionne.
http://crplausanne.ch/ si tu veux voir (galerie = inauguration)
Pour la connexion sur se site aussi un prob d'historique peut être mon navigateur ?
Encore merci,
FikoU
Répondre
#14
Bonjour Ouik,
Merci,
J'ai désactivé le cache Smarty.
Version : 2.2.3.1 (je n'ose pas mettre à jour, cela l'air compliqué et comme j'ai un comité lundi prochain je veux leur dire que le site fonctionne.
Je n'ai pas trouvé de TinyMCE mais microTiny...
Pour la galerie j'ai utilisé prettyPhotos. J'aurai préféré avoir directement le slide sans les vignettes, mais bon ça fonctionne.
http://crplausanne.ch/ si tu veux voir (galerie = inauguration)
Pour la connexion sur se site aussi un prob d'historique peut être mon navigateur ?
Encore merci,
FikoU
Répondre
#15
Pour la connexion sur le site, ça peut être tes cookies, éventuellement. Ceci dit, il y a eu beaucoup de corrections de bugs depuis la 2.2.3.1…
Ouik - communication | outils numériques | design graphique
Répondre
#15
Pour la connexion sur le site, ça peut être tes cookies, éventuellement. Ceci dit, il y a eu beaucoup de corrections de bugs depuis la 2.2.3.1…
Ouik - communication | outils numériques | design graphique
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)