Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[Resolu] Pb à la Mise à jour de FEU + mettre à jour WAMP-PHP 5.3
#26
En repassant sur php 5.2.11 j'ai récupéré phpmyadmin. Donc y priori j'ai un pb de config.
En php version 5.3.0 phpmyadmin donne une erreur lors du démarrage de la session..etc;

Je suis allé voir les fichiers logs dans le répertoire wamp/logs et le fichier appache_serveur_log me donne cette erreur :
"[Sat Aug 07 14:20:24 2010] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico "

C'est vrai je n'ai pas de fichier favicon.ico au niveau du répertoire www. Par contre j'en ai un dans un répertoire cms.
J'ai copié ce fichier dans wamp/www, refais le test même erreur?

Qu'en penses-tu ?
#27
re,

dans ce cas je précauniserait une désinstallation totale
Puis une réinstallation de la dernière version de wamp récupérée sur le site
!! mais attention sauvegarde bien les dossiers wamp\bin\mysql\mysql5xxx\data car les fichiers de bases de données sont ici (à remette à remettre après nouvelle installation) !!
J-C Etiemble Tutoriels v 2.2.x
#28
Je n'avais pas vu, mais dans le même fichier appache_serveur_log il ya d'autres warning de php :
PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.3/ext/php_mysql.dll' - La proc\xe9dure sp\xe9cifi\xe9e est introuvable.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.3/ext/php_mysqli.dll' - La proc\xe9dure sp\xe9cifi\xe9e est introuvable.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.3/ext/php_pdo_mysql.dll' - La proc\xe9dure sp\xe9cifi\xe9e est introuvable.\r\n in Unknown on line 0

Les dll incriminées sont bien dans le répertoire spécifié.
Quelles sont les raisons qui les empêchent d'être chargées?
#29
re,

>Quelles sont les raisons qui les empêchent d'être chargées?
heu surement soit un problème lors de ton installation du PHP 5.3.3 ou windows qui fait une cacanerveux Wink
J-C Etiemble Tutoriels v 2.2.x
#30
Voila où j'en suis :
J'ai désinstallé et réinstallé wamp serveur avec la dernière version téléchargée sur le site wamp, j'ai également téléchargé l'addon 5.2.11 et je l'ai installé.
J'ai installé la version 5.3.3 à partir du pack VC6 x86 Thread safe suivant la procédure que tu m'as indiquée dans une de tes réponses.
J'ai recopié le répertoire data dans wamp/bin/mysql/mysql5.1.36/

Les tests :
en php 5.2.11 j'accède bien aux bases de données avec phpmyadmin,
en php 5.3.0 j'accède également aux bases de données avec phpmyadmin,
en php 5.3.3 là j'ai le même message d'erreur à la connexion. J'ai scruté les logs mais je n'ai pas trouvé d'enregistrement d'erreur.

Quand à cmsms, à chaque projet j'ai la même réponse "500 intrenal server error"
Qu'est-ce qu'il me reste à faire pour fair fonctionner tout cela ?
#31
re,

>en php 5.2.11 j'accède bien aux bases de données avec phpmyadmin,
>en php 5.3.0 j'accède également aux bases de données avec phpmyadmin,
Donc tou est ok

>en php 5.3.3 là ..
tu as un truc qui bloque ne pas utiliser alors

>Quand à cmsms, à chaque projet j'ai la même réponse "500 intrenal server error"
si phpmyadmin fonctionne ton serveur et ok donc vérifie tes fichiers CMS, un htacces ou ...
en version 1.8.1 tout devrait être Ok
J-C Etiemble Tutoriels v 2.2.x
#32
Ok je vais viré le répertoire php5.3.3.

J'ai récupéré un projet en cms1.6.1 en enlevant le htaccess. mais il n'est pas très stable et il manque toute la navigation par les menus.
J'ai 2 autres projets l'un en cms1.7.1 et l'autre en cms1.8.1 issus de mes tentatives d'évolution de version. Pour ces 2 projets j'ai vérifié les htaccess, les config.php tout semble normal. mais j'ai toujours l'internal server error.

Que puis-je tenter d'autre ?
#33
re

mettre à la racine des 1.7.1 et 1.8.1 un fichier phpinfo.php
avec
<?
echo $DOCUMENT_ROOT;
phpinfo();?>
et tester avec cet URL tonsiteatoi/phpinfo.php
J-C Etiemble Tutoriels v 2.2.x
#34
J'ai fais ce test en php 5.2.11 puis en php5.3.0. Pour chaque version de php j'accède à la base de données avec phpmyadmin et chacune des versions de php phpinfo.php pour les 2 racine 1.7.1 et 1.8.1, le système me retoune la page 500 internal server error.

Qu'en penses-tu ?
#35
re,

>et chacune des versions de php phpinfo.php pour les 2 racine 1.7.1 et 1.8.1, le système me retoune la page 500 internal server error

A mon vais je verrais bien un problème de chemin de dossier www
vérifier dans le fichier wamp\scripts\config.inc.php
la variable $wwwDir = $c_installDir.'/www';
si ton www est bien dans le dossier wamp
-> sinon configurer $wwwDir = 'x:/mondossiercms'; si le dossier mondossiercms se trouve ailleurs

et modifier aussi le
\wamp\bin\apache\apache2.x.x\conf\httpd.conf -->
#DocumentRoot "x:/wamp/www/"
#DocumentRoot "x:/mondossiercms"

#<Directory "x:/wamp/www/">
<Directory "x:/mondossiercms">
J-C Etiemble Tutoriels v 2.2.x
#36
J'ai bien le répertoire www dans C:\wamp.

Dans le fichier wamp\scripts\config.inc.php, la variable $wwwDir est bien égale à $c_installDir.'/www'.
Dans le fichier \wamp\bin\apache\apache2.x.x\conf\httpd.conf, la variable DocumentRoot à bien la valeur "x:/wamp/www/" et <Directory "x:/wamp/www/"> est bien configuré.
#37
re,

> la variable DocumentRoot à bien la valeur "x:/wamp/www/" et <Directory "x:/wamp/www/"> est bien configuré.

et tes cms sont bien dans x:/wamp/www/ ?
si oui je ne sais pas
J-C Etiemble Tutoriels v 2.2.x
#38
Oui je confirme mes cms sont bien dans C:/wamp/www
Dans mes début avec cms j'ai fais 2 projets en cms 1.6.6. Avec php5.2.11 ces 2 projets fonctionnent (enfin presque pour l'un, j'ai perdu mes menus) dans cette architecture.

Si toi tu ne sais pas, qu'est-ce que je vais pouvoir faire ? repartir avec une installation complète de cms en version 1.8.1 ? dans ce cas comment ne pas perdre mes données ?
#39
Oups...

Je suis vraiment nul comme boulet je me pose là. J'avais seulement oublié de charger le module rewriting après l'installation de wampserver.
Du coup j'accède au site de mes 2 projets en 1.7.1 et 1.8.1. Bon ce n'est pas encore la panacée mais je vais regarder cela de plus près je pense qu'il y a des pb de versions de modules.
Pardon de t'avoir fais perdre du temps.

Je reprends contacts si je ne m'en sors pas tout seul.

Merci de ta dispo
Cordialement
Alain
#40
Bon ce coup là c'est presque tout bon. j'ai mis à jour tous le modules et j'ai retrouvé toutes mes fonctionnalités sauf une : la connexion avec FrontEndUser 1.11.

J'ai créé mes utilisateurs et pas moyen de me connecter sur le site. Après validation de la saisie par le bouton "submit" il boucle sur la page de connexion sans aucun message et la table module_feu_loggedin reste vide.

Bon je vais chercher. Je vais modifier le titre de mon premier post pour le marquer en résolu, et si je ne trouve pas la solution avec FEU j'ouvrirai un nouveau post au niveau du forum modules.

Merci encore de ton aide
Cordialement

Alain


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)