[Resolu] Pb à la Mise à jour de FEU + mettre à jour WAMP-PHP 5.3

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Citation :#~~~~~ NE PAS SUPPRIMER CE BLOC ~~~~~
#~ Version du CMS: 1.7.1
#~ Nom de l'hébergeur : local
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 1.7.1
#~ Installed Modules:
#~ * CMSMailer: 2.0
#~ * FileManager: 1.0.2
#~ * MenuManager: 1.6.3
#~ * ModuleManager: 1.3.3
#~ * News: 2.10.5
#~ * nuSOAP: 1.0.1
#~ * Printing: 1.0.4
#~ * Search: 1.6.3
#~ * ThemeManager: 1.1.1
#~ * TinyMCE: 2.7.0
#~ * Album: 0.9.3
#~ * DownCnt: 1.0.0
#~ * FormBuilder: 0.6.2
#~ * Captcha: 0.4.1
#~ * CGExtensions: 1.19
#~ * FrontEndUsers: 1.10.1
#~ * CustomContent: 1.5.3
#~ Config Information:
#~ * php_memory_limit:
#~ * process_whole_template: false
#~ * max_upload_size: 10000000
#~ * default_upload_permission: 664
#~ * assume_mod_rewrite: true
#~ * page_extension:
#~ * internal_pretty_urls: false
#~ * use_hierarchy: true
#~ Php Information:
#~ * phpversion: 5.2.11
#~ * md5_function: On (Vrai)
#~ * gd_version: 2
#~ * tempnam_function: On (Vrai)
#~ * magic_quotes_runtime: Off (Faux)
#~ * E_STRICT: 0
#~ * memory_limit: 128M
#~ * max_execution_time: 60
#~ * safe_mode: Off (Faux)
#~ * session_save_path: c:/wamp/tmp (0777)
#~ * session_use_cookies: On (Vrai)
#~ Server Information:
#~ * Server Api: apache2handler
#~ * Server Db Type: MySQL (mysql)
#~ * Server Db Version: 5.1.36
#~ ----------------------------------------------
#~~~~~ NE PAS SUPPRIMER CE BLOC ~~~~~
Bonjour,

J'ai mis à jour ma version de CMS, je suis passé de la v 1.6.6 à la v 1.7.1. J'ai également voulu mettre à jour les modules additionnels que j'avais installés et notamment FrontEndUsers.
Je pense que je n'ai pas utilisé la bonne procédure car j'ai perdu mes 3 utilisateurs que j'avais et la mise en page des formulaires. J'ai désinstallé FEU, puis j'ai supprimé le répertoire FEU dans Modules et j'y ai recopier à la place le le répertoire FEU issu de l'archive à la dernière version. Enfin j'ai réinstallé le module.

Donc j'ai recréé mes utilisateurs mais lorsque je vais sur ma page d'identifiaction pour me connecter sur le site, il me mets les lignes suivantes :

"Strict Standards: Non-static method Events::SendEvent() should not be called statically in C:\wamp\www\randokerlouan\plugins\prefilter.precompilefunc.php on line 84

Strict Standards: Non-static method Events::ListEventHandlers() should not be called statically in C:\wamp\www\randokerlouan\lib\classes\class.events.inc.php on line 104

Strict Standards: Non-static method Events::SendEvent() should not be called statically in C:\wamp\www\randokerlouan\plugins\postfilter.postcompilefunc.php on line 84

Strict Standards: Non-static method Events::ListEventHandlers() should not be called statically in C:\wamp\www\randokerlouan\lib\classes\class.events.inc.php on line 104

Strict Standards: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting,
the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning,
you most likely misspelled the timezone identifier. We selected 'Europe/Paris' for '2.0/DST' instead in C:\wamp\www\randokerlouan\lib\smarty\Smarty_Compiler.class.php on line 400

"
et de plus je ne peux pas me connecter. A part l'erreur de procédure qu'est-ce que je n'ai pas fais pour que cela fonctionne ?

De façon plus générale y a t'il une procédure pour mettre à jour un module ?

Merci d'avance pour vos réponse

Alain
#1
Citation :#~~~~~ NE PAS SUPPRIMER CE BLOC ~~~~~
#~ Version du CMS: 1.7.1
#~ Nom de l'hébergeur : local
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 1.7.1
#~ Installed Modules:
#~ * CMSMailer: 2.0
#~ * FileManager: 1.0.2
#~ * MenuManager: 1.6.3
#~ * ModuleManager: 1.3.3
#~ * News: 2.10.5
#~ * nuSOAP: 1.0.1
#~ * Printing: 1.0.4
#~ * Search: 1.6.3
#~ * ThemeManager: 1.1.1
#~ * TinyMCE: 2.7.0
#~ * Album: 0.9.3
#~ * DownCnt: 1.0.0
#~ * FormBuilder: 0.6.2
#~ * Captcha: 0.4.1
#~ * CGExtensions: 1.19
#~ * FrontEndUsers: 1.10.1
#~ * CustomContent: 1.5.3
#~ Config Information:
#~ * php_memory_limit:
#~ * process_whole_template: false
#~ * max_upload_size: 10000000
#~ * default_upload_permission: 664
#~ * assume_mod_rewrite: true
#~ * page_extension:
#~ * internal_pretty_urls: false
#~ * use_hierarchy: true
#~ Php Information:
#~ * phpversion: 5.2.11
#~ * md5_function: On (Vrai)
#~ * gd_version: 2
#~ * tempnam_function: On (Vrai)
#~ * magic_quotes_runtime: Off (Faux)
#~ * E_STRICT: 0
#~ * memory_limit: 128M
#~ * max_execution_time: 60
#~ * safe_mode: Off (Faux)
#~ * session_save_path: c:/wamp/tmp (0777)
#~ * session_use_cookies: On (Vrai)
#~ Server Information:
#~ * Server Api: apache2handler
#~ * Server Db Type: MySQL (mysql)
#~ * Server Db Version: 5.1.36
#~ ----------------------------------------------
#~~~~~ NE PAS SUPPRIMER CE BLOC ~~~~~
Bonjour,

J'ai mis à jour ma version de CMS, je suis passé de la v 1.6.6 à la v 1.7.1. J'ai également voulu mettre à jour les modules additionnels que j'avais installés et notamment FrontEndUsers.
Je pense que je n'ai pas utilisé la bonne procédure car j'ai perdu mes 3 utilisateurs que j'avais et la mise en page des formulaires. J'ai désinstallé FEU, puis j'ai supprimé le répertoire FEU dans Modules et j'y ai recopier à la place le le répertoire FEU issu de l'archive à la dernière version. Enfin j'ai réinstallé le module.

Donc j'ai recréé mes utilisateurs mais lorsque je vais sur ma page d'identifiaction pour me connecter sur le site, il me mets les lignes suivantes :

"Strict Standards: Non-static method Events::SendEvent() should not be called statically in C:\wamp\www\randokerlouan\plugins\prefilter.precompilefunc.php on line 84

Strict Standards: Non-static method Events::ListEventHandlers() should not be called statically in C:\wamp\www\randokerlouan\lib\classes\class.events.inc.php on line 104

Strict Standards: Non-static method Events::SendEvent() should not be called statically in C:\wamp\www\randokerlouan\plugins\postfilter.postcompilefunc.php on line 84

Strict Standards: Non-static method Events::ListEventHandlers() should not be called statically in C:\wamp\www\randokerlouan\lib\classes\class.events.inc.php on line 104

Strict Standards: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting,
the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning,
you most likely misspelled the timezone identifier. We selected 'Europe/Paris' for '2.0/DST' instead in C:\wamp\www\randokerlouan\lib\smarty\Smarty_Compiler.class.php on line 400

"
et de plus je ne peux pas me connecter. A part l'erreur de procédure qu'est-ce que je n'ai pas fais pour que cela fonctionne ?

De façon plus générale y a t'il une procédure pour mettre à jour un module ?

Merci d'avance pour vos réponse

Alain
#2
re,

>et de plus je ne peux pas me connecter
Réinjecter sauvegarde de la base de données et des fichiers et passer en 1.6.8

Ensuite faire des tests en 1.8.1
Attention à la configuration serveur en PHP 5.x
Pour version 1.7.x (la configuration minimale requise est la version PHP 5.2.4 bien que nous recommandons PHP 5.2.12 )

>De façon plus générale y a t'il une procédure pour mettre à jour un module ?
1- lire le wiki ( ... Attention !! certains modules ont des dépendances )
http://wiki.cmsmadesimple.org/index.php/...Modules/fr
ET d'abord mettre à jour le cms à la dernière version avant de faire une mise à jour du module Et vérifier la compatibilité module/CMS

FEU 1.10.1 fonctionne sans problème avec une version cmsms1.8.1 (attention il faut CGExtensions depuis FEU 1.9 par exemple)

>Nom de l'hébergeur : local
mettre a jour WAMP en version PHP 5.3.1 mini
http://www.wampserver.com/addons_php.php
ou php5.3.2 et mieux PHP 5.3.3
http://www.cmsmadesimple.fr/blog/index.p...Wampserver
J-C Etiemble Tutoriels v 2.2.x
#2
re,

>et de plus je ne peux pas me connecter
Réinjecter sauvegarde de la base de données et des fichiers et passer en 1.6.8

Ensuite faire des tests en 1.8.1
Attention à la configuration serveur en PHP 5.x
Pour version 1.7.x (la configuration minimale requise est la version PHP 5.2.4 bien que nous recommandons PHP 5.2.12 )

>De façon plus générale y a t'il une procédure pour mettre à jour un module ?
1- lire le wiki ( ... Attention !! certains modules ont des dépendances )
http://wiki.cmsmadesimple.org/index.php/...Modules/fr
ET d'abord mettre à jour le cms à la dernière version avant de faire une mise à jour du module Et vérifier la compatibilité module/CMS

FEU 1.10.1 fonctionne sans problème avec une version cmsms1.8.1 (attention il faut CGExtensions depuis FEU 1.9 par exemple)

>Nom de l'hébergeur : local
mettre a jour WAMP en version PHP 5.3.1 mini
http://www.wampserver.com/addons_php.php
ou php5.3.2 et mieux PHP 5.3.3
http://www.cmsmadesimple.fr/blog/index.p...Wampserver
J-C Etiemble Tutoriels v 2.2.x
#3
Bonjour Jce,

J'ai téléchargé php5.3.3 comme indiqué sur le tuto du blog.
j'ai basculé de la version php5.2.11 à la version php5.3.0.
j'ai copié et mis à jour les fichier php.ini et phpForAppache.ini de php5.2.11 dans le répertoire php5.3.3 puis j'ai validé la version php5.3.3.

Je lance Wampserveur et lorsque je veux aller sur localhost la connexion échoue. Aurais-je oublé quelque chose ?

Merci d'avance pour ton aide

Cordialement

Alain
#3
Bonjour Jce,

J'ai téléchargé php5.3.3 comme indiqué sur le tuto du blog.
j'ai basculé de la version php5.2.11 à la version php5.3.0.
j'ai copié et mis à jour les fichier php.ini et phpForAppache.ini de php5.2.11 dans le répertoire php5.3.3 puis j'ai validé la version php5.3.3.

Je lance Wampserveur et lorsque je veux aller sur localhost la connexion échoue. Aurais-je oublé quelque chose ?

Merci d'avance pour ton aide

Cordialement

Alain
#4
Oups je n'avais pas fini,

J'ai une dernière question au sujet de la compatibilité des modules et de la version Cms , j'ai chercher sur le wiki sur CMS MADE SIMPLE FORGE je n'ai pas trouvé de rubrique sur le sujet.
Aurais-je mal cherché ?

Cordialement

Alain
#4
Oups je n'avais pas fini,

J'ai une dernière question au sujet de la compatibilité des modules et de la version Cms , j'ai chercher sur le wiki sur CMS MADE SIMPLE FORGE je n'ai pas trouvé de rubrique sur le sujet.
Aurais-je mal cherché ?

Cordialement

Alain
#5
re,

>Oups je n'avais pas fini,
Donc c'est tout bon alors ?

>sur le wiki sur CMS MADE SIMPLE FORGE je n'ai pas trouvé de rubrique sur le sujet
>Aurais-je mal cherché ?
sur le Wiki y a rien ...
Mais il faut lire d'abord les changelog des versions modules sur la forge dans "Download Section" Et aussi dans l'archive du module

Ma démonstration
-- c'est de regarder attentivement le fichier "maitre du module" en général
xxx.module.php (exemple FrontEndUsers.module.php 1.10.1 pour notre cas ICI)
- chercher la fonction MinimumCMSVersion() ICI 1.7.1
- chercher la fonction GetDependencies() ICI
CMSMailer' => '1.73.9' et 'CGExtensions' => '1.19'
Donc on peut dire que le modue est compatbile PHP 5.3 puisque il fonctionne avec cmsms 1.7.1,
MAIS CMSMailer' => '1.73.9' N'est PAS compatible 5.3 il faut au mini CMSMailer 2.0 (version livré avec la dernière version 1.7.1
Et CGExtensions' => '1.19 sortie le 2010-06-25 et coder par calguy1000 est "garanti"
-- Donc conclusion Ouf avec cmsms 1.7.1 + FEU 1.10.1 c'est bon Wink
Voila c'est pas trop compliqué mais c'est garanti 99%
J-C Etiemble Tutoriels v 2.2.x
#5
re,

>Oups je n'avais pas fini,
Donc c'est tout bon alors ?

>sur le wiki sur CMS MADE SIMPLE FORGE je n'ai pas trouvé de rubrique sur le sujet
>Aurais-je mal cherché ?
sur le Wiki y a rien ...
Mais il faut lire d'abord les changelog des versions modules sur la forge dans "Download Section" Et aussi dans l'archive du module

Ma démonstration
-- c'est de regarder attentivement le fichier "maitre du module" en général
xxx.module.php (exemple FrontEndUsers.module.php 1.10.1 pour notre cas ICI)
- chercher la fonction MinimumCMSVersion() ICI 1.7.1
- chercher la fonction GetDependencies() ICI
CMSMailer' => '1.73.9' et 'CGExtensions' => '1.19'
Donc on peut dire que le modue est compatbile PHP 5.3 puisque il fonctionne avec cmsms 1.7.1,
MAIS CMSMailer' => '1.73.9' N'est PAS compatible 5.3 il faut au mini CMSMailer 2.0 (version livré avec la dernière version 1.7.1
Et CGExtensions' => '1.19 sortie le 2010-06-25 et coder par calguy1000 est "garanti"
-- Donc conclusion Ouf avec cmsms 1.7.1 + FEU 1.10.1 c'est bon Wink
Voila c'est pas trop compliqué mais c'est garanti 99%
J-C Etiemble Tutoriels v 2.2.x
#6
Merci de ces précisions, non ce n'est pas tout bon. J'ai toujours ce pb d'échec à la connexion sur wampseveur si mets en œuvre la version 5.3.3 de php.

Par contre si je reviens en arrière avec php5.2.11 je retrouve ma connexion à wamp et je vois pas où ça bug
#6
Merci de ces précisions, non ce n'est pas tout bon. J'ai toujours ce pb d'échec à la connexion sur wampseveur si mets en œuvre la version 5.3.3 de php.

Par contre si je reviens en arrière avec php5.2.11 je retrouve ma connexion à wamp et je vois pas où ça bug
#7
re,

> J'ai toujours ce pb d'échec à la connexion sur wampseveur si mets en œuvre la version 5.3.3 de php.

je viens de passer en PHP5.3
j'ai suivi la manip indiquée
cela donne
Citation :Récupérer la version 5.3.3 sur le site php.net
Il faut télécharger le pack VC6 x86 Thread Safe en zip , http://windows.php.net/download/
Nom du fichier php-5.3.3-Win32-VC6-x86.zip
On supposera que la version actuelle est la version WampServer 2.0i (11/07/09) avec PHP 5.3.0
Sur votre disque dur, dans le dossier où WAMP a été installé,
- Créer un dossier wamp\bin\php\php5.3.3
- Dézipper l'archive (sauf /extra) dans ce dossier wamp\bin\php\php5.3.3
Ensuite,
Depuis le dossier wamp\bin\php\php5.3.0
Copier les fichiers
1 wampserver.conf : de php5.3.0 vers php5.3.3
2 php.ini : de php5.3.0 vers php5.3.3
3 phpForApache.ini : de php5.3.0 vers php5.3.3
4 Remplacer dans php.ini:
extension_dir = "E:/Dev_web/wamp/bin/php/php5.3.0/ext/"
par
extension_dir = "E:/Dev_web/wamp/bin/php/php5.3.3/ext/"
5 Remplacer dans phpForApache.ini
extension_dir = "E:/Dev_web/wamp/bin/php/php5.3.0/ext/"
par
extension_dir = "E:/Dev_web/wamp/bin/php/php5.3.3/ext/"
Lancer Wampserver
Icone Wampserver, PHP, Version, Valider 5.3.3 TEST OK
J-C Etiemble Tutoriels v 2.2.x
#7
re,

> J'ai toujours ce pb d'échec à la connexion sur wampseveur si mets en œuvre la version 5.3.3 de php.

je viens de passer en PHP5.3
j'ai suivi la manip indiquée
cela donne
Citation :Récupérer la version 5.3.3 sur le site php.net
Il faut télécharger le pack VC6 x86 Thread Safe en zip , http://windows.php.net/download/
Nom du fichier php-5.3.3-Win32-VC6-x86.zip
On supposera que la version actuelle est la version WampServer 2.0i (11/07/09) avec PHP 5.3.0
Sur votre disque dur, dans le dossier où WAMP a été installé,
- Créer un dossier wamp\bin\php\php5.3.3
- Dézipper l'archive (sauf /extra) dans ce dossier wamp\bin\php\php5.3.3
Ensuite,
Depuis le dossier wamp\bin\php\php5.3.0
Copier les fichiers
1 wampserver.conf : de php5.3.0 vers php5.3.3
2 php.ini : de php5.3.0 vers php5.3.3
3 phpForApache.ini : de php5.3.0 vers php5.3.3
4 Remplacer dans php.ini:
extension_dir = "E:/Dev_web/wamp/bin/php/php5.3.0/ext/"
par
extension_dir = "E:/Dev_web/wamp/bin/php/php5.3.3/ext/"
5 Remplacer dans phpForApache.ini
extension_dir = "E:/Dev_web/wamp/bin/php/php5.3.0/ext/"
par
extension_dir = "E:/Dev_web/wamp/bin/php/php5.3.3/ext/"
Lancer Wampserver
Icone Wampserver, PHP, Version, Valider 5.3.3 TEST OK
J-C Etiemble Tutoriels v 2.2.x
#8
Bonjour,

Enfin je vous retrouve, depuis dimanche j'ai tenté d'accéder tous les jours au forum sans succès quasiment jusqu'à jeudi.

Bon j'ai pu passé en php 5.3.3, je pense que je me suis planté de fichier lors du chargement de la version j'ai pris le premier "non thread safe".

Je vais regarder la compatibilité des versions et mettre à jour CMS.

Je te tiens au courant

Merci de ton aide

cordialement
Alain
#8
Bonjour,

Enfin je vous retrouve, depuis dimanche j'ai tenté d'accéder tous les jours au forum sans succès quasiment jusqu'à jeudi.

Bon j'ai pu passé en php 5.3.3, je pense que je me suis planté de fichier lors du chargement de la version j'ai pris le premier "non thread safe".

Je vais regarder la compatibilité des versions et mettre à jour CMS.

Je te tiens au courant

Merci de ton aide

cordialement
Alain
#9
Résultats des courses : lorsque je passe en php 5.3.3, je n'accède plus à la page d'accueil du site ni à l'admin de CMS. si je bascule en php 5.3.0 j'accède à la page d'accueil du site, et aux autres biensiur, et à l'admin de CMS mais j'ai toujours le pb à l'origine de cette discussion à savoir:

les messages suivant sur la page d'identification
""Strict Standards: Non-static method Events::SendEvent() should not be called statically in C:\wamp\www\randokerlouan\plugins\prefilter.precompilefunc.php on line 84

Strict Standards: Non-static method Events::ListEventHandlers() should not be called statically in C:\wamp\www\randokerlouan\lib\classes\class.events.inc.php on line 104

Strict Standards: Non-static method Events::SendEvent() should not be called statically in C:\wamp\www\randokerlouan\plugins\postfilter.postcompilefunc.php on line 84"

J'avoue que je m'y perds un peu.

Cordialement

Alain
#9
Résultats des courses : lorsque je passe en php 5.3.3, je n'accède plus à la page d'accueil du site ni à l'admin de CMS. si je bascule en php 5.3.0 j'accède à la page d'accueil du site, et aux autres biensiur, et à l'admin de CMS mais j'ai toujours le pb à l'origine de cette discussion à savoir:

les messages suivant sur la page d'identification
""Strict Standards: Non-static method Events::SendEvent() should not be called statically in C:\wamp\www\randokerlouan\plugins\prefilter.precompilefunc.php on line 84

Strict Standards: Non-static method Events::ListEventHandlers() should not be called statically in C:\wamp\www\randokerlouan\lib\classes\class.events.inc.php on line 104

Strict Standards: Non-static method Events::SendEvent() should not be called statically in C:\wamp\www\randokerlouan\plugins\postfilter.postcompilefunc.php on line 84"

J'avoue que je m'y perds un peu.

Cordialement

Alain
#10
re,

La configuration de ton php.ini doit être mode production
error_reporting =E_ALL & ~E_DEPRECATED
Sinon tu vas avoir toutes les erreurs
J-C Etiemble Tutoriels v 2.2.x
#10
re,

La configuration de ton php.ini doit être mode production
error_reporting =E_ALL & ~E_DEPRECATED
Sinon tu vas avoir toutes les erreurs
J-C Etiemble Tutoriels v 2.2.x
#11
Bon là encore pas d'effet que j'ai dans le php.in error_reporting = E_ALL ou = E_ALL & ~E_DEPRECATED, cela ne change rein j'ai toujours la série de messages sur la page d'identification de FEU.

Le php.ini à modifier est bien celui qui est dans le répertoire wamp/bin/php/php5.3.0 ?

Cordialement

Alain
#11
Bon là encore pas d'effet que j'ai dans le php.in error_reporting = E_ALL ou = E_ALL & ~E_DEPRECATED, cela ne change rein j'ai toujours la série de messages sur la page d'identification de FEU.

Le php.ini à modifier est bien celui qui est dans le répertoire wamp/bin/php/php5.3.0 ?

Cordialement

Alain
#12
re,

>Le php.ini à modifier est bien celui qui est dans le répertoire wamp/bin/php/php5.3.0 ?
Non il faut se servir du "TrayIcon" Wampserver dans la zone de notification en bas à droite
Clic gauche -> PHp-> Php.ini -> cela ouvre le fichier php.ini et donc les modifications ont à faire
Voir http://www.postimage.org/image.php?v=aV4pzhS
la, puis sauver le fichier .... et Redémarrer les services

Nota : je modifie le titre du 1er post
J-C Etiemble Tutoriels v 2.2.x
#12
re,

>Le php.ini à modifier est bien celui qui est dans le répertoire wamp/bin/php/php5.3.0 ?
Non il faut se servir du "TrayIcon" Wampserver dans la zone de notification en bas à droite
Clic gauche -> PHp-> Php.ini -> cela ouvre le fichier php.ini et donc les modifications ont à faire
Voir http://www.postimage.org/image.php?v=aV4pzhS
la, puis sauver le fichier .... et Redémarrer les services

Nota : je modifie le titre du 1er post
J-C Etiemble Tutoriels v 2.2.x
#13
Rien n'y fait. Après modification du error_reporting dans le php.ini, j'ai toujours cette série de messages.

Alain
#13
Rien n'y fait. Après modification du error_reporting dans le php.ini, j'ai toujours cette série de messages.

Alain
#14
version du cmsms : 1.8.1 ?
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT
#14
version du cmsms : 1.8.1 ?
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT
#15
re,


>Rien n'y fait. Après modification du error_reporting dans le php.ini, j'ai toujours cette série de messages.
Peut être un problème de ton module ou ...

Mon test en PHP 5.3.3 en CMSms 1.8.1 + FrontEndUsers 1.11 = OK

>error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT
Non dans ce cas Le paramètre E_DEPRECATED => activé = warning en PHP 5.3.2 ou 5.3.3

error_reporting =E_ALL & ~E_DEPRECATED
c'est suffisant c'est la Production Value de PHP
J-C Etiemble Tutoriels v 2.2.x
#15
re,


>Rien n'y fait. Après modification du error_reporting dans le php.ini, j'ai toujours cette série de messages.
Peut être un problème de ton module ou ...

Mon test en PHP 5.3.3 en CMSms 1.8.1 + FrontEndUsers 1.11 = OK

>error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT
Non dans ce cas Le paramètre E_DEPRECATED => activé = warning en PHP 5.3.2 ou 5.3.3

error_reporting =E_ALL & ~E_DEPRECATED
c'est suffisant c'est la Production Value de PHP
J-C Etiemble Tutoriels v 2.2.x
#16
Bonjour,

j'ai voulu faire le test en cms1.8.1 php5.3.3 et FEU1.11. Donc j'ai pris la doc chapitre 6.1 et j'ai suivi pas à pas ce qui est marqué dans la doc.
Lorsque je lance la mise à jour, j'ai la page de sélection de la langue, je choisi fr_FR, submit et j'obtiens une page blanche et je ne peux aller plus loin. L'url à été mise à jour : http://localhost/randokerlouan/install/upgrade.php?sessiontest=1.

Je sais pas ce qui coince ?

Merci pour votre aide
Alain
#16
Bonjour,

j'ai voulu faire le test en cms1.8.1 php5.3.3 et FEU1.11. Donc j'ai pris la doc chapitre 6.1 et j'ai suivi pas à pas ce qui est marqué dans la doc.
Lorsque je lance la mise à jour, j'ai la page de sélection de la langue, je choisi fr_FR, submit et j'obtiens une page blanche et je ne peux aller plus loin. L'url à été mise à jour : http://localhost/randokerlouan/install/upgrade.php?sessiontest=1.

Je sais pas ce qui coince ?

Merci pour votre aide
Alain
#17
J'ai trouvé ce qui n'allait pas, un espace en trop dans la directive error_reporting du php.ini.

Je peux avancer maintenant sur mon installation.

Je vous tiens au courant de mes echecs.
Cordialement

Alain
#17
J'ai trouvé ce qui n'allait pas, un espace en trop dans la directive error_reporting du php.ini.

Je peux avancer maintenant sur mon installation.

Je vous tiens au courant de mes echecs.
Cordialement

Alain
#18
Bonjour,

En parlant d'échecs, celui en est un avec un grand E.

J'ai avancé l'installation jusqu'à l'étape 1 de contrôle avec le checksum. Le résultat : tout était au rouge. j'ai donc abandonné et entamé des recherche sur les permissions d'accès sur la présence des répertoires etc tout ok je relance l'install et là plus rien.

J'ai essayé de relancer l'ancien site en basculant sur php5.3.0 avant. J'obtiens le message ERROR: The CGExtension modules could not be found. Alaors que je l'avais installé. De plus je ne peut pas accéder à l'admin de l'ancien site.

Je suis perdu et je ne sais plus quoi faire. Vous avez une idée ?

Merci d'avance

Alain
#18
Bonjour,

En parlant d'échecs, celui en est un avec un grand E.

J'ai avancé l'installation jusqu'à l'étape 1 de contrôle avec le checksum. Le résultat : tout était au rouge. j'ai donc abandonné et entamé des recherche sur les permissions d'accès sur la présence des répertoires etc tout ok je relance l'install et là plus rien.

J'ai essayé de relancer l'ancien site en basculant sur php5.3.0 avant. J'obtiens le message ERROR: The CGExtension modules could not be found. Alaors que je l'avais installé. De plus je ne peut pas accéder à l'admin de l'ancien site.

Je suis perdu et je ne sais plus quoi faire. Vous avez une idée ?

Merci d'avance

Alain
#19
re,

>contrôle avec le checksum
ne pas utiliser mais prendre filezilla en FTP c'est + sur

>J'obtiens le message ERROR: The CGExtension modules could not be found
ben Wink il faut simplement envoyer le module CGExtension dans le dossier module
J-C Etiemble Tutoriels v 2.2.x
#19
re,

>contrôle avec le checksum
ne pas utiliser mais prendre filezilla en FTP c'est + sur

>J'obtiens le message ERROR: The CGExtension modules could not be found
ben Wink il faut simplement envoyer le module CGExtension dans le dossier module
J-C Etiemble Tutoriels v 2.2.x
#20
J'ai retrouvé mon ancien site, ce n'était qu'une question de mise à jour de chemins dans le config.php du répertoire de l'ancien site. Par contre j'ai perdu la navigation, je n'ai plus les menus et j'ai également perdu les news.
Dans l'admin de l'ancien site, le module news est à la version 2.10.6, dans le répertoire modules la version que j'ai trouvée dans le fichier News.modules.php est 2.10.5.
J'ai regardé dans la forge ce qui était dispo au téléchargement c'est la version 2.8.3 ?????

Je voudrai revenir à la situation de mon premier poste et repartir sur une nouvelle mise à jour de cmsms en version 1.8.1. Que dois-je faire pour désinstaller le version 1.8.1 qui ne fonctionne pas ?

Merci de ton aide

Alain
#20
J'ai retrouvé mon ancien site, ce n'était qu'une question de mise à jour de chemins dans le config.php du répertoire de l'ancien site. Par contre j'ai perdu la navigation, je n'ai plus les menus et j'ai également perdu les news.
Dans l'admin de l'ancien site, le module news est à la version 2.10.6, dans le répertoire modules la version que j'ai trouvée dans le fichier News.modules.php est 2.10.5.
J'ai regardé dans la forge ce qui était dispo au téléchargement c'est la version 2.8.3 ?????

Je voudrai revenir à la situation de mon premier poste et repartir sur une nouvelle mise à jour de cmsms en version 1.8.1. Que dois-je faire pour désinstaller le version 1.8.1 qui ne fonctionne pas ?

Merci de ton aide

Alain
#21
re,

>Je voudrai revenir à la situation de mon premier poste et repartir sur une nouvelle mise à jour de cmsms en version 1.8.1.

utiliser la méthode
1- Faire la Mise à jour "complète"
http://www.cmsmadesimple.fr/forum/viewtopic.php?id=558
J-C Etiemble Tutoriels v 2.2.x
#21
re,

>Je voudrai revenir à la situation de mon premier poste et repartir sur une nouvelle mise à jour de cmsms en version 1.8.1.

utiliser la méthode
1- Faire la Mise à jour "complète"
http://www.cmsmadesimple.fr/forum/viewtopic.php?id=558
J-C Etiemble Tutoriels v 2.2.x
#22
Bon je veux bien utiliser cette méthode mais je ne peux même plus lancer phpmyadmin pour faire une sauvegarde de la base de données, et ce que sois en version 5.2.11 ou 5.3.0 or 5.3.3 de php.

C'est usant de ne rien pouvoir faire.
#22
Bon je veux bien utiliser cette méthode mais je ne peux même plus lancer phpmyadmin pour faire une sauvegarde de la base de données, et ce que sois en version 5.2.11 ou 5.3.0 or 5.3.3 de php.

C'est usant de ne rien pouvoir faire.
#23
re,

>mais je ne peux même plus lancer phpmyadmin
il n'y a aucun rapport en la version PHP et phpmyadmin
J-C Etiemble Tutoriels v 2.2.x
#23
re,

>mais je ne peux même plus lancer phpmyadmin
il n'y a aucun rapport en la version PHP et phpmyadmin
J-C Etiemble Tutoriels v 2.2.x
#24
Que peut-il bien se passer pour que phpmyadmin ne fonctionne plus ?
#24
Que peut-il bien se passer pour que phpmyadmin ne fonctionne plus ?
#25
re,

si tu es en local avec wamp repasse avec une version PHP 5.2.11 et vérifie si phpmyadmin fonctionne
Si oui tu as un problème de configuration
*Sinon tu est bon pour une désinstallation-réinstallation mais attention sauvegarde bien les dossiers wamp\bin\mysql\mysql5xxx\data car les fichiers de bases de données sont ici (a remette à remettre après nouvelle installation)
J-C Etiemble Tutoriels v 2.2.x
#25
re,

si tu es en local avec wamp repasse avec une version PHP 5.2.11 et vérifie si phpmyadmin fonctionne
Si oui tu as un problème de configuration
*Sinon tu est bon pour une désinstallation-réinstallation mais attention sauvegarde bien les dossiers wamp\bin\mysql\mysql5xxx\data car les fichiers de bases de données sont ici (a remette à remettre après nouvelle installation)
J-C Etiemble Tutoriels v 2.2.x


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)