Version php pour passer en 2.2.12

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Bonjour,

J'ai voulu mettre à jour la version cms du site xaviergavaud.fr, et je me suis apperçu que la version php actuelle est la 5.6.27. J'ai demandé à l'hebergeur (firstheberge) si je pouvais passer en php7.2.1 comme je l'ai lu quelque part dans le forum notamment pour passer à la version 1.62.6 du module CGextensions.

La réponse est non il me propose d'utiliser la version php 7.0 les autre version ne sont pas supportées. Donc ma question est  comment rendre compatible tout ça ?
Avec CmsMS 2.2.12 et php 7.0, quelle version de CGextensions dois-je utiliser ?

Merci d'avance pour votre réponse

Cordialement

Alain
Répondre
#1
Bonjour,

J'ai voulu mettre à jour la version cms du site xaviergavaud.fr, et je me suis apperçu que la version php actuelle est la 5.6.27. J'ai demandé à l'hebergeur (firstheberge) si je pouvais passer en php7.2.1 comme je l'ai lu quelque part dans le forum notamment pour passer à la version 1.62.6 du module CGextensions.

La réponse est non il me propose d'utiliser la version php 7.0 les autre version ne sont pas supportées. Donc ma question est  comment rendre compatible tout ça ?
Avec CmsMS 2.2.12 et php 7.0, quelle version de CGextensions dois-je utiliser ?

Merci d'avance pour votre réponse

Cordialement

Alain
Répondre
#2
Citation :La réponse est non il me propose d'utiliser la version php 7.0 les autre version ne sont pas supportées.
PHP 7.0 est fini depuis le 10 Jan 2019 Wink  https://www.php.net/eol.php
les versions supportées https://secure.php.net/supported-versions.php
- PHP 7.1 c'est fini le 1/12/19
Donc c'est PHP7.2 ou PHP 7.3 actuellement
et fin novembre ce sera PHP 7.4
Citation :Donc ma question est  comment rendre compatible tout ça ?
il est indiqué sur le forum  Modules, Tags
26/04/2019 - Attention la version 1.62.6 OBLIGE d'avoir au moins PHP 7.2.1
J-C Etiemble Tutoriels v 2.2.x
Répondre
#2
Citation :La réponse est non il me propose d'utiliser la version php 7.0 les autre version ne sont pas supportées.
PHP 7.0 est fini depuis le 10 Jan 2019 Wink  https://www.php.net/eol.php
les versions supportées https://secure.php.net/supported-versions.php
- PHP 7.1 c'est fini le 1/12/19
Donc c'est PHP7.2 ou PHP 7.3 actuellement
et fin novembre ce sera PHP 7.4
Citation :Donc ma question est  comment rendre compatible tout ça ?
il est indiqué sur le forum  Modules, Tags
26/04/2019 - Attention la version 1.62.6 OBLIGE d'avoir au moins PHP 7.2.1
J-C Etiemble Tutoriels v 2.2.x
Répondre
#3
Bonjour
je relance ce poste car Firsthberg ne propose que la version 7.0. Pour les suivantes ils ne sont pas en mesure de les implémenter pour l'intant.

Je reformule ma question : est-ce que la version 2.2.13 ou 2.2.14 de cmsms fonctionnent avec php 7.0 ?

Merci d'avance

Cordialement

Alain
Répondre
#3
Bonjour
je relance ce poste car Firsthberg ne propose que la version 7.0. Pour les suivantes ils ne sont pas en mesure de les implémenter pour l'intant.

Je reformule ma question : est-ce que la version 2.2.13 ou 2.2.14 de cmsms fonctionnent avec php 7.0 ?

Merci d'avance

Cordialement

Alain
Répondre
#4
Citation :Je reformule ma question : est-ce que la version 2.2.13 ou 2.2.14 de cmsms fonctionnent avec php 7.0 ?
OUI la version 2.2.x est bien compatible  mais attention aux modules qui ne seraient pas compatibles avec PHP 7.0
il faut bien vérifier car comme indiqué plus haut par exemple pour CGextensions les dernières version ne sont pas OK avec PHP 7.0 Wink
J-C Etiemble Tutoriels v 2.2.x
Répondre
#4
Citation :Je reformule ma question : est-ce que la version 2.2.13 ou 2.2.14 de cmsms fonctionnent avec php 7.0 ?
OUI la version 2.2.x est bien compatible  mais attention aux modules qui ne seraient pas compatibles avec PHP 7.0
il faut bien vérifier car comme indiqué plus haut par exemple pour CGextensions les dernières version ne sont pas OK avec PHP 7.0 Wink
J-C Etiemble Tutoriels v 2.2.x
Répondre
#5
(06/05/2020, 10:52:35)jce76350 a écrit :
Citation :Je reformule ma question : est-ce que la version 2.2.13 ou 2.2.14 de cmsms fonctionnent avec php 7.0 ?
OUI la version 2.2.x est bien compatible  mais attention aux modules qui ne seraient pas compatibles avec PHP 7.0
il faut bien vérifier car comme indiqué plus haut par exemple pour CGextensions les dernières version ne sont pas OK avec PHP 7.0 Wink


Merci pour cette réponse.
J'ai donc mis à jour la version cms en 2.2.14.
Là j'ai un autre pb : je ne peux plus rien mettre à jour dans l'administration. Pour les contenus le fait de cliquer sur "envoyer" ne met pas àjour mais en plus affiche une page blanche avec ceci  en haut à gauche :
Citation :'2019-09-16 15:24:50'


Il fait la même chose pour l'installation de module, donc je ne peut plus mettre à jour les modules.

Avez vous une idée ? que puis-je faire ?

Merci d'avance pour votre aide
Répondre
#5
(06/05/2020, 10:52:35)jce76350 a écrit :
Citation :Je reformule ma question : est-ce que la version 2.2.13 ou 2.2.14 de cmsms fonctionnent avec php 7.0 ?
OUI la version 2.2.x est bien compatible  mais attention aux modules qui ne seraient pas compatibles avec PHP 7.0
il faut bien vérifier car comme indiqué plus haut par exemple pour CGextensions les dernières version ne sont pas OK avec PHP 7.0 Wink


Merci pour cette réponse.
J'ai donc mis à jour la version cms en 2.2.14.
Là j'ai un autre pb : je ne peux plus rien mettre à jour dans l'administration. Pour les contenus le fait de cliquer sur "envoyer" ne met pas àjour mais en plus affiche une page blanche avec ceci  en haut à gauche :
Citation :'2019-09-16 15:24:50'


Il fait la même chose pour l'installation de module, donc je ne peut plus mettre à jour les modules.

Avez vous une idée ? que puis-je faire ?

Merci d'avance pour votre aide
Répondre
#6
alors
- afficher les erreurs PHP avec dans config.php
// Afficher les erreurs à l'écran
ini_set('display_errors', 1);
// Enregistrer les erreurs dans un fichier de log
// Afficher les erreurs et les avertissements
error_reporting(E_ALL);
ensuite déjà renommer en FTP  les mon des dossiers modules qui pourraient poser problème et tester
J-C Etiemble Tutoriels v 2.2.x
Répondre
#6
alors
- afficher les erreurs PHP avec dans config.php
// Afficher les erreurs à l'écran
ini_set('display_errors', 1);
// Enregistrer les erreurs dans un fichier de log
// Afficher les erreurs et les avertissements
error_reporting(E_ALL);
ensuite déjà renommer en FTP  les mon des dossiers modules qui pourraient poser problème et tester
J-C Etiemble Tutoriels v 2.2.x
Répondre
#7
Ah, j'ai eu cette erreur à un moment, et ça venait d'un module de CG, si je me souviens bien. Essaie de désinstaller les modules optionnels (uniquement ceux-là) un par un.
Répondre
#7
Ah, j'ai eu cette erreur à un moment, et ça venait d'un module de CG, si je me souviens bien. Essaie de désinstaller les modules optionnels (uniquement ceux-là) un par un.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)