Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Mise à jour vers 2.2.8 de 1.12.1
#1
Bonjour,

J'ai effectué la mise à jour de la version cms made simple de la version 1.12.1 vers la dernière 2.2.8
Mais maintenant après la réalisation de la mise à jour (qui a bien fonctionné selon la page de résultat)
Je ne peux plus lancer le site j'ai l' erreur : CMSDumper::getCMS failed!

Que cela soit en admin ou à l’accès du site, comment puis-je faire pour outrepasser cette erreur ?

En supprimant l'appel de ce plugin à la main (qui servait à faire un backup complet du site + base).
p.s( dans la table (cms_modules) il y'a bien le plugin CMSDumper, si j'enlève celui-ci de la table cela pourrait résoudre le problème ?

Aucune sauvegarde à disposition suite à une mauvaise manipulation, donc pas moyen de faire un retour arrière.

Merci.
Claude
Répondre
#2
Bonjour,

le problème vient du module CMSDumper qui à ma connaissance n'est plus compatible avec les dernières versions.
Essaye de le supprimer du dossier /modules/ (copie le ailleurs par sécurité)

Tiens-nous au courant !
Répondre
#3
(06/11/2018, 10:26:50)airelibre a écrit : Bonjour,

le problème vient du module CMSDumper qui à ma connaissance n'est plus compatible avec les dernières versions.
Essaye de le supprimer du dossier /modules/ (copie le ailleurs par sécurité)

Tiens-nous au courant !
Bonjour,

si je le déplace (ou renomme)
plus de site :
Cette page ne fonctionne pas
Impossible de traiter cette demande via www.innoverdrive.fr à l'heure actuelle.
HTTP ERROR 500

La suppression dans la base ne change rien
Supprimer de la base table cms_modules
CMSDumper, installed, 1.3, 0, 1, 0, 0

Dépendance trouvé dans la table cms_module_deps
CMSMailer, CMSDumper, 2.0.2, 2015-01-08 22:52:36, 2015-01-08 22:52:36

Si vous avez une solution sans perte ?
Merci
Répondre
#4
As-tu le détail de l'erreur 500 dans les logs du serveur ? As-tu par ailleurs essayé de le supprimer totalement du dossier "modules" ?
Répondre
#5
(06/11/2018, 12:40:18)airelibre a écrit : As-tu le détail de l'erreur 500 dans les logs du serveur ? As-tu par ailleurs essayé de le supprimer totalement du dossier "modules" ?

Oui erreur 500 (sous chrome,  page blanche sous firefox)
Non puisqu'il y a d'autres modules utilisés par le site

J'ai retrouvé ailleurs un backup (fait justement avec CMSDUMPER) qui date de 2015, donc je vais voir à revenir en arrière.
Par contre repasser en 2.2.8 me semble impossible ?

En passant, justement pour la version 2.2.8 existe t-il un plugin similaire à CMSDUMPER ?

Il serait dommage que je ne puisse pas passer en version 2.2.8, par contre comment faire  dans ce cas pour les dépendances
comme par exemple CmsMailler utilisé pour l'envoi de mail qui repose sur CmsDumper ?

Etc..

Merci
Répondre
#6
Bonjour,

il ne doit y avoir que quelques fichiers qui ne sont pas à jour pour CMSDumper, mais cela suffit à le bloquer et le rendre inopérant pour la version 2 et +.

Pour l'erreur, je te demandais les logs serveur pour voir d'où vient l'erreur. Chaque erreur est consignée dans le log du serveur avec plus de détails.
As-tu essayé de simplement supprimer le module du dossier de modules ?

Merci,
Répondre
#7
Bonjour,

Oui supprimé le dossier mais du coup j'avais une page blanche ou erreur 500 dans firefox.
Pour l'instant retourné en 1.12.1 de 2015 donc site vide.

Merci
Répondre
#8
Pour le module CMS Dumper voir le forum EN (Upgrading 1.12.1 to 2.1.5)
ce module n'existe plus normalement
de plus quand on fait une mise à jour aussi importante, il faut vérifier si les modules existant dans la version 1.12.x sont toujours d'actualité. Sinon il faut les déactiver et ensuite les supprimer avant de passer en 2.x
donc repartir de la 1.12.1 nettoyer les modules et ensuite faire la mise à jour en 2.2.8
J-C Etiemble Tutoriels v 2.2.x
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)