Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Rewrite MleCMS : tout marche en /en et pas en /fr : changement d'host
#1
Bonjour à toutes et à tous,
cela fait déjà plusieurs heures que je gratte, cherche des infos mais si je viens vers vous c'est que je ne vois pas solution.

J'ai un CMSMS qui tourne sur un host 1 (ovh VPS plesk) sans pb avec le MleCMS
Je le fais migrer sur un host 2 (infomaniak cloud) avec le même fichier de config, le même htaccess, tous les caches vidés etc...
la page racine /fr s'affiche mais dés que je change de page : 404
par contre si je bascule en /en je peux naviguer sans problème.

A rien n'y comprendre
je vous remercie vivement d'avance si je peux avoir une piste
Bien à vous !
Aurore
Répondre
#2
Post déplacé dans le bon forum Wink

Quelle version du cms ? et donner les informations du menu Administration du site/Informations du système en haut Vue au format texte.
J-C Etiemble Tutoriels v 2.2.x
Répondre
#3
Bonjour J-C merci
désolé pour le topic

>>le plus étrange c'est que si je change dans option de page l'alias en fra et bien mon site tourne en /fra/qqch

Citation :----------------------------------------------

Cms Version: 1.11.3 Darwin_8494Fr

Installed Modules:

CMSMailer: 5.2.1
CMSPrinting: 1.0.3
FileManager: 1.4.2
MenuManager: 1.8.4
MicroTiny: 1.2.4
ModuleManager: 1.5.5
News: 2.12.10
Search: 1.7.7
ThemeManager: 1.1.7
FormBuilder: 0.7.3
Gallery: 2.1.6
TinyMCE: 2.9.11
GAMadeSimple: 1.1
GoogleMaps: 0.2.1
CGExtensions: 1.32.2
MleCMS: 1.11.4
FrontEndUsers: 1.21.2
CustomContent: 1.9
SelfRegistration: 1.7

Config Information:

php_memory_limit:
process_whole_template:
output_compression:
max_upload_size: 300000000
url_rewriting: mod_rewrite
page_extension:
query_var: page
image_manipulation_prog: GD
auto_alias_content: true
locale:
default_encoding: utf-8
admin_encoding: utf-8
set_names: true

Php Information:

phpversion: 5.6.30
md5_function: On (Vrai)
gd_version: 2
tempnam_function: On (Vrai)
magic_quotes_runtime: Off (Faux)
E_STRICT: 2048
E_DEPRECATED: 8192
memory_limit: 640M
max_execution_time: 60
output_buffering: 20480
safe_mode: Off (Faux)
file_uploads: On (Vrai)
post_max_size: 300M
upload_max_filesize: 300M
session_save_path: /home/clients/f32b47681cbc7f79b4fadbb48cc0e373/tmp (3777)
session_use_cookies: On (Vrai)
xml_function: On (Vrai)
xmlreader_class: On (Vrai)

Server Information:

Server Api: fpm-fcgi
Server Db Type: MySQL (mysql)
Server Db Version: 5.7.22
Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté

----------------------------------------------
Répondre
#4
alors déjà c'est des version obsolètes tout ça
- le cms 1.11.3 est périmé c'était 1.12.02 la dernière en 03/2016
Citation :le plus étrange c'est que si je change dans option de page l'alias en fra et bien mon site tourne en /fra/qqch
c'est sûrement un soucis de config dans MLE c'est ancien tout ça....
J-C Etiemble Tutoriels v 2.2.x
Répondre
#5
Mise à jour obligatoire sous peine de ne pas avoir de réponse… A minima vers 1.12.2, mais de préférence vers 2.2.7, la version actuelle.
Répondre
#6
ok merci...
je mets ma version à jour et reviens rapidement.
Répondre
#7
Code :
[== Indéfini ==]
----------------------------------------------

Cms Version: [b]1.12.2[/b]

Installed Modules:

CMSMailer: [b]5.2.14[/b]
CMSPrinting: [b]1.0.5[/b]
FileManager: [b]1.4.5[/b]
MenuManager: [b]1.8.7[/b]
MicroTiny: [b]1.2.9[/b]
ModuleManager: [b]1.5.8[/b]
News: [b]2.15.2[/b]
Search: [b]1.7.13[/b]
ThemeManager: [b]1.1.8[/b]
FormBuilder: [b]0.8.1.6[/b]
Gallery: [b]2.3.2[/b]
TinyMCE: [b]2.9.11[/b]
GAMadeSimple: [b]1.1[/b]
GoogleMaps: [b]0.2.1[/b]
CGExtensions: [b]1.53.19[/b]
MleCMS: [b]1.11.4[/b]
Captcha: [b]1.0[/b]

Config Information:

php_memory_limit: [b][/b]
process_whole_template: [b][/b]
max_upload_size: [b]300000000[/b]
url_rewriting: [b]mod_rewrite[/b]
page_extension: [b][/b]
query_var: [b]page[/b]
image_manipulation_prog: [b]GD[/b]
auto_alias_content: [b]true[/b]
locale: [b][/b]
default_encoding: [b]utf-8[/b]
admin_encoding: [b]utf-8[/b]
set_names: [b]true[/b]

Php Information:

phpversion: [b]5.6.37[/b]
md5_function: [b]On [/b] (Vrai)
gd_version: [b]2[/b]
tempnam_function: [b]On [/b] (Vrai)
magic_quotes_runtime: [b]Off [/b] (Faux)
E_STRICT: [b]2048[/b]
E_DEPRECATED: [b]8192[/b]
memory_limit: [b]640M[/b]
max_execution_time: [b]60[/b]
output_buffering: [b]20480[/b]
safe_mode: [b]Off [/b] (Faux)
file_uploads: [b]On [/b] (Vrai)
post_max_size: [b]300M[/b]
upload_max_filesize: [b]300M[/b]
session_save_path: [b]/home/clients/f32b47681cbc7f79b4fadbb48cc0e373/tmp[/b] (3777)
session_use_cookies: [b]On [/b] (Vrai)
xml_function: [b]On [/b] (Vrai)
xmlreader_class: [b]On [/b] (Vrai)

Server Information:

Server Api: [b]fpm-fcgi[/b]
Server Db Type: [b]MySQL (mysql)[/b]
Server Db Version: [b]5.7.22[/b]
Server Db Grants: [b]Trouvé un privilège "GRANT ALL" qui semble être adapté[/b]
Server Time Diff: [b]Aucune différence de date du système de fichiers trouvées[/b]

----------------------------------------------

Re,
je suis désolée pour le délai et j'ai beau cherché je ne trouve toujorus pas/
J'ai mis à jour le CMS en 1.12.2

Depuis la mise à jour la homepage s'affiche directement par contre des que je change ça plante.
je suis chez infomaniak alors que son clone sur ovh tournait dans la même config.

mon fichier de htaccess :

Code :
[== Indéfini ==]

Options +FollowSymLinks
RewriteEngine on
RewriteBase /

RewriteCond %{REQUEST_URI} !/$
RewriteCond %{REQUEST_URI} !\.
RewriteRule ^(.*) %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.+).html$ index.php?page=$1


Mon fichier de config :

Code :
[== Indéfini ==]
<?php
# CMS Made Simple Configuration File
# Documentation: /doc/CMSMS_config_reference.pdf
#
$config['dbms'] = 'mysql';
$config['db_hostname'] = 'serveur';
$config['db_username'] = 'user';
$config['db_password'] = 'pass';
$config['db_name'] = 'bdd';
$config['db_prefix'] = '';
$config['timezone'] = 'Europe/Berlin';
$config['admin_dir'] = 'admin';
$config['use_hierarchy'] = '1';
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '';
$config['root_url'] = 'https://testcmsms.abalone.studio';
$config['admin_url'] = 'https://testcmsms.abalone.studio/admin';
$config['internal_pretty_urls'] = '1';
$config['debug'] = true;
?>


J'ai l'impression que c'est la hierarchie qui plante car quand j'ai un autre site sans FR et EN ca fonctionne


[Image: toto.png]

un petit coup de pouce serait le bien venu.
Je vous remercie d'avance
Répondre
#8
Pour le 2e paramètre (auto-redirect), as-tu testé en mettant "aucun" ?
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)