Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
La version 2.3 évolution
#76
Un peu de rigolade Wink
ce soit tsst de dernière  rev SVN 12333
Et je ne vois plus ModuleManager dans l'admin
Il y a eu une modif du fichier et de la version 2.2.1 et aussi modif de version d'autres modules
Donc je modifie le ModuleManager.module.php pour revenir en 2.2 et le miracle se produit je vois à nouveau ModuleManager dans l'admin et je peux faire les mise à jour des autres modules
2 cas sont a envisager!
- je suis pas doué Wink
d'ou ma question su le forum En 
- ou .... [Image: undecided.png]
alors la réponse est super je cite
Citation :The version number was bumped.
Modules no longer auto upgrade.
If you reinstall it will work, or if you were to upgrade, it would work.
J-C Etiemble Tutoriels v 2.2.x
Répondre
#77
alors c'est quand mêm super ça c'est bien fait pour tout le monde ne puise pas tester !!!
parce que tu es obliger soit de compiler une installation du CMS pour pourvoir suivre la SVN ce qui bien tout le monde ne pas pas faire ou alors faut attendre la prochaine sortie d'une béta
J-C Etiemble Tutoriels v 2.2.x
Répondre
#78
Répondre
#79
Citation :...
= pour ne pas pouvoir tester le SVN
J-C Etiemble Tutoriels v 2.2.x
Répondre
#80
aller une petite image de Content Manager en révision SVN 12343
[Image: bug13343-Content-Manager.png]

et le bug est reporté Content Manager ERROR 12343

EDIT
Corrigé en SVN 12344 (minor)
J-C Etiemble Tutoriels v 2.2.x
Répondre
#81
et bientôt une 2.3-beta6
J-C Etiemble Tutoriels v 2.2.x
Répondre
#82
et voila Announcing CMS Made Simple v2.3-beta

en fait c'est bien une béta 6 il faut lire le 2eme post

téléchargement CMSMS is in Beta https://www.cmsmadesimple.org/downloads/cmsms/

lie direct http://s3.amazonaws.com/cmsms/downloads/...nstall.zip
J-C Etiemble Tutoriels v 2.2.x
Répondre
#83
Pour information un peu de doc sur les thèmes v 2.3
"CG ..Il s'agit d'un projet d'article, qui ira sur le site de documentation... mais nous avons pensé que ce serait une bonne idée de donner des instructions aux futurs utilisateurs pour qu'ils puissent jouer avec les thèmes. ....

Draft article #1 - Creating frontend themes in CMSMS 2.3+

Draft article #2 - Overriding module templates

Draft article #3 - Child themes
J-C Etiemble Tutoriels v 2.2.x
Répondre
#84
Je  teste la beta 7 sous Windows 7 avec
wampser 3.1.9
php 7.3.5
Mysql 5.7.26
Apache 2.4.3


Le fichier phar de l'installation ne fonctionne pas, il a fallu utiliser  expanded installer. Après les ennuis ont commencé. Cgfeedmaker ne fonctionne plus et la mise en page du module Gallery est en panne.
Pas vu l'intérêt de Pressroom
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
Répondre
#85
PHAR : ça ne viendrait pas de ta configuration ?

CGfeedMaker n'est plus compatible depuis un moment (même en 2.2), il n'a pas été mis à jour depuis 2014.
Gallery n'est pas encore compatible.
Quant à Pressroom c'est le remplaçant de News, moins mal foutu que ce dernier semble-t-il.
Répondre
#86
Citation :PHAR : ça ne viendrait pas de ta configuration ?
Non j'ai mis à jour les versions antérieures avec

réponse de Robert:


Citation :As mentioned in the changelog... The big difference is that we are running the newest released version of smarty. It appears to have undergone several changes related to building paths.... where it uses \ instead of / on windows.

It appears that it detects windows and uses \ when building paths even though when running under a phar \ will break the URI."

L'enfer est pavé de bonne intensions




Citation :CGfeedMaker n'est plus compatible depuis un moment (même en 2.2), il n'a pas été mis à jour depuis 2014.


Si Si voir ici http://www.evolution-biologique.org




Citation :Quant à Pressroom c'est le remplaçant de News, moins mal foutu que ce dernier semble-t-il.


à voir, je suppose que l'on va perdre les anciens messages et les gabarits
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
Répondre
#87
Ah oui pour PHAR, je viens de lire le message sur le forum EN, c'est dommage… effet secondaire d'une évolution.

CGFeedMaker : je suis étonné que ça tourne encore, je l'ai remplacé il y a un moment déjà par un truc à Rolf, parce que je n'arrivais plus à le faire fonctionner.

Pressroom : à l'heure qu'il est, il n'y a pas de possibilité de transfert automatique (= un module dédié) de News à Pressroom. Il est évident que ça sera indispensable rapidement si on veut mettre à jour les sites existants en 2.3.
Répondre
#88
Citation :Pressroom : à l'heure qu'il est, il n'y a pas de possibilité de transfert automatique (= un module dédié) de News à Pressroom. Il est évident que ça sera indispensable rapidement si on veut mettre à jour les sites existants en 2.3.

pas grave News existe toujours même en 2.3.
s'il existe (News) à la mise à jour il passe dans le dossier /assets/modules/
et c'est tout
J-C Etiemble Tutoriels v 2.2.x
Répondre
#89
Oui sauf qu'il n'est pas sûr qu'il soit maintenu très longtemps, je pense.

Et aussi, les possibilités d'affichage sont bien plus pratiques et souples dans PressRoom que dans News, notamment pour gérer du multilingue.
Répondre
#90
y-a-til un ou plusieurs testeurs sur le PHP 7.4 ?
https://forum.cmsmadesimple.org/viewtopi...92&t=81653
J-C Etiemble Tutoriels v 2.2.x
Répondre
#91
format des adresses internes:
{cms_selflink href='bibliographie' } provoque une erreur chez moi (n'en provoque pas avec version 2.2.11)
mais pas {cms_selflink href='bibliographie'}
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
Répondre
#92
en Révision 12411
avec $config['url_rewriting'] = 'internal'; ou $config['url_rewriting'] = 'mod_rewrite';
je n'ai pas de soucis avec un lien cms_selflink href='xxxxx' }"
mais je ne suis pas sous Win et c'est peut être la le soucis Wink
J-C Etiemble Tutoriels v 2.2.x
Répondre
#93
j'ai refais les tests sous PHP 7.4.0RC3 et j'ai juste corrigé le fichier ib/autoloader.php et plus d'erreur "Deprecated: implode()"
reste à corriger quelques bricole pour l'install aussi et ça doit passer Wink
J-C Etiemble Tutoriels v 2.2.x
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)