Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu] problème d'url rewriting sur la page par defaut
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.1.6
#~ Url du site : lerefugedubienetre.farangprod.com
#~ Hébergeur / Soft : o2switch
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 2.1.6
#~ Installed Modules:
#~ AdminSearch: 1.0.2
#~ CGContentUtils: 2.2.1.1
#~ CGExtensions: 1.53.17
#~ CGGoogleMaps2: 1.1.1
#~ CGJobMgr: 1.3.4
#~ CGSimpleSmarty: 2.1.6
#~ CGSmartImage: 1.21.5
#~ CGUserDirectory: 1.5
#~ CMSContentManager: 1.1.4
#~ CMSForms: 1.11.2
#~ CMSMailer: 6.2.14
#~ CSSPreprocessor: 2.1
#~ CodeMirror: 3.0.0
#~ CompanyDirectory: 1.23.3
#~ DesignManager: 1.1.1
#~ ExtendedTools: 1.3.3
#~ FAQ: 2.0.1
#~ FileManager: 1.5.2
#~ FormBuilder: 0.8.1.6
#~ FrontEndUsers: 2.3
#~ Gallery: 2.2
#~ JQueryTools: 1.3.9
#~ LISE: 1.2.3
#~ LISECategories: 1.2.3
#~ LISEMarques: 1.2.3
#~ LISEPartenaires: 1.2.3
#~ LISEPrestations: 1.2.3
#~ LISETarifs: 1.2.3
#~ MCFramework: 0.0.6
#~ MicroTiny: 2.0.3
#~ MleCMS: 2.0-alpha2
#~ ModuleManager: 2.0.5
#~ NMS: 2.12.2
#~ Navigator: 1.0.3
#~ News: 2.50.6
#~ Orm: 0.3.3
#~ Postcode: 1.2.1
#~ Search: 1.50.2
#~ Storelocator: 0.2
#~ ThemeManager: 1.1.8
#~ TinyMCE: 3.1.4
#~ TruetypeText: 2.2.1
#~ Config Information:
#~ php_memory_limit:
#~ max_upload_size: 8000000
#~ url_rewriting: mod_rewrite
#~ page_extension: .html
#~ query_var: page
#~ auto_alias_content: true
#~ locale: fr_FR.utf8
#~ set_names: true
#~ timezone: Europe/Paris
#~ permissive_smarty: false
#~ Php Information:
#~ phpversion: 7.0.15
#~ md5_function: On (Vrai)
#~ json_function: On (Vrai)
#~ gd_version: 2
#~ tempnam_function: On (Vrai)
#~ magic_quotes_runtime: Off (Faux)
#~ E_ALL: 32767
#~ E_STRICT: 2048
#~ E_DEPRECATED: 8192
#~ test_file_timedifference: Aucune différence de date du système trouvée
#~ test_db_timedifference: Aucune différence de date du système trouvée
#~ create_dir_and_file: 1
#~ memory_limit: 128M
#~ max_execution_time: 120
#~ register_globals: Off (Faux)
#~ output_buffering: 4096
#~ disable_functions:
#~ open_basedir:
#~ test_remote_url: Valable
#~ file_uploads: On (Vrai)
#~ post_max_size: 16M
#~ upload_max_filesize: 8M
#~ session_save_path: /tmp (0700)
#~ session_use_cookies: On (Vrai)
#~ xml_function: On (Vrai)
#~ xmlreader_class: On (Vrai)
#~ check_ini_set: On (Vrai)
#~ curl: On
#~ Performance Information:
#~ allow_browser_cache: Off (Faux)
#~ browser_cache_expiry: 60
#~ php_opcache: Off (Faux)
#~ smarty_cache: Off (Faux)
#~ smarty_compilecheck: Off (Faux)
#~ smarty_cache_udt: Off (Faux)
#~ auto_clear_cache_age: Off (Faux)
#~ Server Information:
#~ Server Software: Apache
#~ Server Api: litespeed
#~ Server Os: Linux 2.6.32-673.26.1.lve1.4.20.el6.x86_64 On x86_64
#~ Server Db Type: MySQL (mysqli)
#~ Server Db Version: 10.0.29
#~ Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
#~ Permission Information:
#~ tmp: /home/farangpr/Sites/lerefugedubienetre/tmp (0755)
#~ tmp_cache: /home/farangpr/Sites/lerefugedubienetre/tmp/cache (0755)
#~ templates_c: /home/farangpr/Sites/lerefugedubienetre/tmp/templates_c (0755)
#~ modules: /home/farangpr/Sites/lerefugedubienetre/modules (0755)
#~ uploads: /home/farangpr/Sites/lerefugedubienetre/uploads (0755)
#~ Masque de création de fichier (umask) : /home/farangpr/Sites/lerefugedubienetre/tmp/cache (0755)
#~ config_file: 0444
#~ ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~


Bonjour,

alors que tout fonctionnait très bien la semaine dernière, je me suis aperçu aujourd'hui que ma page home (page par defaut) ne fonctionnait plus du tout.
Dessus j'ai une gallery (faites avec bootstrap et le module gallery) qui si je la supprime remet en place le template de la page. pensant que ça venait de là, j'ai cherché de ce côté mais finalement je même diapo fonctionne sur d'autres pages ayant pourtant le même template que la page d'accueil.... fausse piste !

Si je déselectionne l'option defaut de la page d'accueil alors elle fonctionne bien en suivant un lien avec url modifié... si l'option defaut est coché, la page fonctionne si je tape l'adresse de la page:

lerefugedubienetre.farangprod.com = erreur!
lerefugedubienetre.farangprod.com/accueil.html = ok

Si je passe une page fonctionnant bien avec le même style de diapo en page par defaut... celle-ci ne fonctionne plus.

C'est donc bien au niveau de l'option "page par defaut" qu'il y'a un soucis !

J'ai alors pensé à un problème de htaccess... j'ai remis celui d'origine mais toujours le même problème.

Si quelqu'un a une idée d'où peut venir le problème, je lui en serai très reconnaissant :p

Merci beaucoup
#2
Bonjour,

si tu enlèves l'encodage en base 64 des images générées dans le slider par - probablement - CGSmartImage, cela fonctionne-t-il ?
#3
Bonjour airelibre,

Je n'ai pas activé d'encodage en base 64 et j'ai beau regarder je ne vois pas où le désactiver.
Par contre dans le module de traitement d'images de Calguy, en changeant le mode d'intégration des images le site refonctionne. Il déconne en utilisant l'option "smart" et fonctionne avec les autres options.
Même l'option "integration en mode smart mais limite le poids de l'image" fonctionne donc, je comprends pas quel est le problème avec "smart" tout court qui lui génère cet encodage en base 64 !

En tout cas, merci pour m'avoir mis sur le fil, ma page d'accueil est revenue à la normale.
#4
Les modes "smart" encodent en base64 les images au lieu d'en générer. Personnellement je le désactive car il empêche par exemple la mise en cache des images. au sein du navigateur.

Le problème vient de là, reste à voir les détails Wink A toi de voir si tu veux creuser bien sûr
#5
Je regarderai, quand j'aurai le temps, si j'y comprends quelque chose.
En attendant merci encore pour le coup de pouce, et je mets le le sujet en résolu Wink
#6
Ca marche - tiens-nous au courant ! a+
#7
Tu peux désactiver l'encodage dans la page en ajoutant noembed="1" dans la balise appelant l'image normalement.
#8
Ouik a écrit :Tu peux désactiver l'encodage dans la page en ajoutant noembed="1" dans la balise appelant l'image normalement.


Aaaah, c'est bon à savoir ça aussi ! Wink

merci


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)