Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Probléme JS dans l'admin: mauvaise URL dans une requete
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 1.12.x
#~ Url du site :
#~ Hébergeur / Soft : OVH (dans un docker)
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 1.12.2
#~ Installed Modules:
#~ CMSMailer: 5.2.14
#~ CMSPrinting: 1.0.5
#~ FileManager: 1.4.5
#~ MenuManager: 1.8.7
#~ MicroTiny: 1.2.9
#~ ModuleManager: 1.5.8
#~ News: 2.15.2
#~ Search: 1.7.13
#~ ThemeManager: 1.1.8
#~ FormBuilder: 0.8.1.3
#~ Captcha: 0.5.2
#~ CGExtensions: 1.53.4
#~ MleCMS: 1.11.4
#~ CGSimpleSmarty: 1.10
#~ CGContentUtils: 1.5.3
#~ JQueryTools: 1.3.9
#~ Uploads: 1.22
#~ GBFilePicker: 1.3.3
#~ Gallery: 2.1.4
#~ ECB: 1.6
#~ CGBlog: 1.13.5
#~ CGGoogleMaps2: 0.99.3
#~ CGSmartImage: 1.21.3
#~ Piwik: 1.0.1
#~ Config Information:
#~ php_memory_limit:
#~ process_whole_template:
#~ max_upload_size: 10000000
#~ url_rewriting: mod_rewrite
#~ page_extension:
#~ query_var: page
#~ image_manipulation_prog: GD
#~ auto_alias_content: true
#~ locale:
#~ default_encoding: utf-8
#~ admin_encoding: utf-8
#~ set_names: true
#~ Php Information:
#~ phpversion: 5.5.9-1ubuntu4.16
#~ md5_function: On (True)
#~ gd_version: 2
#~ tempnam_function: On (True)
#~ magic_quotes_runtime: Off (False)
#~ E_STRICT: 0
#~ E_DEPRECATED: 0
#~ memory_limit: 128M
#~ max_execution_time: 30
#~ output_buffering: 4096
#~ safe_mode: Off (False)
#~ file_uploads: On (True)
#~ post_max_size: 10M
#~ upload_max_filesize: 10M
#~ session_save_path: /var/lib/php5 (1733)
#~ session_use_cookies: On (True)
#~ xml_function: On (True)
#~ xmlreader_class: On (True)
#~ Server Information:
#~ Server Api: apache2handler
#~ Server Db Type: MySQL (mysqli)
#~ Server Db Version: 5.5.47
#~ Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable
#~ Server Time Diff: No filesystem time difference found
#~ ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bonjour,

Mon site a été passé en https il y a peu et j'ai un problème dans l'onglet content>pages. Je n'arrive plus à étendre ma liste de pages.
Je vois qu'une requête ajax est lancé mais elle pointe toujours vers mon adresse en http avec le port 80 alors qu'elle devrait pointer vers une page en https sans port.

Où dois-je faire la modification?

Edit: j'ai bien mon https en faite mais j'ai toujours ce numéro de port qui bloque la requête.

Merci d'avance pour vos réponses.
#2
je ne vois pas trop le rapport avec Modules, Tags Smile

EDIT j'ai déplacé vers Général

mais a tu configuré dans ls pages (contenus /Options)
Utiliser le protocole HTTPS pour cette page

et aussi dans Administration du site / Page par défaut
J-C Etiemble Tutoriels v 2.2.x
#3
jce76350 a écrit :je ne vois pas trop le rapport avec Modules, Tags Smile

je vais déplacer vers général

Je savais pas trop où mettre ça.


jce76350 a écrit :mais a tu configuré dans ls pages (contenus /Options)
Utiliser le protocole HTTPS pour cette page

C'est déjà réglé, quand je regarde ma console firefox et mon log d'erreur apache, c'est la seul anomalie que je relève.
#4
donne un lien vers ton site
J-C Etiemble Tutoriels v 2.2.x
#5
jce76350 a écrit :donne un lien vers ton site

Je n'ai pas assez de messages sur le forum sur pour poster une url.
#6
>Je n'ai pas assez de messages sur le forum sur pour poster une url.
Heu ... ton adresse sans http Smile
J-C Etiemble Tutoriels v 2.2.x
#7
C'est https://sirail.fr/
#8
Ça fait quand même bizarre une adresse en .fr qui débouche sur un site en anglais.
site.com aurait été plus judicieux, non ? Ou alors pas de Mle, mais .fr, .en, .de

Tu pourrais nous donner ton config.php et ton .htaccess, cela pourrait aider.
#9
Cela est une conséquence du bug sur le panneau d'administration:
Je ne peux plus changer les pages par défaut.


Le config.php
Code :
[== PHP ==]
$config['dbms'] = 'mysqli';
$config['db_hostname'] = '*******';
$config['db_username'] = '*******';
$config['db_password'] = '********';
$config['db_name'] = '***********';
$config['db_prefix'] = 'cms_';
$config['timezone'] = 'Europe/Paris';
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '';
$config['query_var'] = 'page';
$config['root_path'] = '/app';
$config['root_url'] = 'http://www.sirail.fr';
$config['ssl_url']='https://www.sirail.fr';
$config['admin_url']='https://www.sirail.fr/admin';

#Désactiver REGISTER_GLOBALS
SetEnv REGISTER_GLOBALS 0
#Désactiver Magixc Quotes
SetEnv MAGIC_QUOTES 0
#Activer PHP5
SetEnv PHP_VER 5_5
# BEGIN Expire headers



Le .htaccess
Code :
[== Indéfini ==]
Options +FollowSymLinks  -Indexes
RewriteEngine on
#RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php?page=$1 [QSA]


#fix for bug on fonts
AddType application/vnd.ms-fontobject    .eot
AddType application/x-font-opentype      .otf
AddType image/svg+xml                    .svg
AddType application/x-font-ttf           .ttf
AddType application/font-woff            .woff
AddType application/font-woff2           .woff2

<IfModule mod_headers.c>
  <FilesMatch ".(eot|otf|svg|ttf|woff|woff2)$">
    Header set Access-Control-Allow-Origin "*"
  </FilesMatch>
</IfModule>
#10
Petite précision:

Il y a une redirection 301 pour tout ce qui rentre par le port 80 via un nginx vers une adresse en https (il y a d autre application sur le serveur).
#11
Supprime cette variable :
Code :
$config['root_path'] = '/app';
Le système doit la trouver par lui-même.

Code :
$config['ssl_url']='https://www.sirail.fr';
$config['admin_url']=$config['ssl_url'].'/'.$config['admin_dir'];
Je ne suis pas certain que tu aies besoin d'indiquer ces 2 variables.

Tu as aussi une erreur de chemin pour piwik : https://../piwik/piwik.js
Vérifie plus en profondeur les redirections du serveur (recherche le terme 80).

Si Jce ne trouve pas d'où vient le problème et que tu restes bloqué, autant rester en http pour l'admin.
#12
Bonsoir,

Pour piwik, c'est normal, je ne l'ai pas encore réinstallé depuis la dernière migration.

Est-ce que je dois encore utiliser la variable root_url, maintenant que j'ai un accès https? Dois-je remplacer sa valeur par celle en ssl_url?
#13
Le cms est suffisamment intelligent pour trouver root_url sans que tu aies besoin de la configurer.
Tu trouveras toutes les infos dans /doc/CMSMS_config_reference.pdf.
#14
Bo,njour,

J'ai les changement dans config.php et rien. J'ai toujours la même requête qui va à la mauvaise adresse.
J'ai toujours
Code :
[== PHP ==]
OPTIONS XHR https://www.sirail.fr:80/admin/listcontent.php [45 ms]
Comme requête dans ma console firefox.

Pouvez-vous 'indiquer comment modifier le paramétrè:
Code :
[== JavaScript ==]
xajax.config.requestURI
dans le code de Cms Made Simple proprement (seul référence au port 80 que j'ai trouvé)?
#15
Ce qui défini le requestURI quand il n'est pas trouvé se trouve dans /include.php en plus de basename(_FILE_) :
Code :
[== Indéfini ==]
line 238 #Fix for IIS (and others) to make sure REQUEST_URI is filled in
if (!isset($_SERVER['REQUEST_URI']))
{
    $_SERVER['REQUEST_URI'] = $_SERVER['SCRIPT_NAME'];
    if(isset($_SERVER['QUERY_STRING']))
    {
        $_SERVER['REQUEST_URI'] .= '?'.$_SERVER['QUERY_STRING'];
    }
}
Fais une udt avec echo $_SERVER['SCRIPT_NAME']; pour connaître sa valeur.
Est-ce que tu as ce problème avec d'autres requêtes ? Ordonner les pages, ajouter un autre contenu...
As-tu vidé le cache navigateur et cms ? Supprime également tes cookies de session. Reconstruit les routes et lance un request sql pour trouver une référence à ":80" dans la bd.
Si tu ne trouves rien, ça ne peux venir que des redirections serveur. Si tu te rends sur https://www.sirail.fr/admin/listcontent.php, reçois-tu une erreur ?
Sinon, je te conseille de poser la question sur le forum.org et/ou de laisser l'admin hors SSL.
#16
Un post qui pourrait t'aider à ce sujet (pour WP) : https://codex.wordpress.org/Administration_Over_SSL
#17
Jean le Chauve a écrit :Ce qui défini le requestURI quand il n'est pas trouvé se trouve dans /include.php en plus de basename(_FILE_) :
Code :
[== Indéfini ==]
line 238 #Fix for IIS (and others) to make sure REQUEST_URI is filled in
if (!isset($_SERVER['REQUEST_URI']))
{
    $_SERVER['REQUEST_URI'] = $_SERVER['SCRIPT_NAME'];
    if(isset($_SERVER['QUERY_STRING']))
    {
        $_SERVER['REQUEST_URI'] .= '?'.$_SERVER['QUERY_STRING'];
    }
}
Fais une udt avec echo $_SERVER['SCRIPT_NAME']; pour connaître sa valeur.
Est-ce que tu as ce problème avec d'autres requêtes ? Ordonner les pages, ajouter un autre contenu...
As-tu vidé le cache navigateur et cms ? Supprime également tes cookies de session. Reconstruit les routes et lance un request sql pour trouver une référence à ":80" dans la bd.
Si tu ne trouves rien, ça ne peux venir que des redirections serveur. Si tu te rends sur https://www.sirail.fr/admin/listcontent.php, reçois-tu une erreur ?
Sinon, je te conseille de poser la question sur le forum.org et/ou de laisser l'admin hors SSL.


Cliquer sur l'url que tu me donnes me fait une redirection 302 vers l'authentification.
Le cache a été nettoyé et les routes rebuildés.
J'ai un print_R de $_SERVER et tout me semble propre.
En fait, c'est juste les requêtes vers listcontent.php qui ont un probléme (page par défaut, ordre des pages).

Edit:J'ai fait une recherche type LIKE %:80% dans ma base de données et je suis tombé sur un résultat dans la table cms_siteprefs.

Code :
[== Indéfini ==]
# sitepref_name, sitepref_value, create_date, modified_date
cf669c2c49b7eeaf80506380723ea25f6, a:15:{s:8:"cg_cmsms";O:29:"CGExtensions\jsloader\libdefn":1:{s:36:"

Le contenu de sitepref_value s'étend sur plusieurs dizaines de lignes et le ':80' trouvé ne concerne pas l'adresse url mais par contre ça contient plein de chemin vers mon wamp de dev!?!


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)