Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Difficultés à efffectuer une installation en local à partir d'une inst
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 1.12.x
#~ Url du site : En local
#~ Hébergeur / Soft : En local
#~ Informations Système :
#~ Linux Debian + Phpmyadmin + mysql + php5
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~
Bonjour à tous,

On m'a demandé d'effectuer des modifications pour le site web d'une association.

Afin de ne pas modifier leur site, j'ai tenté une installation en local à partir de la base mysql du site telechargée et des fichiers du ftp.

LOrsque je vais sur le répertoire en localhost,en premier lieu seule la bannière s'affiche.
En lançant le fichier upgrade.php dans le répertoire instal, seule la page d'accueil s'affiche.

Lorsque je tente d'aller sur une page, j'ai une erreur :
"Not Found

The requested URL /site/le-club.html was not found on this server.
Apache/2.4.10 (Debian) Server at localhost Port 80"

voici mon fichier config.php que j'ai édié:
"
<?php
# CMS Made Simple Configuration File
# Documentation: /doc/CMSMS_config_reference.pdf
#
$config['dbms'] = 'mysql';
$config['db_hostname'] = 'localhost';
$config['db_username'] = ****';
$config['db_password'] = '****';
$config['db_name'] = '****';
$config['db_prefix'] = 'cms_';
$config['db_port'] = 3306;
$config['root_url'] = '/site';
$config['timezone'] = '';
$config['default_encoding'] = 'utf-8';
$config['locale'] = 'fr_FR';
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';
$config['use_hierarchy'] = '1';
$config['query_var'] = 'page';
$config['persistent_db_conn'] = '1';
$config['internal_pretty_urls'] = '';
$config['output_compression'] = '1';
?>

merci pour l'aide que vous pourrez m'apporter.
#2
Bonjour et bienvenue,
On a besoin de plus de renseignements, en particulier le n° de version du cmsms et PHP. Merci de nous donner la configuration système (voir admin du site online) dans les balises forum [ code][ /code] (sans espace).
Nous avons également besoin du fichier .htaccess situé à la racine du site.
Quel est ton hébergement local ? Wamp ?
Dans quel répertoire as-tu placé le site ? www/site/ ?
#3
@Jean le monsieur dit local Debian donc un installation sur une distribution Linux et donc à priori si version Debian à jour
- PHP 5.6.17ou19 +Apache 2.4.10+ mysql 5.5.47 Wink

@MDimech tu nous dit que
Citation :Afin de ne pas modifier leur site, j'ai tenté une installation en local à partir de la base mysql du site telechargée et des fichiers du ftp. En lançant le fichier upgrade.php dans le répertoire instal, seule la page d'accueil s'affiche.
avant toute chose
dans quel dossier as tu mis ton site Web ?? /var/www/ ...?? quel sont les permissions ?
Pour le moment tu ne dois pas pas lancer le fichier upgrade.php, mais modifier le config et tester le site et l'administration déjà
de plus ton config.php est erroné
tu dois avoir seulement
Code :
config['dbms'] = 'mysqli'; // normalement mysqli et non mysql
$config['db_hostname'] = 'localhost';
$config['db_username'] = ****';
$config['db_password'] = '****';
$config['db_name'] = '****';
$config['db_prefix'] = 'cms_';
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';
$config['timezone'] = 'Europe/Paris'; // éventuellment
de plus comme tu as le mod_rewrite, tu dois activer le mode rewrite sur le serveur local, c'est Fait ??

Et je te conseille de MODIFIER LE PHP.INI avec
Code :
;;error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT
error_reporting = E_ALL | E_STRICT
;;display_errors = Off
display_errors = On
;;-> pour afficher les erreurs
pour afficher les erreurs ou message du serveur
J-C Etiemble Tutoriels v 2.2.x
#4
@ MDimech des nouvelles ??
J-C Etiemble Tutoriels v 2.2.x
#5
Désolé de l'attente,

J'ai été vérolé à cause de mon telce week-end. Ce qui m'a fait prendre conscience après une importante mis à jour de sécurité de mon système, que les fichiers du site sont également infectés par des troyens Windows.

De plus il y a des failles de sécurité sur le site.

Je vais voir avec l'administrateur pour régler ça avant de continuer à faire du développement.

Je reviens vers vous ce WE ou en début de semaine.

Merci
#6
>J'ai été vérolé à cause de mon telce
Et qu'est-ce "telce"

>De plus il y a des failles de sécurité sur le site.
quelles failles ?
J-C Etiemble Tutoriels v 2.2.x
#7
Bonsoir à tous,

Je reprends le post avec un autre pseudo.

Désolé de ne pas avoir donné de nouvelles...

J'ai du me créer un nouvel OS suite à l'incident cité plus haut dont l'origine était mon téléphone portable android qui n'était pas protégé... De plus, je n'ai pas accès à tous mes comptes mails d'où le nouveau pseudo.

Pour en revenir à CSSMS. Je n'arrive pas à faire l'installation de la version 1.

La version 2 ne pose pas de problèmes mais le site que j'aimerais modifier en local fonctionne avec la version Ponhpeï.

Lorsque j'essaie d'installer une version 1, l'installation se bloque à l'étape 6:

"
...

Création table module_smarty_plugins ... [fait]

Création table routes ... [fait]

Import des exemples de données ... "

De plus, la base de données reste vide.

Merci pour votre aide.
#8
Citation :J'ai du me créer un nouvel OS ...
Rolleyes

Citation :Lorsque j'essaie d'installer une version 1, l'installation se bloque à l'étape 6

quelle version ? je suppose la 1.12.2
donc tu es en local sur quel système Win ou Linux ? Version PHP apache Mysql ?
mode d’emploi http://wiki.cmsmadesimple.fr/wiki/Instal..._localhost ça doit fonctionner à 100%
J-C Etiemble Tutoriels v 2.2.x
#9
Ma configuration

-Linux Ubuntu Studio 16.04
-Apache 2.4.18 (Ubuntu)
-MySQL : Distrib 5.7.12, for Linux (x86_64)
-PHP : 7.0.4-7ubuntu2

Versions 1 que j'ai tenté d'installer : 1.12 Ponhpei et 1.12.2 Kolonia

Merci Wink
#10
>PHP : 7.0.4-7ubuntu2
ha....
C'est une Nouvelle installation ?
sur dossier vierge et base de données ou préfix de BD vierge ?

normalement la 1.12.x n'est Pas compatible php7
as tu bien mis pour la BD mysqli ?

Et je te conseille de MODIFIER LE PHP.INI avec
Code :
;;error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT
error_reporting = E_ALL | E_STRICT
;;display_errors = Off
display_errors = On
;;-> pour afficher les erreurs
pour afficher les erreurs ou message du serveur

et si le cms est installé passe en mode afficher les erreurs
et donne les erreurs

EDIT midi
je viens de tester sur une clef USB avec XUbuntu 16.04 +lamp PHP 7.0.4-7ubuntu2 (donc idem ton système)
une nouvelle installe de la version 1.12.2 avec modif du PHP.ini error_reporting = E_ALL | E_STRICT
ça passe pas vue le nombre important de messages erreurs et défauts sur les codes mysqli_driver.inc ++ adodb-time.inc.php on line 757
J-C Etiemble Tutoriels v 2.2.x
#11
J'ai refait des test sur machine de test debian en PHP 7 (7.05) en activant les erreurs
le code est bourré de de Deprecated et de Parse error .. l'ors de l'install et bien sur après Wink

mais normalement sans modifier le PHP.INI ça passe en modifiant pour éviter le blocage à l'étape 6 à cause de l'ERREUR
Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime()

Donc
Pour éviter ce blocage tu va modifier le ficher
/install/lib/classes/CMSInstallPage6.class.php à la linge 86 en commentant (mettre // devant @set_magic_quotes_runtime(false);

Code :
//        @set_magic_quotes_runtime(false);

l'install se fait et tout est OK

C'est un "hack" qui normalement ne doit pas être utiliser car les versions 1.12.x ne sont PAS conformes pour PHP 7.x

Il faut donc utiliser les versions 2.x
J-C Etiemble Tutoriels v 2.2.x
#12
@ Micky
Ton " nouvel OS" est en panne de carburant :lol:
J-C Etiemble Tutoriels v 2.2.x
#13
Bref ...

Windows, Wamp.
Après avoir enlevé le .htaccess et modifié le config.php

A l'installation j'ai le message d'erreur suivant

"
Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in C:\wamp\www\aag\lib\smarty\Smarty_Compiler.class.php on line 270
Call Stack
# Time Memory Function Location
1 0.0034 285352 {main}( ) ..\index.php:0
2 0.0328 2123216 Smarty->display( ) ..\index.php:136
3 0.0328 2123360 Smarty->fetch( ) ..\Smarty.class.php:1106
4 0.0328 2123600 Smarty->_compile_resource( ) ..\Smarty.class.php:1254
5 0.0332 2124968 Smarty->_compile_source( ) ..\Smarty.class.php:1422
6 0.0334 2209176 Smarty_Compiler->_compile_file( ) ..\Smarty.class.php:1492
7 0.0335 2209904 preg_replace ( ) ..\Smarty_Compiler.class.php:270
"

L'installation sans écraser les tables et sans installer les extensions me permet de retrouver les articles mais pas le reste. (pages, menu, ... )

En mode sample.

Merci de l'aide que vous pourrez m'apporter
#14
Citation :Windows, Wamp.
une fois tu es sous linux et maintenant sous win c'est complètement incohérent ces installations
C'est une Nouvelle installation ?
sur dossier vierge et base de données ou préfix de BD vierge ?
quelle version du cms ? je suppose la 1.12.2 (ce qui me semble bizarre car le Deprecated The /e modifier a été corrigé)
Version PHP apache Mysql ?

de plus Deprecated est une alerte sans conséquence donc ça doit fonctionner

mais comme je ne comprends pas ce que tu fais et que tu ne donnes pas assez d'information je vais laisser tomber
J-C Etiemble Tutoriels v 2.2.x
#15
Jce, j'aurais fait la même chose que lui pour vérifier si l'erreur provient bien de l'OS. Le pauvre est déjà assez embêté sans qu'on lui en remette une couche Wink
#16
@ Jean le problème c'est que les informations données sont incohérentes et incomplètes ...
et pas de réponse précises au questions

De plus si je ne me trompe pas Smarty_Compiler.class.php vient d'une vielle version 2.x de Smarty qui n'est plus utilisée depuis .... On est en version Smarty 3.x :/
J-C Etiemble Tutoriels v 2.2.x
#17
jce76350 a écrit :
Citation :Windows, Wamp.
une fois tu es sous linux et maintenant sous win c'est complètement incohérent ces installations
C'est une Nouvelle installation ?
sur dossier vierge et base de données ou préfix de BD vierge ?
quelle version du cms ? je suppose la 1.12.2 (ce qui me semble bizarre car le Deprecated The /e modifier a été corrigé)
Version PHP apache Mysql ?

de plus Deprecated est une alerte sans conséquence donc ça doit fonctionner

mais comme je ne comprends pas ce que tu fais et que tu ne donnes pas assez d'information je vais laisser tomber

Je fais de mon mieux pour aider une Association dont le site a été créé sous CMS Made Simple.
Ayant des connaissances en html css et php, j'espère pouvoir apporter l'aide demandée à la personne qui en a la charge.



Afin de ne pas impacter le site, nous avons convenu avec l'administrateur du site que je travaillerai en local.

En effet, j'ai changé d'OS, suite à ton message et en sachant que le site est de plus sous la version 1.12 Ponhpei.

J'ai installer ainsi sur un disque dur Windows et WAMP 2.5 avec :
-Version Apache:
2.4.9
-Version de PHP:
5.5.12
-Version de MySQL:
5.6.17

Une fois Windows et WAMP installés, j'ai importé la Base Mysql du site dans phpMyAdmin.

J'ai ensuite créé un dossier dans le répertoire wamp et copié les fichiers FTP du site.

Puis,j'ai modifié le fichier config.php comme tu me l'avais indiqué dans ton précédent message et supprimé le fichier .htaccess.

Enfin, je suis allé dans le dossier localhost/nom_du_dossier/install/index.php où j'ai eu les messages d'erreur.

Les caractéristiques du site :
-MySQL5.1
-CMS Made Simple™ 1.12 "Pohnpei"

On me demande "juste" de revoir les feuilles de style pour l'instant. http aquariophilie-gouesnou . fr , Le site à améliorer, si possible

Merci pour ton aide.
#18
Citation :Enfin, je suis allé dans le dossier localhost/nom_du_dossier/install/index.php où j'ai eu les messages d'erreur.

Les caractéristiques du site :
-MySQL5.1
-CMS Made Simple™ 1.12 "Pohnpei"
il est impossible d'avoir l'erreur Smarty_Compiler.class.php ... ce fichier n’existe pas en version 1.12.x. il vient sûrement d'un version ancienne 1.9.x ou moins

Citation :j'ai importé la Base Mysql du site dans phpMyAdmin.
J'ai ensuite créé un dossier dans le répertoire wamp et copié les fichiers FT du site.
quel était la version ? si version autre que la 1.12
dans ce cas il faut faire une mise à jour
J-C Etiemble Tutoriels v 2.2.x
#19
[EDIT]

Merci jce76350
#20
En production Il faut mettre à jour en version 1.12.2 Obligatoirement Cause failles possible
et vérifier pour supprimer les fichiers anciens Wink
J-C Etiemble Tutoriels v 2.2.x
#21
Le fichier template en php et ses classes font bugger l'installation et l'upgrade.

J'ai recommencé à zéro avec un nouvel import de la base de données.

J'ai essayé de supprimer les fichiers "à la sauvage" sans succès. Peut être qu'il faut éditer un fichier ?

Merci
#22
Alors il faut utiliser la méthode pas à pas
RAPPEL - en cas de problèmes avec une mise à jour Et de préférence avant mise à jour pour éviter ces "soucis" en utilisant de base la version 1.12.2
J-C Etiemble Tutoriels v 2.2.x
#23
Bonjour,

Je vais faire part de ces manipulations à l'admin.

Une fois faites, je recommencerai l'installation.

Merci JCE

Bonne semaine


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)