Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu] Module Navigator non installé après MAJ v2
#26
Si la 2.1.4 ne corrige pas ton problème, envoie-moi ta bd, je regarderai à ta place, mon couillon Wink
#27
Ha ben c'est gentiment proposé ça, alors du coup je vais m'y mettre tout de suite Smile .

Bon, ben la 2.1.4 ne règle pas mon problème.

Je t'envoie la base.
#28
Bien, après pas mal d'errements, Pavlov et moi avons trouvé la solution : Navigator refuse de s'installer car son type est déjà présent dans la BD :p
Solution, go to DB et supprimez dans la table cms_layout_tpl_type les 2 enregistrements y faisant référence : navigator navigation et navigator breadcrumbs.
Puis, dans l'admin du site, vous installez navigator et pas de message d'erreur Smile
#29
@Jean donne ta solution à Robert ou à Rolf sur le http://forum.cmsmadesimple.org/viewtopic...=3&t=74273, parce c'est un super bug que vous avez trouvé.
J-C Etiemble Tutoriels v 2.2.x
#30
Salut jce,
Alors ces vacances ? pas les pieds dans l'eau, j'espère Wink
J'ai déjà posté hier sur le .org.
Mais il va falloir vérifier plus en avant car un utilisateur a annoncé, à la suite de mon post, que la solution donnée amènerait un autre bug. Je m'en occupe ce soir avec Pavlov Smile
#31
Voilà, on a trouvé le pourquoi et la solution Smile

Le bug se produit lorsqu'on essaye d'upgrader un 1.12 vers 2.+ après avoir raté un premier upgrade (les pénibles débuts de 2.0.0).
Cette installation ratée a créé les tables cms_layout_***. Upgrade ratée, notre utilisateur a juste importé sa bd snapshot à partir de son espace client pour récupérer son site 1.12 en attendant les patchs.
Malheureusement, l'importation du snapshot (backup) à partir de l'espace client ne fait pas un DROP (suppression) des nouvelles tables et la BD 1.12 se retrouve avec des tables spécifiques à 2.0. CQFD.
Voilà comment Mr Calguy pourra reproduire le bug Smile

Il suffit de supprimer les tables cms_layout_*** ou seulement les 2 enregistrements cités plus haut dans la BD du site 1.12 AVANT d'effectuer l'upgrade vers 2.1.4. pour que le module navigator soit automatiquement installé lors de la mise à jour.
#32
Je passe en [Résolu], avec ma gratitude éternelle pour Jean le Chauve et ses 9 heures de hotline Cool .
Merci aussi à jce.
#33
Citation :Alors ces vacances ? pas les pieds dans l'eau, j'espère
non pas d'eau mais que du soleil Wink
Et super pour la résolution du bug (plus fort que robert, tu es)
J-C Etiemble Tutoriels v 2.2.x
#34
Oh oui, encore :p
#35
Bonjour,

J'étais bloqué exactement sur le même problème.
La suppression des tables tables cms_layout_*** avant la mise à jour 2.1.4 m'a effectivement permis de réaliser l'opération.

J'ai dû aussi désinstaller le module GBFilePicker préalablement à la mise à jour.


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)