Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
OVH arret PHP 4.X 5.2 5.3
#1
Bonjour

A partir du 24 Septembre 2015, OVH ne supportera plus les versions PHP obsolètes suivantes:
* PHP 4.x (fin de vie depuis + de 6 ans)
* PHP 5.2 (fin de vie depuis plus de 4 ans)
* PHP 5.3 (fin de vie depuis plus de 8 mois)

Mon site actuel utilise la version 5.2.17. Je dois donc faire une mise a jour de mon Cms c'est exact ?

Mise a jour de 1.10.3 "Hyacinthe" vers la derniere version de CMSMS. Je vais avoir des problemes ?

Cordialement

Maxime





Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: !1.11.x
#~ Url du site :
#~ Hébergeur / Soft : OVH
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 1.10.3
#~ Installed Modules:
#~ CMSMailer: 2.0.2
#~ CMSPrinting: 1.0
#~ FileManager: 1.2.0
#~ MenuManager: 1.7.7
#~ MicroTiny: 1.1.1
#~ ModuleManager: 1.5.3
#~ News: 2.12.3
#~ Search: 1.7
#~ ThemeManager: 1.1.4
#~ Gallery: 1.5.3
#~ FormBuilder: 0.7.2
#~ Showtime: 3.2
#~ Config Information:
#~ php_memory_limit:
#~ process_whole_template: false
#~ output_compression: false
#~ max_upload_size: 64000000
#~ default_upload_permission: 664
#~ url_rewriting: mod_rewrite
#~ page_extension: .html
#~ query_var: page
#~ image_manipulation_prog: GD
#~ auto_alias_content: true
#~ locale:
#~ default_encoding: utf-8
#~ admin_encoding: utf-8
#~ set_names: true
#~ Php Information:
#~ phpversion: 5.2.17
#~ md5_function: On (Vrai)
#~ gd_version: 2
#~ tempnam_function: On (Vrai)
#~ magic_quotes_runtime: Off (Faux)
#~ E_STRICT: 0
#~ memory_limit: 128M
#~ max_execution_time: 120
#~ output_buffering: On
#~ safe_mode: Off (Faux)
#~ file_uploads: On (Vrai)
#~ post_max_size: 64M
#~ upload_max_filesize: 64M
#~ session_save_path: /tmp (0700)
#~ session_use_cookies: On (Vrai)
#~ xml_function: On (Vrai)
#~ Server Information:
#~ Server Api: cgi
#~ Server Db Type: MySQL (mysql)
#~ Server Db Version: 5.1.73
#~ ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Ecrivez votre question ici.
#2
Bonjour,

Tu n'auras pas de problème si tu suis bien les recommandations de ce post :
http://www.cmsmadesimple.fr/forum/viewto...2356#p2356
Ou de cette page :
http://wiki.cmsmadesimple.fr/wiki/Maj_cm...e_host_ftp

Dans le cas de plusieurs versions majeures, il est recommandé de faire par étape, dans ton cas d'abord vers la 1.11.13 puis vers la 1.12.

Sauvegarde, mise à jour et test en local de préférence avant de basculer sur le serveur.

Il faudra également passer ton hébergement sur une version récente de PHP, la 5.5 ou 5.6, en procédant comme indiqué ici : http://www.cmsmadesimple.fr/forum/viewto...067#p41067
#3
Il faut passer obligatoirement maintenant en PHP 5.6.x

la version 5.5.x va passer le 10/07 en fin d' "Active Support"
J-C Etiemble Tutoriels v 2.2.x
#4
ttp://test2.girardetroux.com/

J'ai fait donc ma mise a jour. le site marche en locale mais pas sur le serveur d'OVH..


/home/girardet/www/girardnew/lib/adodb.functions.php:56 - offsetGet
/home/girardet/www/girardnew/lib/classes/class.CmsApp.php:229 - adodb_connect
/home/girardet/www/girardnew/include.php:201 - GetDb
/home/girardet/www/girardnew/index.php:71 - require_once
FATAL ERROR: Could not find database connection key db_password in the config file

Je suis sur d'avoir entré le bon mot de passe.

J'ai crée un fichier .ovhconfig comme indiqué.


Que faire ?

Merci
Cordialement.


$config['dbms'] = 'mysql';
$config['db_hostname'] = 'xxxxxxxxx.mysql.db';
$config['db_username'] = 'xxxxxxxxxx';
$config['db_passwgord'] = 'xxxxxxx';
$config['db_name'] = 'xxxxxx';
$config['db_prefix'] = 'cms_';
$config['db_port'] = 0;
$config['root_url'] = 'h t t p ://tes t.girardetroux.com'; ( j'ai volontairement cassé l'url sinon je ne pouvais pas poster.)
$config['query_var'] = 'page';
$config['timezone'] = 'Europe/Paris';
$config['default_encoding'] = 'utf-8';
$config['admin_dir'] = 'adminsite';
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';


Édité par modérateur [Ouik] : ne jamais laisser les données sensibles visibles !!!
#5
max38320 a écrit :$config['db_passwgord'] = 'xxxxxxx';

passwgord ? Ça ne viendrait pas de là des fois ? -> password.
#6
Effectivement c'est mieux Big Grin

Je n'ai plus le message d'erreur de BDD mais maintenant j'ai une page blanche.

Sad


erci


[== Indéfini ==]
app.engine=php
app.engine.version=5.5
http.firewall=none
environment=production

#PHP5 on OVH MUTU
SetEnv PHP_VER 5.5
SetEnv SESSION_USE_TRANS_SID 0

#Do not display list files of a directory
Options -Indexes

RewriteEngine on


# 301 Redirect all requests that don't contain a dot or trailing slash to
# include a trailing slash
# except for form POSTS
# RewriteCond %{REQUEST_URI} !/$
# RewriteCond %{REQUEST_URI} !\.
# RewriteCond %{REQUEST_METHOD} !POST$
# RewriteRule ^(.*) %{REQUEST_URI}/ [R=301,L]

# Rewrites urls in the form of /parent/child/
# but only rewrites if the requested URL is not a file or directory
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+).html$ index.php?page=$1 [QSA]
#7
Citation :Je n'ai plus le message d'erreur de BDD mais maintenant j'ai une page blanche.
le mode recherche te donne une solution de debugage Cool
Question 1 : Après une mise à jour, j'ai une page blanche ou autre problème d'affichage
J-C Etiemble Tutoriels v 2.2.x
#8
Fatal error: Attempt to connect to database girdardetsite2 on [email protected] failed in /home/girardet/www/girardnew/lib/adodb.functions.php on line 61

Je suis sur d'avoir inséré toutes les bonnes informations.
#9
Essaye en enlevant ceci : $config['db_port'] = 0;
#10
ça ne change rien.

Merci

Cordialement
#11
> Fatal error: Attempt to connect to database girdardetsite2 on :.... adodb.functions.php on line 61
>Je suis sur d'avoir inséré toutes les bonnes informations.

Non c'est pas possible tu es as surement fait une erreur sur un des paramètres
db_hostname, db_username, db_password, db_name
J-C Etiemble Tutoriels v 2.2.x
#12
Citation :$config['db_hostname'] = 'xxxxxxxxx.mysql.db';
$config['db_username'] = 'xxxxxxxxxx';
$config['db_password'] = 'xxxxxxx';
$config['db_name'] = 'xxxxxx';
Ton erreur provient d'une des valeurs entrées ici, il n'y a pas d'autre possibilité.
Vérifie dans le config.php de ton backup 1.10.3 ou l'email envoyé par OVH lors de l'achat de l'hébergement.
#13
Bonjour,

Votre base MySQL a été installée sur notre serveur.


Voici les données techniques:
-----------------------------

MySQL:
Serveur : girardetsite2.mysql.db
Utilisateur : girardetsite2
Nom de la base : girardetsite2

Mot de passe : vous seul le connaissez



J'ai volontairement supprimé la ligne root url car je ne pouvais pas poster le message.
Important:
----------

$config['dbms'] = 'mysql';
$config['db_hostname'] = 'girardetsite2.mysql.db';
$config['db_username'] = 'xxxxxxx';
$config['db_password'] = 'xxxxxx';
$config['db_name'] = 'xxxxxx';
$config['db_prefix'] = 'cms_';
$config['db_port'] = 0;

$config['query_var'] = 'page';
$config['timezone'] = 'Europe/Paris';
$config['default_encoding'] = 'utf-8';
$config['admin_dir'] = 'adminsite';
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';


Si je vais sur l'url /test2.girardetroux.com/install/upgrade.php

J'ai cette erreur

Parse error: syntax error, unexpected $end in /home/girardet/www/girardnew/lib/smarty/libs/sysplugins/smarty_resource_custom.php on line 50

[edit Ouik : j'ai à nouveau supprimé les données sensibles]
#14
Hum, à moins que je ne me trompe, ça n'est pas lié à l'accès à la base de données cette fois. As-tu vérifié que tous les fichiers sont présents sur ovh ?
#15
>Si je vais sur l'url /test2.girard ....upgrade.php

Ca fonctionne ce matin 10h23 et c'est même dangereux ds laisser possible l'accès à tous !!!
j'ai pu lancer la mise à jour :/
de plus comme tu as laisser trainer tes identifiants tu as intérêt à changer rapidement les mots de passe


par contre sauf erreur il n'y a pas la balise
<meta name="Generator" content="CMS Made Simple - Copyright © 2004-14 Ted Kulp. All rights reserved." />
ou
<meta name="generator" content="CMS Made Simple - Copyright © 2004-2014. All rights reserved." />
J-C Etiemble Tutoriels v 2.2.x
#16
Et il faudrait connaître la procédure que tu as suivie. As-tu upgradé sur ton serveur local, puis renvoyé tout vers OVH, ou as-tu tout fait directement sur OVH ?
Soit tes fichiers sont corrompus (comme dit Ouik), soit tu as oublié de vider le dossier tmp.
root_url et db_port ne doivent plus figurer dans le config.php
#17
jce76350 a écrit :>Si je vais sur l'url /test2.girard ....upgrade.php

Ca fonctionne ce matin 10h23 et c'est même dangereux ds laisser possible l'accès à tous !!!
j'ai pu lancer la mise à jour :/
de plus comme tu as laisser trainer tes identifiants tu as intérêt à changer rapidement les mots de passe

Toujours vrai à 15h27. Une telle absence de sécu fait peur...
#18
D'ailleurs, d'après l'install, l'hébergement est toujours en php 5.3...
#19
@ max38320 c'est résolu ??
J-C Etiemble Tutoriels v 2.2.x
#20
Bonjour, pb résolu.

Merci à tous pour votre aide.

J'ai re uploadé tout le site du local vers le ftp.
ça a fonctionné.

Merci beaucoup


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)