Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Version 2.0 RC1
#26
J'utilise maintenant la RC1 de manière intensive pour mettre à jour un gros site (300 pages). Je trouve que le nouveau gestionnaire de contenus est beaucoup plus lent et moins réactif que l'ancien pour ce qui est de déployer ou contracter les sections.

La partie editer un design du gestionnaire de design tourne vite au cauchemar.
Dans la liste de gauche les templates et les css sont en vracs sans aucun ordre. Il faut dérouler et enrouler la liste dans tous les sens pour retrouver ce que l'on cherche. C'est d'autant plus difficile que les templates ne sont plus distingués par leur type ce qui oblige à surcharger les noms avec des préfixes page, news-detail, news-summary...
Si on a un doute sur un template il faut revenir le chercher dans la partie template alors qu'il aurait été tellement plus simple de rendre les noms des templates clickables dans l'éditeur de designs.

Je crois que je vais me fendre d'un message sur le site anglais lorsque les bugs seront moins nombreux (et graves pour une RC1). On peut rêver d'améliorations dans la version 2.1 c'est pourquoi je l'intitulerai 'I have dreams" Big Grin Big Grin
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#27
Citation :Je crois que je vais me fendre d'un message sur le site anglais lorsque les bugs seront moins nombreux
Remarque vu le nombre de testeurs les bugs me semblent pas très nombreux :lol:
Il va y avoir des surprises lors des mise à jour ....
J-C Etiemble Tutoriels v 2.2.x
#28
Il me semblait que la V2 devait mieux gérer les "gros" sites que la V1, perso j'ai un site avec plus de 550 pages (en 1.12), le plier/déplier ne se met en place que si je recharge la page... Je n'ai pas testé en V2 pour le moment.

Concernant le gestionnaire de design, je trouve ça aussi un peu fouillis, mais comme on peut organiser un peu tout, filtrer, je crois qu'il faut déjà tester les différentes possibilités offertes.

Un des trucs qui me gonflent par contre, c'est que la possibilité d'ajouter des classes dans l'éditeur wysiwyg a sauté. Il avait déjà fallu lutter pour le garder quand on est passé de tinymce à micro-tiny, mais là, hop ! :mad:
#29
jce76350 a écrit :Remarque vu le nombre de testeurs les bugs me semblent pas très nombreux :lol:
A quoi servent les deux snapshots journaliers alors?


Je n'arrive pas à faire comprendre à calguy1000 que start_level ne fonctionne pas
http://forum.cmsmadesimple.org/viewtopic...82&t=73097
mon anglais est pourri
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#30
Citation :jce76350 a écrit :
Remarque vu le nombre de testeurs les bugs me semblent pas très nombreux
archeo a écrit :
A quoi servent les deux snapshots journaliers alors?
Il suffit de regarder le nom et le nombre de posteurs sur CMSMS 2.0 Beta
9 reporteurs dont 3 Frenchies

Citation :e n'arrive pas à faire comprendre à calguy1000 que start_level ne fonctionne pas
de toute façon il veut bien comprendre quand il veut seulement

EDIT Je pense (heu... pas sur du tout mais) qu'il a résolu ton problème en SVN 10074
J-C Etiemble Tutoriels v 2.2.x
#31
Pas résolu dans le snapshot de cette nuit. J'ai proposé une solution qui reste à tester. C'est un problème de positionnement d'un pointeur dans un tableau en partant de la fin et dont la dernière valeur m'a l'air d'être vide.

http://forum.cmsmadesimple.org/viewtopic...7&start=15
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#32
@ archeo la rev 10079 doit etre OK (je tai passé les modifs par mail)
J-C Etiemble Tutoriels v 2.2.x
#33
calguy1000 n'a pas tenu compte de la proposition de modification de start_level dans le snapshot de cette nuit. Mais je crois que ce bug l'agace voir le commentaire d'une SVN : "more fixes for stupid start_level param" :lol: :lol: :lol: .

Au sujet du verrouillage du gestionnaire de contenu, ça a l'air de fonctionner correctement avec deux utilisateurs différents. Lorsque l'un édite une page celle-ci apparait verrouillée pour l'autre. Le verrou disparait dés la fin de l'édition. Par contre il faut faire le test en utilisant deux navigateurs différents. Si on ouvre les deux utilisateurs différents dans deux fenêtres de firefox ça bug. Ce qui serait bien c'est que le propriétaire du verrou puisse le supprimer quand il veut
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#34
Vos remarques sur http://www.cmsmadesimple.fr/forum/viewto...265#p42265

@ archeo
Citation :calguy1000 n'a pas tenu compte de la proposition de modification de start_level
Il a modifié mais il n'est pas sur que s'il re-modifie cela perturbe plus suivant le start_level

Citation :Au sujet du verrouillage du gestionnaire de contenu, ça a l'air de fonctionner
ça fonctionne mais faut pas non plus pousser, ça doit être rare que plusieurs utilisateurs modifient le même contenus en même temps :|
J-C Etiemble Tutoriels v 2.2.x
#35
jce76350 a écrit :Il a modifié mais il n'est pas sur que s'il re-modifie cela perturbe plus suivant le start_level
En gros il faut tester quelle modif? et encore en gros, il est pas sur de l'algorithme. Je m'y colle ce soir, je vais tester tous les cas de start_level jusqu'à 6 et tous les level de 1 à 6 (36 possibilités)
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#36
>En gros il faut tester quelle modif?
tu peux le contacter directement sur IRC
par exemple avec ChatZilla
J-C Etiemble Tutoriels v 2.2.x
#37
J'ai fait une dernière proposition de modification de start_level sur le forum anglais vous pouvez tester avec cette base de données http://ciavatti.free.fr/cmsv2/cmsrc1.sql(2).zip qui a des menus avec des menus de niveau 6.

le fichier de remplacement dans modules/Navigator http://ciavatti.free.fr/cmsv2/action.default.txt

Le template "Top simple navigation + left subnavigation + 1 column" est appliqué à toutes les pages

dans le gabarit il faut modifier le start_level du menu de gauche à la ligne :
Code :
[== Indéfini ==]
{Navigator loadprops=0 template='Simple Navigation'  start_level =2 collapse='1'}

J'ai testé pour start menu de 0 à 7 en explorant toutes les pages.
Pour des start level >2 Vous n'aurez pas d'affichage du menu de droite en cliquant sur le menu du haut c'est normal. Pour avoir l'affichage il faut sur une page située à un niveau plus élevée. Pour atteindre ces pages il faut utiliser le menu du bas.

On peut synchroniser les 3 menus en mettant start_level=2 pour le menu de droite et start_level=3 pour le menu du bas

Si vous pouviez refaire les tests....et d'autres plus tordus.... Big Grin Rolleyes
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#38
Peut pas télécharger "action.default.php" change son extension sur ta page en *.txt
J-C Etiemble Tutoriels v 2.2.x
#39
désolé c'est fait
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#40
>le fichier de remplacement dans modules/Navigator http://ciavatti.free.fr/cmsv2/action.default.txt
Déjà ça fonctionne bien sur les pages livrées avec le core Wink
je continue ...
ça a l'air de bien fonctionner mais je ne suis pas un super expert en menus
J-C Etiemble Tutoriels v 2.2.x
#41
Je suis sidéré par la réponse de calguy au sujet de start level. Je préfère ne pas lui répondre. Manifestement il ne sait pas a quoi sert la fonction.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#42
Dans la mesure ou cette fonctionnalité est importante(capitale) pour les sites à fort contenu peut être acceptera-t-il d'intégrer ta modification si d'autres développeurs veulent bien y jeter un œil pour la valider et en discuter avec lui.
Win 7 pro 64 - CMSMS 1.6.4 à 2.2.9
#43
Citation :Je suis sidéré par la réponse de calguy au sujet de start level. Je préfère ne pas lui répondre.
Si tu es sur de ton coup tu peux lui répondre, et donc persévérer
On a déjà eu le cas avec des problèmes sous windaube et on l'a eu à l'usure Wink

Citation : Manifestement il ne sait pas a quoi sert la fonction.
Vu que c'est le seul développeur j'espère que oui il connait la fonction, mais ça l'e... ce truc
comme je ne suis pas expert en menus je ne peux pas faire grand chose, mais il y a ici des "balaises" ici qui peuvent surent argumenter.
J-C Etiemble Tutoriels v 2.2.x
#44
Perso je ne comprends pas l'intérêt du start_level="1", et pourtant j'utilise abondamment le module Navigator (j'ai d'ailleurs débusqué quelques bugs les semaines passées). Tu peux m'expliquer ?
#45
Salut,

En voulant tester la RC1, je me suis confronté à un problème sur lequel je bataille depuis plus de 4 heures sans comprendre.
Je souhaite utiliser le module FrontEndUsers et sa capacité à offrir des « Contenus protégés » comme type de contenu.

J'ai bien créé les groupes, les utilisateurs, choisi « Contenu protégé » et sélectionné les groupes d'utilisateurs pouvant accéder à la page... et bien les pages dites protégées sont lisibles de tous sans identification ou avec identification.

Une piste avant de contacter CG ?

Merci
Exacore - Freelance en communication
#46
Ouik a écrit :Perso je ne comprends pas l'intérêt du start_level="1", et pourtant j'utilise abondamment le module Navigator (j'ai d'ailleurs débusqué quelques bugs les semaines passées). Tu peux m'expliquer ?
Il n'y a pas de start level 1 a juste titre d'après le code. Le soucis c'est que tel que calguy le conçoit il y a un decallage de 1 par rapport à ce que fait menu. Si on a un start level de 2 pour un menu il doit afficher le sous menus de niveau 2 du menu principal correspondant à la page active. Si le start level est de 3 le sous menu de niveau 3. La correction minime que lui propose permet de reproduire exactement le comportement du start level de menu.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#47
exacore a écrit :Salut,

En voulant tester la RC1, je me suis confronté à un problème sur lequel je bataille depuis plus de 4 heures sans comprendre.
Je souhaite utiliser le module FrontEndUsers et sa capacité à offrir des « Contenus protégés » comme type de contenu.

J'ai bien créé les groupes, les utilisateurs, choisi « Contenu protégé » et sélectionné les groupes d'utilisateurs pouvant accéder à la page... et bien les pages dites protégées sont lisibles de tous sans identification ou avec identification.

Une piste avant de contacter CG ?

Merci
Je n'ai pas encore eu le temps de tester FEU avec la V2, désolé. Sur la dernière version de FEU, il a semble-t-il changé pas mal de choses...
#48
archeo a écrit :
Ouik a écrit :Perso je ne comprends pas l'intérêt du start_level="1", et pourtant j'utilise abondamment le module Navigator (j'ai d'ailleurs débusqué quelques bugs les semaines passées). Tu peux m'expliquer ?
Il n'y a pas de start level 1 a juste titre d'après le code. Le soucis c'est que tel que calguy le conçoit il y a un decallage de 1 par rapport à ce que fait menu. Si on a un start level de 2 pour un menu il doit afficher le sous menus de niveau 2 du menu principal correspondant à la page active. Si le start level est de 3 le sous menu de niveau 3. La correction minime que lui propose permet de reproduire exactement le comportement du start level de menu.
Huh ! Il va falloir que tu explicites un peu plus (enfin si tu veux, hein), parce que j'ai guère plus compris. :p
#49
Bonjpour,
Archeo a écrit :Si on a un start level de 2 pour un menu il doit afficher le sous menus de niveau 2 du menu principal correspondant à la page active.
je n'ai suivi que de loin et pas testé, mais est-ce qu'il y a un décalage de 1 si tu compares avec une 1.11?
Parce que le start_level=2 est le second niveau du menu et pas le sous-menu de niveau 2...
{SEO}
Inscrivez-vous à notre Newsletter sur le site (colonne de droite, en bas).
Vous appréciez CMSMS et l'aide qui vous est fournie ici, aidez-nous en participant au projet.
Formation CMS Made Simple | Création de site CMS Made Simple.

C'est en se plantant qu'on devient cultivé.
J'ai un string dans l'Array (Paris Hilton)
#50
jissey a écrit :Bonjpour,
Archeo a écrit :Si on a un start level de 2 pour un menu il doit afficher le sous menus de niveau 2 du menu principal correspondant à la page active.
je n'ai suivi que de loin et pas testé, mais est-ce qu'il y a un décalage de 1 si tu compares avec une 1.11?
Parce que le start_level=2 est le second niveau du menu et pas le sous-menu de niveau 2...
Oui mais du coup c'est le sous menu de niveau 2 qui peut s'afficher. En ce moment je n'a plu de temps dispo pour faire des tests. Mais pour le faire il faut avoir un gabarit avec 3 menus et 3 start level différents. Appliquer ce gabarit à toutes les pages d'une demo du core V1 où on aura ajouté des pages pour atteindre des niveau de sous menus 5 ou 6 et des branchements comme je l'ai fait pour la V2 dans le fichier de base de données que j'ai fourni plus haut. Faire ensuite une mise à jour et comparer le comportement des menus de start level 2 et start level 3.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)