Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Version 2.0 RC1
#1
Version 2.0 RC1 qui sera surement la dernière avant la version finale 2.0
Existe déjà en version SVN et...
arrive en test avec 2 snapshots par jour
[EDIT du 21/06/2015] les snapshots de la RC1 et 2;0
L'annonce sur le forum EN Announcing CMSMS 2.0 RC1



L'information sur le forum En CMSMS 2.0 Update

L'ancienne Discussion sur la version 2.0 béta3
L'ancienne Discussion sur la version 2.0 béta2
L'ancienne Discussion sur la version 2.0 béta1


Merci pour vos retours sur les hébergements compatibles V2
Liste des hébergements compatibles V2

Un forum EN est ouvert pour repoter vos bugs pour cette RCCMSMS 2.0 Beta
Sur ce même forum une discussion pour les développeurs Module Developers

RAPPEL
Le téléchargement est possible suivant 2 possibilités :
A- Nouveau système d'installation/mise à jour en un seul fichier PHAR (Recommandé)
(comprend l'installateur et tous les fichiers de CMSms). cmsms-2.0-rc1-install.zip
1 - Décompacter le fichier cmsms-rc1-install.zip
2 - Cela va créer un fichier cmsms-rc1-install.php et README-FR-PHAR.TXT + phar_modif_Fr.txt
3 - A l'aide de votre navigateur, accédez fichier cmsms-<version>-install.php

B- Variante pour les serveurs incompatibles avec le PHAR (si le PHAR ne fonctionne pas)
Jeu de fichiers cmsms-2.0-rc1-install.expanded.zip
1 - Utiliser le gestionnaire de fichiers de votre Hébergeur créer un nouveau sous-dossier, dans le dossier /cms dans lequel vous souhaitez installer CMSMS. exemple vous pouvez nommer ce dossier cmsms_install
Par exemple : /public_html/cms/cmsms_install
- CMSMS sera installé dans /cms
- les fichiers de l’installateur seront dans cmsms_install
2 - Uploadez le fichier cmsms-rc1-install.expanded.zip dans ce sous-dossier.
3 - Extraire les fichiers de l'archive zip dans ce sous-dossier.
Cela va créer de nombreux fichiers et dossiers. Donc faites attention que vous extrayez les fichiers dans le dossier approprié.
4 - A l'aide de votre navigateur, accédez au dossier créé à l'étape 1.
Par exemple: http://www.monsitewebe/cms/cmsms_install
J-C Etiemble Tutoriels v 2.2.x
#2
Elle est téléchargeable où? Parce que sur le site anglais c'est la beta3 qui est disponible.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#3
Yep, JCE bien qu'en vacances fait tout de même un suivi de sortie des versions : http://jc.etiemble.free.fr/abc/index.php...rcesfr_dev

On en est à la rev10036 pour le moment.
#4
merci, je télécharge et je teste.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#5
Test d'export import de design:

export de "CSSMenu left + 1 column"

à l'import, on obtient le message "un gabarit du même nom existe déjà" ce qui est nouveau car de mémoire les gabarits en doublons avaient un nom modifié avec un 2

même si l'on supprime tous les gabarits le message persiste.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#6
J'ai pas l'impression que l'on progresse avec cette RC1. La version de base de donnée de mon site qui était compatible avec une mise à jour ne l'est plus... Je me demande combien de sites sont compatibles avec une mise à jour. Je pense que dans les mois à venir je vais avoir une grave décision à prendre.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#7
J'avais une erreur "template vide" lors de la mise à jour avec une base de donnée.
J'ai supprimé tous les template sauf minimal et tous les CSS. J'ai ensuite affecté minimal à toutes les pages et là la mise à jour s'est faîtes correctement et j'ai récupéré le contenu de toutes les pages.

C'est maintenant la galère pour mettre en forme les pages. J'ai importé le design "CSSMenu left + 1 column" mais les menus ne fonctionnent pas correctement sur toutes les pages et j'ai maintenant l'erreur :

Erreur : à la ligne7 dans le fichier C:\wamp\www\test-mise-a-jour\lib\smarty\sysplugins\smarty_internal_templatecompilerbase.php :
Erreur de syntaxe "content:content_en" ligne 7 "
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#8
comme c'est la fête ....
voila 2.0-RC1 Fr : 0.99.6_r182-10040-Fr (20/06/2015)
J-C Etiemble Tutoriels v 2.2.x
#9
Et en prime pour l'arrivée de l'été Announcing CMSMS 2.0 RC1

les snapshots de la RC1
2 par jour Cool
J-C Etiemble Tutoriels v 2.2.x
#10
C'est la fête (de l'été, de la musique, de CMSMS) ! Cool
#11
le #5 était effectivement un bug : http://forum.cmsmadesimple.org/viewtopic...82&t=73057 qui est résolu.


Voici quelques étapes et péripéties d'une mise à jour :

J'avais un message d'erreur "templates empty" qui en fait s'est révélé être une feuille de style vide. Une fois l'erreur corrigé la mise à jour s'est poursuivie jusqu'à son terme.

Mais la mise en forme des pages était perdu, les feuilles de styles n'étant pas prise en compte (sauf une) lors de l'association dans le design.

Après pas mal de d'essais infructueux j'ai exporté les gabarits de la V1 un par un en utilisant le gestionnaire de thèmes. L'import s'est passé correctement j'ai récupéré des design contenant le template et les feuilles de style qui lui était associé. L'association se fait maintenant au niveau du design (normal). La mise en forme obtenue avec ces designs est correcte, ouf!

Mais je ne trouve aucune trace des global contents qui devraient être là sous forme de template core::generique. Pourtant ils sont parfaitement fonctionnels, ils contiennent même des erreurs qui ne sont plus supportées par la V2 comme l'utilisation de fonctions PHP entre 2 accolades de smarty. Ais-je laissé passer une info sur un mode compatibilité pour les global contents comparable à ce qui existe pour les menus?
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#12
J'ai remplacé loadprops=0 par start_level="1"

{Navigator loadprops=0 template='cssmenu_ulshadow'}

{Navigator start_level="1" template='cssmenu_ulshadow'}

L'affichage de la page plante au niveau du menu
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#13
Otez moi un doute. Avec ce code, le menu vertical affiche le sous menu de l'item sélectionné dans le menu horizontal. Par exemple si 2 est sélectionné dans le menu horizontal le menu vertical affichera 2.1, 2.2, 2.3.... Si ensuite on sélectionne 2.3 dans le menu horizontal, le menu vertical affichera 2.3.1, 2.3.2, 2.3.3...

Code :
[== HTML ==]
[...]
{* stylesheet  "Navigation Simple - Horizontal" *}
        <h2 class="accessibility">Navigation</h2>
        {Navigator loadprops=0 template='Simple Navigation' number_of_levels='3'}
        <hr class="accessibility" />
[...]
{* Start Sub Navigation, stylesheet  "Navigation Simple - Vertical" *}
            <div id="menu_vert">
              <h2 class="accessibility">Sub Navigation</h2>
              {Navigator loadprops=0 template='Simple Navigation' start_level='2' collapse='1'}
                <hr class="accessibility" />
            </div>
[...]

par contre avec ce code

Code :
[== HTML ==]
[...]
{* stylesheet  "Navigation Simple - Horizontal" *}
        <h2 class="accessibility">Navigation</h2>
        {Navigator loadprops=0 template='Simple Navigation'  start_level='1' number_of_levels='1'}
        <hr class="accessibility" />
[...]
{* Start Sub Navigation, stylesheet  "Navigation Simple - Vertical" *}
            <div id="menu_vert">
              <h2 class="accessibility">Sub Navigation</h2>
              {Navigator loadprops=0 template='Simple Navigation' start_level='2' collapse='1'}
                <hr class="accessibility" />
            </div>
[...]

Le menu vertical affichera toujours le deuxième niveau du menu horizontal quelque soit le sous niveau de sélection dans le niveau horizontal. Si 2 est sélectionné en horizontal le vertical affichera 2.1 2.2 2.3 ... si maintenant on sélectionne en horizontal (dans le menu déroulant) 2.2 on aura toujours en vertical 2.1, 2.2, 2.3... C'est comme cela que ça marchait dans la version 1, enfin je crois
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#14
@ archeo ; je vois que tu suis bien la RC1
mais tu me sembles un peu seul Wink
j'ai testé et j'ai toujours un gros soucis avec certaines mise à jour depuis les 1.12 (j'ai envoyé une BD critique a Robert)
Par contre pour MLE ça m...douile, même après les SVN d'hier.
J'ai fais de test sur béta-pages perso Free PHP 5.6.8, mais c'est pas top pour la V2
J-C Etiemble Tutoriels v 2.2.x
#15
Je suis d'autant plus motivé que je teste la mise à jour de mon site. Pour autant que je puisse en juger ça coince niveau start_level ( http://forum.cmsmadesimple.org/viewtopic...2&t=73097) dans navigator.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#16
est-ce que quelqu'un pourrait faire les tests que j'ai proposé à la fin de ce message http://forum.cmsmadesimple.org/viewtopi … 2&t=73097 pour confirmer que start_level ne fonctionne pas encore de façon correcte.

Les majuscules sont interdites dans les alias de pages : Test ou tEst provoque l'erreur
"L'alias saisi contient des caractères non valides. Les espaces, "/" "." et autres signes de ponctuation/accentuation ne sont pas autorisés."
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#17
Citation :est-ce que quelqu'un pourrait faire les tests que j'ai proposé à la fin de ce message http://forum.cmsmadesimple.org/viewtopi … 2&t=73097 pour confirmer que start_level ne fonctionne pas encore de façon correcte.
quel modif veut tu verifier parce c'est pas clair pour moi
envoi moi ton design en xml

Citation :Les majuscules sont interdites dans les alias de pages : Test ou tEst provoque l'erreur
"L'alias saisi contient des caractères non valides. Les espaces, "/" "." et autres signes de ponctuation/accentuation ne sont pas autorisés."
Par contre le é à et surement les autre accents passent
..contacté.html contactà.html
http://jce.cmsms.fr/cms_dev/default-exte...C3%A9.html

idem pour les nom de gabarits et feuilles de styles : accent possibles
exemple gabaritéà et styleéàçè
[EDIT http://forum.cmsmadesimple.org/viewtopic...2&t=73140]

De plus si je change un design par un autre en étant sur une page (onglet Options) j'ai la page verrouillée automatiquement
[EDIT http://forum.cmsmadesimple.org/viewtopic...2&t=73139]
J-C Etiemble Tutoriels v 2.2.x
#18
La base de données de test est téléchargeable ici :

http://ciavatti.free.fr/cmsv2/cmsrc1.sql.zip

J'ai ajouté des pages avec une hiérarchie de test 1 1.2 1.3 1.2.1 ...
Dans la page d'accueil il faut aller à 1 puis dans le menu déroulant 1.2. Ensuite parcourir les pages de hiérarchie inférieuredans le menu de gauche en observant le comportement du menu de gauche (il n'a pas de css) dont le start_level est à 2.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#19
j'ai fais
Dans la page d'accueil il faut aller à 1 puis dans le menu déroulant 1.2
[Image: 1_2.jpg]

et ça donne
[Image: vue1_2.jpg]

j'ai bon ?
J-C Etiemble Tutoriels v 2.2.x
#20
ensuite il faut cliquer sur 1.2.2

http://ciavatti.free.fr/cmsv2/cmsrc1_122.JPG

puis 1.2.2.1

http://ciavatti.free.fr/cmsv2/cmsrc1_1221.JPG
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#21
>ensuite il faut cliquer sur 1.2.2
[Image: 122.jpg]

>puis 1.2.2.1
[Image: 1221.jpg]
J-C Etiemble Tutoriels v 2.2.x
#22
Manifestement cela ne reste pas bloqué à start_level='2', non? et ce n'est pas du tout le comportement du même menu avec le version 1
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#23
jce76350 a écrit :De plus si je change un design par un autre en étant sur une page (onglet Options) j'ai la page verrouillée automatiquement

Je confirme pareil pour moi. Cette fonction de verrouillage est complétement pourrie. Je pense qu'il serait préférable de l'oublier.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7
#24
>Manifestement cela ne reste pas bloqué à start_level='2',
tu mettre utiliser mes images pour la démo

>Je confirme pareil pour moi. Cette fonction de verrouillage est complétement
j'avais passé un mail à Robert
je vais donc créer un report ce soir [EDIT fait]
J-C Etiemble Tutoriels v 2.2.x
#25
J'ai un peu modifié les noms et alias en préfixant avec ele_ pour qu'il n'y ai pas de confusion avec la hiérarchie. Je refais des copies d'écran et je met le lien vers la base de données.

D'autre part si tu regardes dans le gabarit de le page juste sous le texte menu (<p>menu</p>) il y a le tag {menu loadprops=0 template='simple_navigationV1' start_level='2' collapse='1'} qui manifestement ne fonctionne pas.

J'ai passé au crible tous les autres paramètres de Navigator : pas de lézard.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.0.3,
PhP 7.0.6,
CMS version 2.2.7


Atteindre :


Utilisateur(s) parcourant ce sujet : 2 visiteur(s)