Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Images qui ne s'affichent pas en ligne, mais s'affichent bien en local
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 1.11.11
#~ Url du site :
#~ Hébergeur / Soft :
#~ Informations Système :
#~ #~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ #~ Version du CMS: 1.11.12
#~ #~ Url du site :
#~ #~ Hébergeur / Soft :
#~ #~ Informations Système :
#~ #~ ----------------------------------------------
#~ #~ Cms Version: 1.11.12
#~ #~ Installed Modules:
#~ #~ CMSMailer: 5.2.2
#~ #~ CMSPrinting: 1.0.5
#~ #~ FileManager: 1.4.5
#~ #~ MenuManager: 1.8.6
#~ #~ MicroTiny: 1.2.8
#~ #~ ModuleManager: 1.5.8
#~ #~ News: 2.14.4
#~ #~ Search: 1.7.11
#~ #~ ThemeManager: 1.1.8
#~ #~ Ouverture: 1.0
#~ #~ RJslider: 1.0
#~ #~ CGExtensions: 1.45
#~ #~ CGJobMgr: 1.3.4
#~ #~ CGSimpleSmarty: 1.7.4
#~ #~ NMS: 2.9.5
#~ #~ Guestbook: 1.4_RC2
#~ #~ Config Information:
#~ #~ php_memory_limit:
#~ #~ process_whole_template:
#~ #~ max_upload_size: 16000000
#~ #~ url_rewriting: none
#~ #~ page_extension:
#~ #~ query_var: page
#~ #~ image_manipulation_prog: GD
#~ #~ auto_alias_content: true
#~ #~ locale:
#~ #~ default_encoding: utf-8
#~ #~ admin_encoding: utf-8
#~ #~ set_names: true
#~ #~ Php Information:
#~ #~ phpversion: 5.4.3
#~ #~ md5_function: On (Vrai)
#~ #~ gd_version: 2
#~ #~ tempnam_function: On (Vrai)
#~ #~ magic_quotes_runtime: Off (Faux)
#~ #~ E_STRICT: 0
#~ #~ E_DEPRECATED: 8192
#~ #~ memory_limit: 1024M
#~ #~ max_execution_time: 180
#~ #~ output_buffering: 1
#~ #~ safe_mode: Off (Faux)
#~ #~ file_uploads: On (Vrai)
#~ #~ post_max_size: 16M
#~ #~ upload_max_filesize: 16M
#~ #~ session_save_path: E:/wamp/tmp (0777)
#~ #~ session_use_cookies: On (Vrai)
#~ #~ xml_function: On (Vrai)
#~ #~ xmlreader_class: On (Vrai)
#~ #~ Server Information:
#~ #~ Server Api: apache2handler
#~ #~ Server Db Type: MySQL (mysqli)
#~ #~ Server Db Version: 5.6.12
#~ #~ Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
#~ #~ Server Time Diff: Aucune différence de date du système de fichiers trouvées
#~ #~ ----------------------------------------------
#~ #~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bonjour,

Je suis en train de mettre en ligne un site et je rencontre un souci, tous mes images ne s'affichent pas. EN local sur wamp j'ai bien les images. L'url que MicroTyny a ajouter n'est pas bon car il a ajouter le dossier /MON-SITE/uploads/... au lieu de : uploads/images/... tout simplement. Y a t'il un moyen de configurer cela pour que ca marche en local et en ligne en même temps car la je dois changer tous les url de mes images manuellement et ca fait beaucoup.
Merci.
#2
Copie-nous ton config.php et ton .htaccess
#3
$config['dbms'] = 'mysqli';
$config['db_hostname'] = 'localhost';
$config['db_username'] = '****';
$config['db_password'] = '****';
$config['db_name'] = '****';
$config['db_prefix'] = 'wm_';
$config['timezone'] = 'UTC';
$config['url_rewriting'] = 'mod_rewrite';
$config['root_path'] = 'E:\wamp\www\webm';
$config["image_uploads_path"] = 'E:\wamp\www\webm\uploads';
$config['page_extension'] = '.html';



<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /webm/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php?page=$1 [QSA]
</IfModule>

<IfModule mod_headers.c>
# Disable ETags
Header unset ETag
FileEtag None
# For Security
Header set X-Frame-Options "SAMEORIGIN"
</IfModule>

<IfModule mod_deflate.c>
# Compress css, plaintext, xml, gif, and images in transport.
AddOutputFilterByType DEFLATE text/css text/plain text/xml image/gif image/jpeg image/png
</IfModule>

<IfModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 month"
# Set expires tags on various file types... so that the browser wont attempt to reload them.
ExpiresByType image/jpg "access plus 1 year"
ExpiresByType image/gif "access plus 1 year"
ExpiresByType image/gif "access plus 1 year"
ExpiresByType image/ico "access plus 1 year"
ExpiresByType image/png "access plus 1 year"
ExpiresByType video/x-flv "access plus 1 year"
ExpiresByType application/pdf "access plus 1 year"
ExpiresByType application/x-shockwave-flash "access plus 1 year"
ExpiresByType application/javascript "access plus 1 month"
ExpiresByType text/javascript "access plus 1 month"
ExpiresByType text/css "access plugs 1 month"
<IfModule mod_headers.c>
# Setting cache control to public allows proxy servers to cache the items too.
Header set Cache-Control "public"
</IfModule>
</IfModule>
#4
Enlève $config["image_uploads_path"] et le $config["root_path"].
Ils sont créés par défaut (voir le pdf dans le dossier doc).
#5
Jean le Chauve a écrit :Enlève $config["image_uploads_path"] et le $config["root_path"].
Ils sont créés par défaut (voir le pdf dans le dossier doc).
Ca ne fonctionne pas, ils n'y etaient pas au début mais je les ai ajouté pour résoudre le problème. La je viens de les supprimer mais toujours la même chose quand j'ajoute une image ca affiche /webm/uploads/... donc ca ne fonctionnera pas en ligne sauf si je fait un remplacement avant de maj la bdd.
Merci.
#6
Met en commentaires : #RewriteBase /webm/
#7
Jean le Chauve a écrit :Met en commentaires : #RewriteBase /webm/
Merci mais ca ne fonctionne tjrs pas.
J'ai supprimer les 2 configs et le rewriteBase, ca ne change rien. Je ne sais pas si cette version mais avec une version plus ancienne j'ai n'ai rien fait pour le faire fonctionner. J'ain regarder dans le fichier config.inc de l’éditeur, il n'y a pas de paramètres d'url de fichier qui correspond.
En tous cas merci, je vais faire avec en attendant de trouver un réponse au problème.
#8
il faut
- la sauvegarde la base de données (phpMyAdmin)

0- supprimer le config.php - vider la base de données

1- faire une installation
comme indiqué sur le Wiki
- Etape 5
pour une utilisation avec WAMP utiliser les identifiants standards :
- Serveur de BD = localhost, Nom d'utlisateur = root, mot de passe =vide,
le Nom de la base de donnée = celle que vous avez créer dans phpMyAdmin
le Préfixe des tables sera le même qu celui utilisé dans base de données
ne pas cocher "Installer les exemples de contenus et les gabarits"

à la fin vous aurez une installation minimum avec la seule page accueil Web suffisante pour tester
Tester et vérifier l'Admin et la page Web tout doit être OK
Sinon vous avez un problème de serveur ou de fichier

2- Import de la base de données ancienne version (avec phpMyAdmin)
Pour des raisons de compatibilité vérifier le fichier SQL, il faut supprimer toutes les information du fichier SQL (précédemment sauvegardé) concernant les " ENGINE=xxxx DEFAULT CHARSET=lxxx " pour éviter les problèmes.

3- tests
Tester ....
J-C Etiemble Tutoriels v 2.2.x
#9
Merci pour les infos, je testerai prochainement, car la j'ai déjà mis en ligne.
Merci a tous.


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)