Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Messages d'erreur - Module EventsManager...
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 1.11.11
#~ Url du site : http://terroirs77.fr/cmsmadesimple/
#~ Hébergeur / Soft : OVH
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 1.11.12
#~ Installed Modules:
#~ CMSMailer: 5.2.2
#~ CMSPrinting: 1.0.5
#~ FileManager: 1.4.5
#~ MenuManager: 1.8.6
#~ MicroTiny: 1.2.8
#~ ModuleManager: 1.5.8
#~ News: 2.14.4
#~ Search: 1.7.11
#~ ThemeManager: 1.1.8
#~ CGFavs: 1.0.2
#~ CGExtensions: 1.45
#~ ExtendedTools: 1.1.1
#~ CGSmartImage: 1.17.2
#~ FormBuilder: 0.8.1.1
#~ Gallery: 1.6.1
#~ CGSimpleSmarty: 1.7.4
#~ CGCalendar: 1.14.6
#~ FrontEndUsers: 1.26
#~ AireLibs: 1.3.2
#~ EventsManager: 1.2.7
#~ Config Information:
#~ php_memory_limit:
#~ process_whole_template:
#~ max_upload_size: 64000000
#~ url_rewriting: none
#~ page_extension:
#~ query_var: page
#~ image_manipulation_prog: GD
#~ auto_alias_content: true
#~ locale: fr_FR.utf-8
#~ default_encoding: utf-8
#~ admin_encoding: utf-8
#~ set_names: true
#~ Php Information:
#~ phpversion: 5.4.37
#~ md5_function: On (Vrai)
#~ gd_version: 2
#~ tempnam_function: On (Vrai)
#~ magic_quotes_runtime: Off (Faux)
#~ E_STRICT: 2048
#~ E_DEPRECATED: 8192
#~ memory_limit: 512M
#~ max_execution_time: 300
#~ output_buffering: 4096
#~ safe_mode: Off (Faux)
#~ file_uploads: On (Vrai)
#~ post_max_size: 64M
#~ upload_max_filesize: 64M
#~ session_save_path: /tmp (0700)
#~ session_use_cookies: On (Vrai)
#~ xml_function: On (Vrai)
#~ xmlreader_class: On (Vrai)
#~ Server Information:
#~ Server Api: fpm-fcgi
#~ Server Db Type: MySQL (mysql)
#~ Server Db Version: 5.1.73
#~ Server Db Grants: Impossible de trouver un privilège "GRANT ALL". Cela peut signifier que vous pourriez avoir des problèmes pour installer ou retirer des modules, ou encore l 'ajout et la suppression d'éléments, y compris les pages.
#~ Server Time Diff: Aucune différence de date du système de fichiers trouvées
#~ ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bonjour à tous,

Je viens d'installer le module "EventsManager" et ses modules associés et j'obtiens ces messages d'erreurs que je trouve au-dessus de mes pages de site mais également au dessus de mes pages d'administration de CMSMS :
Code :
[== Indéfini ==]

Strict Standards: Declaration of AireFieldDef::load_from_array() should be compatible with AireDbObject::load_from_array(array $data) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/class.AireFieldDef.php on line 226

Strict Standards: Declaration of AireFieldDef_checkboxes::get_edit_form() should be compatible with AireFieldDef::get_edit_form($mod, $actionid, $value, $smarty) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/fielddefs/class.AireFieldDef_checkboxes.php on line 112

Strict Standards: Declaration of AireFieldDef_checkboxes::add_extra_data() should be compatible with AireFieldDef::add_extra_data($fieldval_obj) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/fielddefs/class.AireFieldDef_checkboxes.php on line 112

Strict Standards: Declaration of AireFieldDef_file::get_edit_form() should be compatible with AireFieldDef::get_edit_form($mod, $actionid, $value, $smarty) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/fielddefs/class.AireFieldDef_file.php on line 175

Strict Standards: Declaration of AireFieldDef_file::add_extra_data() should be compatible with AireFieldDef::add_extra_data($fieldval_obj) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/fielddefs/class.AireFieldDef_file.php on line 175

Strict Standards: Declaration of AireFieldDef_image::get_edit_form() should be compatible with AireFieldDef::get_edit_form($mod, $actionid, $value, $smarty) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/fielddefs/class.AireFieldDef_image.php on line 174

Strict Standards: Declaration of AireFieldDef_image::add_extra_data() should be compatible with AireFieldDef::add_extra_data($fieldval_obj) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/fielddefs/class.AireFieldDef_image.php on line 174

Strict Standards: Declaration of AireFieldDef_text::get_edit_form() should be compatible with AireFieldDef::get_edit_form($mod, $actionid, $value, $smarty) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/fielddefs/class.AireFieldDef_text.php on line 40

Strict Standards: Declaration of AireFieldDef_textarea::get_edit_form() should be compatible with AireFieldDef::get_edit_form($mod, $actionid, $value, $smarty) in /home/terroirskh/www/cmsmadesimple/modules/AireLibs/lib/fielddefs/class.AireFieldDef_textarea.php on line 35

Bien sûr, j'ai parcouru le Forum et j'en conclus que mon souci doit provenir de mon PHP chez OVH !?

Comme je ne suis pas "fortiche" dans ce domaine, je préfère attendre vos conseils avant de faire une bêtise !

J'ai déjà jeté un œil sur le contenu de mon hébergement via FileZilla... mais je ne trouve pas de fichier PHP dans la racine du site...
Donc si quelqu'un pouvait me guider, j'en serai très heureux.
Merci et bonne journée.
Rolleyes
#2
Citation :j'obtiens ces messages d'erreur .... Strict Standards

"Les messages Strict Standards ne sont pas des erreurs, mais des avrtissements aux développeurs, indiquant que la programmation n'a pas respecté strictement ..."
1- Donc déja reporter ces erreurs au développeur

2- c'est ta configuration PHP et en particulier ton php.ini mal configuré
J-C Etiemble Tutoriels v 2.2.x
#3
Merci ...
Citation :1- Donc déja reporter ces erreurs au développeur

Il faut reporter ces erreur au développeur de "EventsManager" ?
Citation :2- c'est ta configuration PHP et en particulier ton php.ini mal configuré

Oui, comment fait-on cela ? Comme je l'ai déjà dit, je ne suis pas "fortiche" dans ce domaine. Si l'on me guide, je trouve mais sinon... Rolleyes
Rolleyes
#4
Chez OVH ça dépend .... du contact :|

le plus simple

dans le fichier include.php du cms
ajouter en ligne avant $dirname = dirname(__FILE__);

Code :
// Désactiver le rapport d'erreurs
error_reporting(0);
J-C Etiemble Tutoriels v 2.2.x
#5
Ah! oui... très efficace !
Alors, je me pose une autre question :

Si je désactive un rapport d'erreur... Comme je fais maintenant, pour constater une erreur ? Je n'aura plus d'alerte à un quelconque problème ?...
Par exemple, un petit problème s'affichait avec "Calendar"... il ne s’affiche plus... super, mais est-ce que mon module travaille correctement pour autant ?
C'est peut-être naïf, mais j'imagine que ce genre d'infos qui s'affichent, servent bien à quelque-chose ...
Mais bon, c’est vrai que ton intervention est efficace au demeurant.
Merci
Rolleyes
#6
Quand tu n'utiliseras plus de modules dépassés, tu n'auras plus d'erreur Wink
Citation :Notice: This project is marked as stale. This means that it may work fine, but it has no file releases or repository commits in over a year. Use your own discretion when using this project.
Si tu vérifies la date de la dernière version, tu verras qu'Airelibre n'y a plus touché depuis plus de 2 ans.
#7
Citation :Si je désactive un rapport d'erreur... Comme je fais maintenant, pour constater une erreur ?
faut savoir Wink
error_reporting(0); désactive l'affichage les erreurs PHP (c'est décoratif)
mais c'est tout les erreurs existent toujours
C'est donc un "Pi-z'aller"

C'est pourquoi il faut reporter les erreurs de codage aux développeurs
J-C Etiemble Tutoriels v 2.2.x
#8
Bonjour,

Citation :Quand tu n'utiliseras plus de modules dépassés, tu n'auras plus d'erreur
Ok... je comprends bien...
Faut qu'on m'explique alors :
Comment se fait-i qu'en utilisant le gestionnaire de module, on tombe sur des versions obsolètes ? Et pourquoi dans ce gestionnaire, la rubrique "mise à jour" ne liste pas les modules "défaillants"... ?
Bon c'est vrai que c'est sans doute un peu plus complexe que ça... mais à l'inverse on peut supposer qu'un module est en "vitrine" parce qu'il fonctionne, non !? Sinon, je ne vois pas bien son utilité...
Bref au bout du compte, j'utilise le module... j'enlève les messages d'erreurs... je reporte les erreurs de codage au développeur... et je ne sais pas si le module est fiable finalement... ?
Je crois que je vais essayer de trouver un autre module qui va dans le même sens... Pourtant, en parcourant le forum, "EventsManager" semblait convenir à pas mal de personne...
Bon je vais poursuivre mes recherches.
Peut-être pouvez-vous m'aiguiller... Je cherche un moyen d'afficher des événements auxquels on peut s'inscrire pour des activités associatives...
Merci encore pour vos réponse qui m'éclairent mais souvent me déconcerte...
Mais je continue à trouver ce CMS génial...
Rolleyes
#9
Citation :Comment se fait-i qu'en utilisant le gestionnaire de module, on tombe sur des versions obsolètes ? Et pourquoi dans ce gestionnaire, la rubrique "mise à jour" ne liste pas les modules "défaillants"... ?
Sauf que c'est bien écrit sur la page du "Gestionnaire de Modules"

Vous êtes encouragés à lire les informations qui se trouvent dans l'aide et sur les liens pour chaque module avant l'installation.
Et donc si le module n'a pas été mis à jour récemment il est donc a ne pas utiliser ou alors avec mille et une précautions
J-C Etiemble Tutoriels v 2.2.x
#10
Bonjour,

Bon, ok... j'ai bien compris... J'essaie donc d'utiliser ces modules avec mille et une précautions !
Et finalement, tout cela me semble fonctionner pas si mal que ça...
Toutefois, je me pose une question,... relative à mes besoins évidemment.

Mon besoin :
J'ai un site pour une association où les visiteurs pourraient s'inscrire à des événements telles que "Randonnées - Conférences - Etc." Je m'oriente donc sur le Module Event-Manager.
Et je comprends que celui-ci a besoins de FrontEndUser pour fonctionner ...
J'ai bon ?
Lorsque j'examine "FEU", je crois comprendre qu'il s'agît d'un module destiné à des "utilisateurs privés" en quelque sorte et qui ont ainsi accès à une partie réservée du site...
Hors, moi je ne souhaite pas de partie privée et j'aimerais simplement que mes visiteurs puissent s'inscrire à un événement public tout simplement.
Ensuite, je comprends également que ces modules "s'embarque avec SelfRegistartion" qui lui autoriserait les utilisateurs à s'enregistrer sur une liste...
Le tout limité à 250 inscriptions...
J'ai bon ?
J'ai l'impression de comprendre, mais pas tout quand même ! Rolleyes
J'essaie bien de "me mettre à la page" pour réaliser le site de mon asso mais je crois que mon grand âge me pose souci pour faire le clair dans tout ça... et pas question de faire appel aux autres membres de l'asso qui sont encore plus nase que moi... C'est dire ! Sad

Bref si quelqu'un pouvait me donner explication claire de ces modules, j'économiserais sur mes achats d'aspirine. Big Grin
Peut-être qu'après tout, il y a plus simple pour obtenir ce que je veux...
Qu'en pensez-vous ?
Rolleyes
#11
Si tu as un problème sur les modules pose ta question sur une nouvelle discussion dans le forum Modules
je vais clôturer cette discussion "Messages d'erreur - Module EventsManager". qui est terminée.
J-C Etiemble Tutoriels v 2.2.x
#12
Désolé... Je vais faire cela. Merci
Rolleyes
#13
Discussion fermée
suivi sur http://www.cmsmadesimple.fr/forum/viewto...802#p40802
J-C Etiemble Tutoriels v 2.2.x
#14
Je plaide coupable, n'ayant mis à jour le module comme il le faudrait depuis maintenant bien longtemps...

Une fois les messages d'erreurs ou notices passées, il devrait néanmoins marcher sur une 1.11. Courage !


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)