Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Version 2.0 Béta3
#1
Version 2.0 Béta3 qui sera surement la dernière béta pour la version 2.0

L'ancienne Discussion sur la version 2.0 béta1
L'ancienne Discussion sur la version 2.0 béta2

La page téléchargement sur cmsmadesimple.org

Pour information un Tutoriel Installateur CMSms V 2.0

Poser vos questions et retours d'information pour la version 2.0 Béta3 sur cette discussion

Merci pour vos retours sur les hébergements compatibles V2
Liste des hébergements compatibles V2

Un forum EN est ouvert pour repoter vos bugs pour cette béta CMSMS 2.0 Beta

[EDIT 9/03/2015]
Les fichiers anciennement
- cmsms-2.0-beta3-install.phar.zip Deviennent cmsms-2.0-beta3-install.zip (système d'installation/mise à jour en un seul fichier PHAR )

- cmsms-2.0-beta3-install.zip Deviennent cmsms-2.0-beta3-install.expanded.zip (Variante pour les serveurs incompatibles avec le PHAR)
J-C Etiemble Tutoriels v 2.2.x
#2
Premiers tests. L'export des designs bloque toujours sur l'ajout de l'extension xml ça on le savait déjà. On peut importer le design en lui ajoutant l'extension xml. Mais l'affichage du site se fait mal : seul la partie "content" s'affiche. Par exemple si on importe css menu+1column après l'avoir exporté, gabarit et css se voit ajouter un 2. En remplaçant méthodiquement gabarit et CSS de la version importé par leur version originale je me suis aperçu que c'est le css print2 qui bug. Ce css masque tout ce qui ne doit pas être imprimé ce qui fait que seule la partie "content" s'affiche. Le css importé ne sait donc plus distinguer si l'on est en mode impression ou en mode affichage. Pourtant les deux fichiers sont rigoureusement identiques.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#3
je pense que les mises à jour ça va être le "Super" problème de la V2 et que pour le moment il n'y pas eu assez de tests d'upgrade V1.11 vers V2 Sad

les reports de bugs, il faut les faire ou les refaire (si possible à confirmer par plusieurs testeurs) à sur le forum EN CMSMS 2.0 Beta

Pour ces reports donner le maximum d'information serveur, version PHP et détailler le plus possible.

d'autre part sur la bêta 3 officielle il y a Typo sur le dossier app\upgrade\2.0-beta2 et donc sur le fichier MANIFEST.DAT qui donne MANIFEST TO VERSION: 2.0-beta2
Des retours sur ce Typo ?

autre bizarrerie: lors de l'édition d'un gabarit si l'on reste plus de x minutes en édition -> message "Désolé, mais vous avez perdu le verrou sur cet item,..."
??
J-C Etiemble Tutoriels v 2.2.x
#4
jce76350 a écrit :autre bizarrerie: lors de l'édition d'un gabarit si l'on reste plus de x minutes en édition -> message "Désolé, mais vous avez perdu le verrou sur cet item,..."
??
Tu as réglé la durée du verrou dans les préférences utilisateur?

Il semble que le bug d'export des designs soit du à la présence d'espaces dans le nom des fichiers, ces espaces étant incompatibles avec Windows
http://forum.cmsmadesimple.org/viewtopic...82&t=71549
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#5
>Tu as réglé la durée du verrou dans les préférences utilisateur?
ha elle bonne cella la... le soucis c'est que c'est aléatoire et pas sur tout les gabarits !

Citation :Il semble que le bug d'export des designs soit du à la présence d'espaces dans le nom des fichiers, ces espaces étant incompatibles avec Windows
C'est résolu en révision 9803 pour moi
J-C Etiemble Tutoriels v 2.2.x
#6
jce76350 a écrit :>Tu as réglé la durée du verrou dans les préférences utilisateur?
ha elle bonne cella la... le soucis c'est que c'est aléatoire et pas sur tout les gabarits !
Smile Smile

Pas vérifié récemment, je le met tout de suite à zéro, car ça se déclenchait sans crier gare avec un délais bien inférieur à 60 minutes

jce76350 a écrit :Il semble que le bug d'export des designs soit du à la présence d'espaces dans le nom des fichiers, ces espaces étant incompatibles avec Windows
C'est résolu en révision 9803 pour moi
L'enregistrement oui mais le bug d'affichage en utilisant le gabarit qui a été sauvegardé non.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#7
>mais le bug d'affichage en utilisant le gabarit qui a été sauvegardé non.

quel est ton problème, donne moi un exemple
J-C Etiemble Tutoriels v 2.2.x
#8
Je n'ai que la partie "content" qui s'affiche. C'est du au CSS "print". Lorsqu'on l'importe, l'option print est décoché dans mediatype alors qu'il est coché dans la version originale. les designs qui n'utilisent pas ce CSS s'affichent correctement (ncleanblue et minimal)
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#9
>je n'ai que la partie "content" qui s'affiche. C'est du au CSS "print" ....

C'est un gabarit standard ou pas ?? que gabarit ?
parce que pour tester il me faut des informations
J-C Etiemble Tutoriels v 2.2.x
#10
Tu prends n'importe quel design standard qui contient un CSS appelé "print" puis tu l'exportes. Ensuite tu l'importes et tu affecte le design importé à une page puis tu teste l'affichage de la page. Ensuite tu édites le CSS qui doit s'appeler "print 2" et tu vas dans type de média tu verras que l'option print est décochée alors qu'elle devrait l'être (elle l'est dans l'original "print"). Il suffit de cocher l'option pour que l'affichage de la page se fasse correctement.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#11
Citation :Tu prends n'importe quel design standard qui contient un CSS appelé "print" puis tu l'exportes. Ensuite tu l'importes et tu affecte le design importé à une page puis tu teste l'affichage de la page ...
j'ai exporté Top simple navigation + left subnavigation + 1 column
Puis importé Top simple navigation + left subnavigation + 1 column2
constat
- sur les Feuille de style Aucune case cochée dans "type de média"
- sur une page avec ce design le "<link rel="stylesheet" type="text/css" href=..." est complet pour ce qui est du code combiné
- par contre l'affichage de la page est en mode simplifié

Si effectivement je coche la case Print dans "type de média" l'affichage redevient OK

en fait ce sont Toutes les cases dans "type de média" qui "pose-problèmes" de l'import

Je pense qu'il faut que tu créer un autre topic car la bug est différent que celui de l'export XLM (fait un lien de ton dernier post exported design files without xml extensions pour information
J-C Etiemble Tutoriels v 2.2.x
#12
OK j'essaie de faire ça pendant le weekend

J'ai testé une mise à jour d'une installation toute fraiche de 1.11.12 vers la beta3 en m'intéressant plus particulièrement aux devenir des menus et de l'impression.

Les menus fonctionnent avec menu manager et leur gabarits, cependant le menu de "left simple navigation + 1 C..." ne fonctionne pas correctement les sous-menus ne se dépliant pas. Le problème est réglé en remplaçant menu par Navigator associé à son gabarit.
Lors des mise à jour des sites, il sera impératif de passer à Navigator et à ses gabarits sous peine de mauvaises surprises (c'est ce qui m'inquiète le plus pour la mise à jour et va me faire travailler les méninges enfin ce qu'il y a dessous). Je vais tester si Navigator peut utiliser les gabarits de menu.

L'impression se fait correctement le CSS print ayant été ajouté à tous les designs.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#13
Il faut IMPERATIVEMENT désinstaller MenuManager sous peine de ralentissements importants de l'affichage admin et sans doute d'autres pépins : http://forum.cmsmadesimple.org/viewtopic...84&t=70686
#14
>Il faut IMPERATIVEMENT désinstaller MenuManager

oui tu as raison mais
- CG devait d'ailleurs le rendre "désinstallé" alors de l'install
(I will consider, after beta2 not installing MenuManager on new installs.)
- dans le cas ou il est désinstallé on ne peux plus exporter de designs
Message =[Vous ne pouvez pas trouver tous les gabarits de MenuManager (MenuManager est-il installé et activé ?] Y-a comme un bug alors Cool
J-C Etiemble Tutoriels v 2.2.x
#15
:lol: Navigator remplace MenuManager devenu obsolète, mais ne fonctionne pas sans lui...
Pourtant, le changelog nous annonce bien :
Citation :MenuManager
- Transformed to use new CmsLayout classes
- Deprecated

Navigator
- New module to replace MenuManager
Comme tu le dis, il y aurait comme un bug Wink
#16
jce76350 a écrit :>Il faut IMPERATIVEMENT désinstaller MenuManager

oui tu as raison mais
- CG devait d'ailleurs le rendre "désinstallé" alors de l'install
(I will consider, after beta2 not installing MenuManager on new installs.)
- dans le cas ou il est désinstallé on ne peux plus exporter de designs
Message =[Vous ne pouvez pas trouver tous les gabarits de MenuManager (MenuManager est-il installé et activé ?] Y-a comme un bug alors Cool

Je confirme chez moi aussi même message

Navigator ne lit pas les gabarits de menumanager. Si on désinstalle menumanager ou s'il n'est pas installé lors d'une mise à jour le site plante : pas de fil d'Ariane, pas de menu. Il faudra donc adapter tous les gabarits et les css de menumanager pour Navigator : lourd. Lors d'une mise à jour 4 gabarits Navigator sont installé par défaut heureusement (que menumanager sait lire?).

Qu'est-ce que Navigator fait de plus que menumanager?
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#17
Citation :Je confirme chez moi aussi même message
je te laisse (ou Jean) déposer le rapport de bug Wink

pour info
[Image: design_export_message.jpg]


Citation :Si on désinstalle menumanager ou s'il n'est pas installé lors d'une mise à jour le site plante : pas de fil d'Ariane, ...
ben oui faut lire les notes de version ou le changelog ...
et pour le fil d'Ariane,faut modifier aussi par exemple par {nav_breadcrumbs root='Home'}

Citation :Qu'est-ce que Navigator fait de plus que menumanager?
des améliorations mais surtout le fait de l'intégrer au "système design"
J-C Etiemble Tutoriels v 2.2.x
#18
Bug du message 10 signalé
http://forum.cmsmadesimple.org/viewtopic...82&t=72170 si vous voulez bien confirmer.

> ben oui faut lire les notes de version ou le changelog ...

Non je l'ai bien lu rassure toi. Ce sur quoi je voulais insister c'est que la gestion des menus de Navigator n'est pas compatible avec la version antérieure menumanager, pour X ou Y bonnes raisons. C'est une originalité, les nouvelles versions d'un logiciel prenant généralement en charge les anciennes versions de leurs fichiers. Il me semble indispensable d'avoir à disposition menumanager, au moins transitoirement, lors d'une mise à jour (pour limiter le stress de la mise à jour?)
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#19
>Bug du message 10 signalé
j'ai confirmé

de plus ajouter le Uninstall MenuManager breaks the export designs

Citation :je voulais insister c'est que la gestion des menus de Navigator n'est pas compatible avec la version antérieure menumanager, ...
Compatible oui si l'on prend soin de remplacer correctement les anciens
{menu ... par{Navigator ...
et les {breadcrumbs} ou {cms_breadcrumbs} par {nav_breadcrumbs ...} ou {Navigator action='breadcrumbs'}

l est sur que les mises à jour vont être délicates mais c'est pour cela qu'il faut dés maintenant se documenter et surtout tester cette V2 Wink
J-C Etiemble Tutoriels v 2.2.x
#20
Hello,
pour info sur l'utilisation de Navigator :
http://www.cmsmadesimple.fr/forum/viewtopic.php?id=5668
{SEO}
Inscrivez-vous à notre Newsletter sur le site (colonne de droite, en bas).
Vous appréciez CMSMS et l'aide qui vous est fournie ici, aidez-nous en participant au projet.
Formation CMS Made Simple | Création de site CMS Made Simple.

C'est en se plantant qu'on devient cultivé.
J'ai un string dans l'Array (Paris Hilton)
#21
jce76350 a écrit :de plus ajouter le Uninstall MenuManager breaks the export designs

Je viens de confirmer

jce76350 a écrit :Compatible oui si l'on prend soin de remplacer correctement les anciens
{menu ... par{Navigator ...
et les {breadcrumbs} ou {cms_breadcrumbs} par {nav_breadcrumbs ...} ou {Navigator action='breadcrumbs'}

Effectivement en remplaçant "menu" par "Navigator" tout fonctionne mais si l'on supprime les 4 gabarits de type Navigator::navigation équivalents de ceux de la version 1 on obtient le message :

Erreur : à la ligne999 dans le fichier C:\wamp\www\maj\lib\classes\class.CmsLayoutTemplate.php :

Message : Could not find default CmsLayoutTemplate row for type Navigator::navigation

En fait, changer le nom du module modifie aussi les gabarits utilisés car les gabarits de "menumanager" n'ont pas été supprimés et sont toujours bien au chaud dans leur répertoire. Il suffit de repasser à "menu" pour le vérifier : la page s'affiche correctement. Reste à voir comment ça va se passer avec un site lambda et des menus tout aussi lambdas, ce sera pour plus tard.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#22
>de plus ajouter le Uninstall MenuManager breaks the export designs
Normalement c'est corrigé en rev 9808
Mais un doute, si un gabarit contient {menu} et que MenuManager est désinstallé, exporter le design n'a pas de message d'alerte (c'est un cas possible [mais tiré par les cheveux] lors de mise à jour)

Citation :Effectivement en remplaçant "menu" par "Navigator" tout fonctionne mais si l'on supprime les 4 gabarits de type Navigator::navigation équivalents de ceux de la version 1 on obtient le message
que je teste mais la .... ça devient un vrai b...l la mise à jour

Et vu le nombre de testeurs, je vais temporisé parce la je Nous (tous les 2) sens un peu seul :/
J-C Etiemble Tutoriels v 2.2.x
#23
Je confirme le problème de verrou il se déclenche au bout d'un temps variable même si on l'a fixé à 60 minute, c'est agaçant en plus.

Je confirme aussi que la mise à jour c'est le b....l . J'ai la mise à jour à partir des élèments suivants :
- base de donnée de mon site, 2. 7 mo, 230 pages (une version ancienne les plus récentes me donnant le message gabarits vides)
- version 11.12 nettoyée de tous les modules sauf gallery et les modules CG déclarés compatibles par leurs auteurs.

La mise à jour s'est faite parfaitement, l'admin fonctionne et tous les modules sauf tyniMCE fonctionnent (à confirmer) et le site aussi.

Mais ce que je voulais tester c'est les menus. Les gabarits utilisent "menu" avec les gabarits du site portant le nom de l'ancienne version mais ceux-ci n’apparaissent pas dans les gabarits (ils sont dans la base de données) du gestionnaire de design qui ne contient que :

*accessible_simple_navigation
*cssmenu
*cssmenu_ulshadow
*minimal_menu
*Simple Navigation

gabarits en version 2 bien sur

Lorsque l'on remplace "menu" par "Navigator" le résultat était prévisible l'affichage de la page s'arrête juste avant l'affichage du menu sans mise en forme. Donc gabarits de menus à refaire en version 2. :mad: :mad: :mad:
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#24
>sauf tyniMCE fonctionnent (à confirmer)

tinyMCE est HS sur la V2 Rolf a essayer de faire des corrections mais c'est pas fini, et c'est un soucis si on fait une mise à jour car plus d'éditeur sur les pages, il faut configurer Microtiny

En fait je pense que il faut utiliser et si besoin ajouter des fonctions c'est assez simple car les plugins sont déjà présents
- exemple table dans \MicroTiny\lib\js\tinymce\plugins
- modifier tinymce_config.js de \MicroTiny\templates par Ajout de : "table" par exemple entre "media et image" dans la ligne plugins: ['autolink link cmsms_linker
cela inser un menu Tableau
+ Et si on veut une icone Tableau ajouter dans la ligne toolbar: 'undo redo | cut
J-C Etiemble Tutoriels v 2.2.x
#25
oui, les menus sont à refaire puisque Navigator renvoie une variable (de type objet contenant la hiérarchie des pages) organisée différemment que dans le module Menumanager.
Voir le lien de mon post précédent.
{SEO}
Inscrivez-vous à notre Newsletter sur le site (colonne de droite, en bas).
Vous appréciez CMSMS et l'aide qui vous est fournie ici, aidez-nous en participant au projet.
Formation CMS Made Simple | Création de site CMS Made Simple.

C'est en se plantant qu'on devient cultivé.
J'ai un string dans l'Array (Paris Hilton)


Atteindre :


Utilisateur(s) parcourant ce sujet : 2 visiteur(s)