Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Version 2.0 Béta2
#76
J'ai fait une mise à jour sans supprimer les modules non compatibles avec la V2. Le résultat a été à la fois catastrophique et spectaculaire : le gestionnaire de module est complétement explosé :
voici tout ce qu'il en reste :

Avertissement

Les version affichées ici représentent les derniers fichiers au format XML disponibles sur la Forge CMSMS™. Ils peuvent être ou non la dernière version disponible.
Utilisation à vos risques et périls

Les modules affichés ici sont fournis par les développeurs de CMS, et des tiers indépendants. Nous ne pouvons garantir que les modules offerts ici soient fonctionnels, testés ou compatibles avec votre système. Vous êtes encouragés à lire les informations qui se trouvent dans l'aide et sur les liens pour chaque module avant l'installation.
Installé
Mises à jour disponibles
Recherche
Modules disponibles
Configuration
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#77
Citation :J'ai fait une mise à jour sans supprimer les modules non compatibles avec la V2. Le résultat a été à la fois catastrophique et spectaculaire
Oui les modules anciens plantent mais cela doit dépendre des modules installés
quel est le problème l'affichage, les modules, ... ??
J-C Etiemble Tutoriels v 2.2.x
#78
Le module manager est complétement HS tout ce qui s'affiche c'est ce que j'ai copié dans mon message. Il n'y a plus aucun lien et pas d'affichage de liste de modules. Si j'ai un moment je vais essayer de trouver le module responsable. J'ai déjà éliminé Gallery et showtime. Gallery fonctionne parfaitement bien sur la V2 tandis que showtime ne peut plus sauvegarder ses réglages.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#79
si les modules ne sont pas compatibles pour la V2, il ne fonctionneront pas correctement et risque de polluer le CMS. Pour le moment seulement quelques modules sont OK pour la V2.
en particulier Gallery ne semble pas compatible à 100%
J-C Etiemble Tutoriels v 2.2.x
#80
Sinon quelqu'un a des nouvelles sur d'éventuelles évolutions de l'installateur .phar et des problèmes rencontrés chez certains hébergeurs.
A mon humble avis l'idée est bonne et s'il y a moyen de "débugguer" cette histoire cela permettrait de favoriser assez nettement les test de la version 2.0 et par suite son adoption. Smile
Win 7 pro 64 - CMSMS 1.6.4 à 2.2.9
#81
Citation :Sinon quelqu'un a des nouvelles sur d'éventuelles évolutions de l'installateur .phar et des problèmes rencontrés chez certains hébergeurs.

Vu le petitpetit..... nombre de testeurs y-a-rien de plus que sur ce post
J'attends toujours les retours des installateurs du cms V2 Wink
J-C Etiemble Tutoriels v 2.2.x
#82
jce76350 a écrit :en particulier Gallery ne semble pas compatible à 100%
La dernière version est pourtant certifiée compatible par son auteur. Je le teste depuis pas mal de temps sans avoir constaté de problème.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#83
sur la dernière newsletter de CMSMS.org

Il est écrit
"We've had some great feedback from the first two betas and look forward to Beta3 coming out imminently. We expect that Beta3 will be the final stage in the beta process, though of course are not limiting ourselves to that just yet - we need to remain flexible to cater for any requirements from this beta. We look forward to being able to announce the release of Beta3 in the very near future"

Qu'en pensez-vous les testeurs ??
J-C Etiemble Tutoriels v 2.2.x
#84
Si tous les bugs signalès de la beta 2 ont été corrigés ma foi pourquoi pas une beta 3 pour régler les problèmes des mises à jour. A ce sujet je me demande quel pourcentage des mises à jour se fait sans problème.
On va tester.
MS-Dos, Gem, geoworks, Windows 1, 2, 3, 3.1, 95, 98, XP, seven, 8, 10 Smile
Mac system 1 à 6
Wampserver 3.1.9,
PhP 7.3.5,
CMS version 2.2.11
#85
C'est la semaine de Noël, alors le père-Noel-Calguy a bossé et résolu une partie des bugs en cours
Il a promis une béta3 avant la fin de cette année alors Y-a-pu-ka-tester Wink
J-C Etiemble Tutoriels v 2.2.x
#86
Je viens de faire un test d'upgrade de 1.11.11 vers 2beta2 avec le phar en local sous MAMP (pas taper) en php5.5.3, et je suis bloqué à l'étape 9 où ne s'affiche que le dossier d'installation, mais rien d'autre, aucune action, pas de mise à jour de modules... je précise que j'ai fait l'upgrade en mode warrior, sans vérifier la compatibilité des modules déjà installés, je me dis que ça vient peut-être de ça ?

Les log php :
Code :
[== Indéfini ==]
PHP Fatal error:  Class 'ModuleOperations' not found in [...]/lib/autoloader.php on line 110
#87
Bon, j'ai aussi testé une install complète qui s'est déroulée normalement (même config que précédemment), et j'ai accès à l'admin, mais pas au site qui affiche une page blanche, et les logs php clignotent... Je vais attendre la beta 3 dans ce cas.
#88
tu as testé avec quelle version du PHAR ??

Normalement il ne doit pas y avoir gros problème sur une installation un mise à jour ou rafraichissement
- bien sur avant de mettre a jour il faut s'assurer que les modules qui ne sont pas du core soit à jour pour la version 1.1.11 installée et éventuellement faire un test sans les modules dont on est pas sur de la compatibilité.

- il y a a faire attention car le module CMSPrinting est supprimé du paquet et si mise à jour unknown tag "print"
- pour les design seul le gabarit est incorporé au Design, pour les blocs de contenu il faut les ajouter à la main au design

Attendre la béta 3 est une mauvaise idée car si tout le mode attend .... il n'y aura pas de retour de bug Rolleyes
Car il faut aussi pousser les dev de modules à la mise à jour de leurs modules et la c'est pas gagné Sad
J-C Etiemble Tutoriels v 2.2.x
#89
Héhé je me doutais de ta réponse, et tu as raison. J'en déduis que l'install de la beta 2 ne doit pas poser de soucis ? Parce que en install neuve, j'ai ça comme message dans les logs :
Code :
[== Indéfini ==]
PHP Fatal error:  Call to a member function htmlarea() on a non-object in [...]/lib/smarty/sysplugins/smarty_internal_templatebase.php(151) : eval()'d code on line 39

Pour répondre à ta question, j'ai utilisé le phar disponible ici : http://jc.etiemble.free.fr/abc/index.php...rcesfr_dev qui semble être la version d'aujourd'hui.
#90
Citation :PHP Fatal error: Call to a member function htmlarea()
a quel moment ? quelle étape ? donne des infos pour voir

Si tu as pris la 0.99.4_r141-9776-Fr, je peux te dire qu'elle est passée cet après midi à tous mes tests (install + mise à jour de 1.11.11) sans problème sur WAMP PHP 5.4.36
J-C Etiemble Tutoriels v 2.2.x
#91
Ah pardon, c'est après l'étape 9 où d'ailleurs je n'ai pas d'erreur au départ : le frontend affiche une page blanche, l'admin est fonctionnelle, sous MAMP PHP 5.5.18.

Et il semble bien que ce soit cette version, oui.
#92
Bon, je viens de faire un nouveau test sur un hébergement Simple Hosting Gandi, PHP 5.4.34 : même chose.

Et je viens de trouver un bug aussi : j'ai pu mettre 2 pages simultanément à "page par défaut", ce qui fait que du coup je ne peux les désactiver ou supprimer ni l'une ni l'autre. Et il doit y avoir un conflit pour l'affichage de la page d'accueil, mais bon, là j'ai toujours une page blanche.
#93
Citation :c'est après l'étape 9 ...
y a rien aprés la l'étape 9 .... la 9 c'est la fin, il y a les liens pour se connecter au site ou à l'admin
http://jc.etiemble.free.fr/abc/uploads/i..._new_9.jpg
Citation :l'admin est fonctionnelle, sous MAMP PHP 5.5.18.
ça fonctionne alors ?
J-C Etiemble Tutoriels v 2.2.x
#94
Ben à l'étape 9, j'ai le message qui me dit que tout est bon avec les liens vers le site et l'admin et donc l'admin est ok, sinon page blanche en front et toujours la même erreur fatale dans les logs.

Petite précision : la dernière install que j'ai faite, j'ai laissé s'installer les exemples de pages, etc. Du coup, je m'aperçois que seule la page d'accueil en frontend ne fonctionne pas et renvoie une page blanche, le reste est ok.
#95
Citation :donc l'admin est ok
des choses anormales ??
Citation : sinon page blanche en front et toujours la même erreur fatale dans les logs.
ton message de log n'est pas significatif et ne donne pas d'information précise sur l'erreur
ça pourrait être un soucis sur l'encodage des pages ou de la BD
et si tu actives le mode debug ($config['debug'] = trueWink dans le config.php ?
J-C Etiemble Tutoriels v 2.2.x
#96
Sur l'admin, rien d'anormal du tout.

Bon, visiblement, c'est le template simplex qui fout la merde en homepage, si je passe à minimal, la page d'accueil s'affiche. Je vais regarder d'où ça peut venir.
#97
Citation :Bon, visiblement, c'est le template simplex qui fout la merde en homepage, si je passe à minimal, la page d'accueil s'affiche. Je vais regarder d'où ça peut venir.
je viens de faire un test sur une debian et effectivement simplex bloque
Ce qui est bizarre c'est que sur WAMP pas de soucis
J-C Etiemble Tutoriels v 2.2.x
#98
OK, trouvé : le bug n'intervient que si on n'assigne pas de langue par défaut dans l'admin, c'est la 1e ligne du template qui pose souci.
Code :
[== HTML ==]
<!--[if gt IE 8]><!--> <html lang='{$nls->htmlarea()}' dir='{$nls->direction()}'> <!--<![endif]-->
#99
Il semble que l'installateur n'installe pas les fichiers de langues dans \lang\ext\ donc pas de langue fr_FR.php
Tu peux me confirmer

Edit c'est sur et re-re tester ; n'installe pas les fichiers de langues dans \lang\ext\
J-C Etiemble Tutoriels v 2.2.x
Alors que c'est ce qui devrait se passer si on sélectionne un paquet de langues supplémentaire pendant l'install, non ?


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)