Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Comment faire la Mise à jour version 1.x
#1
ATTENTION CETTE DISCUSSION est UNIQUEMENT pour les Version 1.x
La grande nouveauté de la version 2.x est le système Installation-Mise à jour-Rafraîchissement tout en un.
- Mettre à jour CmsMadeSimple 2.x sur son ordinateur
- Mettre à jour CmsMadeSimple 2.x sur son hébergeur distant (méthode par défaut, utilise le FTP)




1- Faire la Mise à jour "complète"
-----------------------------------

ATTENTION il FAUT impérativement :
[la communauté francophone exigera de vous que vous conserviez dans le code HTML de vos pages la ligne suivante]
<meta name="Generator" content="CMS Made Simple - Copyright © 2004-13 Ted Kulp. All rights reserved." />
<meta name="Generator" content="CMS Made Simple - Copyright © 2004-2017. All rights reserved." />


ATTENTION aux versions PHP prendre la version de CMSms en fonction !!!
Cette possibilité permet aussi de faire une mise à jour depuis une version (très) ancienne Wink

Voir aussi le wiki

NOTA VERSION 1.11.x lire attentivement le changelog (En)


NOTA VERSION 1.10.x lire attentivement cet avertissement

Comment faire la Mise à jour depuis la version 1x vers la version 1plus ?
en utilisant la version complète (jusqu'a la V 1.xx)
Cette méthode permet de faire "une marche arrière" si problèmes

En supposant que CMSMS version 1x soit installé dans le répertoire /cms
- Sauvegarder la base de données vérifier la sauvegarde (Hé oui ...)
- En FTP vider le répertoire tmp/templates_c (les fichiers Temporaires de template)
- En FTP créer un répertoire /cms1plus
- Copier en FTP les Nouveaux fichiers de la version 1plus (Tous y compris les fichiers modules à mettre à jour), SAUF les répertoires tmp et uploads
- vérifier que le répertoire cms/install est bien sur le serveur !!! celui de la dernière version bien sur - OU alors envoyer le dossier /install de la dernière version si vous l'avez supprimé Wink
- copier config.php de /cms vers /cms1plus (Donnez les permissions 666 à ce fichier)
- copier les répertoires tmp et uploads de /cms vers /cms1plus
- copier éventuellement les fichiers googlexx et sitemap.xml, favicon.ico etc.... de /cms vers /cms1plus
- Et ne pas oublier vos modules mis à jour (autres que ceux compris l'archive 1plus)
- renommer le répertoire /cms en répertoire /cmsold
- renommer le répertoire /cms1plus en répertoire /cms
- Vider le cache du navigateur ...
- Se connecter en Admin http://monsite.fr/cms/admin/
ou Faire "un pt'it coup d'upgrade" (si nécessaire)
Il suffit de se connecter http://monsite.fr/cms/install/upgrade.php
et de suivre les instructions
EN ETAPE 1 vérifier l'intégrité de vos fichiers CMSMS en comparant avec le fichier de contrôle - Inutile si utilisation d'un Bon FTP
- faire un test du site, cela doit être OK
- passer en Admin ,
- vérifier les Modules installés
- faire un test sur les pages et les articles
- ajuster les petits détails
Changez les permissions à 444 sur le fichier "config.php" (sécurité)
C'est fini..
Aprés tous les tests on supprime le répertoire /cmsold

Nota : quand on fait une installation complete le répertoire INSTALL est présent, il est conseillé soit de le supprimer. Afin de pouvoir faire les mise à jours, necessitant l'upgrade, il est mieux de le renommer, pour faire les mises à jour

Pour information
- http://wiki.cmsmadesimple.fr/wiki/Base_Installation
- Voir éventuellement Transfert sur un nouveau serveur

- le WiKi Se mettre à jour d'une très très ancienne version

POUR FAIRE UNE MISE à JOUR depuis une ancienne version UTILISER UNIQUEMENT la dernière version complète

En cas de problèmes avec une mise à jour
J-C Etiemble Tutoriels v 2.2.x
#2
2- Faire la Mise à jour "-diff-"
-------------------------------

ATTENTION il FAUT impérativement :
[la communauté francophone exigera de vous que vous conserviez dans le code HTML de vos pages la ligne suivante]
<meta name="Generator" content="CMS Made Simple - Copyright © 2004-13 Ted Kulp. All rights reserved." />
<meta name="Generator" content="CMS Made Simple - Copyright © 2004-2017. All rights reserved." />


ATTENTION aux versions PHP prendre la version de CMSms en fonction !!!
NOTA VERSION 1.10.x lire attentivement cet avertissement

Comment faire la Mise à jour depuis la version 1x vers la version 1plus ?
en utilisant le fichier de Mise à jour "-diff-1x-1plus" de 1x vers 1plus

En supposant que CMSMS version 1x soit installé dans le répertoire /cms
- Sauvegarder la base de données vérifier la sauvegarde (Hé oui ...)
- Vider le répertoire tmp/templates_c (les fichiers Temporaires de template)
- vérifier que le répertoire cms/install est bien sur le serveur !!! celui de la dernière version bien sur - OU alors envoyer le dossier /install de la dernière version si vous l'avez supprimé Wink
(sinon la mise à jour NE pourra Pas être faite correctement)
- Copier en FTP les Nouveaux fichiers de la version 1plus (Tous y compris les fichiers de vos modules à mettre à jour)
Donnez les permissions 666 au fichier config.php
- Vider le cache du navigateur ...
- Se connecter en Admin http://monsite.fr/cms/admin/
ou Faire "un pt'it coup d'upgrade" (si nécessaire)
Il suffit de se connecter http://monsite.fr/cms/install/upgrade.php
et de suivre les instructions
EN ETAPE 1 vérifier l'intégrité de vos fichiers CMSMS en comparant avec le fichier de contrôle - Inutile si utilisation d'un Bon FTP
- faire un test du site, cela doit être OK
- passer en Admin ,
- vérifier les Modules installés
- faire un test sur les pages et les articles
- ajuster les petits détails
Changez les permissions à 444 sur le fichier "config.php" (sécurité)
C'est fini.
Le répertoire INSTALL est présent, il est conseillé soit de le supprimer. Afin de pouvoir faire les mise à jours, nécessitant l'upgrade, il est mieux de le renommer, pour faire les mises à jour

Pour information
http://wiki.cmsmadesimple.fr/wiki/Base_Installation

- ATTENTION AVANT toute mise à jour lire attentivement le fichier doc/changelog.txt et les notes de version (releasenotes.txt) du dossier /install
- Lire aussi le WiKi Se mettre à jour d'une très très ancienne version


En cas de problèmes avec une mise à jour
J-C Etiemble Tutoriels v 2.2.x
#3
Re,

Pour information un Guide d'installation de CMSMS disponible sur cmsmadesiple.fr
http://www.cmsmadesimple.fr/boutique-cms...stallation
à Télécharger au format odt (2.8 Mo) ou pdf (1.2 Mo)

Plus
Tutoriel Installation-Upgrade pour CMSMS version >1.6
http://jc.etiemble.free.fr/abc/index.php...ssourcesfr
J-C Etiemble Tutoriels v 2.2.x
#4
Nota juillet 2010

ATTENTION sur le serveurs de FREE.fr n'utiliser QUE les versions cmsms 1.6.x
en date du 13/07/2010 Version 1.6.8 Pouebo
en date de fin oct 2012 version 1.6.12 ( Non supportées par le Team CMSms )

En n'oubliant pas de passer en PHP5
Créer un fichier .htaccess à la racine de l'hébergement (site)
NOTA : (la racine du site c'est le dossier qui comprend l'ensemble de ton site.)
avec
# PHP-5
<ifDefine Free>
PHP 1
</ifDefine>


EDIT DU O8/09/2015
Consulter Version 5.6 de php sur les pages perso Free le PHP 5.6.8 est activé sur toutes les pagesperso de free.fr
- les versions 1.12.x fonctionnent correctement
- les versionx 2.x fonctionnement problématique sur les menus Gestions des fichiers et Gestion des modules
J-C Etiemble Tutoriels v 2.2.x
#5
ATTENTION aux versions PHP prendre la version de CMSms en fonction !!!
http://www.cmsmadesimple.fr/forum/viewto...595#p12595
J-C Etiemble Tutoriels v 2.2.x
#6
Additif !!!

Si problème d'installation ou erreur consulter le Wiki
http://wiki.cmsmadesimple.fr/wiki/Messages_erreurs

une des erreurs est :
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR ....

Vérifier que la version de CMSms est compatible avec la version PHP de votre serveur
Pour les version CMSms 1.7 et supérieures (la configuration minimale requise est la version PHP 5.2.4 bien que nous recommandons PHP 5.2.12 - Attention : Nous ne supportons pas les paramètres E_DEPRECATED ou E_STRICT en ce moment - PHP 4.x n'est plus supporté !)
Pour les version CMSms 1.6.x (PHP maxi 5.2.x - ne pas utiliser PHP 5.3.x)
J-C Etiemble Tutoriels v 2.2.x
#7
Ce n'est pas toujours évident pour un nouveau de trouver cette documentation hyper importante, pourrait-on l'épingler dans "Accueil» Installation" qui a comme description : Installation, mise à jour et configuration ?
#8
nos docs sont encore trop dispersées ... faudrait réussir à tout recentrer sur le wiki, quitte à n'avoir ici qu'une série de lien pointant vers les différents articles concerné

AMHA
#9
RAPPEL - en cas de problèmes avec une mise à jour Et de préférence avant mise à jour pour éviter ces "soucis" Smile

il faut
- la sauvegarde la base de données de l'ancienne version (phpMyAdmin)
- les fichiers de la nouvelle version stable
- créer dans phpMyAdmin une base de données

- ATTENTION AVANT toute mise à jour lire attentivement le fichier doc/changelog.txt et les notes de version (releasenotes.txt) du dossier /install
- Lire aussi le WiKi Se mettre à jour d'une très très ancienne version


En local avec WAMP ou MAMP ou ... distribution Linux
Un tuto vidéo pour l'installation sur un serveur wamp par Jean le Chauve : http://www.youtube.com/watch?v=ZyTKGLff3...e=youtu.be

1- faire une installation avec dernière version la version stable et avec les modules standards uniquement
comme indiqué sur le Wiki
- Etape 5
pour une utlisation avec WAMP utiliser les identifiants standards :
- Serveur de BD = localhost, Nom d'utlisateur = root, mot de passe =vide,
le Nom de la base de donnée = celle que vous avez créer dans phpMyAdmin
le Préfixe des tables sera le même qu celui utilisé dans base de données de l'ancienne version
ne pas cocher "Installer les exemples de contenus et les gabarits"

à la fin vous aurez une installation minimum avec la seule page accueil Web suffisante pour tester
Tester et vérifier l'Admin et la page Web tout doit être OK
Sinon vous avez un problème de serveur ou de fichier

2- Import de la base de données ancienne version (avec phpMyAdmin)
Pour des raisons de compatibilité vérifier le fichier SQL, il faut supprimer toutes les information du fichier SQL (précédemment sauvegardé) concernant les " ENGINE=xxxx DEFAULT CHARSET=lxxx " pour éviter les problèmes.

3- tests et upgrade
upgrader (si nécessaire) Il suffit de se connecter http://monsite.fr/cms/install/upgrade.php
Tester ....
Incorporer les modules non standard (téléchargés depuis la forge) un par un ET valider l'installation des modules puis tester
ainsi de suite pour avoir la correspondance entre le site en local et le site en production
Si anomalie et/ou erreur vérifier la doc, et lire les notes de version, et le fichier changelog.txt.

Et lire le wiki est un complément
J-C Etiemble Tutoriels v 2.2.x
#10
Question 1 : Après une mise à jour, j'ai une page blanche ou autre problème d'affichage
Réponse 1 : afin d'afficher les erreurs, ajouter provisoirement en début du fichier include.php (ou à la fin du config.php) ces lignes :
Code :
// Afficher les erreurs à l'écran
ini_set('display_errors', 1);
// Enregistrer les erreurs dans un fichier de log
// Afficher les erreurs et les avertissements
error_reporting(E_ALL);
Bien sûr après réglages ou modifications supprimer ces lignes.


Question 2 : J'ai des messages d'erreurs ou des notices d'affichés
Réponse 2 : ajouter provisoirement en début du fichier include.php (ou à la fin du config.php) ces lignes :
Code :
// Désactiver TOUS les rapport d'erreurs
error_reporting(0);
Bien sûr après réglages ou modifications supprimer ces lignes.

NOTA en version 2.x le fichier include.php se trouve dans le dossier /lib

Nota bis pour passer en mode debug sur le config.php comme indiqué dans la doc
Code :
$config['debug'] = true;
J-C Etiemble Tutoriels v 2.2.x


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)