Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu] Problème modification du contenu d'une page
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: #1.10.3
#~ Url du site : discrim.fr
#~ Hébergeur / Soft : OVH
#~ Informations Système :
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bonjour à tous,

Je suis un nouvel utilisateur de ce CMS. J'ai repris un site en développement qui avait été commencé avec.

La semaine dernière j'ai mis en place quelques pages dans contenu > pages.
Aujourd'hui, je veux modifier ces mêmes contenus mais le tinyMCE n’apparaît plus sur la page d'édition des "Pages" onglet "Accueil". Je précise que tinyMCE est bien activé car il s'affiche sur d'autres pages de l'admin.

Je ne comprends pas pourquoi ce champ d'édition n’apparaît plus sur le formulaire de modification ni de création de page.

Je compte beaucoup sur votre aide, je vais être coincé si je ne trouve pas de solution.

Merci d'avance
#2
la case "Afficher éditeur WYSIWYG Oui/Non" sous le contenu est cochée


Extensions » Éditeur TinyMCE WYSIWYG Avancé -> Démarrage permis coché
J-C Etiemble Tutoriels v 2.2.x
#3
Je n'ai plus cette case non plus.

Seuls les champs :
  • type de contenu
  • titre de la page
  • texte du menu
  • parent
sont affichés...
#4
Extensions » Éditeur TinyMCE WYSIWYG Avancé -> Démarrage permis coché ?
de toute façon Afficher éditeur WYSIWYG Oui/Non est présente donc autre problème sur ta config

Vider le cache CMS et navigateur
J-C Etiemble Tutoriels v 2.2.x
#5
oui c'est coché
#6
Mes préférences » Préférences du compte utilisateur Sélection du WYSIWYG à utiliser : ??
J-C Etiemble Tutoriels v 2.2.x
#7
Sinon désinstaller Tiny et réinstaller
J-C Etiemble Tutoriels v 2.2.x
#8
tinymce sélectionné

Il n'y a que cette page qui n'affiche pas le champ...

j'ai essayé de voir dans la base de données où est stocké ce content mais je n'arrive pas à trouver, il n'y a pas de blob dans la table content ni d'index vers une éventuelle autre table.

pourtant le contenu apparait sur le frontoffice, il doit bien être stocké quelque part ?!
#9
Sur une seule page de contenu ?
quand ccte page est en édition
...url ...content_id=XX&page=
id = le Num de la page dans le contenu donc dans la BD table _content et _content_props
J-C Etiemble Tutoriels v 2.2.x
#10
non, sur toutes les pages d'édition de "Pages" dans "Contenu"

J'ai ce genre d'URL : /admin/editcontent.php?_sx_=0e0ead3f&content_id=56&page=


Le pire c'est que je n'avais pas ce problème la semaine dernière, tout allait bien quand j'ai laissé le boulot pour le weekend, et ce matin, plus moyen d'afficher le content de la page...
#11
t_id=56 = donne le content_id 56 dans BD
J-C Etiemble Tutoriels v 2.2.x
#12
sinon je ne vois toujours pas pourquoi le contenu ne s'affiche pas pour édition...
#13
Citation :je ne vois toujours pas pourquoi le contenu ne s'affiche pas pour édition.
moi non plus

donc déja désinstaller Tiny et réinstaller pour voir Wink
J-C Etiemble Tutoriels v 2.2.x
#14
Options de la page accueil : Désactiver l'éditeur WYSIWYG sur cette page (indépendamment du modèle ou de la configuration de l'utilisateur) : décocher
#15
Après avoir fait tout ce que mes collègues ont pu te dire de tester et si aucun résultat :

sous firefox : Crtl + Shift + J pour activer la console Javascript. Regarde s'il y a des erreurs
#16
Bonjour,
quand j'ai ce problème, c'est qu'il y a un soucis dans le gabarit. Vérifie tes tag {content} si tu en as plusieurs.
Ou bien, c'est que j'utilise "advanced content" et que le type de contenu n'est pas "contenu avancé".
Ou bien le type de contenu est "separateur", entete de section...

Il faut chercher de ce côté puisque les vérifications de base n'ont rien donné.

Il faut que tu nous donnes les infos sur ton install comme demandé à la création du post, notamment la liste des modules!
{SEO}
Inscrivez-vous à notre Newsletter sur le site (colonne de droite, en bas).
Vous appréciez CMSMS et l'aide qui vous est fournie ici, aidez-nous en participant au projet.
Formation CMS Made Simple | Création de site CMS Made Simple.

C'est en se plantant qu'on devient cultivé.
J'ai un string dans l'Array (Paris Hilton)
#17
C'est possible que ça vienne d'un gabarit ? que faut-il que je recherche exactement... c'est que ce n'est pas pratique de coder sans surbrillance

Voici le gabarit "principal" :

Code :
[== XHTML ==]
{global_content name='main-header'}
    
<body class="home blog">
  <div id="art-main">
     <div class="art-sheet">
         <div class="art-sheet-body">
      <div class="art-header">
            <div class="art-nav">
                <div class="l"></div>
                <div class="r"></div>
                {menu}
            </div>    
        <div class="art-header-jpeg"></div>
             <div id="title">
        <div class="bnd-title">{title}</div>
        </div>    
        <div id="capa2" align="left">{global_content name='logo'}</div>
      </div>
      <div id="capa3">{global_content name='top-right-image-links'}</div>

          <div class="art-content-layout">
        {global_content name='main-content-layout'}    
          </div>

      {global_content name='sidebar'}

          {global_content name='footer'}
                
       </div><!--end art-sheet-->
   </div><!--end art-main-->
  {global_content name='scrolltop'}
  <div id="lien_top"></div>

  <!-- citation JS -->
     {global_content name='citations_JS'}
  <!-- end citation JS -->

</body>
</html>

Et contenu de "main-content-layout" ;

Code :
[== XHTML ==]
<div id="art-content-layout-row">
        <div class="art-layout-cell art-content">
          <!-- To edit the caption text add a title tag like in the sample. -->
          <!-- each image must be 436x269px -->
                  <div class="art-post">
                     <div class="art-post-tl"></div>
                     <div class="art-post-tr"></div>
                     <div class="art-post-bl"></div>
                     <div class="art-post-br"></div>
                     <div class="art-post-tc"></div>
                     <div class="art-post-bc"></div>
                 <div class="art-post-cl"></div>
                     <div class="art-post-cr"></div>
                     <div class="art-post-cc"></div>
                     <div class="art-post-body">
                            <div>{content}</div>
             </div>
             <div class="navigation">
            <div class="alignright"></div>
             </div><!--navigation-->
          </div><!--end art-post-->
          <div class="cleared"></div>
            </div><!--art-layout-cell art-content-->
                <div class="cleared"></div>                             
              </div>

J'ai beau examiner, je ne vois pas ...
#18
Citation :Aujourd'hui, je veux modifier ces mêmes contenus mais le tinyMCE n’apparaît plus sur la page d'édition des "Pages" onglet "Accueil". Je précise que tinyMCE est bien activé car il s'affiche sur d'autres pages de l'admin.
Je résume, tu n'as pas de wysiwyg uniquement sur la page d'accueil, tu l'as partout ailleurs.
Donc, vérifie les options de la page d'accueil comme écrit plus haut.
#19
On ne voit pas de {content} dans ton gabarit qui est sans doute raccordé uniquement à la page d'accueil.
Ce n'est donc pas le whysiwyg que tu ne vois pas, c'est le champ contenu en entier qu'il te manque. jissey a trouvé la bonne résolution.
#20
En fait le tag {content} est dans le bloc de contenu global main-content-layout, inclus dans le gabarit par les lignes :

Code :
[== XHTML ==]
<div class="art-content-layout">
        {global_content name='main-content-layout'}    
          </div>

Faut-il en conclure que le tag {content} doit se trouver directement dans le gabarit et non pas inclu via un bloc de contenu global ?
#21
>Faut-il en conclure que le tag {content} doit se trouver directement dans le gabarit et non pas inclu via un bloc de
>contenu global ?

oui je confirme, il faut qu'il y ai {content} dans ton gabarit
#22
Citation :le tag {content} doit se trouver directement dans le gabarit
Oui sinon le Tiny il est pas "content" [ :lol: ! ]
J-C Etiemble Tutoriels v 2.2.x
#23
D'accord c'est bon en effet ça refonctionne maintenant ! eh bé ! il fallait le savoir...

Merci à tous pour votre aide ! notamment à Jissey qui a eu le bon feeling !


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)