Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[resolu] Mise à jour 152 => 1.10.2
#1
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: !1.6.x
#~ Url du site : localhost
#~ Hébergeur / Soft : wamp
#~ Informations Système : php 535
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bonjour à tous,

Tout d'abord tous mes bons voeux aux lecteurs/utilisateurs de ce forum.

Bien, je vais vous demander un peu d'indulgence, car je reprends et doit remettre à flot la version 152 sur un site en production. Je ne connais CMS made simple et donc, je vais découvrir en même temps.

(Test en local, bien sur)

Alors ce que j'ai fait,

1er) j'ai lu pas mal de post sur le forum, mais rien trouvé qui corresponde vraiment à mon erreur
2me) j'ai lu et relu la documentation d'installation et suivi cette dernière pour la mise à jour

Lors de celle ci, j'ai l'erreur suivante que je n'arrive pas à résoudre :

Code :
[== Indéfini ==]
Fatal error: Class 'ContentOperations' not found in F:\Site\html\lib\autoloader.php on line 82

Quelqu'un aurait-il un moment, pour me souffler des pistes pour résoudre cette erreur ? Je pense que cela ne va pas être la seule.

Merci d'avance
#2
Bonjour à tous,

J'ai modifié par des addons, le serveur wamp conf pour test:
apache => 2.055
php => V 5.25
Mysql => V 5.1.41

Alors maintenant j'ai les erreurs suivantes. Je suppose qu'elles viennent de module ou plugin non reconnu. Comment faire pour les déactivés alors que j'arrive même pas sur la page index ?
Code :
[== Indéfini ==]

ERROR: The CGExtensions module could not be found.

Citation :string(104) "Smarty error: [in tpl_body:25 line 8]: [plugin] unknown tag - 'anchor' (core.load_plugins.php, line 124)" string(111) "Smarty error: [in tpl_body:25 line 17]: [plugin] unknown tag - 'cms_selflink' (core.load_plugins.php, line 124)" string(103) "Smarty error: [in tpl_body:25 line 33]: [plugin] unknown tag - 'menu' (core.load_plugins.php, line 124)" string(113) "Smarty error: [in tpl_body:25 line 71]: [plugin] unknown tag - 'global_content' (core.load_plugins.php, line 124)" string(110) "Smarty error: [in tpl_body:25 line 76]: [plugin] unknown tag - 'breadcrumbs' (core.load_plugins.php, line 124)" string(106) "Smarty error: [in tpl_body:25 line 81]: [plugin] unknown tag - 'content' (core.load_plugins.php, line 124)" string(103) "Smarty error: [in tpl_body:25 line 83]: [plugin] unknown tag - 'news' (core.load_plugins.php, line 124)" string(106) "Smarty error: [in tpl_body:25 line 101]: [plugin] unknown tag - 'search' (core.load_plugins.php, line 124)" string(110) "Smarty error: [in tpl_body:25 line 113]: [plugin] unknown tag - 'cms_module' (core.load_plugins.php, line 124)"


Fatal error: Call to undefined function smarty_cms_function_anchor() in C:\wamp\www\html\tmp\templates_c\%%E8^E85^E855A813%%tpl_body%3A25.php on line 11
#3
Bonjour, as-tu accès à l'administration du site ?
Et on ne sait pas très bien ce que tu as fait.
Ton site local avant upgrade fonctionnait-il ?
#4
Code :
ERROR: The CGExtensions module could not be found.

je pars du principe que tu n'as pas accès à l'admin (pire scénario)

télécharge le module CGExtensions dans sa dernière version (ici un tar.gz)

tu dézippe ton archive et tu claques les fichiers dans ./modules/CGExtensions

ça te corrigera déjà ta première erreur


Pour la seconde je ne peux que faire des hypothèses, déjà commence par vider le cache de cmsmadesimple dans ./tmp/templates_c
#5
bonjour tous les deux,


Je vais télécharger CGExtensions et le mettre en place. En effet, comme je le disais, je reprends le site derrière une personne qui n'a rien laissé, bien au contraire.

Je ne sais pas si j'ai accès à l'admin, comment me rendre sur la page administrateur. Je peux avoir les pass ( je pense ) !
#6
Dans tous les cas, tu auras besoin du login et pass ftp.
Avec cela, tu auras accès au config.php qui te donnera le login et pass de la base de données et tu pourrais alors réinitialiser le mot de passe admin si tu ne le retrouves pas.
Maintenant, ne serait-il pas plus judicieux d'en profiter pour refaire un nouveau site, il y a eu tellement de modifications depuis ta version...
#7
Ben en fait, j'ai récupéré les fichiers les données du fichier config., il n'y a pas de soucis.

Refaire l'ensemble du site oui, bien sur, mais je suis devant un degré d'urgence, car c'est une collectivité, et il faut que cela se fasse avant fin du mois pour des tonnes de raisons,.

Bien pour revenir à mes erreurs, j'ai bien mis CExtensions et je n'ai plus que la suivante maintenant:
Code :
[== Indéfini ==]
Fatal error: Class 'cms_cache_handler' not found in C:\wamp\www\html\modules\CGExtensions\CGExtensions.module.php on line 73

En tous les cas, merci de la démarche d'aide que vous m'apportez.
#8
Va dans l'onglet administration du site, informations système et colle les données ici.
Également ton config.php (en effaçant le login et le pass de la bd).
#9
Voici le contenu du fichier config, sans bien sur le MDP et ID, Par contre, je n'ai pas accès au site, donc à l'administration pour les informations systèmes ( puisque j'ai l'erreur cité juste avant )

Puis je les trouver ailleurs ?

Code :
[== Indéfini ==]
<?php


#CMS Made Simple Configuration File
#Please clear the cache (Site Admin->Global Settings in the admin panel)
#after making any changes to path or url related options

#-----------------
#Behaviour Settings
#-----------------

# These settings will effect the overall behaviour of the CMS application, please
# use extreme caution when editing these.  Additionally, some settings may have
# no effect on servers with significantly restricted configurability.

# If you are experiencing propblems with php memory limit errors, then you may
# want to try enabling and/or adjusting this setting.
# Note: Your server may not allow the application to override memory limits.
$config['php_memory_limit'] = '';

# In versions of CMS Made Simple prior to version 1.4, the page template was processed
# in it's entirety.  This behaviour was later changed to process the head portion of the
# page template after the body.  If you are working with a highly configured site that
# relies significantly on the old order of smarty processing, you may want to try
# setting this parameter to false.
$config['process_whole_template'] = false;

# CMSMS Debug Mode?  Turn it on to get a better error when you
# see {nocache} errors, or to allow seeing php notices, warnings, and errors in the html output.
# This setting will also disable browser css caching.
$config['debug'] = false;

# Output compression?
# Turn this on to allow CMS to do output compression
# this is not needed for apache servers that have mod_deflate enabled
# and possibly other servers.  But may provide significant performance
# increases on some sites.  Use caution when using this as there have
# been reports of incompatibilities with some browsers.
$config['output_compression'] = false;

#-----------------
#Database Settings
#-----------------

#This is your database connection information.  Name of the server,
#username, password and a database with proper permissions should
#all be setup before CMS Made Simple is installed.
$config['dbms'] = 'mysql';
$config['db_hostname'] = 'localhost';
$config['db_username'] = '';
$config['db_password'] = '';
$config['db_name'] = 'cms';
#Change this param only if you know what you are doing
$config["db_port"] = '';


#If app needs to coexist with other tables in the same db,
#put a prefix here.  e.g. "cms_"
$config['db_prefix'] = 'cms_';

#Use persistent connections?  They're generally faster, but not all hosts
#allow them.
$config['persistent_db_conn'] = false;

#Use ADODB Lite?  This should be true in almost all cases.  Note, slight
#tweaks might have to be made to date handling in a "regular" adodb
#install before it can be used.
$config['use_adodb_lite'] = true;

#-------------
#Path Settings
#-------------

#Document root as seen from the webserver.  No slash at the end
#If page is requested with https use https as root url
#e.g. http://blah.com
$config['root_url'] = 'http://www.exemple.fr';
if(isset($_SERVER['HTTPS']) && $_SERVER['HTTPS']=='on')
{
$config['root_url'] = str_replace('http','https',$config['root_url']);
}

#Path to document root. This should be the directory this file is in.
#e.g. /var/www/localhost
$config['root_path'] = '/home/wwwromu/html';

#Name of the admin directory
$config['admin_dir'] = 'admin';

#Where do previews get stored temporarily?  It defaults to tmp/cache.
$config['previews_path'] = '/home/wwwromu/html/tmp/cache';

#Where are uploaded files put?  This defaults to uploads.
$config['uploads_path'] = '/home/wwwromu/html/uploads';

#Where is the url to this uploads directory?
$config['uploads_url'] = $config['root_url'] . '/uploads';


#---------------
#Upload Settings
#---------------

#Maxium upload size (in bytes)?
$config['max_upload_size'] = 1000000;

#Permissions for uploaded files.  This only really needs changing if your
#host has a weird permissions scheme.
$config['default_upload_permission'] = '664';

#------------------
#Usability Settings
#------------------

#Allow smarty {php} tags?  These could be dangerous if you don't trust your users.
$config['use_smarty_php_tags'] = false;

#Automatically assign alias based on page title?
$config['auto_alias_content'] = true;

#------------
#URL Settings
#------------

#Show mod_rewrite URLs in the menu? You must enable 'use_hierarchy' for this to work for modules
$config['assume_mod_rewrite'] = false;

#Extension to use if you're using mod_rewrite for pretty URLs.
$config['page_extension'] = '';

#If you don't use mod_rewrite, then would you like to use the built-in
#pretty url mechanism?  This will not work with IIS and the {metadata} tag
#should be in all of your templates before enabling.
$config['internal_pretty_urls'] = false;

#If you're using the internal pretty url mechanism or mod_rewrite, would you like to
#show urls in their hierarchy?  (ex. http://www.mysite.com/parent/parent/childpage)
$config['use_hierarchy'] = false;

#If using none of the above options, what should we be using for the query string
#variable?  (ex. http://www.mysite.com/index.php?page=somecontent)
$config['query_var'] = 'page';

#--------------
#Image Settings
#--------------

#Which program should be used for handling thumbnails in the image manager.
#See http://wiki.cmsmadesimple.org/index.php/User_Handbook/Admin_Panel/Content/Image_Manager for more
#info on what this all means
$config['image_manipulation_prog'] = 'GD';
$config['image_transform_lib_path'] = '/usr/bin/ImageMagick/';

#Default path and URL for uploaded images in the image manager
$config['image_uploads_path'] = '/home/wwwromu/html/uploads/images';
$config['image_uploads_url'] = $config['root_url'] . '/uploads/images';


#------------------------
#Locale/Encoding Settings
#------------------------

#Locale to use for various default date handling functions, etc.  Leaving
#this blank will use the server's default.  This might not be good if the
#site is hosted in a different country than it's intended audience.
$config['locale'] = '';

#In almost all cases, default_encoding should be empty (which defaults to utf-8)
#and admin_encoding should be utf-8.  If you'd like this to be different, change
#both.  Keep in mind, however, that the admin interface translations are all in
#utf-8, and will be converted on the fly to match the admin_encoding.  This
#could seriously slow down the admin interfaces for users.
$config['default_encoding'] = '';
$config['admin_encoding'] = 'utf-8';

#---------------------------------------------
#Use the old stylesheet logic?  It's much slower, but it works with older
#versions of CMSMS.  You'll also need this set to true if there is a module
#that uses a stylesheet callback.  Leave it as false instead you really
#need it.
$config['old_stylesheet'] = false;

# URL of the Admin Panel section of the User Handbook
$config['wiki_url'] = 'http://wiki.cmsmadesimple.org/index.php/User_Handbook/Admin_Panel/fr';

#Enable backwards compatibility mode?  This basically will allow some
#modules written before 1.0 was released to work.  Keep in mind that this
#will use a lot more memory and isn't guaranteed to fix the problem.
$config['backwards_compatible'] = false;

#Not used anymore... kept around, just in case
$config['disable_htmlarea_translation'] = false;
$config['use_Indite'] = true;
?>
#10
mmmm le problème est que tu traine cette vielle version et que cgExtension est pour une 1.10.x


balance la nouvelle version de cmsmadesimple (1.10.2) par dessus tes fichiers, tu va sur tonsite.fr/install/upgrade.php et fait la mise à jour.

A la section "mise à jour des modules" il est a parier que ça bloque vu l'ancienneté des fichiers, on verra à ce moment là
#11
si tu est en CMS version 1.6.x et que tu as pris la dernière version de CGExtensions, cela ne fonctionnera PAS

Jean a dit "Va dans l'onglet administration du site, informations système et colle les données ici."
J-C Etiemble Tutoriels v 2.2.x
#12
Voilan j'ai ecrasé les fichiers et j'ai toujours cette erreur

Code :
[== Indéfini ==]
Fatal error: Class 'ContentOperations' not found in C:\wamp\www\html\lib\autoloader.php on line 82
#13
Code :
#-------------
#Path Settings
#-------------

#Document root as seen from the webserver.  No slash at the end
#If page is requested with https use https as root url
#e.g. http://blah.com
$config['root_url'] = 'http://www.exemple.fr';
Qu'estce qui est écrit comme adresse : http://localhost/ ?

Et tu ne peux pas aller à l'administration ? ça n'a rien à voir avoir index.php, généralement c'est http://localhost/répertoireOùSeTrouveCms/admin
Et sur le site en production, c'est www.tondomaine.fr/admin
#14
Citation :Refaire l'ensemble du site oui, bien sur, mais je suis devant un degré d'urgence, car c'est une collectivité, et il faut que cela se fasse avant fin du mois pour des tonnes de raisons,.
Le site en ligne fonctionne en 1.5.2 depuis 3 ans, il peut encore attendre 2, 3 semaines, non ? Y aurait-il eu un nouveau chef :lol:
Il a combien de pages, ton site ? Donne-nous son adresse, on te dira combien de temps il faut pour le recréer.
Ce n'est que du copier-coller, et, par rapport aux erreurs citées en début de post, il ne semble pas y avoir de module spécifique, à part les news. 2 jours de travail max pour un débutant.
#15
D'accord, je suis prêt à faire. Tu as raison, il pourrait bien attendre, mis à part le fait qu'il était affecté sur un serveur local et ...... Si c'était aussi simple ( mdr)

Bien alors plutôt que de chercher à faire la mise à jour, vous avez raison, comment récupérer le design ? Comment récupérer les articles dans la base ? et la mise en page ?

Le site en production est visible ici

En fait, c'est un vrai boxon dans le dossier qui contient le site, qu'une chatte y perdrait ses petits. D’où mon test en local pour arriver les mises à jour. Soupir !!!!
#16
Tu as tout, puisque tu as le site en ligne.
Rends-toi à cette page : http://www.ville-behren.fr/admin/login.php
Entre le login et le mot de passe et tu seras dans la console d'administration.
Tu récupéreras tout ce dont tu as besoin et tu le colleras dans ton nouveau site.

Première chose à faire, installer la version 1.10.2 sur ton serveur dans un nouveau répertoire

Puis tu regardes la documentation et tu te familiarises avec l’administration, comment on crée des pages, comment on relie les pages aux gabarits, et les css aux gabarits...
Quelles sont tes connaissances informatiques ?
#17
Pour mes connaissances, elles sont bonnes. Mais bon jusque maintenant j'ai plutot fonctionné avec la concurrence, cad, joomla Wink

Je vais installer la nouvelle version de cms made

Par contre, je vais arreté là pour ce soir, et je reprendrai Lundi si vous êtes d'accord, faut bien s'occuper un peu de la famille. Merci et à Lundi.
#18
Alors, ça ira tout seul, tu pigeras vite.
Bonne soirée
#19
prend juste note que certain code présent dans le gabarit des pages ne fonctionnera plus

exemple : {stylesheet} est remplacé par {cms_stylesheet}

C'est le seul de mémoire Smile
#20
Bien le bonjour à tous,

Voila, j'ai installé la dernière version du script en local pour pouvoir faire les modifs. Alors juste une question, car je pense pouvoir récupérer une grande partie de la BD.

Qu' a été changé depuis la version 1.53

Merci

Je rajoute ce qui a été demandé plus haut

Citation :[== Indéfini ==]
CMS Install Information:

CMS Version

1.5.3

Installed Modules

CMSMailer

1.73.14

FileManager

0.4.5

MenuManager

1.5.3

ModuleManager

1.2.1

News

2.9.3

nuSOAP

1.0.1

Printing

0.2.6

Search

1.5.3

ThemeManager

1.1.0

TinyMCE

2.4.13

ABFlashGallery

0.2

FrontEndUsers

1.3.1

Calendar

0.7.11

FormBuilder

0.4.4

FeuCalendar

0.1

NMS

1.0.1

CGExtensions

1.6

SimpleGoogleMap

1.0.1

CGGoogleMaps

1.0

Forum

0.9.2

Captcha

0.3.1

RSS2HTML

1.2.2

relatives

0.2

Download

0.3b

SiteMapMadeSimple

1.1.4

CompanyDirectory

1.1.6

Album

0.9.3

Chat

0.2.0

Statistics

0.8.0b9

CodePress

0.1.2

Map

0.3

AjaxMadeSimple

0.1.5

Banners

2.2.1

Questions

1.0.3

pisearch

1.72

Glossary

0.6.5

FormBrowser

0.2.3

Blogs

0.3.3.1

DecisionTree

0.1.4

Slide

1.0
#21
Il y a plein de modules qui ne fonctionneront sans doute plus avec la nouvelle version.
Certains ont été remplacés par d'autres, comme Calendar qui est devenu CGCalendar.
Je suppose qu'il y a également des modules qui ne sont pas utilisés (chat, forum, decision tree) ou ne sont pas très utiles (glossary, codepress).

Je pense que la meilleure chose à faire est de laisser le site en l'état et de repenser un nouveau site à ton aise (en ajoutant déjà une page contact).

Il faudrait l'avis des administrateurs de ce forum, en particulier du spécialiste des problèmes de mises à jour : JCE.
#22
>>Alors juste une question, car je pense pouvoir récupérer une grande partie de la BD.

on ne récupère pas la bdd. Soit tu met à jour la bdd avec cmsmadesimple Soit tu as sous les yeux les deux installations et tu copie le contenu de l'ancien sur le nouveau. Dans l'ordre :

les fichiers dans ./uploads
les gabarits en modifiant {stylesheet} par {cms_stylesheet}
les balises utilisateurs en vérifiant que le code fonctionne (en cas de doute, copie les ici une à une)
les global content
les gabarits du menu

et enfin le contenu des pages


Normalement à ce niveau c'est juste du copier/coller et ça devrait déjà être bon
#23
La liste des modules à jour pour 1.10.+
http://forum.cmsmadesimple.org/viewtopic...35#p265635
#24
Bonjour Bess

Merci pour ce coup de main.

J'ai pour le moment, transféré l'ensemble des fichiers qui se trouvaient dans le dossier ./uploads
J'ai recrée les gabarits en faisant attention à ton conseil de modification de la balise {stylesheet} par {cms_stylesheet}

Pardon de mon ignorance.

Quand tu parles de balises utilisateurs et vérifier que le code fonctionne, je m'y prend comment ? Les balsies c'est bien =>extensions=>Balises ?

Idem pour les global content, je les trouve ou ?

Dans les gabarits menu, je trouve dans l'ancienne version => Gabarits se trouvant dans la base de données ainsi que
Gabarits sous forme de fichier

Lesquel prendre en compte dans la nouvelle version ?

Merci encore
#25
Bonjour Jean, aurais tu un lien pour télécharger les modules,
Merci


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)