Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 Re : Installation » [Resolu]Installation v2.2.6 en local » 05/03/2018 17:30:45

Merci pour ta réponse Jissey.

J'ai eu du mal à trouver où créer cet utilisateur mais c'est fait et l'installation s'est bien terminé.

Donc Pb résolu, je modifie le premier poste et à bientôt pour de nouvelles aventures

Amicalement

Alain

#2 Installation » [Resolu]Installation v2.2.6 en local » 05/03/2018 12:50:54

AG1111
Réponses : 3

Bonjour,

Je suis bloqué sur l'installation en local de la v2.2.5 ainsi que pour la v2.2.6. Avec Wampserver 2.4 (Apache version 2.49, PHP version 2.5.12, Sql version 5.6.17)

La base de donnée est crée vide et le phar coince à l'étape 4 "Informations sur la configuration de base" car il veut absolument un mot de passe  avec le message suivant

[== Indéfini ==]
Accs refus pour l'utilisateur: 'root'@'@localhost' (mot de passe: OUI) 

si j'en mets un cela ne change rien il reste coincé là. Cela se produit quelque soit le mode utilisé avancé ou non.

Pour une installation en locale on ne met pas de mot de passe sur la db d'habitude?

L'interclassement de la db est "utf8_general-ci"

Avez-vous une idée

Merci d'avance pour votre aide

Alain

#3 Re : Modules, Tags » [RESOLU] FEU: suite à MàJ 1.12 en 2.2.5 connexion user impossible » 08/01/2018 19:06:42

Bon, je n'ai pas trouvé pourquoi ça ne fonctionne pas mais j'ai trouvé un contournement : je passe par reCaptcha et là pas de pb.

Donc sans être résolu je modifie mon premier poste mais si vous avez une idée du pourquoi ceci se produit je suis preneur.

Dans la foulée je passe le site en prod en version 2.2.5. donc à bientôt pour d'autres surprises.

Amicalement

Alain

#4 Re : Modules, Tags » [RESOLU] FEU: suite à MàJ 1.12 en 2.2.5 connexion user impossible » 07/01/2018 11:46:51

Merci Ouik, j'ai fini par les trouver.

Par contre, ça ne m'avance pas beaucoup car le code qui affiche la partie captcha du template de loggin est le même que celui qui existe en cmsms v 1.12. SI je passe ce code de la v 2.2.5 en 1.12 il fonctionne et à l'inverse le code de la v1.12 ne fonctionne pas non plus en v2.2.5. Ce qui peut être rassurant. Autre précision ce comportement est le même avec IE et Chorme donc ce ne doit pas être un pb de config de navigateur.

J'ai lu dans un texte de JCE "CMS Made Simple Version 2.0" qui date de 2015, dans les problèmes de mise à jour, que la portée des variables Smarty à changée et qu'il faut les copier explicitement dans un autre champs d'application. Là je coince car mes compétences en Smarty sont quasi nulles et je sais pas comment m'en sortir.

Voici le code :

[== Indéfini ==]
  {if isset($captcha)}
  <div class="row">
    <p class="col-md-4 text-right"><label for="feu_captcha">{$captcha_title}:</label></p>
    <div class="col-md-8">{$captcha}
       <div class="row">{$input_captcha}</div>
  </div>
  {/if}

Dans le code de la page j’obtiens :

[== Indéfini ==]
<div class="row">
    <p class="col-md-4 text-right"><label for="feu_captcha">Veuillez entrer le texte de l'image:</label></p>
    <div class="col-md-8"><input type="hidden" name="hncaptcha" value="31122132231111123221331113221122"/>
<input type="hidden" name="hncaptcha_public_key" value="4b4de"/>
<img class="captchapict" src="/tmp/cache/hn_captcha_4b4de.jpg" width="198" height="72" alt="This is a captcha-picture. It is used to prevent mass-access by robots. (see: www.captcha.net)" title="No Bots allowed" />


       <div class="row"></div>
  </div>

Donc, à priori, c'est la variable $input_captcha qui ne fonctionne pas. Mais dans ce cas pourquoi les autres variables Smarty de ce gabarit fonctionnent et pas celle là ?

Que faire ?

Merci d'avance

#5 Modules, Tags » [RESOLU] FEU: suite à MàJ 1.12 en 2.2.5 connexion user impossible » 05/01/2018 18:12:53

AG1111
Réponses : 3

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.2.4
#~ Url du site : randokerlouan.fr
#~ Hébergeur / Soft : ovh
#~ Informations Système :
#~      ----------------------------------------------
#~      Cms Version: 2.2.5
#~      Installed Modules:
#~          AdminSearch: 1.0.4
#~          CGExtensions: 1.57.1
#~          CGGoogleMaps2: 1.1.1
#~          CGSimpleSmarty: 2.1.7
#~          CMSContentManager: 1.1.6
#~          CMSMailer: 6.2.14
#~          Captcha: 0.5.5
#~          CmsJobManager: 0.1.2
#~          CustomContent: 1.10
#~          DesignManager: 1.1.4
#~          DownCnt: 2.5.0
#~          FileManager: 1.6.5
#~          FilePicker: 1.0.2
#~          FormBuilder: 0.8.1.6
#~          FrontEndUsers: 2.7.1
#~          Gallery: 2.3.2
#~          Gbook: 2.2.6
#~          JQueryTools: 1.4.0.3
#~          MenuManager: 1.50.3
#~          MicroTiny: 2.2.2
#~          ModuleManager: 2.1.3
#~          Navigator: 1.0.8
#~          News: 2.51.3
#~          Printing: 1.1.2
#~          Search: 1.51.2
#~          SiteMapMadeSimple: 1.2.8
#~          ThemeManager: 1.1.8
#~      Config Information:
#~          php_memory_limit:
#~          max_upload_size: 128000000
#~          url_rewriting: mod_rewrite
#~          page_extension: .html
#~          query_var: page
#~          auto_alias_content: true
#~          locale:
#~          set_names: true
#~          timezone: Europe/Paris
#~          permissive_smarty: false
#~      Php Information:
#~          phpversion: 5.6.30
#~          md5_function: On  (Vrai)
#~          json_function: On  (Vrai)
#~          gd_version: 2
#~          tempnam_function: On  (Vrai)
#~          magic_quotes_runtime: Off  (Faux)
#~          E_ALL: 32759
#~          E_STRICT: 2048
#~          E_DEPRECATED: 8192
#~          test_file_timedifference: Aucune différence de date du système trouvée
#~          test_db_timedifference: Aucune différence de date du système trouvée
#~          create_dir_and_file: 1
#~          memory_limit: 512M
#~          max_execution_time: 300
#~          register_globals: Off  (Faux)
#~          output_buffering: 4096
#~          disable_functions: _dyuweyrj4, _dyuweyrj4r, dl
#~          open_basedir:
#~          test_remote_url: Echec
#~          file_uploads: On  (Vrai)
#~          post_max_size: 130M
#~          upload_max_filesize: 128M
#~          session_save_path: /tmp (0700)
#~          session_use_cookies: On  (Vrai)
#~          xml_function: On  (Vrai)
#~          xmlreader_class: On  (Vrai)
#~          check_ini_set: On  (Vrai)
#~          curl: On
#~      Performance Information:
#~          allow_browser_cache: Off  (Faux)
#~          browser_cache_expiry: 60
#~          php_opcache: On  (Vrai)
#~          smarty_cache: Off  (Faux)
#~          smarty_compilecheck: Off  (Faux)
#~          auto_clear_cache_age: Off  (Faux)
#~      Server Information:
#~          Server Software: Apache
#~          Server Api: fpm-fcgi
#~          Server Os: Linux 4.4.67-ovh-vps-grsec-zfs-classid On  x86_64
#~          Server Db Type: MySQL (mysqli)
#~          Server Db Version: 5.5.55
#~          Server Db Grants: Impossible de trouver un privilège "GRANT ALL". Cela ne conduit pas nécessairement à des problèmes... Mais si vous avez des problèmes pour installer/retirer des modules ou ajouter/supprimer des éléments de contenu ou pages cela pourrait en être la cause.
#~      Permission Information:
#~          tmp: /home/randoker/www/test/tmp (0705)
#~          tmp_cache: /home/randoker/www/test/tmp/cache (0705)
#~          templates_c: /home/randoker/www/test/tmp/templates_c (0705)
#~          modules: /home/randoker/www/test/modules (0705)
#~          uploads: /home/randoker/www/test/uploads (0705)
#~          Masque de création de fichier (umask) : /home/randoker/www/test/tmp/cache (0705)
#~          config_file: 0444
#~      ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~

Bonjour à toutes et à tous avec mes meilleurs vœux pour 2018.


Sur un environnement de test en ligne, j'ai mis à jour ce site de la version 1.12 à la version 2.2.5., j'ai également mis à jour tous les modules additionnels à leur dernière version. Tout fonctionne sauf que les utilisateurs ne peuvent se connecter sur le site parce que le champ de saisie de l'image captcha n'apparaît pas. Je sais un truck connu et la solution est de mettre à jour CGExtension, mais il est à la dernière version ??

Connexion sur randokerlouan.fr

J'ai essayé de trouver le gabarit 'loggin' du module mais il n'est pas accessible à partir de l'admin ni dans les "utilisateurs du site" ni dans les "parametres FEU".

Où se cachent les gabarits de FEU ?

Avez-vous une idée ?


Merci d'avance pour vous réponses

Cordialement

Alain

#6 Re : Installation » [Resolu] install V2.2.2 » 10/07/2017 11:45:58

Merci à tous les 3 pour vos réponses.
Je suis d'accord Jce ce n'est trop grave et il y a pire.

Bon je pense que la routine n'était pas encore passée puisque la notification était toujours là.
Merci Ouik : c'est bien ça il y a une petite croix, pas facile à voir, dans le corps de la notification qui la supprime.

Je modifie le premier poste

à bientôt

Alain

#7 Re : Installation » [Resolu] install V2.2.2 » 10/07/2017 10:44:51

Bon j'ai vidé le cache et là le site est accessible normalement.

Mais cela n'explique pas la notification pour le passage en de v2.2.1 en v2.2.2

#8 Installation » [Resolu] install V2.2.2 » 10/07/2017 10:13:53

AG1111
Réponses : 5

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.2.2
#~ Url du site : xaviergavaud.fr
#~ Hébergeur / Soft : Firstheberg
#~ Informations Système :
#~      ----------------------------------------------
#~      Cms Version: 2.2.2
#~      Installed Modules:
#~          AdminSearch: 1.0.4
#~          CGExtensions: 1.55.6
#~          CMSContentManager: 1.1.5
#~          CMSMailer: 6.2.14
#~          Captcha: 0.5.5
#~          CmsJobManager: 0.1
#~          DesignManager: 1.1.3
#~          FileManager: 1.6.3
#~          FilePicker: 1.0
#~          FormBuilder: 0.8.1.6
#~          Gallery: 2.3.1
#~          MenuManager: 1.50.3
#~          MicroTiny: 2.2
#~          ModuleManager: 2.1.1
#~          Navigator: 1.0.7
#~          News: 2.51.2
#~          Search: 1.51.2
#~          SiteMapMadeSimple: 1.2.8
#~          ThemeManager: 1.1.8
#~      Config Information:
#~          php_memory_limit:
#~          max_upload_size: 10000000
#~          url_rewriting: mod_rewrite
#~          page_extension: .html
#~          query_var: page
#~          auto_alias_content: true
#~          locale:
#~          set_names: true
#~          timezone: Europe/Paris
#~          permissive_smarty: false
#~      Php Information:
#~          phpversion: 5.6.27
#~          md5_function: On  (Vrai)
#~          json_function: On  (Vrai)
#~          gd_version: 2
#~          tempnam_function: On  (Vrai)
#~          magic_quotes_runtime: Off  (Faux)
#~          E_ALL: 22527
#~          E_STRICT: 0
#~          E_DEPRECATED: 0
#~          test_file_timedifference: Aucune différence de date du système trouvée
#~          test_db_timedifference: Une différence de date avec l'environnement PHP a été détectée. Cela peut causer des problèmes lorsque vous publiez des articles.
#~          create_dir_and_file: 1
#~          memory_limit: 128M
#~          max_execution_time: 120
#~          register_globals: Off  (Faux)
#~          output_buffering: 4096
#~          disable_functions: dl, exec, shell_exec, system, passthru, popen, pclose, proc_open, proc_nice, proc_terminate, proc_get_status, proc_close, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, escapeshellcmd, shell-exec, fpassthru, crack_check, crack_closedict, crack_getlastmessage, crack_opendict, psockopen, symlink, ini_restore, posix_getpwuid, getmyuid, listen, diskfreespace, tmpfile, link, ignore_user_abord, highlight_file, source, show_source, fpaththru, virtual, posix_ctermid, posix_getcwd, posix_getegid, posix_geteuid, posix_getgid, posix_getgrgid, posix_getgrnam, posix_getgroups, posix_getlogin, posix_getpgid, posix_getpgrp, posix_getpid, posix, _getppid, posix_getpwnam, posix_getrlimit, posix_getsid, posix_getuid, posix_isatty, posix_setegid, posix_seteuid, posix_setgid, posix_times, posix_ttyname, posix_uname
#~          open_basedir:
#~          test_remote_url: Valable
#~          file_uploads: On  (Vrai)
#~          post_max_size: 10M
#~          upload_max_filesize: 10M
#~          session_save_path: /tmp (1777)
#~          session_use_cookies: On  (Vrai)
#~          xml_function: On  (Vrai)
#~          xmlreader_class: On  (Vrai)
#~          check_ini_set: On  (Vrai)
#~          curl: On
#~      Performance Information:
#~          allow_browser_cache: Off  (Faux)
#~          browser_cache_expiry: 60
#~          php_opcache: Off  (Faux)
#~          smarty_cache: On  (Vrai)
#~          smarty_compilecheck: Off  (Faux)
#~          auto_clear_cache_age: On  (Vrai)
#~      Server Information:
#~          Server Software: Apache
#~          Server Api: cgi-fcgi
#~          Server Os: Linux 3.2.0-4-amd64 On  x86_64
#~          Server Db Type: MySQL (mysqli)
#~          Server Db Version: 5.5.55
#~          Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
#~      Permission Information:
#~          tmp: /srv/filer02/dyopsy2901/www/tmp (0705)
#~          tmp_cache: /srv/filer02/dyopsy2901/www/tmp/cache (0705)
#~          templates_c: /srv/filer02/dyopsy2901/www/tmp/templates_c (0705)
#~          modules: /srv/filer02/dyopsy2901/www/modules (0705)
#~          uploads: /srv/filer02/dyopsy2901/www/uploads (0705)
#~          Masque de création de fichier (umask) : /srv/filer02/dyopsy2901/www/tmp/cache (0705)
#~          config_file: 0444
#~      ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Suite à mon dernier poste du 06/07, j'ai mis à jour la version cms en 2.2.2.
Résultat : tout fonctionne chic.
Mais :

j'ai toujours la notification comme quoi il faut que passe à la 2.2.2,
j'ai pu modifier les paramètres globaux pour remettre en ligne le site,
dans la base de donnée la data sitepref_value est bien à "0" mais le message "site en maintenance" s'affiche lorsque  l'on accède directement au site et ce avec tous les navigateurs dont je dispose



Que faut-il faire pour que ça marche ?

Merci d'avance

Alain

#9 Re : Installation » [Resolu] parametres globaux pas moyen de sortir du mode de mainteance » 09/07/2017 17:16:51

Je vais suivre tes conseils.

Merci pour votre aide, je modifie le premier poste

à bientôt

Alain

#10 Re : Installation » [Resolu] parametres globaux pas moyen de sortir du mode de mainteance » 09/07/2017 10:15:34

Désolé de ce retard à vous répondre, mais il n'y avais pas moyen de faire afficher la page d'identification du forum donc pas moyen de répondre. J'ai contourné le pb en changeant de navigateur et là je peux m'identifier sur le forum.

J'en ai profité pour tester la mise à jour des paramètres globaux sur le site et là ça fonctionne....??? la question est de savoir pourquoi FireFox me 'a joué ce tour?

Merci à tous les deux pour votre aide. J'ai commencé par remettre le site en ligne en passant le champ sitepref_value à NULL.

Puis j'ai regardé ce que me disait la console lors d'une mise à jour des paramèttres globaux : j'ai bien une erreur js : "ReferenceError : cms_confirm is not defined  siteprefs.php:94:5"

Est-ce que cela vous inspire une expication sur le pb d'origine ?

#11 Re : Installation » [Resolu] parametres globaux pas moyen de sortir du mode de mainteance » 07/07/2017 11:07:45

Oui c'est la première chose que j'ai faite quand je me suis aperçu que cette donnée ne se mettait pas à jour.

#12 Re : Installation » [Resolu] parametres globaux pas moyen de sortir du mode de mainteance » 07/07/2017 08:31:28

Bonjour,

Merci pour ta réponse.
Non cela fait pareil sur les autres onglets des paramètres globaux, l'action sur le bouton "Envoyer" est sans effet.

#13 Installation » [Resolu] parametres globaux pas moyen de sortir du mode de mainteance » 06/07/2017 16:30:02

AG1111
Réponses : 9

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.2.1
#~ Url du site : xaviergavaud.fr
#~ Hébergeur / Soft : firstheberg
#~ Informations Système :
#~      ----------------------------------------------
#~      Cms Version: 2.2.1
#~      Installed Modules:
#~          AdminSearch: 1.0.3
#~          CGExtensions: 1.55.6
#~          CMSContentManager: 1.1.5
#~          CMSMailer: 6.2.14
#~          Captcha: 0.5.5
#~          CmsJobManager: 0.1
#~          DesignManager: 1.1.2
#~          FileManager: 1.6.3
#~          FilePicker: 1.0.alpha
#~          FormBuilder: 0.8.1.6
#~          Gallery: 2.3.1
#~          MenuManager: 1.50.3
#~          MicroTiny: 2.1.1
#~          ModuleManager: 2.1
#~          Navigator: 1.0.6
#~          News: 2.51.1
#~          Search: 1.51.1
#~          SiteMapMadeSimple: 1.2.8
#~          ThemeManager: 1.1.8
#~      Config Information:
#~          php_memory_limit:
#~          max_upload_size: 10000000
#~          url_rewriting: mod_rewrite
#~          page_extension: .html
#~          query_var: page
#~          auto_alias_content: true
#~          locale:
#~          set_names: true
#~          timezone: Europe/Paris
#~          permissive_smarty: false
#~      Php Information:
#~          phpversion: 5.6.27
#~          md5_function: On  (Vrai)
#~          json_function: On  (Vrai)
#~          gd_version: 2
#~          tempnam_function: On  (Vrai)
#~          magic_quotes_runtime: Off  (Faux)
#~          E_ALL: 22527
#~          E_STRICT: 0
#~          E_DEPRECATED: 0
#~          test_file_timedifference: Aucune différence de date du système trouvée
#~          test_db_timedifference: Une différence de date avec l'environnement PHP a été détectée. Cela peut causer des problèmes lorsque vous publiez des articles.
#~          create_dir_and_file: 1
#~          memory_limit: 128M
#~          max_execution_time: 120
#~          register_globals: Off  (Faux)
#~          output_buffering: 4096
#~          disable_functions: dl, exec, shell_exec, system, passthru, popen, pclose, proc_open, proc_nice, proc_terminate, proc_get_status, proc_close, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, escapeshellcmd, shell-exec, fpassthru, crack_check, crack_closedict, crack_getlastmessage, crack_opendict, psockopen, symlink, ini_restore, posix_getpwuid, getmyuid, listen, diskfreespace, tmpfile, link, ignore_user_abord, highlight_file, source, show_source, fpaththru, virtual, posix_ctermid, posix_getcwd, posix_getegid, posix_geteuid, posix_getgid, posix_getgrgid, posix_getgrnam, posix_getgroups, posix_getlogin, posix_getpgid, posix_getpgrp, posix_getpid, posix, _getppid, posix_getpwnam, posix_getrlimit, posix_getsid, posix_getuid, posix_isatty, posix_setegid, posix_seteuid, posix_setgid, posix_times, posix_ttyname, posix_uname
#~          open_basedir:
#~          test_remote_url: Valable
#~          file_uploads: On  (Vrai)
#~          post_max_size: 10M
#~          upload_max_filesize: 10M
#~          session_save_path: /tmp (1777)
#~          session_use_cookies: On  (Vrai)
#~          xml_function: On  (Vrai)
#~          xmlreader_class: On  (Vrai)
#~          check_ini_set: On  (Vrai)
#~          curl: On
#~      Performance Information:
#~          allow_browser_cache: Off  (Faux)
#~          browser_cache_expiry: 60
#~          php_opcache: Off  (Faux)
#~          smarty_cache: On  (Vrai)
#~          smarty_compilecheck: Off  (Faux)
#~          auto_clear_cache_age: On  (Vrai)
#~      Server Information:
#~          Server Software: Apache
#~          Server Api: cgi-fcgi
#~          Server Os: Linux 3.2.0-4-amd64 On  x86_64
#~          Server Db Type: MySQL (mysqli)
#~          Server Db Version: 5.5.55
#~          Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
#~      Permission Information:
#~          tmp: /srv/filer02/dyopsy2901/www/tmp (0705)
#~          tmp_cache: /srv/filer02/dyopsy2901/www/tmp/cache (0705)
#~          templates_c: /srv/filer02/dyopsy2901/www/tmp/templates_c (0705)
#~          modules: /srv/filer02/dyopsy2901/www/modules (0705)
#~          uploads: /srv/filer02/dyopsy2901/www/uploads (0705)
#~          Masque de création de fichier (umask) : /srv/filer02/dyopsy2901/www/tmp/cache (0705)
#~          config_file: 0444
#~      ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Bonjour,

Je viens juste de faire la mise à jour de ce site en v2.2.1. Tout fonctionne sauf que je ne peux pas remettre le site en ligne au niveau des paramètres globaux site en maintenance oui ou non la mise à jour de cette donnée ne se fait pas.


Vous avez une idée

Merci d'avance

Alain

#14 Re : Modules, Tags » [Resolu] Altenative au module captcha ? » 27/01/2017 11:25:09

Je viens de refaire 2 tests et cela fonctionne bien.

je vais surveiller ça de près.

Merci pour ton aide

Alain

#15 Re : Modules, Tags » [Resolu] Altenative au module captcha ? » 25/01/2017 11:16:14

Merci pour ta réponse.

Cela doit fonctionné puisque cela fait 2 jours que je ne reçois plus de messages...

Merci pour ton aide, je modifie le premier poste

Amicalement

Alain

#16 Re : Modules, Tags » [Resolu] Altenative au module captcha ? » 23/01/2017 16:48:23

Bon l'envoi du message fonctionne mais je ne suis pas sur qu'il y ait un contrôle.

J'ai paramétré le module Captcha avec la clé du site et la clé secrète, j'ai ajouté la div indiquée pour afficher le windget
dans le gabarit du formulaire sous formbuilder. Il doit manquer quelque chose car cela n'affiche rien d 'autre après avoir cocher la case "je ne suis pas un robot".

Voila le code du formulaire :

[== Indéfini ==]
	{if isset($has_captcha) && $has_captcha == 1}
                <div class="g-recaptcha" data-sitekey="6LeL3hIUAAAAAErE2o7Ip85jKMtwzuAcw9GlEkoH"></div>
		{* <div class="captcha">{$graphic_captcha}{$title_captcha}<br />{if !empty($input_captcha)}{$input_captcha}{/if}</div> *}
	{/if}
	<div class="submit">{$prev}{$submit}</div>
	</div>
	{$fb_form_end}

Je soupçonne qu'il manque quelque chose mais quoi ?

#17 Re : Modules, Tags » [Resolu] Altenative au module captcha ? » 23/01/2017 12:46:20

Ok, je vais tester cela et je te tiens au courant

Merci

#18 Re : Modules, Tags » [Resolu] Altenative au module captcha ? » 23/01/2017 10:51:00

Merci Jissey pour ta réponse.
Je suis aller voir sur google et cela semble un peu compliqué à mettre en œuvre. Si j'ai bien compris, il faut aller chercher un code pour le site, mettre le script qui va bien dans les méta données de la page et modifier le gabarit du formulaire pour y mettre le code donné par google.

Dans le module Captcha il y a dans le champ "librairie" un" valeur recaptcha. Est-ce que cela fait référence au recaptcah de Google ? ou est-ce autre chose ?

#19 Modules, Tags » [Resolu] Altenative au module captcha ? » 22/01/2017 12:08:49

AG1111
Réponses : 9

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.1.5
#~ Url du site : xaviergavaud.fr
#~ Hébergeur / Soft : firstheberg
#~ Informations Système :
#~      ----------------------------------------------
#~      Cms Version: 2.1.6
#~      Installed Modules:
#~          AdminSearch: 1.0.2
#~          CGExtensions: 1.53.5
#~          CMSContentManager: 1.1.4
#~          CMSMailer: 6.2.14
#~          Captcha: 0.5.3
#~          DesignManager: 1.1.1
#~          FileManager: 1.5.2
#~          FormBuilder: 0.8.1.3
#~          Gallery: 2.1.4
#~          MenuManager: 1.50.2
#~          MicroTiny: 2.0.3
#~          ModuleManager: 2.0.5
#~          Navigator: 1.0.3
#~          News: 2.50.6
#~          Search: 1.50.2
#~          SiteMapMadeSimple: 1.2.8
#~          ThemeManager: 1.1.8
#~      Config Information:
#~          php_memory_limit:
#~          max_upload_size: 10000000
#~          url_rewriting: mod_rewrite
#~          page_extension: .html
#~          query_var: page
#~          auto_alias_content: true
#~          locale:
#~          set_names: true
#~          timezone: Europe/Paris
#~          permissive_smarty: false
#~      Php Information:
#~          phpversion: 5.6.27
#~          md5_function: On  (Vrai)
#~          json_function: On  (Vrai)
#~          gd_version: 2
#~          tempnam_function: On  (Vrai)
#~          magic_quotes_runtime: Off  (Faux)
#~          E_ALL: 22527
#~          E_STRICT: 0
#~          E_DEPRECATED: 0
#~          test_file_timedifference: Aucune différence de date du système trouvée
#~          test_db_timedifference: Une différence de date avec l'environnement PHP a été détectée. Cela peut causer des problèmes lorsque vous publiez des articles.
#~          create_dir_and_file: 1
#~          memory_limit: 128M
#~          max_execution_time: 120
#~          register_globals: Off  (Faux)
#~          output_buffering: 4096
#~          disable_functions: dl, exec, shell_exec, system, passthru, popen, pclose, proc_open, proc_nice, proc_terminate, proc_get_status, proc_close, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, escapeshellcmd, shell-exec, fpassthru, crack_check, crack_closedict, crack_getlastmessage, crack_opendict, psockopen, symlink, ini_restore, posix_getpwuid, getmyuid, listen, diskfreespace, tmpfile, link, ignore_user_abord, highlight_file, source, show_source, fpaththru, virtual, posix_ctermid, posix_getcwd, posix_getegid, posix_geteuid, posix_getgid, posix_getgrgid, posix_getgrnam, posix_getgroups, posix_getlogin, posix_getpgid, posix_getpgrp, posix_getpid, posix, _getppid, posix_getpwnam, posix_getrlimit, posix_getsid, posix_getuid, posix_isatty, posix_setegid, posix_seteuid, posix_setgid, posix_times, posix_ttyname, posix_uname
#~          open_basedir:
#~          test_remote_url: Valable
#~          file_uploads: On  (Vrai)
#~          post_max_size: 10M
#~          upload_max_filesize: 10M
#~          session_save_path: /tmp (1777)
#~          session_use_cookies: On  (Vrai)
#~          xml_function: On  (Vrai)
#~          xmlreader_class: On  (Vrai)
#~          check_ini_set: On  (Vrai)
#~          curl: On
#~      Performance Information:
#~          allow_browser_cache: Off  (Faux)
#~          browser_cache_expiry: 60
#~          php_opcache: Off  (Faux)
#~          smarty_cache: On  (Vrai)
#~          smarty_compilecheck: Off  (Faux)
#~          smarty_cache_udt: On  (Vrai)
#~          auto_clear_cache_age: On  (Vrai)
#~      Server Information:
#~          Server Software: Apache
#~          Server Api: cgi-fcgi
#~          Server Os: Linux 3.2.0-4-amd64 On  x86_64
#~          Server Db Type: MySQL (mysql)
#~          Server Db Version: 5.5.46
#~          Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
#~      Permission Information:
#~          tmp: /srv/filer02/dyopsy2901/www/tmp (0705)
#~          tmp_cache: /srv/filer02/dyopsy2901/www/tmp/cache (0705)
#~          templates_c: /srv/filer02/dyopsy2901/www/tmp/templates_c (0705)
#~          modules: /srv/filer02/dyopsy2901/www/modules (0705)
#~          uploads: /srv/filer02/dyopsy2901/www/uploads (0705)
#~          Masque de création de fichier (umask) : /srv/filer02/dyopsy2901/www/tmp/cache (0705)
#~          config_file: 0444
#~      ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~


Bonjour,

Je suis confronté à un comportement étrange du formulaire de contact de ce site. Je reçois quotidiennement 3 à 5 messages issus du formulaire contact, qui proviennent souvent de Russie et qui renvoient  vers des sites de jeux et/ou porno.

J'ai modifié le texte du message envoyé et la modification a été prise en compte sur les messages suivants. Je suis passé de 5 caractères à 8 l'image captcha, cela à duré 2 jours avant que des messages reviennent.

Le paramétrage captcha est le même que sur mes autres sites à savoir :

[== Indéfini ==]
Librairie : HNCaptcha
Nb Char : 8
Min-size : 20
Max-size: 30
Max rotate: 25
noisy
Secret position; 15
Collect_garbage_after : 10
Max lifetime : 10

Ce paramétrage est-il bon ? Est-ce Captcha qui est en cause ou est-ce une forme de hacking ?

Le seul moyen efficace que j'ai trouvé est de désactivé la page de contact, mais ce n'est le but recherché. Qu'est-ce que je peux faire ?

Merci d'avance pour vos conseils.

Cordialement

Alain

#20 Re : Installation » [Resolu]Des scripts inconnus et non désiré s'incrustent dans mes pages » 24/05/2016 09:22:40

Merci JCE pour ta réponse. En effet ça marche, c'est moi qui ne réfléchis pas aussi bien qu'un miroir.

Mon problème est résolu, je modifie le premier poste

Merci pour votre aide

Amicalement

Alain

#21 Re : Installation » [Resolu]Des scripts inconnus et non désiré s'incrustent dans mes pages » 19/05/2016 17:29:04

ouf. J'ai résolu le pb.

Je suis reparti d'une installation nouvelle dans un répertoire vide et une base de données vide. J'ai scanné tous les fichiers de uploads avant de les transférer sur le site et j'ai annalyser le dump de la base de données avant de la recharger.

j'en ai profité pour mettre à jour la version cms et celles des modules.

J'ai retrouvé un fonctionnement normal.
J'ai également mis en service les directives du htaccess.txt du répertoire doc.

Par contre j'ai encore un souci avec le renommage du répertoire admin comme le préconise Bess, renommage du répertoire et ajout d'une directive dans config.php.

Lorsque je fais cela, le site fonctionne mais je ne peux plus accéder à l'administration du site. Est-ce un fonctionnement normal ou devrais je pouvoir accéder à l'administration après avoir renommé le répertoire admin ?

#22 Re : Installation » [Resolu]Des scripts inconnus et non désiré s'incrustent dans mes pages » 15/05/2016 10:18:26

Merci à tous les 2 pour vos réponses.

Je me mets au travail et je vous tiens au courant de mes travaux.

Amicalement

Alain

#23 Installation » [Resolu]Des scripts inconnus et non désiré s'incrustent dans mes pages » 14/05/2016 12:11:46

AG1111
Réponses : 6

#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 2.1.1
#~ Url du site : paotredpagan.bzh
#~ Hébergeur / Soft : ovh
#~ Informations Système :
#~      ----------------------------------------------
#~      Cms Version: 2.1.1
#~      Installed Modules:
#~          CMSMailer: 5.2.4
#~          AdminSearch: 1.0
#~          FileManager: 1.5.2
#~          MenuManager: 1.50.2
#~          MicroTiny: 2.0.2
#~          ModuleManager: 2.0.1
#~          News: 2.50.3
#~          Search: 1.50.2
#~          ThemeManager: 1.1.8
#~          CGExtensions: 1.51
#~          JQueryTools: 1.3.8
#~          SiteMapMadeSimple: 1.2.8
#~          FormBuilder: 0.8.1.2
#~          Captcha: 0.5.2
#~          CMSContentManager: 1.1
#~          DesignManager: 1.1.1
#~          Navigator: 1.0.2
#~      Config Information:
#~          php_memory_limit:
#~          max_upload_size: 64000000
#~          url_rewriting: mod_rewrite
#~          page_extension:
#~          query_var: page
#~          auto_alias_content: true
#~          locale:
#~          set_names: true
#~          timezone: Europe/Paris
#~          permissive_smarty: false
#~      Php Information:
#~          phpversion: 5.6.20
#~          md5_function: On  (Vrai)
#~          json_function: On  (Vrai)
#~          gd_version: 2
#~          tempnam_function: On  (Vrai)
#~          magic_quotes_runtime: Off  (Faux)
#~          E_STRICT: 2048
#~          E_DEPRECATED: 8192
#~          test_file_timedifference: Aucune différence de date du système trouvée
#~          test_db_timedifference: Aucune différence de date du système trouvée
#~          create_dir_and_file: 1
#~          memory_limit: 512M
#~          max_execution_time: 300
#~          register_globals: Off  (Faux)
#~          output_buffering: 4096
#~          disable_functions: _dyuweyrj4, _dyuweyrj4r, dl
#~          open_basedir:
#~          test_remote_url: Valable
#~          file_uploads: On  (Vrai)
#~          post_max_size: 64M
#~          upload_max_filesize: 64M
#~          session_save_path: /tmp (0700)
#~          session_use_cookies: On  (Vrai)
#~          xml_function: On  (Vrai)
#~          xmlreader_class: On  (Vrai)
#~          check_ini_set: On  (Vrai)
#~          curl: On
#~      Performance Information:
#~          allow_browser_cache: Off  (Faux)
#~          browser_cache_expiry: 60
#~          php_opcache: On  (Vrai)
#~          smarty_cache: On  (Vrai)
#~          smarty_compilecheck: Off  (Faux)
#~          smarty_cache_udt: On  (Vrai)
#~          auto_clear_cache_age: On  (Vrai)
#~      Server Information:
#~          Server Software: Apache
#~          Server Api: fpm-fcgi
#~          Server Os: Linux 3.14.60-grsec-hosting-web-3.14 On  x86_64
#~          Server Db Type: MySQL (mysql)
#~          Server Db Version: 5.5.46
#~          Server Db Grants: Impossible de trouver un privilège "GRANT ALL". Cela ne conduit pas nécessairement à des problèmes... Mais si vous avez des problèmes pour installer/retirer des modules ou ajouter/supprimer des éléments de contenu ou pages cela pourrait en être la cause.
#~      Permission Information:
#~          tmp: /home/randoker/paotredpagan.bzh/paotredpagan/tmp (0705)
#~          tmp_cache: /home/randoker/paotredpagan.bzh/paotredpagan/tmp/cache (0705)
#~          templates_c: /home/randoker/paotredpagan.bzh/paotredpagan/tmp/templates_c (0705)
#~          modules: /home/randoker/paotredpagan.bzh/paotredpagan/modules (0705)
#~          uploads: /home/randoker/paotredpagan.bzh/paotredpagan/uploads (0705)
#~          Masque de création de fichier (umask) : /home/randoker/paotredpagan.bzh/paotredpagan/tmp/cache (0705)
#~          config_file: 0444
#~      ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~



Des scipts indésirables se retrouvent dans le code source de la page d'accueil du site, ce qui provoque l'arrêt de mes scripts, c'est comme cela que j'ai découvert le pb.

En consultant le wiki sur le sujet je me suis aperçu que mon .htacces était trop light, j' aurai besoin d'aide pour le mettre au point.
Mais avant cela, que dois-je faire pour supprimer ces scripts indésirable ?
La base de données peut-elle être impactée ? je n'ai rien vu à priori dans l'export sql, mais j'ai pu rater quelque chose.

Je pensais faire une réinstallation complète à partir des fichiers de la forge dans les version qui sont en cours avant de faire une mise à jour CMS et modules et modifer le .htacces.


Y a t'il d'autres solutions que le htaccess pour se prémunir contre de telles attaques  ?


Merci d'avance pour vos réponses et sages conseils

Amicalement

Alain

#24 Re : Installation » [Resolu] Pb de mise à jour de modules sur V2.1.1 » 14/05/2016 11:56:08

Bonjour,

Pardon pour ce silence radio, en effet j'ai refait un rafraichissement et cela à résolu le pb. Je modifie le premier poste et j'ouvre un poste pour un pb de sécurité.

Amicalement

Alain

#25 Re : Vous, vos sites ... » Un petit site pour découvrir l'univers d'un artiste » 03/04/2016 20:33:37

Merci pour ta réponse Jean Le Chauve,

en effet j'ai rajouté ce qu'il fallait, je pense,  pour le canonical des news et du dossier de presse.

Je ne m'étais pas rendu compte que le fond d'écran de la page d'accueil n'était pas assez large, cela n'apparaît sur mon écran. Si je modifie la largeur de l'image, la hauteur aussi va augmenter et le résultat ne sera pas à la hauteur de ce qu'attend l'artiste. Quelle solution reste t-il ? répéter l'image ? une couleur de fond ? un conseil peut-être ?

Pour les meta données, j'en étais resté à une description  et une liste de mots clés uniques pour tout le site. Au vu de ta réponse, je conclue qu'il faut reprendre cela et l'adapter à toutes les pages. Bon j'ai encore un peu de boulot......

Amicalement

Alain

Ps : une validation css3 c'est bien aussi ?

Pied de page des forums

Propulsé par FluxBB