Forum CMS Made Simple Francophone

Aide francophone sur CMS Made Simple

Vous n'êtes pas identifié(e).

Annonce

ATTENTION

  • Prenez le temps de rechercher si quelqu'un n'a pas déjà proposé une solution à votre problème. Sur le forum français et sur le wiki
  • Pensez à mettre à jour votre version de CMS Made Simple. Nous ne faisons de support que sur LA dernière version de CMS Made Simple.
  • Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider
  • Ajoutez [Résolu] au début du titre de votre 1er message lorsqu'une solution a été trouvée.

#1 Re : Modules, Tags » Impossible d'installer le module Products ... » 06/06/2018 13:44:31

Bonjour,
Merci de placer les infos cms dans une balise [ quote][ /quote] pour qu'elles n'apparaissent pas comme mot-clé dans la recherche du forum.

#2 Re : Installation » Problème lors de la mise à jour 2.2.5 vers 2.2.7 sur modules » 01/06/2018 14:30:23

Bonjour locodinodi,
La recherche dans ce forum a été améliorée par Bess il y a quelques années pour que les informations du cms ne soient pas prises en compte SI ET SEULEMENT SI elles sont placées dans une balise [ code] ou écrites dans le champs spécifique lors de la création du premier post.
Ici, toutes tes infos cms vont renvoyer un résultat positif pour la recherche, par exemple si je tape "CGGoogleMaps2" qui est dans tes infos, ton post apparaît, alors qu'il n'a aucun rapport avec ce module.
Pourrais-tu modifier ton premier message et placer tes infos entre [ code] et [ /code] sans les espaces ?
Merci d'avance.

#3 Re : Modules, Tags » [Résolu] Caractères spéciaux dans les alias LISE, CustomGS, etc... » 10/05/2018 21:29:26

Salut Pierre,
Non, je ne travaille plus et j'ai un autre hobby, mais je continue à suivre le forum en mode quiet.
Bonne continuation à vous

#4 Re : Modules, Tags » [Résolu] Caractères spéciaux dans les alias LISE, CustomGS, etc... » 10/05/2018 17:53:16

Voilà plus d'1 an que je n'ai plus ouvert le cms, mais n'y a-t-'il pas la possibilité d'ajouter un event au moment d'enregistrer la nouvelle page qui appellerait une udt de remplacement d'alias ?

#5 Re : Modules, Tags » [Résolu] Caractères spéciaux dans les alias LISE, CustomGS, etc... » 10/05/2018 17:20:29

Ok, je vois, ce n'est pas l'url qui te gêne, car, n'en déplaise à Pierrepercée, c'est une bonne innovation : depuis 2010 l'icann a autorisé cela pour les langues arabes, chinoises...
Tu aurais peut-être plus de chance de te faire comprendre en écrivant dans le topic des modules : https://forum.cmsmadesimple.org/viewforum.php?f=7 en montrant l'exemple que tu viens de me donner.
Il y a déjà un autre post à ce sujet, peut-être que l'auteur a trouvé une façon de le contourner, tu devrais lui envoyer un message : https://forum.cmsmadesimple.org/viewtop … as#p336178
Si ça foire, la solution la plus simple est de de ne pas mettre d'accent dans les définitions de champ sad .
Bonne chance.

#6 Re : Modules, Tags » [Résolu] Caractères spéciaux dans les alias LISE, CustomGS, etc... » 10/05/2018 09:15:23

Bonjour Brick,
Pourquoi est-ce un problème d'avoir des caractères accentués dans les alias ?

#8 Re : Modules, Tags » [Résolu] Menu (Onglets ou sections déroulantes) dans une seule page » 14/12/2017 13:44:06

Bonjour,

Beaucoup de solutions s'offrent à toi avec l'aide de différentes technologies.
JQuery UI en est une :
Onglets
ou encore menus dépliants (accordéon)

#9 Re : Modules, Tags » [Résolu] Affichage Détail Article » 27/09/2017 10:12:33

Bonjour et bienvenue,
Comme nous n'avons aucune information au sujet de ton cms (voir bandeau ATTENTION), il est difficile de te répondre avec précision.

Renseignez impérativement le formulaire de nouveau message de manière la plus complète que possible. Dans votre CMS utiliser le menu Administration du site/Informations du système en haut Vue au format texte. Ces informations demandées nous permettent de mieux vous aider

L'erreur 404 t'indique que le serveur ne trouve pas la page ayant comme alias "Mon histoire". Soit le nom de la page n'est pas correct, soit tu n'as pas activé la réécriture d'url.

#10 Re : Modules, Tags » [Résolu]CMSMS 2.2.3.1 - E-commerce - Module Products 2.28 - Import CSV » 14/09/2017 15:58:15

Je ne vois qu'une différence entre tes différentes lignes et la 4ème : le FLAG p; qui est en minuscule.
Je suppose que tu l'avais remarqué et déjà essayé de le passer en majuscule.

Je n'ai pas ce module, mais je pense que si tu peux importer, tu devrais pouvoir exporter. Tu pourrais créer quelques produits et faire un export pour comparer les 2 fichiers.

#11 Re : Modules, Tags » [Résolu]CMSMS 2.2.3.1 - E-commerce - Module Products 2.28 - Import CSV » 14/09/2017 14:35:25

Bonjour,
As-tu vérifié s'il n'y a pas de caractères cachés dans ton fichier csv (notepad++ affichage->symboles spéciaux->afficher tous les caractères) ?

#12 Re : Modules, Tags » Module Form Builder : erreur écriture des résultats dans un fichier » 02/09/2017 08:11:47

Bonjour,
@jce Le post en question : http://www.cmsmadesimple.fr/forum/viewtopic.php?id=5975

@Dominique
Passe uploads en 755 (ou 705)
As-tu vidé la table cms_module_fb_flock ?

Les messages que j'ai pu trouver concernant cette erreur pointent vers :
Mauvaise data dans la table,
version PHP (https://forum.cmsmadesimple.org/viewtop … 9&p=333862).

Vérifier les logs serveur.
Vérifier également le nom du fichier et son emplacement (préférence du champs) ex : uploads/filename.txt (pas de caractères spéciaux ni espace...).
Enfin, teste avec un autre type de réception des données (mail, bd...) afin de mieux cerner l'endroit où ça déconne.

#13 Re : Général » [RESOLU] Peut-on formater le texte du titre d'une news? » 17/06/2017 22:12:42

Salut,
Tu crées un champ : titreFormate (texte, public, wysiwyg) ;

{if !empty($entry->titreFormate)}
   {$entry->titreFormate}
{else $entry->title}
{/if}

à peu de choses près. Pas besoin de se casser plus la tête, tes url et flux restent ainsi dépendant de $entry->title.
Pour le flux RSS (c'est du XML), c'est normal que ça ne fonctionne pas si tu ajoutes des balises, le document devient non conforme pour son doctype.

#14 Re : Modules, Tags » ecommerce - orders - bouton paiement manuel » 21/04/2017 12:20:40

Salut,
Je ne sais pas si tu as trouvé la solution, mais il me semble que chaque formulaire a une id qui te permet de modifier la css d'un objet en particulier.

#15 Re : Modules, Tags » [Résolu] LISE et sa pagination » 05/04/2017 19:13:13

Si c'est pas résolu, non, peut-être qu'AireLibre passera sur ce post, il est le spécialiste de LISE.
Bonne chance.

#16 Re : Modules, Tags » [Résolu] LISE et sa pagination » 05/04/2017 09:22:28

Pour vérifier si une condition est remplie, on n'utilise pas empty(), c'est un booléen.

{foreach from=$items item=item}
{if $item->vendu === FALSE}{code affichage}{/if}
{/foreach}

#17 Re : Modules, Tags » [Résolu] LISE et sa pagination » 04/04/2017 20:13:14

C'est ta condition qui n'est pas bonne : {if empty($item->vendu)} voudrait dire {s'il n'y a aucun item de vendu, alors fait (...)} et encore, je suis à peu près certain que ça ne veut rien dire du tout.

{foreach from=$items item=item}
{if $item->vendu}(rien, laisse vide){else}{code affichage}{/if}
{/foreach}

Ou alors, je n'ai toujours pas compris, et cela m'arrive souvent ces derniers temps wink.
Ça ne coûte rien de mettre l'entièreté du code du foreach, et ce serait plus facile à comprendre pour moi.

#18 Re : Modules, Tags » [Résolu] LISE et sa pagination » 04/04/2017 00:21:31

Je suppose que le code de pagination est dans ton gabarit.

{foreach from=$items item=item}
  {if empty($item->vendu)}  
     (...)
     {$nonVendu+1}
  {/if}
{/foreach}
{if $nonVendu>9}{codepagination}{/if}

ou encore

{foreach from=$items item=item}
  {if empty($item->vendu)}  
     (...)
     {counter start=0 assign=nonVendu}
  {/if}
{/foreach}
{if $nonVendu>9}{codepagination}{/if}

#19 Re : Général » Pas d'impression du logo du site [résolu] » 04/04/2017 00:07:03

Parce que l'image est en background. Par défaut, les imprimantes n'impriment pas le background pour ne pas gaspiller d'encre. Généralement, si on imprime, c'est pour le contenu, pas pour le logo wink.
Sur Firefox : tu cliques sur Fichier->Mise en page (ou aperçu avant impression->mise en page)->options->cocher imprimer le fond de page.

#20 Re : Installation » https et déconnection admin » 22/03/2017 01:15:48

Pas de piste dans les logs et journal d'administration ?

#21 Re : Modules, Tags » LISE : Rechercher mot clé dans le titre » 17/03/2017 18:57:32

Je vais me mêler de ce qui ne me regarde pas, mais je suis assez vieux pour assumer wink
Je trouve que ta recherche par mot-clé ne sera pas efficace. Une erreur d'orthographe (extrêmement fréquente de nos jours wink), un synonyme et c'est foutu, la recherche ne renverra rien surtout que tu n'as pas des tonnes de formations.
Pourquoi ne pas utiliser ta page "les formations" pour toutes les afficher dans des tabs au survol de la souris (JQuery) ?

En passant, tu utilises les majuscules accentuées, ou pas, suivant les cas. Ce serait mieux de respecter la charte graphique à ce sujet. Et diplômante, pas dîplomante wink.

#22 Re : Général » [Résolu] Changements V1.12.2 -> V2.1.6 sur le scope ? » 17/03/2017 18:43:26

Tu as essayé le scope=global ? Le message d'erreur indique que les variables en question n'existent pas dans le gabarit.

#23 Re : Modules, Tags » LISE : Rechercher mot clé dans le titre » 15/03/2017 20:28:42

Le code que je t'ai donné ne fonctionne sans doute pas.
Airelibre connaissant le module, il a donné la bonne réponse à ton problème :

est'il possible d'effectuer une recherche exclusivement dans le titre de  l'item plutôt que dans l'ensemble des champs ajouté dans mon module ?

Puis tu lui réponds :

Moi j'aurais voulu qu'on puisse indiquer sur quel champ chercher

Faudrait savoir wink

Ensuite, tu dis ne pas connaître à l'avance le terme à rechercher dans le titre, on peut en déduire que ce sera l'internaute qui le choisira. Il te suffirait alors d'en faire une variable et de le mettre dans {LISEMonModule search_title=$variable}.
Mais comment veux-tu qu'il trouve le mot-clé exact si tu ne lui donnes pas à choisir dans une liste prédéfinie ?
Ce serait sympa que tu réfléchisses un peu plus à ton algorithme. Que veux-tu exactement et quelle sera la procédure à suivre pour l'internaute ?

#24 Re : Modules, Tags » LISE : Rechercher mot clé dans le titre » 15/03/2017 17:59:56

Je parlais d'une erreur de sécurité, car Smarty 3 n'accepte plus tous les modificateurs PHP comme c'était le cas dans les précédentes versions.
L'erreur que tu as indiquée montre une erreur de syntaxe, essaye ceci :

{if $item->title|strpos:"$actionparams.search" !== false}

strpos() cherche la première occurrence d'un terme dans l'ensemble de la string, donc trouvera le terme dans tout le titre, même s'il se trouve à la fin de la string.

#25 Re : Modules, Tags » LISE : Rechercher mot clé dans le titre » 14/03/2017 19:36:36

Est-ce que tu as eu une erreur de sécurité ou pas ?
Et ceci :
{if $item->title|strpos("$actionparams.search") != false}

Sinon, https://board.s9y.org/viewtopic.php?f=11&t=20294

Pied de page des forums

Propulsé par FluxBB