Forum CMS Made Simple FR

Version complète : Site offline suite changement version PHP
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Bonjour à tous,

j'ai mis à jour la version php de mon site qui est hébergé chez 1&1, de la version PHP 7.0 à la version 7.5...

Suite à ça le site ne s'affiche plus, un message d'erreur s'affiche :

Parse error: syntax error, unexpected 'new' (T_NEW) in /homepages/33/d387610631/htdocs/include.php on line 73

Je suis revenu à la version php 7.0 mais le site ne s'affiche plus avec toujours le même message

Comment faire ?

Merci d'avance pour votre aide
Citation :j'ai mis à jour la version php de mon site qui est hébergé chez 1&1, de la version PHP 7.0 à la version 7.5...

heu PHP 7.5 Wink

comme tu ne donne pas la version du CMS  utilisé ça va être dur de n'aider
avec "/htdocs/include.php" ce n'est sûrement pas une version 2.x ??
mais as tu bien vider le cache du CMS et le cache du navigateur ?
Bonjour,

Commence en effet par vider le cache faire fonctionner le site en 7.0. As-tu des logs d'erreur sur 1&1 ?

Ensuite une fois que ca fonctionne, passer en 7.1 pour tester

Tiens-nous au courant,
(15/01/2019, 11:58:32)jce76350 a écrit : [ -> ]
Citation :j'ai mis à jour la version php de mon site qui est hébergé chez 1&1, de la version PHP 7.0 à la version 7.5...

heu PHP 7.5 Wink

comme tu ne donne pas la version du CMS  utilisé ça va être dur de n'aider
avec "/htdocs/include.php" ce n'est sûrement pas une version 2.x ??
mais as tu bien vider le cache du CMS et le cache du navigateur ?

Bonjour, merci pour votre aide, je suis bien repassé en version PHP 7.0 chez 1&1 , sans plus de résultat, toujours le même message d'erreur.

J'ai du repasser en version PHP 5.6 pour qu'il fonctionne, le probleme est résolu. Reste que je dois changer obligatoirement cette version PHP vers la 7.5

Vers quelle version du CMS dois je passer pour qu'il soit compatible ? Est ce que je vais perdre mon contenu lors de l'upgrade ? Ou Bien dois je installer une nouvelle version pour repartir à zéro et "reconstruire" le site ?

(15/01/2019, 17:20:14)airelibre a écrit : [ -> ]Bonjour,

Commence en effet par vider le cache faire fonctionner le site en 7.0. As-tu des logs d'erreur sur 1&1 ?

Ensuite une fois que ca fonctionne, passer en 7.1 pour tester

Tiens-nous au courant,

Bonjour, merci pour votre aide, je suis bien repassé en version PHP 7.0 chez 1&1 , sans plus de résultat, toujours le même message d'erreur.

J'ai du repasser en version PHP 5.6 pour qu'il fonctionne, le probleme est résolu. Reste que je dois changer obligatoirement cette version PHP vers la 7.5

Vers quelle version du CMS dois je passer pour qu'il soit compatible ? Est ce que je vais perdre mon contenu lors de l'upgrade ? Ou Bien dois je installer une nouvelle version pour repartir à zéro et "reconstruire" le site ?
Citation :je suis bien repassé en version PHP 7.0 chez 1&1 , sans plus de résultat, toujours le même message d'erreur.
1- déjà donne nous la version du CMS utilisée actuellement
le problème c'est que si tu utilise une version 1.12.2 ce n'est pas compatible PHp 7.0
J"avais fait un correctif non officiel que j'ai mise sur ma page perso pour cette compatibilité PHP 7.0
Jeu de fichiers pour rendre la version 1.12.02 compatible avec PHP 7.x

Citation :J'ai du repasser en version PHP 5.6 pour qu'il fonctionne, le probleme est résolu. Reste que je dois changer obligatoirement cette version PHP vers la 7.5
Y pas de version PHP 7.5 Wink
2- chez 1&1 c'est soit php 7.1 ou 7.2  ou éventuellement PHP 7.3
Sinon PHP 7.0 et PHP 5.6 C'est  : Support jusqu'en décembre 2018. donc plus suivi
[Image: 1and1-php.png]
Citation :Vers quelle version du CMS dois je passer pour qu'il soit compatible ? Est ce que je vais perdre mon contenu lors de l'upgrade ? Ou Bien dois je installer une nouvelle version pour repartir à zéro et "reconstruire" le site ?

RE déjà donne nous la version du CMS utilisée actuellement pour connaître les possibilités de passage à une version actuelle qui est la 2.2.8. et non tu perdra rien c'est c'est fait dans les règles et donc je te conseille das ce cas de faire un test en local avant de passer en production.
Des nouvelles ?