Forum CMS Made Simple FR

Version complète : URL rewrite : MleCMS - chemin du dossier image et autres réécrit
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Citation :#~~~~~ DEBUT BLOC A NE PAS SUPPRIMER ~~~~~
#~ Version du CMS: 1.11.13
#~ Url du site :
#~ Hébergeur / Soft :
#~ Informations Système :
#~ ----------------------------------------------
#~ Cms Version: 1.11.3 Darwin_8494Fr
#~ Installed Modules:
#~ CMSMailer: 5.2.1
#~ CMSPrinting: 1.0.3
#~ FileManager: 1.4.2
#~ MenuManager: 1.8.4
#~ MicroTiny: 1.2.4
#~ ModuleManager: 1.5.5
#~ News: 2.12.10
#~ Search: 1.7.7
#~ ThemeManager: 1.1.7
#~ FormBuilder: 0.7.3
#~ Gallery: 1.6
#~ TinyMCE: 2.9.11
#~ GAMadeSimple: 1.1
#~ GoogleMaps: 0.2.1
#~ CGExtensions: 1.32.2
#~ MleCMS: 1.11.4
#~ Config Information:
#~ php_memory_limit:
#~ process_whole_template:
#~ output_compression:
#~ max_upload_size: 2000000
#~ url_rewriting: none
#~ page_extension:
#~ query_var: page
#~ image_manipulation_prog: GD
#~ auto_alias_content: true
#~ locale:
#~ default_encoding: utf-8
#~ admin_encoding: utf-8
#~ set_names: true
#~ Php Information:
#~ phpversion: 5.3.3
#~ md5_function: On (Vrai)
#~ gd_version: 2
#~ tempnam_function: On (Vrai)
#~ magic_quotes_runtime: Off (Faux)
#~ E_STRICT: 0
#~ E_DEPRECATED: 0
#~ memory_limit: 128M
#~ max_execution_time: 30
#~ output_buffering: 4096
#~ safe_mode: Off (Faux)
#~ file_uploads: On (Vrai)
#~ post_max_size: 8M
#~ upload_max_filesize: 2M
#~ session_save_path: /tmp (1777)
#~ session_use_cookies: On (Vrai)
#~ xml_function: On (Vrai)
#~ xmlreader_class: On (Vrai)
#~ Server Information:
#~ Server Api: cgi-fcgi
#~ Server Db Type: MySQL (mysql)
#~ Server Db Version: 5.1.73
#~ Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
#~ ----------------------------------------------
#~~~~~ FIN BLOC A NE PAS SUPPRIMER ~~~~~


Bonjour à toutes et à tous.
Je me permets de venir vers vous car je ne comprends pas le problème.
C'est la première fois que je suis confrontée à cela malgré plusieurs install de ce CMS que j'adore Smile


Le problème se situe au niveau de la réécriture.
Elle fonctionne mais mes images ne sont plus accessibles car le chemin est erroné.

En fait dans le code source j'ai bien : uploads/images/monimage.jpg mais si je l'ouvre dans un onglet, l'image recherché est

/FR/mon-dossier/le-nom-de-ma-page/uploads/images/monimage.jpg

A rien n'y comprendre Sad




mon fichier config :

Code :
[== Indéfini ==]
$config['dbms'] = 'mysql';
$config['db_hostname'] = 'localhost';
$config['db_username'] = '******';
$config['db_password'] = '******';
$config['db_name'] = '*****';
$config['db_prefix'] = '';
$config['timezone'] = 'Europe/Berlin';

$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';

#$config['use_hierarchy'] = false;


et le fichier .htaccess

Code :
[== Indéfini ==]
Options +FollowSymlinks
RewriteEngine on


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php?page=$1 [QSA]


Ce qui est étrange c'est que j'ai un autre site avec les même config et pas de soucis (j'ai downgrader CGEextension et MleCMS pour avoir la même config) mais rien n'y fait ....


Je vous remercie sincèrement d'avance pour un petit coup de pouce.
Emilie.




PS j'oubliai mon module est configurer comme suit :

Détection de la langue :

Commutateur de hiérarchie :

Detection de la langue : Aucun.

Commutateur de hierarchie : oui

Restriction de la recherche MLE : Non
Bonjour,
une URL peut-être?
C'est plus facile avec un exemple en direct-live!
Citation : Cms Version: 1.11.3 Darwin_8494Fr
Attention Mettre à jour en CMSMS 1.12.0 pour des raisons de sécurité
Merci Jissey pour ta réponse voici une petite url : http://laure.abalone-studio.fr/

La page d'accueil fonctionne mais dès que on passe à une autre page, ça ne marche plus :Sad

jce : je vais m'occuper prochainement de la mise à jour...

Merci en tout pour le coup de pouce.
un exemple :


ce que j'ai remarqué

http://laure.abalone-studio.fr/en/rooms-...-room.html : ne fonctionne pas
http://laure.abalone-studio.fr/vassily-k...-room.html : fonctionne

c'est pas une histoire de hierarchy ?
ça me rappelle un problème que j'ai eu :
essaie en mettant une url forcée (champ URL de l'onglet Options) et non en laissant faire CMSMS avec l'alias de la page.
effectivement cela fonctionne mais est-il possible de prendre en compte les sous-dossier ?

genre chambres/qqche/mapage


(j'oubliai : un grand merci déja j'ai une alternative à mon problème) SmileSmileSmile
Citation :effectivement cela fonctionne mais est-il possible de prendre en compte les sous-dossier ?
OUI Smile
Smile
tu as une idée du comment ? car si je rajoute dans l'url un dossier genre chambre/ma chambre.html je perd les images

merci d'avance.
en ne mettant pas de caractères spéciaux et encore moins d'espace, donc :
chambre/ma_chambre.html
apparemment c'est le même problème.
il ne supporte pas dossier...

cette page

Dés qu'il y a un dossier, il me réécrit l'url de l'image :

http://monsite /chambres/uploads/images/contenu/kandinsky-room.jpg

au lieu de http://monsite/uploads/images/contenu/kandinsky-room.jpg

Qu'est qui peut bien se passer ? y a t'il un paramètre que j'ai oublié ?
JCE, t'as une idée? je sèche et je n'ai plus le temps. Je n'ai pas ce genre de problème...
merci beaucoup pour ton aide jissey en tout cas j'ai au moins une alternative.

Ce qui est étrange c'est que j'ai un configuration où ça marche pafaitement avec les mêmes modules notamment :

- CMS 1.11.3
- CGExtensions 1.31.2
- MleCMS 1.11.3 (j'ai essayé avec version supérieure)

et la je suis en

- CMS 1.11.3
- CGExtensions: 1.32.2 (j'ai essayé de downgrader sur une copie en 1.31.2) mais ça ne change rien.
- MleCMS: 1.11.4


La seule chose qui change dans tous les exemples que j'ai c'est CGEextension qui est plus récente ?

mais si je reviens downgrade la version est ce qu'il peut rester des "traces" ?
Juste une idée en passant à tester. J'ai vu que tu n'as pas la balise :
Code :
[== HTML ==]
<base href="http://www.domain.tld/" />

Où « http://www.domain.tld/ » est à remplacer par ton domaine.
Cette balise « base » permet de définir le répertoire de base pour les URL relatives utilisées dans le document. Peut-être que ça aidera.

Elle se rajoute entre les balises <head></head>.
Super Exacore c'est ça Smile Smile Smile



Un grand merci à tous pour votre aide.

effectivement la balise base pour url_rewrite à fonctionner.


Merci beaucoup Big Grin
Toujours aussi doué exacore, dommage que tu passes si rarement Wink
Je m'en doutais un peu quand j'ai vu ton problème, c'est typique.
Par contre, normalement cette balise est intégrée par CMSMS, as-tu modifié ton fichier « config.php » ?
Code :
[== config.php ==]
$config['show_base'] = true;
Citation :Je m'en doutais un peu quand j'ai vu ton problème, c'est typique.
je n'ais pas de "$config['show_base'] = true;" mais dans les pages il y bien <base href= ...
Cette balise est normalement dans les gabarits par défaut depuis ....
Par contre j'utilise MLE en 1.11.5
jce76350 a écrit :je n'ais pas de "$config['show_base'] = true;" mais dans les pages il y bien <base href= ...

C'est normal, ici j'ai mis le nom de la variable pour forcer l'affichage de la balise <base/> mais en l'absence de sa valeur à « false » elle prend la valeur « true » par défaut.
Donc la variable que j'ai mis ici est inutile à « true » (sauf pour le référencement de cette page :p ).
exacore a écrit :Je m'en doutais un peu quand j'ai vu ton problème, c'est typique.
Par contre, normalement cette balise est intégrée par CMSMS, as-tu modifié ton fichier « config.php » ?
Code :
[== config.php ==]
$config['show_base'] = true;


oui c'est possible que je l'ai modifiée
il va falloir que je regarde ça de plus près

En tout cas c'est RESOLU.
encore merci et bravo à la bonne réactivité de ce forum Big Grin
Bizarre ton histoire, car tu nous as donné ton config.php en début de post et il ne contient pas $config['show_base'] et est donc true dans le config.php que tu nous as donné. Le seul autre moyen de surcharger cette valeur est d'écrire {metadata show_base=false} dans le gabarit.
Citation :Bizarre ton histoire, car tu nous as donné ton config.php en début de post et il ne contient pas $config['show_base'] et est donc true dans le config.php que tu nous as donné. Le seul autre moyen de surcharger cette valeur est d'écrire {metadata show_base=false} dans le gabarit.

Ou d'avoir viré le tag du template.